16:30:21 <trinaths> #startmeeting ovn4nfv
16:30:21 <collabot`> Meeting started Tue Apr 17 16:30:21 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:21 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:30:21 <collabot`> The meeting name has been set to 'ovn4nfv'
16:30:27 <trinaths> #chair trinaths
16:30:27 <collabot`> Current chairs: trinaths
16:31:27 <ak_dev_> Hello, sorry for coming in late
16:32:23 <trinaths> #link Agenda: https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
16:33:06 <trinaths> ak_dev_ no problem
16:34:05 <trinaths> Hi Amir_m
16:34:10 <trinaths> Hi ak_dev_
16:34:17 <Amir_m> Hello Trinaths
16:34:48 <trinaths> Hi
16:35:02 <trinaths> Amir_m - lets start from ovn sfc
16:35:11 <Amir_m> Okay
16:36:13 <Amir_m> For me I've been trying to install the OVS git repo as advised by John, but I'm getting the same problem
16:36:45 <Amir_m> The only change is that the man pages shows the newly added ovn-nbctl sfc commands
16:37:28 <trinaths> ok
16:37:33 <Amir_m> But whenever I try to create the port pairs, I get this error:
16:37:42 <Amir_m> [heat-admin@overcloud-controller-0 ~]$ ovn-nbctl lsp-pair-add n1 vnf1-p1 vnf1-p2 pp1
16:37:46 <trinaths> can you post to john
16:37:47 <Amir_m> ovn-nbctl: unix:/usr/local/var/run/openvswitch/ovnnb_db.sock: database connection failed (No such file or directory)
16:37:55 <trinaths> ovn did not start
16:38:00 <Amir_m> [heat-admin@overcloud-controller-0 ~]$ sudo ovn-nbctl lsp-pair-add n1 vnf1-p1 vnf1-p2 pp1
16:38:10 <Amir_m> ovn-nbctl: unknown command 'lsp-pair-add'; use --help for help
16:38:13 <trinaths> $> ps -ef | grep ovn
16:38:58 <Amir_m> no it is working I can get outputs when I use the ovn-nbctl show
16:39:36 <Amir_m> There has to be something missing, probably from my side
16:39:50 <trinaths> then is the path to pvnnb_db.sock
16:39:55 <trinaths> is valid ?
16:40:03 <Amir_m> yes it is
16:40:12 <trinaths> can you check ovnnb_db.sock path
16:40:16 <trinaths> can you share the output
16:40:21 <Amir_m> [heat-admin@overcloud-controller-0 ~]$ ovn-nbctl show
16:40:21 <trinaths> $> ps -ef | grep ovn
16:40:29 <Amir_m> ovn-nbctl: unix:/usr/local/var/run/openvswitch/ovnnb_db.sock: database connection failed (No such file or directory)
16:40:36 <Amir_m> [heat-admin@overcloud-controller-0 ~]$ sudo ovn-nbctl show
16:40:45 <Amir_m> switch a542f881-3239-4898-bedd-609cc42e9f67 (neutron-01f2cf7b-0291-4106-ab42-706d80ff44a1) (aka n1)     port 7d44f7b3-10e6-4e98-8645-03234d2e7b6c (aka ap)
16:41:04 <Amir_m> as you can see, I get output when I use sudo
16:41:10 <trinaths> agree.
16:41:15 <Amir_m> so OVN is up and working
16:41:20 <trinaths> please share the output of
16:41:29 <trinaths> $> ps -ef  | grep ovn
16:41:52 <Amir_m> root       29920   29919  0 Mar27 ?        00:29:36 ovsdb-server --detach --monitor -vconsole:off --log-file=/var/log/openvswitch/ovsdb-server-nb.log --remote=punix:/run/openvswitch/ovnnb_db.sock --pidfile=/run/openvswitch/ovnnb_db.pid --remote=db:OVN_Northbound,NB_Global,connections --unixctl=ovnnb_db.ctl --private-key=db:OVN_Northbound,SSL,private_key --certificate=db:OVN_Northbound,SSL,certificate --ca-cert=db:OVN_Northbound
16:43:09 <trinaths> check the path - /usr/local/var/run/openvswitch/ovnnb_db.sock
16:43:32 <trinaths> I think the ovnnb_db.sock path is - /run/openvswitch/ovnnb_db.sock
16:43:41 <trinaths> different ?
16:44:13 <Amir_m> the /usr/local/var/run/openvswitch/ovnnb_db.sock doesn't exist
16:44:24 <Amir_m> itis the /run/openvswitch/ovnnb_db.sock
16:44:34 <trinaths> but your error is
16:44:35 <trinaths> [heat-admin@overcloud-controller-0 ~]$ ovn-nbctl show
16:44:36 <trinaths> ovn-nbctl: unix:/usr/local/var/run/openvswitch/ovnnb_db.sock: database connection failed (No such file or directory)
16:45:04 <Amir_m> but when I use sudo I don't get this error
16:45:32 <trinaths> user privileges.
16:45:39 <trinaths> and env
16:46:25 <trinaths> how ovn/ovs are started ? i mean which user starts them ?
16:46:39 <Amir_m> I think heat-admin
16:46:50 <trinaths> sure ?
16:46:59 <trinaths> i think root
16:47:13 <Amir_m> so
16:47:15 <trinaths> as per your ( ps command)
16:48:06 <trinaths> can you resolve this issue and try suggestions from john.
16:48:19 <Amir_m> I'm working on it
16:48:24 <trinaths> ok.
16:49:52 <trinaths> ak_dev_ - Hi, how were your exams going on
16:50:23 <ak_dev_> trinaths: they have not started yet, but yeah the submissions are going good
16:50:34 <ak_dev_> a lot of them before exams start
16:50:45 <trinaths> ak_dev_ have you replied james comments ?
16:51:01 <ak_dev_> not yet, I just got back from the lab, will reply soon
16:51:09 <ak_dev_> i noticed that laas is also up
16:51:23 <ak_dev_> we can use that for the development of this charm now
16:52:20 <trinaths> ok.
16:52:44 <trinaths> since James is actively responding now, we need to push some thing for review.
16:53:01 <trinaths> is it possible to submit patches for review by this weekend
16:53:25 <ak_dev_> yeah true
16:53:26 <ak_dev_> trinaths: I am not sure about that, since exams start this friday
16:53:32 <ak_dev_> i will try to push though
16:53:45 <ak_dev_> atleast one component
16:54:37 <trinaths> yes. please push a patch so that we are active in the project and some good comments come in.
16:55:48 <ak_dev_> trinaths: sure
16:56:03 <ak_dev_> will try my best to
16:56:12 <trinaths> please share the review URL with me so that I can follow up with the team.
16:56:29 <ak_dev_> once i have the url, i will mail it to you
16:56:35 <trinaths> ak_dev_ thank you for your efforts. I wish all the very best for the exams.
16:56:46 <ak_dev_> trinaths: thank you :-)
16:57:07 <trinaths> ak_dev_ :)
16:58:29 <trinaths> Amir_m: got something working ?
16:59:19 <Amir_m> I'm not trying anything during our meeting, will do after the meeting
17:02:08 <trinaths> Amir_m : Ok.
17:02:53 <trinaths> with Amir_m and ak_dev_ work we are proposing new scenarios for GAMBIA release.
17:03:13 <trinaths> I have sent intent for participation for TSC.
17:04:04 <trinaths> #topic open discussion
17:04:30 <ak_dev_> nothing to discuss from my side, thanks!
17:04:41 <ak_dev_> look forward to having good work in GAMBIA release
17:04:45 <trinaths> if you have any topic to discuss lets proceed else we can sign off the meeting. we can concentrate on our works.
17:05:13 <Amir_m> I have nothing to add
17:05:25 <trinaths> ok.
17:05:51 <trinaths> thank you all for attending today weekly meeting, lets meet next week with some progress in tasks.
17:06:03 <trinaths> #action - ovn sfc scenario - Amir_m
17:06:13 <trinaths> #action ak_dev_ - ovn-openstack charms
17:06:26 <trinaths> #action trinaths - MS8 milestone preperation
17:06:38 <trinaths> #endmeeting