16:30:11 <trinaths> #startmeeting ovn4nfv
16:30:11 <collabot`> Meeting started Tue Apr 24 16:30:11 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:11 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:30:11 <collabot`> The meeting name has been set to 'ovn4nfv'
16:30:17 <trinaths> #chair trinaths
16:30:17 <collabot`> Current chairs: trinaths
16:30:25 <trinaths> Hi
16:30:29 <trinaths> Hi Amir_m
16:30:38 <Amir_m> Trinaths Hi
16:30:49 <trinaths> lets not wait for Aakash, he is preparing for his exams starting tomorrow
16:30:56 <Amir_m> Okay
16:31:22 <trinaths> #link Agenda: https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
16:31:56 <trinaths> #action Debug k8s-ovn chanrms issue. - aakash_kt
16:32:02 <Amir_m> With the help of Ben Pfaf I was able to locate the old build directory and get the config option used to deploy the old version of OVS
16:32:11 <trinaths> Amir_m, how was your PoC moving
16:32:28 <trinaths> Amir_m - super you. Excellent
16:32:49 <Amir_m> The reason I was looking for the old config options is to avoid ending up with two OVSs running on controller and compute nodes
16:33:10 <trinaths> agree.
16:33:20 <trinaths> one question - Why you have two OVS here ?
16:33:48 <Amir_m> After that I tried many times to build the OVS from John repo, but unfortunately things are getting more complictaed
16:34:01 <trinaths> ok.
16:35:06 <Amir_m> as the official manual of OVS says, if you are upgrading you need to use the same config options used with the old deployment to avoid having two OVSs
16:35:34 <trinaths> ok.
16:35:35 <Amir_m> Now, I even can't create vm from openstack
16:35:54 <trinaths> ok.
16:36:13 <trinaths> so what can be a proposed solution.
16:36:21 <Amir_m> I was kind of expecting this to happen
16:36:28 <trinaths> ok
16:37:04 <Amir_m> because we are overlooking higher levels, I mean Openstack (overcloud and undercloud) and OPNFV
16:37:36 <trinaths> ok.
16:37:47 <trinaths> We shall simplify this then.
16:38:11 <trinaths> Since you are aware of the APEX installation, document the same with basic OVN working.
16:38:25 <Amir_m> I think that there should be a cleaner way for doing this upgrade, either through openstack neutron, or via modifying the ansible playbooks used in the OPNFV deployment to force it use John's repo
16:38:26 <trinaths> now for OVN SFC, lets move to devstack for our PoC.
16:38:42 <trinaths> Amir_m +1
16:38:51 <Amir_m> ?
16:38:59 <trinaths> I agree with your comment.
16:39:18 <Amir_m> okay
16:39:45 <Amir_m> And this was waht I included in email to OPNFV-dev mailing list, but got no reply
16:40:34 <trinaths> Can you re-install a fresh environment, and try OVS (john repo) and Openstack Devstack (main branch or queens release) and SFC PoC ?
16:40:48 <Amir_m> I will
16:40:59 <trinaths> opnfv-tech-discuss guys may not reply ovn/ovs specific queries.
16:41:08 <trinaths> ovs-discuss is the main ML.
16:41:24 <Amir_m> okay got it
16:41:37 <trinaths> with your understanding/findings with devstack, we will go with a blue-print to APEX team on required upgrade.
16:42:05 <trinaths> by that time we can have some concrete working solution inplace.
16:42:13 <Amir_m> Sure, I will
16:42:35 <trinaths> ok. I think, by next week you can have a working PoC.
16:42:45 <trinaths> follow, johns devstack guide
16:43:08 <trinaths> #link https://github.com/doonhammer/ovs/blob/sfc.v30/Documentation/tutorials/ovn-openstack.rst#setting-up-devstack
16:43:14 <Amir_m> I have a quick question regarding overcloud
16:43:21 <trinaths> please
16:43:47 <Amir_m> How can I force a reboot to the non-responsive (hanging) overcloud controller
16:44:23 <Amir_m> I tried a couple of KVM solutions but didn't work
16:45:21 <trinaths> too tough for me to answer this now.
16:45:24 <trinaths> #link https://www.slideshare.net/OPNFV/how-many-ohs-an-integration-guide-to-apex-tripleo
16:45:35 <trinaths> but the above link may help a little bit.
16:45:41 <Amir_m> no problem Trinaths
16:45:48 <Amir_m> Thanks
16:45:54 <trinaths> ok.
16:46:49 <trinaths> Next week I will in PTO. so we may not have the weekly meeting. Also, We have F release on 27th April, Friday.
16:47:08 <Amir_m> I know about the F release
16:47:14 <Amir_m> but what is PTO?
16:47:18 <trinaths> please complete the PoC using devstack by 1st of May.
16:47:28 <trinaths> Paid Time Off - Vacation
16:47:42 <Amir_m> okay, enjoy it to the max :))
16:47:52 <trinaths> :)
16:48:38 <trinaths> post the queries to john or ovs-discuss with cc to me. If I have something to help I can ping straight away.
16:48:51 <trinaths> btw, have you received your first stipend ?
16:49:10 <Amir_m> sure I will. and this time if I have issues, I think John will be of a great help to me
16:49:21 <Amir_m> yes I did, thanks for asking
16:49:39 <trinaths> really. true. John will of real help for OVN.
16:51:29 <trinaths> ok. I have nothing more to share.
16:51:41 <Amir_m> me neither
16:52:28 <trinaths> lets end this weekly meeting here. and meet on 8th May.
16:52:47 <Amir_m> okay, thanks Trinaths
16:52:54 <trinaths> #action - Complete OVN-SFC PoC using OpenStack-Devstack (Queens) and johns OVS repo.
16:53:08 <trinaths> thanks Amir_m.
16:53:19 <trinaths> #topic ovn4nfv
16:53:27 <trinaths> #endmeeting