15:30:46 <trinaths> #startmeeting ovn4nfv weekly meeting
15:30:46 <collabot_> Meeting started Tue May 29 15:30:46 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:46 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:46 <collabot_> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:30:52 <trinaths> #chair trinaths
15:30:52 <collabot_> Current chairs: trinaths
15:31:16 <trinaths> #topic Agenda https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:31:30 <trinaths> Hi Amir_m
15:31:35 <Amir_m> Hi Trinaths
15:32:03 <trinaths> Can you share the status of your task
15:32:33 <Amir_m> 1. I've been doing trials to install devstack+ovn pver the past week
15:32:40 <trinaths> ok
15:33:00 <Amir_m> 2. The trials were using CentOS7 and Ubuntu 16.04 LTS
15:33:17 <Amir_m> 3. Non of the trials succeeded :(
15:33:35 <trinaths> oh. Ubuntu 1604 must go well.
15:33:45 <trinaths> what is the issue you are seeing in ubuntu 1604
15:33:46 <trinaths> ?
15:33:47 <Amir_m> 4. On the other hand, installing Devstack is very smooth
15:34:15 <Amir_m> again: installing devstack alone isn't a problem
15:34:33 <trinaths> ok
15:35:13 <Amir_m> the problem is the same on centos and ubuntu, too many arguments to a function
15:35:32 <trinaths> can you post the error to John
15:35:33 <Amir_m> and the worlddump files doesn't tell alot
15:35:48 <trinaths> worlddump might not help on this
15:36:04 <Amir_m> currently I'm trying to install the stable Pike release with ovn
15:36:28 <trinaths> ok.
15:36:40 <trinaths> what is exact OVN/Devstack error you are facing ?
15:37:54 <Amir_m> error in OVS/datapath/linux/flow_netlink.c too many argument to function 'metadata_dst_alloc'
15:38:17 <trinaths> this ovs is from John ovn-sfc 3.0 repo ?
15:38:52 <Amir_m> no I'm trying to install devstack+ovn with the standard repos first to isolate problems
15:39:32 <trinaths> but when you try the same at your university lab you were successful with OVN+Devstack i guess
15:40:06 <Amir_m> it was once and never again
15:40:29 <trinaths> ok.
15:40:34 <Amir_m> My bit is that maybe they synchronized the queens release afterwards
15:40:46 <trinaths> ok.
15:40:53 <trinaths> give a try with Queens release .
15:40:56 <trinaths> then
15:40:56 <Amir_m> that is why I'm trying the pike
15:41:21 <Amir_m> all my trials were using queens
15:41:36 <trinaths> can you try Ocata rather than Pike.
15:41:36 <Amir_m> or in other words the latest
15:42:02 <Amir_m> after the trial with pike finish I will do
15:42:38 <trinaths> please shoot a mail with this error to John and opnfv-tech-discuss and ovs-discuss - brief the devstack environment.
15:42:43 <trinaths> ok
15:42:55 <Amir_m> sure
15:43:43 <trinaths> that way we may get some help from outside while we solve ourselves.
15:43:56 <trinaths> Ok. keep this on running this way.
15:43:58 <Amir_m> no problem
15:44:13 <trinaths> Lets hook to another task.
15:44:27 <trinaths> while both require devstack+ovn
15:45:00 <trinaths> you can get some knowledge on containers and VMs hybrid environment.
15:45:02 <Amir_m> which task do you mean?
15:45:21 <trinaths> this task doesn't require  john ovn-sfc repo.
15:45:38 <Amir_m> ok
15:45:47 <trinaths> normal devstack+ovn can do this.
15:45:58 <Amir_m> do what?
15:46:33 <trinaths> which ever be achieved early
15:46:42 <trinaths> cn+vm hybrid support
15:46:47 <Amir_m> okay
15:47:01 <trinaths> #link http://docs.openvswitch.org/en/latest/howto/openstack-containers/
15:47:40 <trinaths> #link https://github.com/shettyg/ovn-docker
15:48:51 <trinaths> apart from the task ovn-sfc, while in progress please go through, https://github.com/openvswitch/ovn-kubernetes/tree/master/vagrant
15:48:53 <trinaths> #link
15:49:10 <trinaths> #link https://github.com/openvswitch/ovn-kubernetes/tree/master/vagrant
15:49:39 <trinaths> with the above repo you can run ovn with k8s and understand networking with containers.
15:50:08 <trinaths> #link https://blog.russellbryant.net/category/docker/
15:50:41 <trinaths> while john/ovs-discuss/opnfv-tech-discuss reply the errors, try Ovn with CN+VM
15:51:18 <Amir_m> you mean using vagrant
15:51:51 <trinaths> yes. its predefined env. where you have ovn+k8s env
15:52:03 <Amir_m> yes
15:52:37 <trinaths> it will be simple for you to understand container networking and OVN support for container with k8s coe.
15:52:57 <trinaths> I feel you will not have more hardships in this vagrant setup.
15:53:16 <trinaths> please give a try and let's see how it goes.
15:53:25 <Amir_m> sure
15:55:04 <trinaths> but for our cn+vm hybrid support with ovn, we use docker containers - https://github.com/shettyg/ovn-docker
15:55:34 <trinaths> we go for docker containers because installer projects adopt them easily.
15:56:02 <trinaths> #link http://docs.openvswitch.org/en/latest/howto/docker/
15:56:43 <trinaths> #action 1. Amir to send a mail to John, opnfv-tech-discuss and ovs-discuss on ovs related issues.
15:57:11 <trinaths> #action 2. Amir to understand and try ovn+k8s using vagrant setup
15:57:37 <trinaths> #action 3. Amir to try ovn+docker implementation.
15:59:07 <trinaths> Amir_m : in your free time please go through #link http://galsagie.github.io/2015/10/10/kuryr-ovn/ which joins cn with vms via ovn
15:59:32 <Amir_m> copied
16:00:16 <trinaths> ok.
16:01:23 <trinaths> Amir_m : can you try this #link https://github.com/openstack/networking-ovn/tree/master/vagrant/sparse
16:02:30 <trinaths> this can make our life simple for cn+vm scenario with ovn
16:02:33 <Amir_m> what is this?
16:02:43 <Amir_m> ok
16:03:06 <trinaths> ??
16:03:09 <trinaths> #link https://www.siliconloons.com/posts/2016-02-20-ovn-vagrant/
16:05:13 <trinaths> this vagrant box from openstack-devstack #link https://github.com/openstack-dev/devstack-vagrant
16:06:41 <trinaths> Amir_m : please give a try and mail me if you are stuck, we can meet at opnfv-ovn4nfv and solve the issues as they come and reach the milestones.
16:07:06 <Amir_m> okay
16:09:07 <trinaths> Amir_m : i have one thought to share. in ovn+devstack vagrant, check the ovs version and openstack versions. then update ovs with John ovn-sfc repo sfc3.0
16:09:14 <trinaths> try to stack agan.
16:09:16 <trinaths> again
16:09:30 <trinaths> *
16:09:52 <trinaths> see that way our ovn-sfc repo is build with devstack.
16:10:38 <Amir_m> I didn't get you point
16:10:53 <Amir_m> *your
16:11:17 <trinaths> ok.
16:11:37 <trinaths> vagrant boxes are isolated environments.
16:11:47 <trinaths> so from the above links.
16:12:47 <trinaths> download vagrantfile. #link https://github.com/openstack-dev/devstack-vagrant/blob/master/Vagrantfile
16:13:11 <trinaths> start the box and check the ovs and devstack based openstack versions
16:13:30 <trinaths> there by  verify OVN functionality.
16:13:59 <trinaths> then replace the ovs with John's OVS ovn-sfc repo and restack devstack.
16:14:06 <trinaths> lets see how it goes.
16:14:53 <Amir_m> I recall that one of John's colleagues was using vagrant env. to demonstrate sfc using ovn
16:14:53 <trinaths> dont do this change when ovs version in vagrant box is much differed to John's OVS version.
16:15:00 <trinaths> yes.
16:15:02 <trinaths> true said.
16:15:35 <trinaths> put a mail on this to John. may be he can share the vagrantFile with us.
16:15:48 <trinaths> this can make our task simple.
16:15:50 <trinaths> :)
16:15:54 <Amir_m> okay
16:17:05 <trinaths> #action 4. Amir to discuss with John on ovn-sfc vagrant file.
16:17:36 <trinaths> Amir_m: I think with vagrant env, we can move fast on our goals.
16:18:03 <Amir_m> me too
16:18:11 <trinaths> Amir_m : please let me know right at the moment, when you are struck any where. I will surely help you.
16:18:46 <trinaths> please mail me the issue, and we can discuss the same at #opnfv-ovn4nfv irc chat room or by email
16:18:53 <Amir_m> I will
16:19:08 <trinaths> ok.
16:19:30 <trinaths> #action 5. Trinath to tag the ovn repo with 6.1 F release.
16:19:53 <trinaths> #action 6. Trinath to focus on ovn for edge initiatives
16:20:37 <trinaths> Amir_m : I think we have much tasks elaborated to achieve while we meet next week.
16:21:00 <trinaths> Amir_m: please keep posting your tasks status, so that we can meet the goals on time.
16:22:45 <trinaths> #topic open discussion
16:23:05 <trinaths> Amir_m you have anything to discuss
16:23:26 <Amir_m> No I don't
16:23:43 <Amir_m> thank you
16:23:51 <trinaths> ok. can we end the meeting. we still have 7 more mins
16:24:03 <Amir_m> yes you can
16:24:13 <Amir_m> thanks again
16:25:00 <trinaths> Amir_m: ok thank you
16:25:28 <trinaths> #endmeeting