15:30:51 <trinaths> #startmeeting ovn4nfv_weeklymeeting
15:30:51 <collabot_> Meeting started Tue Jun  5 15:30:51 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:51 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:51 <collabot_> The meeting name has been set to 'ovn4nfv_weeklymeeting'
15:31:10 <trinaths> #chair trinaths
15:31:10 <collabot_> Current chairs: trinaths
15:31:44 <trinaths> #link Agenda: https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:32:03 <trinaths> Amir_m Hello
15:32:05 <Amir_m> Hello Trinaths
15:32:40 <trinaths> Amir_m - hope your vacation is going well and holy month is moving good.
15:33:03 <Amir_m> Yes everything is going well, thanks
15:33:07 <trinaths> ok.
15:33:17 <Amir_m> Finally
15:33:25 <trinaths> ...
15:33:38 <Amir_m> I was able to install Devstack with SFC
15:33:43 <trinaths> super
15:33:45 <trinaths> excellent
15:33:58 <Amir_m> and launched 3 vms, 2 vnfs
15:34:03 <Amir_m> created 2 sfcs
15:34:20 <Amir_m> tested them with ovn trace and it is working
15:34:30 <trinaths> very nice
15:34:32 <trinaths> wonderful
15:34:34 <trinaths> :)
15:34:40 <Amir_m> :D
15:34:45 <Amir_m> aha
15:34:51 <trinaths> what might be the issue with our CentOS
15:34:58 <Amir_m> this was all thanks to Numan Siddique advice from redhat
15:35:22 <Amir_m> to disable building the kernel modules
15:35:30 <trinaths> hey! numan is a nice guy. He works for networking-ovn openstack project
15:36:22 <Amir_m> I've documented everything so that reproducing the environment from Centos installation until sfc creation will be easy
15:36:47 <trinaths> ok.
15:37:26 <Amir_m> also as a side I was reading the resources you pointed out in our last meeting, but didn't want to disrupt the devstack+sfc environment
15:37:39 <trinaths> agree.
15:38:00 <trinaths> but you can spawn another vm and try ovn+cn setup
15:38:26 <Amir_m> I installed the devstack on physical machine
15:38:46 <trinaths> Amir_m - oops. any reason for that
15:38:54 <Amir_m> I will try spawning a VM
15:39:11 <Amir_m> for the OVN+CN
15:39:36 <trinaths> ok.
15:39:39 <Amir_m> not a specific reason
15:39:43 <trinaths> ok.
15:40:37 <trinaths> For our MS1 we need to do PoC on Apex Installer based environment. So we need to document the diff  - what is required to push ovn+sfc into apex installer.
15:41:50 <Amir_m> any recommendation about the start point in this regard
15:42:04 <Amir_m> ?
15:42:09 <trinaths> yes. Last time when you tried Apex installer based setup.
15:42:25 <trinaths> what are your finding for OVN upgrade ?
15:42:51 <Amir_m> it was mainly the OVS version that doesn't support sfc
15:43:13 <Amir_m> and our many trials that failed to install OVS from John's repo
15:43:18 <trinaths> ok.
15:43:37 <trinaths> how are they successful today in our devstack environment ?
15:43:49 <Amir_m> it was very smooth
15:43:53 <trinaths> ok.
15:44:07 <Amir_m> I did the following modifications to the local.conf file:
15:44:33 <Amir_m> - Added (unicomminted and edited) 		OVN_REPO=https://github.com/doonhammer/ovs 		OVN_BRANCH=sfc.v30 	- Uncommented this line  		OVN_BUILD_MODULES=False
15:45:08 <trinaths> With this guidance, we need to bringup new ovs and sfc on Apex environment.
15:45:36 <trinaths> As I see with your project page, #link https://wiki.opnfv.org/pages/viewpage.action?pageId=13210692
15:46:22 <Amir_m> Do you mean doing so in cooperation with the apex team?
15:46:34 <trinaths> community collaboration might get slower since we need to align with their roadmap to integrate our PoC and gain support from Apex Installer for our new scenario
15:46:52 <trinaths> yes - in collaboration with apex team.
15:47:25 <trinaths> #action trinaths - To add JIRA tickets in APEX project regarding OVS changes and PoC.
15:48:38 <trinaths> #action Amir_m - To submit detailed setup and PoC documentation to ovn4nfv project for gerrit review.
15:48:58 <Amir_m> using Devstack?
15:49:42 <trinaths> for now let it be devstack. We will merge the docs when Apex based instructions are available
15:49:51 <Amir_m> okay
15:50:20 <Amir_m> the detailed doc is already available as I said above
15:50:28 <trinaths> #action Amir_m - replicate ovn-sfc on Apex environment.
15:50:44 <trinaths> okay.
15:51:08 <Amir_m> I think this is the time to start reading about apex integration, right?
15:51:15 <trinaths> true said.
15:51:39 <trinaths> but parallely ovn-cn-vm scenario too.
15:51:51 <Amir_m> okay :)
15:52:37 <trinaths> yes. we have our backlog and MS1 still in progress.
15:52:57 <trinaths> :)
15:53:36 <trinaths> #action Amir_m - Understand Apex installer fundamentals and integration required for OVN-SFC scenario.
15:55:33 <trinaths> Okay.
15:55:38 <Amir_m> okay
15:56:00 <trinaths> Amir_m - Is your university lab ready ?
15:56:39 <Amir_m> I didn't contacted the sys admin, as I was satisfied by the machine I bought
15:57:04 <Amir_m> But it should be ready, I will contact him to make sure it is ready
15:58:14 <trinaths> Since, for installing the setup with Apex installer, you need a high end machine as you have at your university.
15:58:44 <Amir_m> yes, I understand
16:00:04 <trinaths> ok. please enquire about its status. so that we can complete that task too..
16:00:15 <Amir_m> sure
16:00:26 <trinaths> I think we are on track now with our tasks.
16:00:55 <Amir_m> I'm happy to read these words from you :)
16:01:40 <trinaths> :)  really.
16:02:15 <Amir_m> of course, it was a series of disappointments every time a trial fails
16:02:32 <trinaths> ok. Lets move with same confidence and finish ovn-cn-vm too.. so that we can collaborate with apex team.
16:02:58 <Amir_m> okay
16:03:19 <trinaths> I have nothing more to discuss. Lets meet next week with some progress on action items. please let me know you have some thing to discuss else we can end this meeting.
16:03:35 <Amir_m> sure
16:03:44 <Amir_m> I nothing at my end
16:03:49 <Amir_m> thanks for your time
16:03:59 <trinaths> ok.
16:04:25 <trinaths> please continue with conquering the action items.
16:04:38 <Amir_m> ok
16:04:38 <trinaths> thanks for the excellent work.
16:04:46 <trinaths> #endmeeting