15:30:26 <trinaths> #startmeeting OVN4NFV Weekly Meeting
15:30:26 <collabot_> Meeting started Tue Jun 12 15:30:26 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:26 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:26 <collabot_> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:30:33 <trinaths> #chair trinaths
15:30:33 <collabot_> Current chairs: trinaths
15:33:07 <trinaths> #topic Agenda #link https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:33:13 <trinaths> hi Amir_m
15:33:24 <Amir_m> Hello Trinaths
15:34:15 <trinaths> with respect to you committer rights, you have not signed contribution agreement i think.
15:34:38 <Amir_m> yes
15:34:47 <trinaths> let Aric or Ray clarify this and give you the document to provide you with contribution rights.
15:35:05 <Amir_m> I think you already replied to Aric in this regard
15:35:20 <trinaths> yes.
15:35:30 <Amir_m> I will just wait until tomorrow, if no reply I will follow up
15:35:41 <trinaths> agree.
15:36:27 <trinaths> #topic Action Items
15:38:27 <trinaths> 1, Replicate ovn-sfc on Apex environment
15:38:52 <Amir_m> I've read the Apex integration guide and watched Dan Radez and Tim Rozet on this regard
15:39:08 <trinaths> Amir_m - is the server at your university lab up ?
15:39:21 <Amir_m> yes
15:40:03 <trinaths> ok. Any update on Apex integration.
15:40:06 <Amir_m> but I don't know what is the start point, to do such replication
15:40:18 <Amir_m> I've read the Apex integration guide and watched Dan Radez and Tim Rozet on this regard
15:40:32 <trinaths> ok. Do this way.
15:40:59 <trinaths> step 1: Install OPNFV environment with Apex installer
15:41:13 <trinaths> step 2: enable ovn4nfv scenario.
15:41:39 <trinaths> step 3: update the environment manually to realize SFC usecase.
15:42:07 <trinaths> step 4: run the SFC usecase.
15:42:29 <Amir_m> do you mean, like what we were trying to do previously?
15:42:31 <trinaths> step 5: capture the changes for integration with apex installer.
15:42:38 <trinaths> Amir_m - yes.
15:43:20 <trinaths> what are the pitfalls at that time we learned for the integration ?
15:43:51 <Amir_m> What is the SFC usecase?
15:44:14 <Amir_m> mainly the OVN repo didn't support sfc
15:45:17 <trinaths> agree. we need to update the old repo with Johns repo.
15:45:37 <Amir_m> okay
15:46:10 <Amir_m> But I think I will need to contact Tim and/or Dan a lot to get this done
15:46:24 <trinaths> can you give a try on this.
15:46:29 <Amir_m> sure
15:46:31 <trinaths> Dan moved to some other projects
15:46:45 <trinaths> we have Tim as the only contact.
15:46:53 <Amir_m> okay
15:47:36 <trinaths> please put a mail to Tim with CC to me on this. lets see how it moves.
15:47:44 <Amir_m> sur
15:47:53 <Amir_m> *sure
15:47:56 <trinaths> but in mean time try how we can locally update the ovs repo and fix this.
15:48:16 <Amir_m> what do you mean by locally?
15:48:51 <trinaths> like, hacking apex installed environment. and then listing the fixes required to realize the sfc scenario.
15:49:11 <Amir_m> ok, got you
15:50:36 <trinaths> we ourselves cannot integrate the list of fixes we have for OVN sfc scenario. We need the approval/time and collaboration with apex team to do this.
15:51:40 <trinaths> so put a mail to Tim Rozet (redhat) and try hacking apex installed environment to integrate sfc scenario.
15:51:49 <trinaths> agree ?
15:51:59 <Amir_m> agree
15:52:09 <trinaths> ok.
15:52:50 <trinaths> (2) ovn cn-vm scenario
15:52:53 <Amir_m> for the vm+cn scenario, I have a question
15:52:59 <trinaths> yes please
15:53:20 <Amir_m> do you want me to deploy ovn+Docker
15:53:31 <Amir_m> or ovn+K8s
15:53:35 <Amir_m> or both
15:53:37 <trinaths> ovn_k8s
15:53:42 <trinaths> no both.
15:53:57 <Amir_m> okay
15:54:15 <trinaths> since apex and joid installers both support k8s+ovn scenario,
15:54:18 <Amir_m> another question do you want me to try the overlay or the underlay
15:54:29 <trinaths> also k8s can orchestrate VMs along with CNs,
15:55:11 <Amir_m> another question do you want me to try the overlay or the underlay?
15:55:25 <trinaths> we will use k8s + ovn for support for our hybrid scenario.
15:55:33 <trinaths> this make our work a bit easier.
15:56:06 <trinaths> doubts ?
15:56:21 <trinaths> #link https://www.mirantis.com/blog/virtlet-run-vms-as-kubernetes-pods/
15:57:07 <Amir_m> did you see my overlay or underlay question above?
15:58:20 <trinaths> Amir_m - overlay or underlay ? can you be more clear
15:59:08 <Amir_m> in the ovn-K8s you can deploy over and Openstack or without openstack
15:59:57 <trinaths> can you look how apex and joid k8s+ovn scenarios are doing?
16:00:05 <Amir_m> sure
16:00:22 <Amir_m> in the latest release, right?
16:01:29 <trinaths> ok. update - in Fraser, they remove the scenario k8s+ovn in Apex.
16:01:49 <Amir_m> so in Euphrates I will need to check
16:03:36 <trinaths> wait. sorry, my mistake - odl+k8s is supported in apex.
16:03:44 <trinaths> not ov+k8s
16:03:52 <trinaths> #link https://wiki.opnfv.org/display/SWREL/Euphrates+Scenario+Status
16:04:00 <trinaths> #link https://wiki.opnfv.org/display/SWREL/Fraser+Scenario+Status
16:05:12 <Amir_m> in Euphrates: k8-ovn-lb-noha	JOID
16:05:22 <trinaths> yes.
16:05:27 <trinaths> only JOID is supporting.
16:05:37 <trinaths> lets do this way.
16:06:11 <trinaths> step 1 - Install opnfv F with Joid. scenarion k8s-ovn-lb-noha.
16:06:54 <trinaths> step 2 - upgrade k8s with virtlet.
16:07:20 <trinaths> step 3 - understand how OVN k8s is working in JOID.
16:08:15 <trinaths> step 4 - using k8s + ovn - spawn CN and VM.
16:08:31 <trinaths> step 5 - check the connectivity between CN and VM via OVN
16:09:25 <trinaths> Amir_m - comments ?
16:09:25 <Amir_m> will the jump server take both Apex and JOID
16:09:25 <Amir_m> installations?
16:09:25 <trinaths> no. any one - one time
16:09:35 <Amir_m> but the priority is for ...?
16:09:59 <trinaths> tasks 1 - Apex OVN SFC
16:10:11 <trinaths> Task 2 - Joid OVN CN VM
16:10:18 <Amir_m> okay
16:10:38 <trinaths> but for task 2 to do a PoC, try k8s locally with VM and CN on OVN.
16:11:13 <trinaths> understand the environment so that when Joid comes in place, it will be easy to integrate.
16:11:20 <Amir_m> ok
16:12:23 <trinaths> #action - work with LF team for contributor rights - Amir_m
16:13:07 <trinaths> #action ovn sfc scenario integration with apex installer. - list of fixes and user guide.
16:13:28 <trinaths> #action ovn vm cn scenario PoC with K8s.
16:14:09 <trinaths> i think we are focused on our goals.
16:14:24 <trinaths> ?
16:14:26 <Amir_m> Yes we are
16:14:37 <trinaths> #topic Test cases
16:15:29 <trinaths> now that we have some thing working, we need to write functional tests for scenarios we are working on.
16:16:40 <trinaths> #action - Functional test for scenario - outline (trinaths)
16:17:18 <trinaths> functional tests account when we have the scenarios ready and integrated into installers.
16:18:18 <trinaths> but we shall write the functional tests once we complete document the list of changes required to do manually to realize scenarios in respective installers.
16:18:45 <trinaths> lets have this in our TODO.
16:19:00 <trinaths> valsee - Hi
16:19:41 <trinaths> ok. thats all from my end.
16:19:49 <Amir_m> is there any perf. tests that should be written, they general to any scenario
16:20:23 <trinaths> i think no. at this moment. since we are showcasing any platform here.
16:20:46 <trinaths> I will find this out how we go with tests.
16:21:54 <Amir_m> great
16:22:04 <Amir_m> I've nothing more to add
16:23:11 <valsee> trinaths: Hi
16:23:21 <trinaths> may be we can have perf.tests like #link https://blog.russellbryant.net/2017/05/30/ovn-geneve-vs-vxlan-does-it-matter/
16:23:56 <trinaths> its a comparison with encapsulation
16:24:29 <trinaths> valsee - its OVN4NF meeting you have something to share.
16:25:30 <trinaths> we have 5 more minutes to go.
16:25:37 <trinaths> #topic Open discussion
16:26:09 <trinaths> Amir_m ?
16:26:14 <trinaths> valsee ?
16:26:29 <Amir_m> Trinaths: next Friday and Monday i will be on vacation () eid Al-fetr
16:27:05 <trinaths> Amir_m - okay. Will you attend the weekly meeting on tuesday ?
16:27:13 <Amir_m> yes
16:27:14 <valsee> trinaths: not yet
16:27:29 <trinaths> Amir_m - Happy Eid Al fetr.
16:27:43 <trinaths> valsee - can you introduce yourself.
16:27:43 <Amir_m> Thanks Trinaths
16:28:45 <valsee> Thanks
16:29:08 <trinaths> #endmeeting