15:37:12 <trinaths> #startmeeting OVN4NFV Weekly Meeting
15:37:12 <collabot> Meeting started Tue Jul 24 15:37:12 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:37:12 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:37:12 <collabot> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:37:21 <trinaths> #chair trinaths
15:37:21 <collabot> Current chairs: trinaths
15:38:01 <Amir_m> Sorry for being late
15:38:17 <Amir_m> I was stuck in a meeting with my supervisor
15:38:24 <trinaths> no worries.
15:38:41 <trinaths> #agenda #link https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:39:18 <trinaths> Amir_m : Hi, how are you doing.. Hope your vacation went well. Fully into your acadamics
15:39:47 <Amir_m> The vacation was dramatic (the Army issue)
15:39:57 <Amir_m> and yes I'm back into academic
15:40:09 <trinaths> oh!, what was the Army issue ?
15:40:54 <Amir_m> I served for 3 years as reserve officer, and I'm under recall untill the age 46
15:41:15 <Amir_m> I got a recall when I was here in Canda, but I couldn't answer that call
15:41:44 <Amir_m> so I got a lawsuit that I had to figure out, to be allowed to leave the country again
15:41:58 <trinaths> How you are planing to continue the work now? Have you got the server with you ? or your University server ready for use ?
15:42:16 <trinaths> oh! ok. Its happy you are back to academics again. :)
15:42:29 <Amir_m> university server is ready and I've already installed Fraser release on it
15:42:49 <trinaths> ok.
15:42:58 <trinaths> #topic Action Items
15:43:34 <Amir_m> the blocker now is how to realize the OVN-VM-SFC scenario
15:43:39 <trinaths> ok
15:43:46 <trinaths> what is issue you are facing.
15:44:26 <Amir_m> Tim's suggestions was mainly pointing to how to modify the 'overcloud-full.sh' file
15:44:39 <trinaths> can you point me to that file.
15:44:54 <Amir_m> this file isn't available in undercloud or overcloud deployments
15:45:05 <Amir_m> it is only available on github
15:45:53 <Amir_m> #link https://github.com/opnfv/apex/blob/stable/fraser/build/overcloud-full.sh#L173
15:47:31 <trinaths> I think RPMs does this task. Have you tried execute the file in overcloud deployment.
15:47:44 <Amir_m> How?
15:48:18 <Amir_m> when you deploy OPNFV, every thing happens without your intervention
15:48:37 <Amir_m> I mean the undercloud and then the overcloud deployments
15:50:37 <trinaths> agree.
15:51:11 <trinaths> As per Tim email, I think we need to build the RPMs with appropriate changes to FRASER repo. and install the RPMs.
15:51:30 <trinaths> Hi Trinath, Amir,
15:51:42 <trinaths> as per the Tim reply above
15:52:27 <Amir_m> I agree to and this was in my reply to your email.
15:52:35 <Amir_m> But how to do this?
15:52:49 <trinaths> again, from Tim mail,
15:52:50 <trinaths> We may need to do something similar but in python (we no longer build artifacts in bash) here to compile and/or install the new OVS in master branch:
15:53:19 <Amir_m> is there any tutorial I can follow or something similar
15:54:08 <trinaths> lets get the help on OVN deployment and there by help on adding John OVN SFC.
15:56:01 <Amir_m> Get the help from who? Tim?
15:56:12 <trinaths> yes. Is that really RPMs ?
15:56:18 <trinaths> or ansible playbooks. ?
15:57:59 <Amir_m> I'm not sure, but I think it is RPMs. By modifying the build files that produces the RPMs, then use these RPMs to deploy OPNFV
16:00:23 <trinaths> can we clone this repo and try modify the file and build RPMs and there by use them  for the deployment ?
16:02:15 <Amir_m> I tried to locate where should I modify to point to John's OVN-SFC repo, but wasn't lucky to find
16:04:44 <trinaths> as said, in mail from Tim, its .py files from master branch we need to use to generate rpms. but as per the master branch I see playbooks too.
16:05:05 <trinaths> for undercloud, are they using playbooks ?
16:05:16 <Amir_m> I have no clue
16:05:24 <trinaths> ok
16:05:58 <trinaths> #action trinaths To investigate on Apex deployments with RPMs/Playbooks.
16:06:20 <trinaths> I have put a mail to Tim, hope you have received the same
16:07:18 <trinaths> since, we have VM-SFC solution working with John Repo, lets wait for Tim inputs and finalize the solution.
16:07:48 <trinaths> #action trinaths Amir_m - Discuss with Tim from Apex team on integration issues.
16:08:04 <trinaths> Agree ?
16:08:44 <trinaths> thoughts ?
16:09:15 <Amir_m> okay
16:09:42 <Amir_m> but as you know it took me two trials over 3-4 weeks to get a reply from Tim
16:10:04 <trinaths> agree. let me haunt him
16:10:11 <Amir_m> please
16:10:30 <trinaths> yes. or we will haunt the TSC guys for ample guidance
16:11:22 <trinaths> ok,
16:11:35 <trinaths> #topic VM CN OVN - Hybrid Support.
16:12:14 <trinaths> For both these use-cases, we need Tim's help
16:12:32 <trinaths> Amir_m - how were you able to go with this ?
16:12:57 <Amir_m> I believe if we sorted out the first scenario, it will be easier for the second one
16:13:16 <trinaths> both are of different kind.
16:13:46 <trinaths> in the first scenario, we have proved the solution as awaiting integrate to Apex installer.
16:14:05 <trinaths> in the second scenario, we haven't proved the solution.
16:14:08 <trinaths> Agree ?
16:14:11 <trinaths> comments ?
16:14:24 <Amir_m> I started to work on the second but I left the machine in Egypt and now I have only one server to work on
16:14:30 <Amir_m> Yes
16:14:50 <trinaths> oh!.
16:15:47 <Amir_m> I will try to secure a small extra machine here, but this is not guranteed
16:15:51 <trinaths> you need vacation again ?
16:15:57 <Amir_m> why
16:16:20 <trinaths> to bring back the server. :)
16:16:27 <Amir_m> :))
16:16:44 <Amir_m> As I said I'll try to get a small extra machine
16:17:29 <trinaths> ok. sounds good.
16:17:47 <trinaths> ok. Were you able to bring up the setup with k8s ?
16:18:45 <Amir_m> T be honest I don't remember, lots of things happened since then
16:18:54 <trinaths> We need with to prove ours PoCs soon, so that we have ample time to work with communities to integrate our work
16:19:10 <trinaths> ok.
16:19:20 <Amir_m> I will do my best in this regard
16:19:28 <trinaths> May be we need to start k8s scenario then.
16:19:46 <Amir_m> ok
16:19:57 <trinaths> lets do this way, using k8s and ovn plugin, we can always bring up the CN OVN environment.
16:20:14 <trinaths> its proved by JOID and APEX installer.
16:21:51 <trinaths> sorry, I think only JOID.
16:21:57 <trinaths> but Apex supports K8s
16:22:02 <Amir_m> Yes I was checking
16:22:12 <Amir_m> it is only JOID for K8-OVN
16:22:23 <trinaths> k8s-odl-nofeature-noha
16:22:34 <trinaths> from Apex.
16:22:44 <Amir_m> yes
16:23:24 <trinaths> For the second scenario, the below are our task items
16:23:38 <trinaths> 1. k8s CN OVN scenario.
16:23:53 <trinaths> 2. K8s Kubevirt VM
16:24:07 <trinaths> 3. K8s CN VM OVN Scenario
16:24:30 <trinaths> 4. (if possible) K8s Multus multi interface CN VM OVN scenario.
16:24:54 <trinaths> we need to clear one by one from 1 to 3 for our usecase.
16:25:08 <Amir_m> okay
16:25:51 <trinaths> for each step, please update me on any issues and completeness. Also please document the same.
16:26:15 <Amir_m> I will do. I always document my work
16:26:57 <trinaths> step 4 is not required. but its interesting to working with K8s and multus CNI plugin for CN VM scenarios with OVN. its helpful when CN+VM OVN SFC is required.
16:27:29 <trinaths> #action Amir_m - Work on k8s CN VM OVN Scenario.
16:28:26 <trinaths> Amir_m - please put some extra effort to complete this CN VM OVN scenario. Apex integration requires more time. and you may need to submit work for Apex project.
16:29:00 <Amir_m> okay
16:30:07 <trinaths> Amir_m - let me know immediately if need any help. I will always help you achieve these milestones.
16:30:21 <Amir_m> sure
16:30:32 <trinaths> we are to the end of this meeting. thank you for you dedication and good work.
16:30:50 <Amir_m> thanks you Trinath
16:30:58 <trinaths> lets discuss via emails and meet with some good work in hand in our next meeting.
16:31:13 <Amir_m> ok
16:31:35 <trinaths> Amir_m - I was happy, I haven't expected you to be fast in learning and finishing ovn-sfc PoC. really a nice work.
16:31:48 <Amir_m> Thanks
16:32:07 <trinaths> ovn-sfc is a bit challenging when compared to ovn-cn-vm scenario.
16:32:25 <trinaths> its always fun at learning and reaching the milestones.
16:32:34 <Amir_m> sure
16:32:38 <trinaths> bye
16:32:41 <trinaths> #endmeeting