15:32:21 <trinaths> #startmeeting ovn4nfv-meeting
15:32:21 <collabot> Meeting started Tue Aug  7 15:32:21 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:21 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:32:21 <collabot> The meeting name has been set to 'ovn4nfv_meeting'
15:32:28 <trinaths> #chair trinaths
15:32:28 <collabot> Current chairs: trinaths
15:32:56 <trinaths> #link Agenda - https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:32:59 <trinaths> hi Amir_m
15:33:10 <Amir_m> Hi Trinaths
15:33:51 <trinaths> Amir_m:  Can you update me on the tasks
15:34:03 <trinaths> Openstack TripleO Heat template - https://review.openstack.org/#/c/587491/
15:34:26 <trinaths> there were no reviews, I was chasing the tripleo guys but need more attention from them
15:34:45 <trinaths> as thought it take more time.
15:35:01 <Amir_m> I wasn't successful in getting a machine from my school, so I bought a small used machine for my trials
15:35:48 <Amir_m> according to this link #link https://github.com/openvswitch/ovn-kubernetes I need OVS installed first
15:36:11 <trinaths> ok. I thought of working with TSC OPNFV on getting a new lab server hosted by partner companies.
15:36:18 <Amir_m> so I was struggling with getting OVS installed on Ubuntu from John's repo
15:36:37 <Amir_m> I was getting this error: SSL error:02001002:system library:fopen:No such file or directory: bss_file.c:175
15:37:11 <Amir_m> So currently I'm trying to generate the packages myself from the John's repo source
15:37:30 <Amir_m> I'm following this #link https://sites.google.com/site/nandydandyoracle/openvswitch-ovs/ovs-source-build-ubuntu-linux-16-04
15:38:35 <trinaths> #action trinaths Discuss with OPNFV TSC or XCI guys on a server for OVN scenario development and testing
15:39:08 <trinaths> Amir_m: Previously it worked for us. Now why we are getting this error. Did we go for a different method ?
15:39:22 <Amir_m> previously it didn't work
15:39:37 <trinaths> oops!.
15:39:55 <Amir_m> I'm installing OVs/OVN alone not as a prt of Devstack
15:39:55 <trinaths> we have installed Johns OVS and run OVN SFC.
15:39:58 <trinaths> correct ?
15:40:37 <Amir_m> yes we did but as part of Devstack not standalone installation
15:41:08 <trinaths> ok.
15:41:12 <trinaths> Can you try, https://github.com/openvswitch/ovn-kubernetes/blob/master/docs/INSTALL.UBUNTU.md
15:41:26 <trinaths> I mean, https://github.com/openvswitch/ovn-kubernetes/blob/master/docs/INSTALL.UBUNTU.md#installing-ovs-and-ovn-from-sources
15:42:05 <Amir_m> This actually the tutorial I'm following and getting the error
15:42:24 <trinaths> ok. can you try with a apt-get update and upgrade.
15:42:50 <trinaths> before compiling the sources.
15:42:53 <Amir_m> I'm getting the error when make modules_install
15:43:36 <trinaths> ok.
15:43:59 <trinaths> https://mail.openvswitch.org/pipermail/ovs-discuss/2017-May/044409.html
15:44:34 <trinaths> #link https://mail.openvswitch.org/pipermail/ovs-discuss/2017-May/044410.html
15:44:57 <trinaths> can you check with that mailing list.
15:45:26 <trinaths> Amir_m: I have a suggestion. Rather that waiting for your school to provide the VM,
15:45:45 <trinaths> can you grab a trial account in GCP and spawn a VM and try on that ?
15:46:00 <trinaths> thoughts ?
15:46:02 <Amir_m> I'm already working on the machine I bought
15:46:13 <trinaths> up to certain level of usage its free for 12 months
15:46:21 <trinaths> Amir_m:  ok. sounds good.
15:46:42 <Amir_m> I've already mentioned this in my first line in this log
15:47:03 <trinaths> agree. just want to suggest, :)
15:47:29 <trinaths> Amir_m: any oppurtunity to discuss with Apex guys on Tripleo patches ?
15:47:46 <Amir_m> What do you mean by discuss
15:48:18 <Amir_m> I submitted a file that has only one modified line
15:49:02 <Amir_m> I'm waiting for feedback from them on weather we will need to add more files or what are the next steps needed from our side
15:49:20 <trinaths> I mean by "discuss" irc chat with reviewers at apex channel.
15:49:29 <trinaths> Amir_m: agree.
15:49:45 <trinaths> these guys are not active with reviews. as I see
15:49:55 <Amir_m> To be honest I'm not familiar with IRC chats
15:50:02 <trinaths> ok. No issues.
15:50:08 <trinaths> I will look into them
15:50:13 <Amir_m> But welling to give a hand if I get to know how
15:50:29 <trinaths> +1
15:52:24 <trinaths> There is development lead from intel guys on OVN4NFV where they want to host a repo of forked OVS with their changes into our repo.
15:52:41 <trinaths> hope you had a look at the mail conversation
15:53:05 <Amir_m> Yes I did. the one Sirni
15:53:11 <Amir_m> *with
15:53:32 <trinaths> #link https://lists.opnfv.org/g/opnfv-tech-discuss/topic/ovn4nfv_discuss_about_ovn/24217788?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,24217788
15:53:35 <trinaths> yes.
15:54:13 <trinaths> Srini is the principal Architect NFV and SDN at Intel. I worked with him for 10 years.
15:54:58 <trinaths> the new development in C will benefit ovn for NFV and edge.
15:55:18 <Amir_m> How can I help in this front?
15:55:20 <trinaths> ok. I believe we are focused on ovn-cn-vm task.
15:55:37 <trinaths> Amir_m:  test or contribute code as per the requirement.
15:56:37 <trinaths> But that need a CI/CD process in place to host a repo within our ovn4nfv repo.
15:56:48 <trinaths> this requires TSC/XCI community approval.
15:58:01 <trinaths> Amir_m: I think, we are done with our meeting.
15:58:31 <Amir_m> Ok, I have nothing to add
15:58:37 <trinaths> Amir_m: lets focus on ovn-vm-cn scenario and come up with a success story.
15:58:41 <Amir_m> Will keep you posted
15:58:48 <Amir_m> Thanks Trinaths
15:58:52 <trinaths> ok. thank you Amir_m
15:59:14 <trinaths> I will wait for some time till I see srini join the meeting.
15:59:32 <trinaths> Amir_m: you may wait or leave the meeting for your next works.
16:00:00 <Amir_m> I will wait silently :))
16:00:11 <trinaths> me too :)
16:20:10 <trinaths> ok. Thank you attending the meeting. lets meet next week with good work.
16:20:15 <trinaths> #endmeeting