15:31:37 <trinaths> #startmeeting ovn4nfv Weekly meeting
15:31:37 <collabot> Meeting started Tue Aug 14 15:31:37 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:37 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:37 <collabot> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:32:17 <trinaths> #chair trinaths
15:32:17 <collabot> Current chairs: trinaths
15:32:52 <trinaths> #link Agenda - https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:32:56 <trinaths> hi Amir_m
15:33:22 <Amir_m> Hi Trinaths
15:35:23 <trinaths> Amir_m: how are you doing.
15:35:45 <Amir_m> I'm good. How about yourself?
15:35:54 <trinaths> #topic Openstack TripleO Heat template - https://review.openstack.org/#/c/587491/
15:36:55 <trinaths> Amir_m:  I have seen comments on gerrit.
15:37:15 <Srini_> Ok. I am here.
15:37:22 <Srini_> Hi Trinath, Srini here.
15:37:35 <trinaths> Let's put a mail to Tim and Sravanan on the review comments and suggestions
15:37:39 <trinaths> Srini_:  Hi
15:37:51 <trinaths> Srini_: how are you doing?
15:38:01 <Srini_> Very good Trinath. How about you?
15:38:13 <trinaths> Srini_: I'm good too.
15:38:29 <Srini_> I need to leave in another 20 minutes for my 9:00AM call.
15:38:35 <trinaths> ok.
15:38:42 <Srini_> Can we discuss about OVN changes?
15:39:07 <trinaths> Amir_m:  can we discuss the tripleo template changes after Srini_ discussion ?
15:39:13 <Amir_m> sure
15:39:21 <Srini_> Thanks Amir and Trinath.
15:39:25 <trinaths> thank you
15:39:30 <Srini_> Let me give brief background.
15:39:42 <trinaths> Srini_:  yes, Please give the work details
15:39:59 <Srini_> We are working on K8S based Edge deployment.
15:40:21 <Srini_> to deploy containerized VNFs from ONAP.
15:40:44 <Srini_> As you may know, networking workloads are different from the Enterprise application workloads.
15:40:54 <trinaths> agree
15:41:12 <Srini_> In case of networking workloads, multiple virtual interfaces need to be attached to the container.
15:41:28 <trinaths> ok
15:41:38 <Srini_> FOr example, in firewall container, one might like to have protected interface, DMZ interfaces and External interface.
15:41:49 <trinaths> ok
15:42:05 <Srini_> In today OVN-Kubernetes, it is not possible to assign more than one virtual network interface.
15:42:23 <trinaths> Using Multus ?
15:42:38 <Srini_> To make OVN to be leveraged for network functions, we had to make some changes to OVN and we did them.
15:43:15 <Srini_> Since OVN4NFV project is meant to make OVN for NFV, we felt that this is right home to put the changes here.
15:43:56 <trinaths> ok
15:44:24 <Srini_> Hence the request for fork OVN in OVN4NFV project and contribute changes there. Once it is done, we will need to work with OVN team to upstream them. We want to take baby step now to create repo and make changes.
15:44:43 <Srini_> I am done :-) and comments and suggestions please.
15:45:15 <Srini_> Multus - Yes, even with that, there are issues in OVN. Hence, we made changes to OVN.
15:45:30 <trinaths> Srini_:  :-) as per our mail conversation, ovn4nfv project repo (other project repos) currently hold only OPNFV release specific stuff.
15:45:38 <Srini_> Multus works okay with other CNIs such as flannel. But not OVN unfortunatley.
15:46:09 <trinaths> Srini_:  so you want to work on Multus too for those changes ?
15:46:26 <Srini_> There are no changes required in Multus.
15:46:52 <Srini_> Only OVN changes required.
15:47:57 <Srini_> On your question on relevancy for OPNFV:  Current OVN is meant for Enterprise app containers. Since this group is trying to leverage OVN for NFV, I felt that this is right home for this. Do you agree?
15:48:29 <trinaths> Srini_:  inorder to fork a project repo into ovn4nfv repo we need approval from OPNFV TSC and XCI teams. XCI may need to setup the CI/CD process to test/verify the changes.
15:48:36 <trinaths> Srini_: agree.
15:49:00 <Srini_> Ok. What is the process to take it through TSC and XCI teams?
15:49:20 <trinaths> Srini_:  also, all the changes your team does, must be reviewed and verified to commit into git.
15:49:35 <Srini_> Of course.
15:50:07 <trinaths> Srini_: we need to post this proposal to opnfv-tech-discuss for TSC and XCI.
15:50:42 <trinaths> Srini_: we may need to attend the weekly meeting chaired by BinHu to explain the changes.
15:51:25 <Srini_> Sure. I just met Bin Hu yesterday for Lunch. I wish we had this discussion last week and I would have brough this up with him yesterday.
15:51:45 <Srini_> I can do that. Help us walk through the process.
15:51:46 <trinaths> Srini_: ok.
15:51:48 <trinaths> Bin Hu <bh526r@att.com>
15:51:56 <Srini_> Yes.
15:52:14 <Srini_> Write up a presentation and ask for a slot in Bin Hu meeting? Is that the first step?
15:52:23 <trinaths> Srini_:  I will add your team as contributors to the project for now.
15:52:50 <Srini_> Ok.
15:52:53 <trinaths> Srini_: yes, ask for a slot and present the requirements, and ask for help from XCI
15:53:46 <trinaths> Srini_:  Please attend weekly meeting to discuss the progress.
15:54:18 <Srini_> Okay. Will do.  Would I proposed  to create a repo in OVN4NFV project at the end of the presentation?
15:54:38 <trinaths> Srini_: once things are ready and project repo is forked, and CI/CD is up your team can propose the changes.
15:55:14 <trinaths> I will add yourself as core reviewer once things are in place so that the code is reviewed.
15:55:22 <trinaths> Srini_: how will the code be tested ?
15:55:25 <Srini_> CI/CD :  Is that required rightaway or required at the end of making changes?
15:55:40 <Srini_> Ok, That is great.
15:55:54 <trinaths> Srini_: any change to git must go through the CI/CD verified.
15:56:15 <trinaths> Srini_: How will you test the code ?
15:56:28 <trinaths> Srini_:  what setup is required ?
15:56:31 <Srini_> I am not familiar with the CI/CD. Is partial engineer is good enough? does it involve full time engineer?
15:56:58 <trinaths> initially full time engineer till the setup is complete.
15:57:22 <trinaths> if Intel hosts the CI/CD environment, that need to be added into OPNFV process
15:57:25 <Srini_> When you say setup:  Do you mean physical server/lab setup?
15:57:35 <trinaths> yes
15:57:51 <Srini_> Doesn't OPNFV have labs?
15:59:06 <Srini_> Is CI/CD setup,  server setup to be finalized before getting the repo created?
15:59:09 <trinaths> I think Intel PODs are available
15:59:16 <trinaths> #link CI/CD https://build.opnfv.org/ci/
15:59:56 <trinaths> some thing like, initial setup can run a non modified repo with tests all passing.
16:00:17 <Srini_> I need to run. Ritu, can you get more details so that we can have comprehesive presentation to OPNFV architecture meeting?
16:00:19 <trinaths> when ever the changes are made, relevant tests need to added.
16:00:37 <ritusood> ok
16:00:42 <trinaths> Srini_: ok. I will continue with ritusood
16:01:07 <Srini_> I understand. I guess frist step is to get the repo created and then complete the coding and then add tests and CI/CD. Is that right chain of events?
16:01:38 <Srini_> I hope we don;t have to give complete clarity on all of them just to get repo created.
16:01:53 <Srini_> I  need to run. thanks Trinath and Amir for your time. I will catch up with you later.
16:01:56 <Srini_> Bye
16:02:33 <trinaths> Srini_:  (1) Get the repo created/forked (2) get CI/CD (3) Make changes to code (4) Pass the build (5) merge the code to Git
16:03:34 <ritusood> What are the requirements for the test cases for CI/CD?
16:03:42 <trinaths> ritusood: please make a presentation and add me along with team. I will attend the meeting and presentation and move to the next milestone
16:04:02 <ritusood> ok
16:04:10 <trinaths> ritusood: as of now, only OPNFV specific releases are being adopted to the build testing.
16:04:43 <trinaths> ritusood:  we need to discuss with XCI guys on our work and requirements for CI/CD.
16:04:53 <ritusood> ok.
16:04:59 <trinaths> Intel already has POD for OPNFV development.
16:05:08 <trinaths> we can use them for the purpose.
16:05:52 <ritusood> Ok. Do we need to figure out CI/CD before the presentation
16:05:53 <trinaths> ritusood: I have a question. Once you make a forked repo to OVN4NFV, you will submit changes for gerrit review.
16:06:20 <trinaths> how will the reviewers know that the changes are working fine ?
16:06:38 <trinaths> the changes are not cracking others changes ?
16:06:49 <ritusood> We'll have testcases for the modified code
16:06:59 <trinaths> ritusood: right. I agree
16:07:07 <trinaths> ritusood:  now, how will you test them ?
16:07:43 <trinaths> in an OVN environment, right ?
16:07:44 <ritusood> Right now we have scripts that verify the functionality
16:07:48 <ritusood> yes
16:08:05 <trinaths> the same scripts must for the CI/CD build environment
16:08:26 <ritusood> ok makes sense.
16:09:11 <ritusood> For the presentation is there a format that needs to be followed
16:09:56 <trinaths> when ever you trigger a commit, the CI/CD process initiates the test environment with the changes you have made and run the tests to check consistency, error code, programmable work flow and desired test results are published to OPNFV gerrit.
16:10:08 <trinaths> ritusood:  there is no specific format for presentation.
16:10:43 <ritusood> ok. I think I got the information we needed.
16:10:50 <trinaths> ritusood: great.
16:11:31 <trinaths> ritusood: Please let me know in CC for any communication so that I will a track of happenings and help you onboard quickly.
16:11:34 <ritusood> Can you provide the link where we should request for slot for presentation
16:12:26 <trinaths> just put a mail to opnfv-tech-discuss or look for BinHu meeting invite where you can request a slot.
16:12:39 <trinaths> time up. ritusood  hope you got all the details.
16:12:44 <trinaths> Amir_m: ping
16:12:44 <ritusood> ok sounds good
16:12:47 <ritusood> thank you
16:12:49 <trinaths> :)
16:13:14 <trinaths> Amir_m:  please update on work status
16:13:33 <Amir_m> Ok
16:14:05 <Amir_m> The blocker I used to have when I was installing OVS was my fault
16:14:20 <Amir_m> I was trying to install OVS from John's repo
16:14:40 <Amir_m> Bu I realized that we don't have features in the second scenario
16:14:56 <Amir_m> so I managed to install OVS and OVN
16:15:06 <trinaths> true said. its simple CN VM OVN networking scenario.
16:15:21 <trinaths> Tests be, CN <-- Connectivity --> VM
16:15:31 <trinaths> ping, ssh etc..
16:15:35 <trinaths> via OVN
16:15:46 <trinaths> Amir_m:  nice.
16:16:04 <Amir_m> but I ran into other problems because this tutorial #link: https://github.com/openvswitch/ovn-kubernetes isn't complete
16:16:20 <Amir_m> so I brought a master node and 2 minions using vagrant
16:16:22 <trinaths> :-)
16:16:37 <trinaths> ritusood:  comments ?
16:16:37 <Amir_m> and will test connectivity after our meeting
16:16:42 <trinaths> ok.
16:16:58 <Amir_m> after that I will look into Kubevirt
16:17:22 <trinaths> with our kubevirt how can you spawn the CNs ?
16:17:32 <trinaths> in PODs ?
16:18:07 <Amir_m> Yet I don't know. I will start to understand :)
16:18:14 <trinaths> Amir_m:  ok.
16:18:31 <Amir_m> I'm just foolowing the steps we agreed on in a previous meeting
16:19:14 <Amir_m> 1. k8s CN OVN scenario
16:19:15 <trinaths> Amir_m:  one doubt. Saravanan (reviewer of TripleO heat templates) commented on Docker containers. Do you think we need to work on OVN Docker container and VM approach ? rather than involve K8S here ?
16:19:27 <Amir_m> 2. K8s Kubevirt VM
16:19:33 <Amir_m> 3. K8s CN VM OVN Scenario
16:20:00 <trinaths> ok.
16:20:07 <trinaths> make sense.
16:20:14 <trinaths> add, 4. http://docs.openvswitch.org/en/latest/howto/docker/
16:20:36 <trinaths> lets see which best fits our Apex integration.
16:20:47 <Amir_m> ok
16:21:22 <trinaths> Amir_m:  can you put a straight mail to Tim and Saravanan on the help we need on review comments and next steps to proceed further. Please add me in CC.
16:21:42 <Amir_m> sure, I will do after this meeting
16:21:48 <trinaths> Amir_m: ok.
16:22:38 <trinaths> #action ritusood - Prepare presentation on new OVN work => OVN forked repo and CI/CD process.
16:22:58 <trinaths> #action Amir_m:  work on K8S OVN CN scenario
16:23:33 <Amir_m> Ok
16:23:38 <trinaths> #action Amir_m: discuss with TripleO reviewer team on changes/help required for next integration steps.
16:24:07 <trinaths> Amir_m: collaboration with other communities takes time since we need reviewers help to merge the code and move on.
16:24:30 <trinaths> ok. that's all from my end.
16:24:37 <trinaths> #topic Open discussion
16:24:46 <Amir_m> I eventually get to know this fact Trinaths :(
16:25:00 <trinaths> Amir_m: what fact ?
16:25:14 <Amir_m> That fact that it takes time
16:25:20 <trinaths> :D
16:26:13 <trinaths> really it take time, I mentioned it earlier since there are many patches of higher importance to be merged/reviewed so the queue will be high.
16:26:32 <trinaths> ]
16:26:51 <trinaths> Ok. Any more to discuss ?
16:27:03 <Amir_m> Nothing from my end
16:27:10 <trinaths> ritusood: there ?
16:27:22 <trinaths> #topic OVN4NFV
16:27:33 <trinaths> #endmeeting