15:31:08 <trinaths> #startmeeting ovn4nfv
15:31:08 <collabot> Meeting started Tue Sep 18 15:31:08 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:08 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:08 <collabot> The meeting name has been set to 'ovn4nfv'
15:31:12 <trinaths> Hi Srini
15:31:22 <trinaths> #chair trinaths
15:31:22 <collabot> Current chairs: trinaths
15:31:36 <Srini> Is there anything you need from me to get the repository created?
15:31:40 <trinaths> #topic  Agenda
15:32:14 <trinaths> #link https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:32:40 <trinaths> Srini: I will check and approve the repo creation.
15:33:15 <trinaths> Srini: regarding committer role, the team must initially be contributors attending weekly meeting and submitting the blue prints.
15:33:52 <trinaths> Srini: after few cycles, I will post a gerrit review or mail for committer promotion.
15:34:32 <trinaths> #action: trinaths  : review and approve the creation of k8sOVNplugin repo
15:34:37 <Srini> Okay. Understood on committer roles.
15:34:54 <Srini> Thanks. Please let us know once you get the repo created.
15:34:55 <trinaths> Srini: can your team groom the plugin blueprint page
15:35:13 <trinaths> Srini: https://wiki.opnfv.org/display/OV/K8S+OVN+NFV+Plugin
15:35:18 <Srini> Will do. Currently Ritu is busy in debugging some stuff.
15:35:27 <trinaths> ok.
15:36:00 <trinaths> Also, please add the Action items so that we can see the contributions points
15:36:32 <Srini> Okay. You mean work items?
15:36:42 <trinaths> yes
15:37:07 <Srini> Ok. Will do.
15:37:29 <trinaths> thanks Srini
15:37:57 <trinaths> Amir_m: hi
15:38:00 <Srini> I guess we are good on K8S-OVN4NFV agenda item.
15:38:58 <Amir_m> Trinaths: Hi
15:39:02 <trinaths> Srini: yes. From the agenda, I have added the initial work items. And we need to groom with more details.
15:40:19 <trinaths> #action Srini : Srini team to update https://wiki.opnfv.org/display/OV/K8S+OVN+NFV+Plugin page with more details of the plugin, like API, Interfaces, functional flow etc ..
15:40:20 <Amir_m> I've been trying to figure out the problem with the K8s cluster I launched using vagrant, so far didn't solve the problem
15:40:52 <Amir_m> Also I checked and found that there were no OVN processes running on the K8smaster node
15:41:08 <trinaths> Amir_m: ok. Can you post the error in tech-discuss
15:41:18 <trinaths> Srini: comments ?
15:41:25 <Amir_m> so currently I'm setting up a cluster using VM myself
15:41:32 <trinaths> ok
15:42:00 <trinaths> Amir_m: one important Date is Sept 21, where we need to branch out the repo for G release.
15:42:15 <Amir_m> The problem simply is that kubectl can't find the api-server
15:42:21 <trinaths> by that time we have PoC UG ready, we can push it to the repo.
15:42:32 <trinaths> Amir_m: ok
15:42:38 <Srini> Seems like a basic problem.  I hope you have set the kubconfig file properly.
15:42:49 <trinaths> Srini: +1
15:43:28 <Srini> You can send an email to me and Ritu with your kubeconfig file, where your API server is running on (FQDN/IP address) and mainly your setup picture.
15:43:37 <Amir_m> The problem is there is no such file or the admin config file
15:44:14 <Amir_m> that is why I'm setting up a cluster myself without using vagrant
15:44:21 <trinaths> Amir_m: did you check $HOME/.kube ?
15:44:39 <Srini> Send us the deployment picture and we will see we can help.
15:45:12 <Srini> Also send us the kubectl command you are using (arguments and all).
15:45:17 <Amir_m> Srinin: ok
15:45:22 <trinaths> Amir_m:  please share the issue details and deployment picture to Srini team, they can help you resolve this soon.
15:45:32 <Amir_m> I will
15:45:51 <trinaths> Amir_m: ok
15:46:45 <trinaths> Amir_m:  I will review and merge OVN-SFC UG this week.
15:46:51 <Amir_m> Srini: for now, if you  know a good way/tutorial to setup a vm hosted k8s cluster, please let me know
15:47:10 <Srini> Sure. I will find out from Ritu.
15:47:42 <Amir_m> You can reach me at 16aiam@queensu.ca
15:48:04 <trinaths> #link https://www.profiq.com/kubernetes-cluster-setup-using-virtual-machines/
15:48:29 <trinaths> Amir_m:  can the above link be helpful ?
15:48:40 <Amir_m> Trinaths: already used that page
15:49:14 <Srini> Trianth, I need to go now. Amir, please send details to opnfv-techdiscuss and I will request Ritu to respond.
15:49:30 <Amir_m> for the record I can use google too :D
15:49:48 <trinaths> ok
15:49:49 <trinaths> https://github.com/davidkbainbridge/k8s-playground
15:49:58 <trinaths> #link https://github.com/davidkbainbridge/k8s-playground
15:50:14 <trinaths> Can you check this ?
15:50:37 <trinaths> or put a mail to opnfv-tech-discuss, we can get more info there
15:50:57 <Amir_m> ok, thanks Trinaths
15:51:19 <trinaths> Ok.
15:52:00 <trinaths> thats all from my end.
15:52:05 <Amir_m> I've no more to add
15:52:10 <Amir_m> Thanks
15:52:23 <trinaths> Amir_m: which guide you are following for VM based K8S setup ?
15:52:44 <Amir_m> #link https://medium.com/@KevinHoffman/building-a-kubernetes-cluster-in-virtualbox-with-ubuntu-22cd338846dd
15:52:46 <trinaths> let me try the same and give some solution
15:53:00 <Amir_m> #link https://www.profiq.com/kubernetes-cluster-setup-using-virtual-machines/
15:53:29 <Amir_m> and for vagrant I used  #link https://github.com/openvswitch/ovn-kubernetes/blob/master/vagrant/README.md
15:53:39 <trinaths> ok
15:54:02 <trinaths> Amir_m:  which VMs are you using - Libvirt or Vagrant based ?
15:54:10 <Amir_m> vagrant
15:54:20 <trinaths> ok. Can you share the VM specs ?
15:54:55 <trinaths> I mean, RAM, HDD, VCPUs
15:55:11 <Amir_m> It is hidden in the vagrant file
15:55:23 <Amir_m> I can look it up  and let you knwp
15:55:34 <trinaths> I have 16GB machine idle at my lab. I will try the tutorial you are following and resolve the issues.
15:55:37 <trinaths> ok.
15:55:49 <trinaths> Amir_m: look into VagrantFile.
15:56:45 <trinaths> Amir_m: can you share the VagrantFile you are using, I will also try that setup.
15:57:56 <Amir_m> #link https://github.com/openvswitch/ovn-kubernetes/blob/master/vagrant/Vagrantfile
15:57:57 <trinaths> the tutorial you are using is of VirutalBox.
15:59:10 <trinaths> #action trinaths : work on ovn-k8s lab using #link https://github.com/openvswitch/ovn-kubernetes/blob/master/vagrant/Vagrantfile
15:59:35 <trinaths> #action Amir_m : to post the issues with ovn-k8s to tech-discuss
16:00:22 <Amir_m> I will give a try to the vagrant tutorial you shared above
16:00:26 <trinaths> Lets conclude this by Sept 30th. So that we have PoC ready.
16:00:29 <trinaths> Amir_m: +1
16:00:40 <Amir_m> ok
16:01:06 <trinaths> Amir_m:  Please mail me if you have doubts/issues so that I can collaborate with you virtually and guide you complete the tasks.
16:01:31 <trinaths> okay. We are in sync with this weeks work.
16:01:37 <trinaths> lets continue the good work.
16:01:40 <Amir_m> ok
16:02:03 <trinaths> #endmeeting