15:30:33 <trinaths> #startmeeting OVN4NFV Weekly Meeting
15:30:33 <collabot> Meeting started Tue Oct  2 15:30:33 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:33 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:33 <collabot> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:30:48 <trinaths> #topic Agenda
15:30:57 <trinaths> #link https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:31:05 <trinaths> Hi Amir_m , How are you doing.
15:31:29 <trinaths> Good News , OVN Scenarios are enabled in Apex with ROCKY (latest OpenStack release)
15:31:33 <Amir_m> Hi Trinath, I'm good thanks
15:32:00 <Amir_m> Indeed, this is good news :d
15:32:30 <trinaths> Amir_m:  With this integration we need to work on integrating the OVN-SFC scenario
15:33:05 <trinaths> Amir_m:  we will take this after our OVN-CN-VM scenario
15:33:17 <Amir_m> Trinaths: ok
15:33:33 <trinaths> Amir_m:  Can you outline the issue.
15:33:43 <trinaths> you are facing while debugging with ritu.
15:34:17 <Amir_m> For the OVN-CN-VM scenario, I believe that one or more of the params I'm using to configure ovn-kube isn't correct
15:34:46 <trinaths> oh ok.
15:35:07 <Amir_m> I just wanted someone, probably more knowledgeable than me, to review the detailed steps I provided and help me out
15:35:09 <trinaths> did you find any working configuration
15:35:43 <trinaths> I have gone through the steps you have given. But they are not understandable.
15:36:05 <Amir_m> Ritu, after asking about a clarification about the issues I'm facing, pointed me to the vagrant tutorial I've already used the  very first time
15:36:35 <trinaths> ok
15:36:40 <Amir_m> Could you give me one example of what you don't understand
15:36:46 <trinaths> Amir_m:  can you elaborate this ==>   2. Used host-only network on adapter2, NAT on adapter1
15:37:37 <Amir_m> According to the tutorial I'm using, I used host-only network for my VMs
15:38:04 <trinaths> Amir_m:  can you point me to that line in the tutorial
15:38:47 <trinaths> ritusood: Hi, How are you doing .
15:40:00 <ritusood> good.
15:40:15 <Amir_m> https://www.profiq.com/kubernetes-cluster-setup-using-virtual-machines/
15:40:22 <trinaths> ritusood:  Amir_m has tried the vagrant tutorial you have shared. he was successful with vagrant
15:40:38 <ritusood> That's great
15:40:47 <Amir_m> Trinaths: Vagrant didn't work for me
15:40:54 <trinaths> ritusood:  Can you share a working configuration if you have for ovn-kube
15:41:04 <trinaths> Amir_m: ok.
15:41:20 <Amir_m> What worked is to setup the K8s cluster myself using VMs
15:41:44 <trinaths> Amir_m: we have ritusood here, do you want to discuss your queries.
15:41:49 <ritusood> Sure I can do that. Also we have a working deployment in ONAP that installs all required packages
15:41:56 <ritusood> I can share that also
15:43:00 <trinaths> Amir_m:  can you share what is required for you at the current state of your deployment.
15:43:13 <trinaths> ritusood:  we are deploying with ONAP. We are doing a manual setup
15:43:44 <Amir_m> I already have k8s cluster of VMs (one master+ 2 nodes)
15:43:55 <ritusood> what happens when you start ovnkube
15:44:07 <ritusood> does it crash
15:44:34 <Amir_m> Master can see nodes but their status isn't ready, because network provider (OVN in our case) isn't properly configured
15:45:00 <Amir_m> so I just want my ovnkube configuration to be double checked
15:45:20 <Amir_m> given the K8s cluster details
15:45:30 <trinaths> Amir_m: can you share the config via paste.openstack.org
15:45:47 <Amir_m> what is paste.openstack.org?
15:46:24 <Amir_m> it is already the last two steps in the detailed file I've already shared with you and Ritu
15:46:25 <trinaths> is a editor for sharing things.
15:46:31 <trinaths> ok
15:46:55 <trinaths> Amir_m: you mean,
15:46:55 <trinaths> 12. On each worker/host node start the ovnkube 	$ export TOKEN=favqjd.ubjbvyay2j7efxon 	$ nohup sudo ovnkube -k8s-kubeconfig kubeconfig.yaml -loglevel=4 -logfile="/var/log/openvswitch/ovnkube.log" -k8s-apiserver="http://$CENTRAL_IP:6443" -init-node="$NODE_NAME" -nodeport -nb-address="tcp://$CENTRAL_IP:6641" -sb-address="tcp://$CENTRAL_IP:6642" -k8s-token="$TOKEN" -init-gateways -service-cluster-ip-range=$SERVICE_IP_SUBNET
15:47:21 <trinaths> can you share the contents of kubeconfig.yaml
15:47:55 <trinaths> ritusood:  can you see the steps 12 and 13 in the email attachment sent by Amir_m
15:48:16 <ritusood> ok
15:49:26 <Amir_m> #link http://paste.openstack.org/show/731276/
15:50:13 <trinaths> Amir_m: can you share the contents of kubeconfig.yaml
15:50:40 <Amir_m> sure just a second
15:50:51 <trinaths> ok
15:54:21 <ritusood> There is a CNI configuration that seems to be missing here
15:54:57 <ritusood> --network-plugin=cni --cni-conf-dir=/etc/cni/net.d --cni-bin-dir=/opt/cni/bin/
15:55:30 <trinaths> Amir_m: can you share the kubeconfig.yaml
15:55:35 <Amir_m> at the end of this http://paste.openstack.org/show/731277/
15:55:44 <trinaths> also, can you re run the command with comments from ritusood
15:59:10 <ritusood> here is ours http://paste.openstack.org/show/731278/
16:00:25 <trinaths> Amir_m: there is some diff you might move into your yaml file.
16:01:41 <trinaths> like, "kind:"
16:02:21 <trinaths> ritusood:  who generated this config file ?
16:02:46 <Amir_m> Not me!
16:03:19 <trinaths> ritusood:  i mean is it generated by ONAP or written as per your setup specs ?
16:03:24 <trinaths> Amir_m:  :) I know.
16:03:49 <ritusood> We have a vagrant deployment for kubernetes in ONAP
16:04:13 <ritusood> called Krd. This is part of that project
16:04:34 <ritusood> Another question is whether ovnkube is running on all nodes
16:04:56 <Amir_m> Trinaths and Ritu: I was following the only ovn-kube tutorial available, which is poorly written #link https://github.com/openvswitch/ovn-kubernetes
16:06:08 <trinaths> ritusood: I have query. Can We use KRD from ONAP to deploy that part of the setup ?
16:06:29 <ritusood> Sure. Let me give you the link
16:07:14 <ritusood> https://gerrit.onap.org/r/gitweb?p=multicloud/k8s.git;a=tree;f=vagrant;h=6191e2828ee38b8018c0de1259cc5c04462c7524;hb=refs/heads/master
16:07:45 <ritusood> One difference there is that we are using flannel as CNI
16:08:07 <trinaths> ok.
16:08:14 <ritusood> and using ovn-kubernetes with Multus for multiple interfaces
16:08:42 <trinaths> ritusood: ok. will KRD work independently without ONAP configuration ?
16:08:55 <ritusood> In your scenario getting the vagrant woring from ovn-kubernetes will be helpful
16:09:23 <ritusood> I was able to get the vagrant working. What is the issue that you are seeing?
16:10:29 <ritusood> KRD can work without ONAP
16:11:15 <trinaths> Amir_m: Can you give a try. Or use the Config file from ritusood  and modify as per your environment and check the installation ?
16:11:50 <Amir_m> You mean give vagrant a try?
16:12:43 <trinaths> yes. with any appropriate changes to config files from files shared by ritusood
16:13:00 <Amir_m> ok
16:14:08 <trinaths> ritusood:  can you share the config you have to Amir_m, so that we can give a try with updated config files.
16:14:35 <ritusood> Sure I'll send a email to him with our configuration
16:15:02 <trinaths> Amir_m:  if it does'nt work, please use the link #link  https://gerrit.onap.org/r/gitweb?p=multicloud/k8s.git;a=tree;f=vagrant;h=6191e2828ee38b8018c0de1259cc5c04462c7524;hb=refs/heads/master shared by ritusood to bring up a new setup using KRD installation from ONAP
16:15:27 <trinaths> ritusood:  for every communication please cc me so that I can have a picture on what is going on.
16:15:32 <ritusood> ok
16:15:40 <ritusood> trinaths: Any update on the repo creation?
16:15:40 <trinaths> ok. lets move to other topics.
16:15:54 <trinaths> ritusood: :) yes, INFRA team will create the repo today.
16:16:09 <trinaths> I will update Srini and you on this once Repo is created.
16:16:14 <ritusood> :) great
16:16:21 <trinaths> [21:34] <bramwelt> trinaths: Hi [21:37] <trinaths> bramwelt: I have raised a helpdesk ticket to create a repo. https://gerrit.opnfv.org/gerrit/#/c/51587/ As per aric suggestion, I have updated INFO.yml. What can be the next steps. Kindly help me move forward. [21:40] <bramwelt> trinaths: Thanks for the ping. We'll get the repo made today and let you know when it's up. :) [21:43] <trinaths> bramwelt: :) thank you. Please ma
16:16:31 <trinaths> the above is the chat I had with Infra team
16:16:47 <trinaths> me on this. We have the code ready and need to submit to this repo.
16:17:14 <trinaths> ritusood:  can you update with detailed specifics of OVN4NFV K8S plugin? in the wiki page
16:17:31 <trinaths> since, TSC or other teams can review our plugin
16:17:41 <ritusood> Yes. Srini already put some details I'll add more today
16:17:51 <trinaths> so they need more info on how we are developing the same.
16:17:56 <trinaths> ritusood: ok
16:18:34 <trinaths> #action Amir_m - Work with ritusood to update config files and try the installation. if it doesn't work use KRD installation from ONAP
16:20:00 <trinaths> #action ritusood - Update OVN4NFV-K8S plugin wiki page with more detailed architecture, functional design along with focus on Testing guidelines. Also add references if any.
16:20:34 <trinaths> #action trinaths - Work with infra team to create k8s-ovn4nfv-plugin repo and update Srini team to enable code checkin.
16:20:46 <trinaths> team, any thing more to discuss ?
16:20:51 <trinaths> we have 10 mins more
16:23:13 <trinaths> ok. Lets continue the good work.
16:23:27 <trinaths> Amir_m: please mail me if you find a bottle neck.
16:23:39 <trinaths> ritusood:  kindly please help Amir_m  to enabe the ovn-k8s setup.
16:23:48 <Amir_m> Sure
16:24:02 <ritusood> Sure
16:24:13 <trinaths> ritusood:  our intention is to enable OVN for Container and VM hybrid environment.
16:24:30 <trinaths> such a PoC/use-case can also help you for ONAP scenarios.
16:24:37 <trinaths> bye all.
16:24:41 <trinaths> #endmeeting