15:30:55 <trinaths> #startmeeting ovn4nfv Weekly Meeting
15:30:55 <collabot`> Meeting started Tue Oct 23 15:30:55 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:55 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:55 <collabot`> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:31:03 <trinaths> #chair  trinaths
15:31:03 <collabot`> Current chairs: trinaths
15:31:42 <trinaths> #action Amir to conclude on ovn+cn+virtlet implementation
15:36:35 <trinaths> #agenda https://wiki.opnfv.org/display/OV/Meeting+Agenda
15:36:51 <trinaths> Amir - on leave today.
15:36:58 <trinaths> ritusood: Hi
15:37:15 <ritusood> @trinaths Hi
15:37:15 <collabot`> ritusood: Error: "trinaths" is not a valid command.
15:37:31 <ritusood> Ok
15:38:08 <trinaths> was your code ready ?
15:38:47 <trinaths> ritusood: #link https://wiki.opnfv.org/display/OV/K8S+OVN+NFV+Plugin - Do you want to update the documentation
15:38:51 <ritusood> Yes we have seed code ready
15:39:25 <trinaths> ritusood: use gerrit.opnfv.org to put forward the init code.
15:39:36 <trinaths> I will verify and approve.
15:39:51 <ritusood> ok great
15:40:09 <trinaths> move the documentation from the above WIKI to an .rst file and upload as README.
15:40:25 <ritusood> I plan to update the wiki and put the seed code this week
15:40:33 <trinaths> but how you are going to prove that the code commited to repo is working as required ?
15:41:13 <ritusood> For that we need a kubernetes setup
15:41:25 <trinaths> Nice.
15:41:48 <trinaths> Do you want to have Intel's Devops for this plugin ?
15:41:51 <ritusood> In ONAP we have a vagrant that we use to setup a cluster.
15:42:48 <trinaths> ritusood:  for every checkin/commit, we have a jenkins job validate this commit before posting to the repo. so it can be either OPNFV hosted one or a 3rdparty one
15:43:22 <ritusood> Even for the initial release?
15:44:06 <trinaths> yes.
15:45:27 <ritusood> ok. Can you point me to link that shows what all is required
15:45:56 <trinaths> we need to discuss with infra team for this. for now can you pick up a Intel based setup with jenkins to run the commit in the required environment ? and post the test report in a public repo ?
15:46:03 <trinaths> can this be possible.
15:46:41 <trinaths> or. in OPNFV intel itself has pods and jobs. can you ask the OPNFV team there to setup one job for this ?
15:47:01 <trinaths> #action ritusood - enable CI/CD for plugin development.
15:47:51 <ritusood> Let me check with the OPNFV team at Intel to see what can be done
15:48:05 <trinaths> ok.
15:48:26 <trinaths> please go ahead and share your first commit.
15:48:33 <trinaths> add me and srini as reviewers.
15:49:06 <trinaths> once we have good contribution running, I will add you as one of the contributors with privileges.
15:49:21 <ritusood> I'll do that this week. Just for my understanding for it to be merged we need to enable CI/CD
15:49:34 <ritusood> is that correct?
15:49:43 <trinaths> yes.
15:50:18 <trinaths> it the initial checkin is just a README with directory structure then CI/CD can be done when real code is moved in
15:50:22 <ritusood> ok I don't have that part ready
15:50:30 <ritusood> I see
15:50:54 <ritusood> I'll do that
15:51:28 <trinaths> ok. please submit the code. as per the impact of the code under review we can opt on priority of CI/CD.
15:51:47 <trinaths> any thing more to discuss ?
15:51:50 <ritusood> ok understood.
15:51:58 <ritusood> No this is great.
15:52:09 <ritusood> thanks for your help
15:52:15 <trinaths> Amir is on leave today. We can conclude if nothing to discuss
15:52:18 <trinaths> welcome.
15:52:23 <ritusood> yes
15:52:37 <trinaths> thankyou
15:52:38 <trinaths> bye
15:52:41 <ritusood> bye
15:52:42 <trinaths> #endmeeting