15:30:19 <trinaths> #startmeeting ovn4nfv weekly meeting
15:30:19 <collabot`> Meeting started Tue Oct 30 15:30:19 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:19 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:19 <collabot`> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:30:30 <trinaths> #topic Agenda
15:30:48 <trinaths> #link https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:31:15 <trinaths> Amir - Attending ONS Days at ottawa. Not attending for today.
15:33:15 <trinaths> #action trinaths - Conclude and Tag OVN SFC PoC scenario documentation and ready for release.
15:33:19 <trinaths> ritusood:  hi
15:33:27 <ritusood> hi
15:33:51 <trinaths> ritusood: how are you doing ? got your contributor rights for the repo ?
15:34:16 <ritusood> I'm doing good thank you. No I didn't
15:34:26 <ritusood> How much time does it take?
15:34:38 <trinaths> it must not take a day more.
15:34:52 <trinaths> Aric or trevor from LF can do that
15:35:10 <trinaths> can you update me CI/CD for the repo
15:35:53 <ritusood> I've added unit test cases and we are planning to use those for Jenkins
15:37:09 <trinaths> jenkins be hosted at your labs and supporting opnfv gerrit ?
15:38:38 <ritusood> I'm not sure about the hosting part. I discussed with Srini and he mentioned that OPNFV should have servers for Jenkins. Is that correct understanding?
15:38:49 <ritusood> from LF
15:38:56 <trinaths> opnfv has jenkins
15:39:18 <trinaths> may be you need to talk to infra team for your jobs for this repo.
15:39:53 <trinaths> #action ritusood - check with opnfv infra team for repo specific jobs. k8s-ovn4nfv-plugin
15:39:55 <ritusood> ok. Do you know of any contact name?
15:40:08 <trinaths> ritusood:  have you ever tried, k8s managing vms ?
15:40:30 <ritusood> yes we have tried virtlet
15:41:08 <ritusood> and this is in KRD deployment we have in ONAP
15:41:09 <trinaths> ritusood: is that virtlet installation working ?
15:41:18 <trinaths> ok
15:41:20 <trinaths> #link http://status.opnfv.org/
15:41:43 <ritusood> yes we have tested connectivity between containers and VMs also
15:42:00 <trinaths> #link https://wiki.opnfv.org/display/INF/Continuous+Integration
15:42:28 <trinaths> ritusood:  can you share virtlet installation and VM and CN networking guidelines if you have any
15:42:38 <trinaths> Amir is struck at virtlet installation
15:43:48 <ritusood> Sure we can share them. Victor in my team worked on it. He has created playbooks for the installation
15:44:04 <ritusood> I'll send an email
15:44:34 <trinaths> ok
15:44:56 <trinaths> ritusood:  i just pushed a mail to you which i received from amir regarding the virtlet issues we are facing.
15:44:57 <ritusood> For the repo is it ok to submit code or should I first checkin a empty directory structure with readme
15:45:33 <trinaths> ritusood: [1] checking the empty directory structure. with README and plugin documentation
15:45:41 <trinaths> [2] Checking the code as appropriate.
15:46:05 <trinaths> [2.1] Mean time check with opnfv infra team to enable custom jobs for the repo. to validate the code.
15:46:33 <trinaths> ritusood: is the code c/python/go/java ?
15:46:48 <ritusood> Code is in go
15:47:05 <trinaths> ok. Will srini be reviewing the code ?
15:47:20 <trinaths> i'm myself not a GO expert to review.
15:47:47 <ritusood> Victor from my team will review
15:48:20 <trinaths> ritusood: ok
15:48:20 <ritusood> if you know anyone else that will also help
15:48:24 <ritusood> ok
15:48:29 <trinaths> ritusood:  i will scout
15:48:33 <trinaths> ritusood:  check #link https://docs.opnfv.org/en/latest/infrastructure/xci.html
15:49:38 <ritusood> ok
15:50:34 <trinaths> ritusood: let me check for xci guys who can help us. mean time, put forward CI query to OPNFV helpdesk. and lets see hoe it goes.
15:51:00 <ritusood> I'll push empty directory structure with Readme today when I get permission
15:51:19 <trinaths> great
15:51:50 <trinaths> #action ritusood - Checking directory structure with README for k8s-ovn4nfv-plugin
15:51:50 <ritusood> ok I'll put query to OPNFV helpdesk for CI
15:51:56 <trinaths> ok.
15:52:04 <trinaths> sounds good
15:52:14 <trinaths> anything else you want to discuss.
15:52:26 <trinaths> Amir is attending ONS days at ottawa today.
15:52:33 <trinaths> so he is absent for today meeting
15:52:42 <ritusood> ok
15:53:02 <ritusood> Nothing else to discuss. We hope to get the code merged in soon
15:53:14 <trinaths> ritusood: yes. +1
15:53:14 <ritusood> Thanks for your help
15:53:32 <trinaths> ritusood: let me understand Go while you Go with the code.
15:53:35 <trinaths> :)
15:53:40 <ritusood> :)
15:53:48 <trinaths> you are working at US ?
15:53:49 <ritusood> sounds good
15:53:57 <ritusood> yes how about you?
15:54:08 <trinaths> i'm from India.
15:54:12 <ritusood> ok
15:54:25 <trinaths> ok. let conclude this meeting.
15:54:34 <ritusood> yes thank you
15:54:38 <ritusood> bye
15:54:42 <trinaths> Opnfv G release is on 2nd November
15:54:47 <trinaths> #endmeeting