15:30:17 <trinaths> #startmeeting ovn4nfv-weekly-meeting
15:30:17 <collabot`> Meeting started Tue Nov 20 15:30:17 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:17 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:17 <collabot`> The meeting name has been set to 'ovn4nfv_weekly_meeting'
15:30:24 <trinaths> #chair trinaths
15:30:24 <collabot`> Current chairs: trinaths
15:30:42 <trinaths> #link Agenda: https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:30:57 <trinaths> hi electrocucaracha - Victor
15:31:08 <electrocucaracha> hey Good morning
15:31:29 <trinaths> hello, Good Day.
15:31:43 <trinaths> you are into which TimeZone ?
15:31:49 <electrocucaracha> PST and you?
15:31:54 <trinaths> IST
15:32:14 <trinaths> Good Morning
15:32:16 <trinaths> Hi Amir_m
15:32:24 <electrocucaracha> got it, so good evening hehehe
15:32:32 <Amir_m> Hi Trinaths
15:32:34 <trinaths> electrocucaracha: hehehe
15:32:53 <trinaths> Thanks you for attending this weekly meeting Amir_m  electrocucaracha
15:33:16 <trinaths> electrocucaracha: ritu not joining ?
15:33:33 <electrocucaracha> no, she is still on vacation
15:33:39 <trinaths> ok.
15:33:53 <trinaths> Lets move on to the Agenda
15:34:01 <trinaths> #link Agenda: https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:34:18 <trinaths> We have concluded G release 7.0
15:35:00 <trinaths> From OVN4NFV we have completed PoC on OVN-SFC scenario for 7.0 and OVN-CN-VM scenario for 7.1
15:35:09 <trinaths> thanks Amir_m
15:35:21 <trinaths> We need to conclude the second one for 7.1
15:35:55 <trinaths> the next steps be integrating ovn-cn-vm scenario to Compass4NFV installer
15:36:07 <trinaths> so, this is the plan we have now.
15:36:15 <trinaths> any comments on G release
15:36:17 <trinaths> ?
15:37:07 <trinaths> ok, lets move to the next topic
15:37:21 <trinaths> #topic k8s-ovn4nfv-plugin
15:37:44 <trinaths> electrocucaracha: I have seen the patch #link https://gerrit.opnfv.org/gerrit/#/c/64833/
15:37:53 <trinaths> electrocucaracha:  it still need a Jenkins +1
15:38:17 <trinaths> electrocucaracha:  i was unable to validate on unit tests jenkins job is executing
15:38:37 <electrocucaracha> yes, according to the logs Jenkins can't find the bash file which installs and executes tests
15:38:38 <trinaths> comments ?
15:38:45 <trinaths> ok
15:39:01 <electrocucaracha> I was thinking that maybe was the execution permissions
15:39:02 <trinaths> did infra team include this job ?
15:39:03 <electrocucaracha> https://gerrit.opnfv.org/gerrit/#/c/65225/
15:39:48 <electrocucaracha> this was the first patch which was fixed later https://gerrit.opnfv.org/gerrit/#/c/64973/
15:40:05 <trinaths> #link https://gerrit.opnfv.org/gerrit/#/c/65227/
15:40:42 <electrocucaracha> AFAIK OPNFV don't offer a Jenkins Sandbox where it's possible to test this
15:40:51 <trinaths> electrocucaracha: infra team has approved the above patch.
15:40:58 <electrocucaracha> so I'm kind of blind in how to fix it
15:41:22 <trinaths> electrocucaracha: yes. its for a good reason. all tests go from installers.
15:41:52 <electrocucaracha> so do you have a idea about how to test it
15:42:02 <trinaths> electrocucaracha: as per OPNFV community, even the new k8s-ovn4nfv-plugin must go with a scenario is any of opnfv installers.
15:42:25 <trinaths> electrocucaracha:  I think we need to push this to infra team to take a look.
15:42:38 <electrocucaracha> yeah
15:43:03 <trinaths> every Monday they have a weekly meeting.
15:43:20 <electrocucaracha> did you know at what time?
15:43:22 <trinaths> so we can attend the same or raise a helpdesk ticket with our requirement.
15:43:36 <electrocucaracha> or I can send an email to them
15:43:47 <trinaths> Weekly on Monday at 15:00UTC; IRC #opnfv-meeting
15:43:52 <electrocucaracha> Trevor Bramwell is aware of this issue
15:44:04 <trinaths> they support a zoom session
15:44:04 <trinaths> https://wiki.opnfv.org/display/meetings/Infra+Working+Group+Meeting
15:45:07 <trinaths> any comments from trevor ?
15:45:38 <electrocucaracha> well, he abandoned my last patch https://gerrit.opnfv.org/gerrit/#/c/65225/
15:46:17 <electrocucaracha> I think that they fixed https://gerrit.opnfv.org/gerrit/#/c/65227/
15:46:18 <trinaths> yes, seen it. but they posted the patch #link  https://gerrit.opnfv.org/gerrit/#/c/65227/
15:46:25 <trinaths> yes.
15:46:35 <trinaths> now I have just gave a recheck.
15:46:40 <electrocucaracha> so let me recheck the patch that has a seed code
15:46:49 <trinaths> ok
15:47:13 <electrocucaracha> :O he did it
15:47:37 <trinaths> #link https://build.opnfv.org/ci/job/ovn4nfv-k8s-plugin-verify-master/3/console
15:47:42 <trinaths> recheck console
15:47:53 <trinaths> ok.
15:47:56 <electrocucaracha> yeah, it's installing go
15:48:08 <trinaths> electrocucaracha: is that the shell script alone tests the code ?
15:48:17 <trinaths> or will it trigger a test batch ?
15:48:32 <electrocucaracha> yes, basically it installs go first for running tests later
15:49:06 <trinaths> ok.
15:49:12 <electrocucaracha> mmm it failed, but I have an idea how to fix it
15:49:53 <trinaths> electrocucaracha: may be we need to send a mail with this error log, Sending email to: tbramwell@linuxfoundation.org agardner@linuxfoundation.org rgrigar@linuxfoundation.org
15:49:59 <trinaths> as suggested by jenkins
15:50:46 <trinaths> electrocucaracha: what is the plan for k8s-ovn4nfv-plugin deliverables ?
15:50:47 <electrocucaracha> well, the error is related with the dependencies that the source code is downloading, in other words is in our side
15:51:00 <trinaths> ok.
15:51:15 <trinaths> you mean, go: verifying k8s.io/client-go@v9.0.0+incompatible: checksum mismatch 	downloaded: h1:/PdJjifJTjMFe0G4ESclZDcwF1+bFePTJ2xf+MXjcvs= 	go.sum:     h1:2kqW3X2xQ9SbFvWZjGEHBLlWc1LG9JIJNXWkuqwdZ3A= Makefile:24: recipe for target 'test' failed
15:51:31 <trinaths> verifying k8s.io/client-go@v9.0.0+incompatible: checksum mismatch downloaded
15:51:36 <trinaths> is the error
15:51:48 <electrocucaracha> yes, we are using go 1.11 which is using a new package management model
15:52:34 <trinaths> then, the scripts need to be update for the required versions
15:53:17 <electrocucaracha> kind of, this is using go modules, so the files go.mod and go.sum contains those dependencies
15:53:25 <trinaths> ok.
15:53:34 <electrocucaracha> that are autogenerated by the go compiler
15:54:00 <trinaths> electrocucaracha: there is a checksum mismatch
15:54:44 <trinaths> can we give appropriate hosts to download from - in the scripts ?
15:54:57 <trinaths> like we give in sources.list
15:55:20 <electrocucaracha> mmm, I don't know but I don't think so
15:55:27 <trinaths> ok
15:55:44 <electrocucaracha> golang uses git repositories to build its dependencies
15:56:12 <electrocucaracha> so in your code, you're literally importing github.com/goproject/module...
15:56:42 <trinaths> electrocucaracha: ok. are these repos different or those particular versions of required packages are not existing ?
15:57:13 <electrocucaracha> maybe, the hashcode changed
15:57:16 <trinaths> electrocucaracha: for such kind of case, we need to verify manually the required packages and availability.
15:57:41 <trinaths> "hashcode change" can be
15:58:36 <trinaths> electrocucaracha: lets have this as an action item to think on.
15:58:59 <electrocucaracha> sure
15:59:07 <trinaths> #action electrocucaracha - Resolve Jenkins jobs issue - https://build.opnfv.org/ci/job/ovn4nfv-k8s-plugin-verify-master/3/console
15:59:13 <trinaths> ok.
15:59:23 <trinaths> moving to next topic.
15:59:36 <trinaths> #topic OVN-CN-VM scenario progress. - virtlet Ansible playbook based setup.
15:59:43 <trinaths> Amir_m: Hi
15:59:49 <Amir_m> Hi
15:59:56 <trinaths> can you update on the scenario
16:00:08 <trinaths> we have electrocucaracha (Victor) here to help us
16:00:40 <Amir_m> I've tried to do the installation on the CentOS jumpserver but it didn't work
16:01:08 <trinaths> Amir_m: any error report ?
16:01:40 <Amir_m> I've shared the error with Victor
16:02:25 <Amir_m> But nothing worked out
16:02:45 <trinaths> electrocucaracha: can you please help us on this scenario.
16:03:15 * electrocucaracha trying to remember what was the latest error
16:03:46 <electrocucaracha> so Amir_m , are you sure that the services are created and configured properly?
16:05:07 <Amir_m> Can you share your email with me and will send you the details right after the meeting
16:06:17 <Amir_m> I am in a doctor appointment right now
16:06:29 <trinaths> Amir_m: oh! ok.
16:07:00 <trinaths> electrocucaracha: can you also share the setup environment pre-requisites with Amir_m
16:08:09 <electrocucaracha> sure, in this case given that is using a VM, the host doesn't really matter
16:08:27 <trinaths> ok.
16:08:30 <electrocucaracha> I mean it can be any OS as long as it has enough memory and disk
16:08:48 <trinaths> what is the RAM and HDD space requirements
16:10:24 <electrocucaracha> well the default configuration which starts 6 VMs requires +40 GB, but it can be overwritten to an All-in-One which can be configured to use ~8GB
16:10:48 <trinaths> Amir_m: i guess all-in-on supports well.
16:10:56 <Amir_m> I've used a custmed pdf.yml file in the config directory
16:11:15 <trinaths> Amir_m: can you share the file for review
16:11:34 <trinaths> but I think, with customization too there was no impact.
16:11:35 <Amir_m> I will after the meeting
16:11:44 <electrocucaracha> https://git.onap.org/multicloud/k8s/tree/vagrant/config/samples/pdf.yml.aio
16:12:37 <Amir_m> I just modefied the ram and CPU requirements
16:12:53 <Amir_m> To fit host capacity
16:13:06 <electrocucaracha> but you are still getting an error right?
16:14:14 <Amir_m> Ye
16:14:48 <electrocucaracha> are you using the vagrant-libvirt provider?
16:15:04 <Amir_m> Yes
16:15:59 <electrocucaracha> mmm ok, you can send us the error in a pastebin link to take it a look
16:16:36 <electrocucaracha> http://paste.openstack.org/
16:16:42 <Amir_m> I will as soon as I get back to the office
16:17:07 <electrocucaracha> no worries
16:17:26 <Amir_m> Your email please
16:17:27 <trinaths> electrocucaracha: can you share you email so that Amir_m can update you. Also, Amir_m please put me in the mail if I can help.
16:17:49 <Amir_m> Sure
16:18:16 <electrocucaracha> you mean, this one victor.morales@intel.com
16:18:27 <trinaths> yes.
16:18:58 <trinaths> Amir_m: you said you have sent to victor the errors many times but how if you missed the email ?
16:19:42 <trinaths> ok. we have 10 more mins
16:19:46 <trinaths> #topic Hunter - MS2 - Nov 23rd - Release plan discussion.
16:19:54 <Amir_m> So Victor is electrocucaracha
16:20:04 <trinaths> Amir_m: yes.
16:20:05 <electrocucaracha> yeah ;)
16:20:11 <trinaths> :)
16:20:30 <Amir_m> How can I know? :)
16:21:06 <trinaths> me too don't know, I just googled, and found a mail thread victor replied with his IRC name. ;)
16:21:55 <electrocucaracha> I also register that nickname in NickServ
16:22:24 <trinaths> ok
16:22:33 <trinaths> Regarding H release.
16:23:01 <trinaths> electrocucaracha: can we have a PoC for plugin with working functionality for H release - mid April 2019 ?
16:23:51 <electrocucaracha> we recently did a demo for verizon using it, so I guess that it's doable for april
16:24:29 <electrocucaracha> given that we're releasing the source code it's going to be easy to share and replicate that
16:24:49 <trinaths> Amir_m: for G 7.2, we need to have our scenario ready. and for H we need to integrate with any installer.
16:25:24 <trinaths> electrocucaracha: can you share the presentation on this plugin if possible.
16:26:19 <trinaths> electrocucaracha: as said, I will showcase this plugin PoC and source code availability for H release. But we need to get Jenkins CI functioning before hand.
16:26:19 <electrocucaracha> well, we didn't focus on the plugin, it was more like showing what the KRD does
16:26:33 <trinaths> krd ?
16:27:08 <electrocucaracha> Kubernetes Reference Deployment, it's basically the vagrant project
16:27:18 <trinaths> ok.
16:27:23 <electrocucaracha> https://www.slideshare.net/VictorMorales34/hybrid-vfirewall-onap-use-case
16:27:24 <trinaths> got it.
16:27:36 <trinaths> Amir_m electrocucaracha you have any thing to share/update
16:27:41 <trinaths> we have 3 more minutes
16:27:53 <electrocucaracha> mm nope
16:28:04 <trinaths> #action Amir_m - share the errors with victor and update the scenario tasks
16:28:19 <trinaths> #action trinaths - complete H MS2
16:28:24 <trinaths> ok.
16:28:58 <trinaths> Amir_m electrocucaracha - thank you for your time and patience. I hope we had a great discussion
16:29:06 <electrocucaracha> thanks trinaths
16:29:13 <trinaths> electrocucaracha: when is ThanksGiving holiday ?
16:29:23 <electrocucaracha> this thru
16:29:28 <trinaths> ok.
16:29:48 <trinaths> thank you guys, ending the meeting. lets meet next week
16:29:52 <trinaths> #topic
16:29:58 <trinaths> #endmeeting