15:29:55 <trinaths> #startmeeting ovn4nfv-weekly-meeting-15Jan2019
15:29:55 <collabot`> Meeting started Tue Jan 15 15:29:55 2019 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:55 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:29:55 <collabot`> The meeting name has been set to 'ovn4nfv_weekly_meeting_15jan2019'
15:30:24 <electrocucaracha> hey trinaths
15:30:25 <trinaths> #topic Agenda: https://wiki.opnfv.org/display/OV/Meeting+Agenda
15:30:34 <trinaths> hey electrocucaracha
15:30:40 <trinaths> ritu joining ?
15:30:46 <electrocucaracha> I think so
15:30:57 <electrocucaracha> she got the email about the meetings
15:31:16 <trinaths> yes. i sent it
15:31:18 <electrocucaracha> and she didn't tell me anything about it
15:31:35 <trinaths> electrocucaracha: how was the ONAP+OPNFV meetup at france
15:32:04 <electrocucaracha> it was interesting in the sense that new players were going
15:32:09 <electrocucaracha> like Reza from Mirantis
15:32:21 <electrocucaracha> he was exploring the capabilities of ONAP
15:32:50 <trinaths> ok. so there is an action for moving to production readiness
15:32:52 <electrocucaracha> from my point of view, the project that requires a lot of effort and resources is integration
15:34:05 <trinaths> ok.
15:34:17 <trinaths> true said, integration requires much more efforts
15:34:26 <trinaths> even test suite will dynamically change
15:34:30 <trinaths> ritusood: Hi
15:34:38 <ritusood> Hello everyone
15:34:58 <electrocucaracha> hey ritusood
15:35:33 <trinaths> ritusood: hello
15:35:39 <ritusood> Hi
15:36:02 <trinaths> electrocucaracha: attended Amir intern session ?
15:36:31 <electrocucaracha> yes, he was there in most of the sessions that I attended
15:37:27 <trinaths> ok
15:37:46 <trinaths> well, lets start with code reviews and discuss the work progress.
15:37:52 <trinaths> #link https://gerrit.opnfv.org/gerrit/#/c/65961/
15:38:27 <ritusood> Yes that is unit test cases
15:39:23 <ritusood> #link https://gerrit.opnfv.org/gerrit/#/c/65829/
15:39:39 <ritusood> that is code cleanup that should be reviewed first
15:40:06 <trinaths> https://gerrit.opnfv.org/gerrit/#/c/65961/1/internal/pkg/config/config_test.go
15:40:10 <trinaths> line 100-112
15:40:23 <trinaths> can we have that config file contents as var ?
15:40:35 <trinaths> and use that var in the function ?
15:40:58 <trinaths> comments ?
15:41:18 <electrocucaracha> I haven't take a look of the changes
15:41:21 <ritusood> Yes go allows this syntax
15:41:29 <electrocucaracha> so hopefully I can do it in this week
15:41:45 <ritusood> this code is comping and running and also passed Jenkins
15:42:21 <electrocucaracha> well, yes but it has a low code coverage isn't it?
15:42:38 <trinaths> ritusood: agree, it passed jenkins. What i'm looking is reusability.
15:42:46 <ritusood> you mean for this file?
15:42:53 <trinaths> yes.
15:43:11 <trinaths> the config contents from Line 100-112
15:43:25 <trinaths> electrocucaracha:  yes. agree.
15:43:47 <trinaths> since its a inital test suite, i think we can move on and groom it as we go.
15:45:18 <ritusood> ok
15:47:11 <trinaths> ritusood: please change https://gerrit.opnfv.org/gerrit/#/c/65961/ as suggested.
15:47:26 <trinaths> any comments on this review ? please share
15:49:18 <ritusood> I'll try making this change as suggested but have to see if Ginkgo framework supports that
15:49:58 <trinaths> AFAIK, it support. please check it and post your comments. We will merge this soon.
15:50:24 <trinaths> next commit, #link https://gerrit.opnfv.org/gerrit/#/c/65829/
15:52:12 <trinaths> https://gerrit.opnfv.org/gerrit/#/c/65829/3/cmd/ovn4nfvk8s/ovn4nfvk8s.go , L 58
15:52:18 <trinaths> its a log right ?
15:53:01 <trinaths> electrocucaracha: ritusood : I have a doubt why you have used logrus? why not Go provided logging ?
15:54:53 <electrocucaracha> I think that it's what ovn-kubernetes uses, right?
15:55:21 <trinaths> ok.
15:55:49 <trinaths> electrocucaracha: I have a basic doubt, are we implementing CNI again ?
15:57:26 <ritusood_> Sorry got disconnected
15:57:40 <electrocucaracha> that plugin provides a new cni binary
15:57:40 <ritusood_> the last comment I saw was baout logrus
15:58:05 <trinaths> agree.
15:58:11 <ritusood_> logrus provides better logging facilities
15:58:21 <trinaths> ritusood_:  ok. got it
15:58:44 <trinaths> I feel there are more development for plugin to come-in.
15:58:56 <trinaths> ritusood_:  thanks for README update https://www.amazon.in/Century-Novelty-AX-AY-ABHI-10611-Natural-Coconut/dp/B0032TG0BO
15:59:01 <ritusood_> I missed the cni binary comment
15:59:07 <trinaths> ritusood_: sorry
15:59:10 <trinaths> wrong link
15:59:18 <trinaths> https://gerrit.opnfv.org/gerrit/#/c/65829/3/internal/pkg/config/config.go
15:59:25 <electrocucaracha> hahaha
15:59:34 <trinaths> #link https://gerrit.opnfv.org/gerrit/#/c/66331/
15:59:56 <trinaths> ritusood_: I mean, are we re-implementing the CNI again ?
16:01:12 <ritusood_> We have a new CNI for ovn4nfv-k8s
16:01:35 <ritusood_> that CNI is used to add multiple interfaces
16:02:21 <trinaths> ok. can multus doesn't support that ?
16:02:21 <ritusood_> I needs to be used with Multus
16:02:26 <ritusood_> No
16:02:49 <ritusood_> Multus dosn't support dynamic network creation
16:03:10 <ritusood_> that is one of the requirements and that is the reason we are using OVN
16:03:31 <trinaths> ritusood_: got it.
16:03:38 <trinaths> ritusood_:  thank you
16:04:43 <trinaths> ritusood_:  i have couple of comments posted for the commits. kindly please review  and update the same.
16:04:56 <trinaths> electrocucaracha: please review the commits.
16:04:58 <ritusood_> Sounds good
16:05:27 <electrocucaracha> ok, I'm going to look for some time do to it
16:05:43 <trinaths> #topic k8s-ovn4nfv-plugin - Next todo
16:06:12 <trinaths> electrocucaracha: ritusood_ : How we proceed next ?
16:06:40 <ritusood_> We are looking for resources to integrate with Compass
16:07:15 <ritusood_> We'll let you know if someone can do that soon
16:07:17 <trinaths> ritusood_:  that is a priority item for OPNFV release.
16:07:23 <trinaths> ritusood_: thank you
16:07:50 <trinaths> ritusood_:  regarding tests, we need a functionality test suite.
16:08:22 <ritusood_> We need a kubernetes deployment for that
16:08:40 <trinaths> that will come with Installer deployment i guess
16:09:03 <ritusood_> you mean with Compass?
16:09:42 <trinaths> ritusood_: yes.
16:10:07 <trinaths> we need to have test suite other than unit-tests to test the compass based deployment.
16:10:38 <ritusood_> Yes agreed
16:11:04 <trinaths> ritusood_: ok
16:12:05 <trinaths> electrocucaracha, ritusood_ : any proposals for OpenStack, KubeCon and ONS Americas 2019 ?
16:12:40 <electrocucaracha> I was thinking to submit something for the ONS
16:12:54 <electrocucaracha> but I haven't decided yet
16:13:04 <trinaths> ok
16:13:44 <trinaths> i was planning for OpenStack and ONS.
16:13:59 <electrocucaracha> any specific topic?
16:14:33 <trinaths> Open Infrastructure
16:15:09 <trinaths> AirShip, KataContainers and trying Sidecar Proxy for Kata Containers
16:15:30 <trinaths> some related topics to OpenStack+K8S+OpenInfra
16:16:13 <trinaths> for ONS, I was thinking for 2 topics. I dont think I get a travel support for ONS 2019. But some co-author can present it.
16:16:17 <electrocucaracha> there is an effort to integrate Airship in XCI
16:16:50 <trinaths> ok. May be that can is a session topic.
16:17:47 <trinaths> #topic Open Discussion.
16:18:33 <trinaths> please vote for "Prakash Ramchandran" contesting for "independent Board of Directors  - 2019 - OpenStack".
16:19:16 <electrocucaracha> ok, I'll if I get the link
16:19:22 <ritusood_> ok
16:20:09 <trinaths> electrocucaracha: from OpenStack Berlin summit 2018, I have seen more on intro session on Open Infra, with K8S
16:20:57 <trinaths> we have 10 mins more.
16:21:13 <trinaths> please share if you have anything to discuss
16:22:11 <electrocucaracha> nope, basically that's from my side
16:22:34 <trinaths> ok.
16:22:36 <trinaths> ritusood_: ??
16:23:29 <trinaths> ok. Let continue the good work.
16:23:31 <trinaths> Bye all
16:23:56 <trinaths> #action ritusood_ : work on recent commits.
16:25:04 <trinaths> #action ritusood_ : Compass and k8s-ovn4nfv-plugin integration
16:25:25 <trinaths> thanks electrocucaracha ritusood_ for attending the weekly meeting
16:25:30 <trinaths> #endmeeting