15:30:44 <trinaths> #startmeeting ovn4nfv-meeting
15:30:44 <collabot`> Meeting started Tue Jan 22 15:30:44 2019 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:30:44 <collabot`> The meeting name has been set to 'ovn4nfv_meeting'
15:30:51 <trinaths> #chair trinaths
15:30:51 <collabot`> Current chairs: trinaths
15:31:22 <trinaths> #link Agenda: https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
15:31:30 <trinaths> electrocucaracha: Hello
15:32:23 <electrocucaracha> Hi trinaths
15:32:46 <trinaths> ritu will be joining ?
15:33:55 <electrocucaracha> yes, she is here
15:34:15 <ritusood> Hi everybody
15:34:24 <trinaths> ritusood: Hi
15:34:50 <trinaths> electrocucaracha:  have any comments of code to be merged ?
15:35:25 <electrocucaracha> I think that ritusood has been addressed all our comments, isn't it?
15:35:48 <trinaths> #link https://gerrit.opnfv.org/gerrit/#/c/65961/
15:36:54 <trinaths> electrocucaracha, ritusood: can we merge the above one ?
15:38:23 <ritusood> Yes
15:38:31 <ritusood> It depends on the other patch
15:38:32 <electrocucaracha> yes, it's fine
15:38:38 <trinaths> electrocucaracha, ritusood: https://gerrit.opnfv.org/gerrit/#/c/65829/3/internal/pkg/config/config.go L17
15:38:49 <electrocucaracha> I'd prefer a long description in the commit message but it's fine
15:39:06 <trinaths> do you think version be configurable via source code ?
15:39:57 <electrocucaracha> which version are you talking about?
15:40:40 <trinaths> Version = "0.1.0"
15:40:44 <trinaths> line 17
15:42:41 <electrocucaracha> yeah, maybe there is a way to don't specify there
15:43:31 <trinaths> as ritusood commented, the version changes as per the deployment. We cannot ask the end user to configure this from code for their deployment preference.
15:44:32 <ritusood> We can remove this for now as this is not been used anywhere and come up with another scheme
15:44:42 <ritusood> for version control
15:45:38 <electrocucaracha> +1
15:45:38 <trinaths> ritusood: sounds good. "version control" you mean the version of ovn4nfv-plugin for internal usage or user specific reference?
15:46:39 <ritusood> Yes
15:46:51 <ritusood> It is for internal usage
15:47:10 <ritusood> Ok I'll remove it
15:47:15 <trinaths> ritusood: ok.
15:47:33 <trinaths> please upload a new patchset for review.
15:48:07 <ritusood> sounds good
15:48:09 <trinaths> I think the #link https://gerrit.opnfv.org/gerrit/#/c/65961/ and #link  https://gerrit.opnfv.org/gerrit/#/c/65829 are dependent and need to merged
15:48:14 <trinaths> at the same time
15:48:22 <trinaths> the first is good to go
15:48:46 <trinaths> there is another pending on #link https://gerrit.opnfv.org/gerrit/#/c/66331/
15:48:59 <trinaths> changes to README file.
15:49:11 <trinaths> I have a simple comment ritusood to consider.
15:49:30 <trinaths> Now README is more descriptive.
15:49:31 <ritusood> I updated the Readme and uploaded a new patch just now
15:49:45 <ritusood> taking care of the comment
15:50:15 <trinaths> ritusood:  excellent.
15:50:24 <trinaths> electrocucaracha: comment on https://gerrit.opnfv.org/gerrit/#/c/66331/ ?
15:50:51 * electrocucaracha was doing a quick check
15:50:56 <trinaths> ok
15:52:01 <electrocucaracha> I think that the line 110 is wrong, isn't it?
15:52:21 <electrocucaracha> https://gerrit.opnfv.org/gerrit/#/c/66331/6/README.rst@110
15:52:34 <electrocucaracha> that needs to be before the line 108
15:52:46 <electrocucaracha> I mean annotations is part of the block of code
15:52:58 <trinaths> agree.
15:53:29 <trinaths> but i dont find any difference.
15:53:51 <trinaths> line 110 defines, annotations code block
15:54:10 <ritusood> I fee the same
15:54:30 <electrocucaracha> well, .. code-block:: yaml is a sphinix instruction that formats the code
15:54:42 <trinaths> electrocucaracha: To meet the requirement of multiple interfaces and IP's per pod, a Pod annotation like below is required when working with Multus:
15:54:54 <trinaths> electrocucaracha: yes. its docs instruction
15:54:58 <electrocucaracha> so if the line 108 is not included, it won't have the proper style at  the end
15:55:11 <trinaths> electrocucaracha:  its not like that.
15:55:15 <ritusood> Yes I agree but from the documentation purpose that can be part of the yaml block or not
15:55:38 <trinaths> electrocucaracha: " .. code-block" is enough
15:56:06 <trinaths> I feel there is no requirement to specify "yaml".
15:56:14 <electrocucaracha> yes, but annotations: is part of the yaml section
15:56:36 <trinaths> then Line 108 be moved to Line 110
15:56:38 <trinaths> ?
15:56:50 <electrocucaracha> yes, it's important
15:56:54 <electrocucaracha> and makes difference
15:57:02 <trinaths> electrocucaracha: agree
15:57:07 <ritusood> it is showing up correctly
15:57:13 <ritusood> that is what I mean
15:57:48 <ritusood> it is documentation and if you render it shows up the way we want
15:57:51 <electrocucaracha> ritusood: that annotations line is part of the yaml block of code
15:57:56 <trinaths> ritusood: I mean, "annotations:" be move to ".. code-block" section for yaml file correctnes
15:58:09 <ritusood> ok
15:58:16 <electrocucaracha> yes, please
15:58:43 <electrocucaracha> regarding the section of authors/contributors at the end
15:58:49 <electrocucaracha> ?
15:58:55 <electrocucaracha> it's fine to keep them?
15:59:10 <electrocucaracha> usually, commits shown who are the contributors
15:59:12 <trinaths> electrocucaracha: yes.
15:59:17 <electrocucaracha> or another files
15:59:25 <trinaths> doubt: why electrocucaracha is not added ?
15:59:52 <electrocucaracha> well, it's not common to see it there
16:00:41 <trinaths> electrocucaracha: then we can have AUTHORS file for this project.
16:00:52 <electrocucaracha> yeah
16:01:45 <ritusood> I uploaded new patch for README
16:01:51 <trinaths> ritusood: can you update the file with another file for AUTHORS
16:02:07 <ritusood> I'll like to do in another patch
16:02:24 <trinaths> ok
16:04:21 <trinaths> electrocucaracha:  you comments on updated readme ?
16:04:47 <electrocucaracha> ok, I can put them there
16:05:24 <trinaths> ritusood: Line: 102
16:05:29 <trinaths> This plugin is currently tested to work with Multus and Flannel providing the first network interface.
16:05:44 <trinaths> Multus configured with Flannel ?
16:06:01 <ritusood> yes
16:06:50 <trinaths> the wording be changed ?
16:08:37 <electrocucaracha> and remove the line 175
16:08:48 <electrocucaracha> or use the proper url
16:10:38 <trinaths> ritusood: for README please consider the proposed changes. we can merge the document.
16:11:13 <ritusood> I'll add authors later other than that I'll update the README
16:11:21 <trinaths> ritusood: +1
16:11:26 <electrocucaracha> thanks ritusood
16:11:45 <trinaths> #topic Compass integration
16:12:33 <ritusood> We have identified a resource but still waiting for internal approval to start working on this
16:12:37 <trinaths> electrocucaracha, ritusood: please share your thoughts on compass integration
16:13:04 <trinaths> ok. then, we require functional tests
16:13:46 <ritusood> Once we have resource commitment then we can start looking into that
16:14:01 <trinaths> ritusood: ok.sounds good
16:14:31 <trinaths> #action: update Readme and Code clean up patchsets - ritusood
16:15:12 <trinaths> we have 15 minutes more
16:15:33 <trinaths> #topic ONS Americas - Demo ideas and OpenStack Summit
16:16:14 <electrocucaracha> isn't yesterday last day for CFP of ONS?
16:16:35 <trinaths> electrocucaracha, ritusood:  last week OPNFV marketing team want its projects to showcase a demo which collaborates with LNF and ONAP.
16:16:48 <trinaths> yes it was, its OPNFV marketplace demo
16:16:56 <trinaths> at ONS Americas 2019.
16:17:07 <trinaths> I asked srini on this but there was no reply.
16:17:49 <trinaths> since this plugin main requirement is in ONAP. I thought this effort be showcased at summit.
16:18:03 <electrocucaracha> yeah, makes sense
16:19:12 <trinaths> if your team is attending/presenting at the summit, they can give a marketplace demo at OPNFV booth collaboration of OPNFV, LNF and ONAP. also I think Intel will have a booth at marketplace
16:19:59 <electrocucaracha> trinaths: maybe, usually the approval process for conferences is weird
16:20:26 <trinaths> electrocucaracha:  ok.
16:20:52 <electrocucaracha> but what you proposed makes sense
16:20:59 <ritusood> We can check interest internally at Intel
16:21:49 <trinaths> electrocucaracha, ritusood: please check with Srini for suggestions.
16:22:22 <ritusood> ok
16:22:57 <trinaths> For OpenStack summit ? Jan 23rd is the deadline.
16:23:07 <trinaths> have some ideas to submit ?
16:23:20 <trinaths> This time summit is in denver.
16:23:54 <electrocucaracha> none
16:24:04 <trinaths> ok.
16:24:12 <trinaths> i'm done.
16:24:33 <ritusood> Please review the patches I took care of the comments
16:24:35 <trinaths> like OpenStack OSM is also getting some focus
16:24:41 <trinaths> ritusood:  sure
16:24:59 <trinaths> im thinking for OSM OVN integration.
16:25:08 <trinaths> that was from my end.
16:25:16 <trinaths> we have 5 more minutes to go
16:25:21 <ritusood> Can you share more on OSM>
16:25:26 <trinaths> any comments/suggestion
16:25:40 <trinaths> ritusood: sure. I will share the PPT and architecture
16:25:50 <ritusood> ok sounds good
16:26:36 <electrocucaracha> great, thanks
16:26:49 <trinaths> thank you for attending the meeting and contributing good work.
16:26:51 <trinaths> bye.
16:26:58 <ritusood> bye
16:27:00 <trinaths> #endmeeting