15:31:18 <trinaths> #startmeeting ovn4nfv
15:31:18 <collabot`> Meeting started Tue Jan 29 15:31:18 2019 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:18 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:31:18 <collabot`> The meeting name has been set to 'ovn4nfv'
15:31:29 <trinaths> #chair trinaths
15:31:29 <collabot`> Current chairs: trinaths
15:31:39 <trinaths> #link Agenda: https://wiki.opnfv.org/display/OV/Meeting+Agenda
15:31:44 <trinaths> Hi electrocucaracha
15:31:55 <trinaths> Good Morning
15:33:31 <electrocucaracha> Hey trinaths
15:33:42 <electrocucaracha> Good afternoon
15:33:44 <ritusood> Hi everyone
15:33:50 <trinaths> hi all
15:33:54 <trinaths> hi electrocucaracha ritusood
15:34:08 <trinaths> #link Agenda: https://wiki.opnfv.org/display/OV/Meeting+Agenda
15:35:07 <trinaths> ritusood: electrocucaracha suggested to commit each change individually for easy review on #link https://gerrit.opnfv.org/gerrit/#/c/65829
15:35:52 <ritusood> ok
15:36:27 <ritusood> I'll upload patches soon
15:36:31 <trinaths> ok
15:36:45 <trinaths> ritusood:  do you have any patches for review ?
15:37:16 <trinaths> ritusood:  also, the README file need some more changes, like new AUTHORS file.
15:37:35 <ritusood> Yes, I'll upload those patches soon
15:38:28 <ritusood> I'll be adding one more patch after that
15:38:37 <trinaths> #action ritusood: Update new commits from https://gerrit.opnfv.org/gerrit/#/c/65829 as suggested.
15:38:40 <trinaths> ok
15:39:02 <trinaths> electrocucaracha, ritusood:  any update on Compass installer support ?
15:39:51 <ritusood> We have identified a resource and very likely it'll be approved but haven't heard about the final approval yet
15:39:59 <trinaths> ok
15:40:20 <trinaths> may be by next week we can expect something good
15:40:49 <ritusood> yes
15:41:05 <trinaths> sounds good
15:41:41 <trinaths> electrocucaracha, ritusood: what is the plan for k8s-ovn4nfv-plugin next steps.
15:42:29 <ritusood> We are adding provider network support
15:42:44 <trinaths> excellent.
15:43:18 <trinaths> ritusood: can you share the design changes ? also update the wiki page with the required changes
15:43:36 <ritusood> Ok
15:44:10 <ritusood> Some changes will be outside of the k8s-ovn4nfv-plugin
15:44:21 <trinaths> ritusood: can you give a brief note of the changes ?
15:46:08 <ritusood> Currently we are evaluating how provider network support can be added with k8s-ovn4nfv-plugin  and KRD. We'll be using localnet bridge for that. Those changes will be in KRD
15:46:49 <ritusood> We are doing PoC's and coming up with final design
15:47:15 <trinaths> so, how user can input the provider network range ?
15:48:40 <ritusood> That will be provided during deployment
15:48:45 <ritusood> of KRD
15:51:11 <trinaths> ok. will that be another yaml file ?
15:51:35 <ritusood> yes
15:52:28 <trinaths> ok.
15:53:20 <trinaths> ritusood: please check-in a new spec on this support. so that we can have more details on this implementation
15:53:32 <ritusood> ok
15:54:37 <trinaths> #action ritusood: new spec for provider networks support
15:55:25 <trinaths> ritusood:  please create a new directory, 'specs' and checkin the new implementations for k8s-ovn4nfv-plugin
15:56:03 <ritusood> ok
15:56:33 <trinaths> #topic ovn4nfv with OSM
15:57:03 <trinaths> I have done some study in the last week on how OVN can be integrated to OSM.
15:57:34 <trinaths> OpenSource MANO (OSM) is a native NFV MANO (management and orchestration) from ETSI
15:57:56 <trinaths> OSM is on release 4 with release 5 to support containers.
15:58:53 <trinaths> VMware, BT, Telefonica etc.. team is working for OSM.
15:59:23 <ritusood> ok
16:00:05 <electrocucaracha> that project is specially driven by Telefonica, isn't it?
16:00:19 <trinaths> electrocucaracha: yes
16:00:41 <trinaths> at OPNFV, SFC team is driving OSM-SFC-ODL initiative.
16:00:48 <trinaths> https://wiki.opnfv.org/display/sfc/OSM+guide
16:00:51 <trinaths> #link https://wiki.opnfv.org/display/sfc/OSM+guide
16:01:06 <trinaths> its a intern project fro odl opnfv team
16:01:17 <trinaths> the intern is from india, CHENNAI, Tamilnadu.
16:01:36 <trinaths> I meet him in october. and had a discussion on the same
16:02:16 <trinaths> OSM be integrated with OpenStack VIM.
16:02:26 <trinaths> VIM (Virtual Infrastructure Manager)
16:02:41 <trinaths> OpenStack is configured to use OVN along side OVS.
16:03:00 <trinaths> in ovn4nfv we have PoC implementation for SFC with OpenStack Tacker.
16:03:33 <trinaths> I'm exploring more to how I can replace TACKER with OSM to support additional VNFM (VNF MANAGER)
16:03:57 <trinaths> This is what i have from my end.
16:04:08 <trinaths> I will draft a WIKI page and PPT with my proposal.
16:04:22 <trinaths> once I have in place, we can discuss and improve the same.
16:04:48 <ritusood> sounds good
16:05:14 <trinaths> since OSM release today, doesn't support Container VNFs, OVN with VM is the approach
16:05:50 <ritusood> Are you going to use Compass?
16:05:55 <trinaths> ritusood, electrocucaracha: you are all aware of ETSI NFV and MEC architectures ?
16:06:28 <electrocucaracha> trinaths: no
16:07:40 <trinaths> ok. I will add few slides with these architectures too
16:08:02 <trinaths> any comments/suggestions while we move to next topic
16:08:33 <ritusood> Meeting time
16:08:49 <ritusood> I want to discuss about that
16:09:12 <trinaths> #topic open discussion
16:09:24 <trinaths> ritusood: the stage is yours
16:09:59 <ritusood> This time is not going to work with me for next few weeks
16:10:05 <trinaths> ok.
16:10:13 <trinaths> can you suggest a new time
16:10:35 <ritusood> Also can we have zoom meeting?
16:11:40 <trinaths> sure.
16:11:50 <trinaths> I went for Zoom meeting initially.
16:12:11 <trinaths> but the team at that time suggested IRC only since we can have a log of the things.
16:13:04 <trinaths> For Zoom meeting for our project, we need to look for new time where the Zoom session is free from OPNFV provided Zoom session lists.
16:13:11 <ritusood> ok I spoke to Srini he prefers Zoom also and if we have different time he may be able to join
16:13:28 <ritusood> I see
16:13:49 <trinaths> let me check with OPNFV Zoom sessions
16:14:11 <trinaths> availability for our time slots.
16:14:15 <ritusood> Can you figure out and suggest some meeting times and we can check with Srini also
16:14:34 <trinaths> sure.
16:15:11 <trinaths> ritusood, electrocucaracha: can you share your meeting time preferences
16:16:13 <trinaths> electrocucaracha: ritusood and srini are all in the same timezone/office/location ?
16:16:24 <ritusood> Yes
16:16:25 <electrocucaracha> trinaths: yes, we are in the PsT
16:16:31 <trinaths> ok
16:16:37 <trinaths> i'm to IST
16:16:51 <trinaths> so its always be night time to me
16:16:53 <trinaths> :)
16:17:04 <ritusood> We have lot of ONAP meetings in our mornings
16:17:13 <trinaths> ritusood: oh ok
16:17:28 <trinaths> can we shift our meeting to PST evening or night ?
16:17:34 <trinaths> with that be fine ?
16:17:35 <ritusood> so we'll have to find a slot that is not clashing with that.
16:17:46 <trinaths> are you okay with TUESDAY ?
16:18:51 <ritusood> Night may not work as we have early morning meetings
16:19:21 <ritusood> Can you do early morning meeting that will be evening for us?
16:20:23 <trinaths> IST early morning meeting may trouble me. since my day time is busy with rush to office.
16:20:41 <ritusood> ok
16:21:38 <trinaths> what evening time is free for your team ?
16:21:52 <trinaths> electrocucaracha: ritusood and srini can join
16:23:47 <trinaths> we have 7 more minutes to go
16:24:20 <ritusood> I would prefer a time either before 7:00 and after 9:00 AM for next few weeks and then I'll be ok to do between that slot also
16:24:20 <ritusood> Let's do this over email
16:24:20 <ritusood> Let me also check with Srini to see if he has any slot available in the morning
16:24:26 <trinaths> from the OPNFV mailing list, I have srini suggesting some demo for ONS Americas 2019 with OPNFV.
16:24:34 <trinaths> any update on that electrocucaracha, ritusood?
16:24:34 <ritusood> Are you coming for ONS this year?
16:25:08 <ritusood> Yes we are thinking of doing a demo with provider networks
16:25:09 <trinaths> ritusood: dont know. I'm moving to new employer, F5 Networks.
16:25:38 <ritusood> I see.
16:26:24 <trinaths> ritusood: update me with the time where your team can join. also we need to check the Zoom session availability from OPNFV for that time slot.
16:26:56 <ritusood> Yes please start a email with the Zoom time suggestions and we can decide from there
16:27:02 <trinaths> ritusood:  next few weeks you will contributing to ovn4nfv work or you are on vacation?
16:27:45 <trinaths> #action trinaths: Start OPNFV Zoom session available slots for ovn4nfv Zoom meetings
16:27:46 <ritusood> I'm not going on vacation I need to drop my daughter to school for next couple of weeks
16:27:54 <trinaths> ritusood:  ok.
16:28:12 <trinaths> ok.
16:28:19 <trinaths> that's all from my end.
16:28:24 <trinaths> any updates ?
16:28:33 <ritusood> Sounds good
16:28:39 <trinaths> any comments before we close this meeting.
16:28:56 <ritusood> Not from me
16:29:22 <electrocucaracha> nothing from my side
16:30:01 <trinaths> #endmeeting