14:05:30 <farheen_cefalu_a> #startmeeting Architecture Committee
14:05:30 <collabot> Meeting started Thu Mar 28 14:05:30 2019 UTC.  The chair is farheen_cefalu_a. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:30 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:30 <collabot> The meeting name has been set to 'architecture_committee'
14:10:28 <farheen_cefalu_a> #topic Docker Proxy Bryan Sullivan
14:12:49 <farheen_cefalu_a> #info Ability for people to pull and push through the docker proxy.  Is it allowed?  And there are some basic rules around that.  There is an acumos user name pwd.  And are they allowed to docker pull.  Is it a public model?  Do they own it?  If it's public is it open source?  If it's not open source do they have a right to use.  If it's public and not open source you have to have the right to use.  The docker prox
14:15:15 <farheen_cefalu_a> #info sidecar to enginex.  It validates and responds back yes, you can add.  the docker registry api you probably know that it is a complicated thing.  It involves oauth as an enabler.  When you want to login to a docker registry you are authenticated by a third party using oauth.  You have a registry and a proxy that validates your access to this resource.  When the user logs in pull and push is re-verified that t
14:16:34 <farheen_cefalu_a> #info then it checks the users right to pull or push.  This works in Boreas.  I have verified.  Any time you get in the middle of a protocol you have potential of breaking things.  It is functioning for pull and push.  The bigger arch. question is, is this the role that Acumos should have?
14:17:41 <farheen_cefalu_a> #info Where do these images live?  Many people are not going to have a docker registry that is baked into the platform.  The docker registry is way outside the acumos platform.  There are many doors to this docker registry.  There are many protocols around acumos entry.
14:18:45 <farheen_cefalu_a> #info We need to look at the complexity of completing these goals.  There are limits to what we can guarantee to the security of the platform.
14:20:39 <farheen_cefalu_a> #info Manoop: We can provide a minimal one click download and install however the minimal security is oauth samples.  We should not support all options we should give minimal.
14:22:13 <farheen_cefalu_a> #info Bryan: We will apply the rules and controls that we have.  In the context of deployment environment what actually has access to what resource under what terms will be a Clio discussion.  My experience in implementing the docker proxy it's complicated, technically challenging and may introduce fragility to the user experience.
14:23:41 <farheen_cefalu_a> #info Mukesh: Is this docker proxy to be used for onboarding? Bryan: Yes.  When a human wants to access an image they will be able to do it thru the docker proxy.  They login thru the docker proxy.  Manoop: Will it check portal user credentials? Yes, it calls the jwt token of the api like for onboarding.
14:25:15 <farheen_cefalu_a> #info Guy: We (onboarding) have gone over this before.  We are OK with it. It is a viable way to go.  It is perfectly usable.  With this docker push user will be logging in to pull the docker image.  Is there a way we can track which user and how many?
14:26:09 <farheen_cefalu_a> #info Manoop: Is there a user story for pulls?  Mukesh: Assuming docker proxy can seamlessly be integrated into CDS.  Manoop: We need to understand and document that.
14:26:36 <farheen_cefalu_a> #action Bryan create a user story for the Clio release for docker proxy pull
14:27:59 <farheen_cefalu_a> #info Bryan: Deployment is going to be substantial in the Clio release. I provide a front end that is not thru portal.  Portal requires the scanning service thru the security verification library.
14:33:46 <farheen_cefalu_a> #info Manoop: I want details for the ML Workbench.  Bryan: The blue things are web service component.  The role of kong proxy and ingress controller becomes more important because there may be many ms many layers.  Just like zool proxy is a reverse proxy layer.  There may be reverse proxy's so the security of the platform and apis. Security will become important
14:36:16 <farheen_cefalu_a> #info Why jenkins?  Jenkins is a single consolidated engine that is conducting processes.  What is the advantage?  The user onboards a model and sees a progress screen on the portal.  The portal is reaching out to dbase or where we are in the step table.  The things thats writing to the step table is monitoring and that thing can write to the step table.  It's a question of who populates the data in that step.  The
14:37:54 <farheen_cefalu_a> #info a build function.  It will conduct multiple ms.  Kazi: I have a diagram Bryan: use draw.io so we can drill down into the subsystems it will be very helpful.
14:38:16 <farheen_cefalu_a> #info: Manoop: We will continue to brainstorm.
14:38:52 <farheen_cefalu_a> #topic Clio Schedule Nat Subramanian
14:41:19 <farheen_cefalu_a> #info Nat: Reviewing Clio Revised Sprint Calendar.  Kazi feels it is no doable due to the overlap with the Boreas release.  Nat: We have to start Clio on time in order to make it to the November thanksgiving break.
14:44:11 <farheen_cefalu_a> #info Bryan: Our experience in Boreas we tried to start it before the holidays that really didn't help us at all.  I would not start the next release before January of next year.
14:45:29 <farheen_cefalu_a> #action Kazi and Bryan bring your concerns to the Tuesday 4/2 4PM EDT TSC call.
14:56:53 <farheen_cefalu_a> #topic ML Workbench
14:57:48 <farheen_cefalu_a> #info Chris: I am working with Eric Ball on the deploy fix.  We will work with LF foundation to get the jenkins.
14:57:56 <farheen_cefalu_a> #topic Scorecard
14:58:21 <farheen_cefalu_a> #info CDS Chris: 95%
15:00:57 <farheen_cefalu_a> #info ML Workbench Kazi: We are not getting response about how we will be integrated with the workbench.  How to integrate the nifi with the workbench.  That is a big blocker.  How to interface the backend and how to manage the user containers.  We knew we wanted to do a lite integration with the be in this release.  We can solve this.  The bigger question is how are we going to launch the containers.  Nifi and Zep
15:03:29 <farheen_cefalu_a> #info will re-use the CMLP team.  Manoop: Based on the blocker do you see progress with four weeks left?  Kazi: It is a big concern.  From the architecture perspective we have to come to some conclusion in the next week.  If you see that is not happening then we will raise it as a concern.  From architecture perspective i want the design finalization by next week.  They have to do a POC and provide a
15:04:25 <farheen_cefalu_a> #info Kazi: We started with the assumption thinking that the CMLP team had the solution but have not gotten a reply from CMLP.  We have significant risk that we are not going to be able to deliver.
15:08:46 <farheen_cefalu_a> #info we may have to leverage the access we have to launch using the kubernetes api. Manoop: If you need help from CMLP then reach out to Sayee.
15:09:18 <farheen_cefalu_a> #action Kazi propose to Anwar that we need help from CMLP
15:09:25 <farheen_cefalu_a> #endmeeting