#acumos-meeting: Architecture Committee

Meeting started by farheen at 15:06:11 UTC (full logs).

Meeting summary

  1. Loose Ends that people want to bring to the table about Clio release. (farheen, 15:06:47)
    1. Murali - brought up the Clio release open defects. (farheen, 15:08:36)
    2. Ken and Murali did a deep dive into issues and filtered on issues from the maintenance release. there are 3 that are open and high. (farheen, 15:12:51)
    3. Acumos-3731 is a new requirement and not a bug. (farheen, 15:13:17)
    4. Acumos-3707 loading Dashboard and Project giving error. Ken is working this issue. (farheen, 15:14:01)
    5. Security verification high defect. Bryan said it is a work in progress. (farheen, 15:14:46)

  2. Logging API integration plan (Vineet) (farheen, 15:15:28)
    1. this has been demonstrated last week. It is done. Will be sharing API. (farheen, 15:16:27)

  3. Review deployment namespace/port (farheen, 15:17:16)
    1. Bryan - How are services exposed what sort of controls do you have over that. What should we adopt as a project to maintain these platforms. These are complex platforms. Such as rabbit mq bus that connects services automatically. These techniques will help us with maintenance effort. Defer this discussion until after Clio. We want to (farheen, 15:18:53)
    2. Guy - This can go under the deployment configuration. Watching people deploy the system are struggling. Therefore for new people it can be a big challenge. It should be simple enough for people to read documentation and deploy the platform. (farheen, 15:19:59)
    3. ACTION: / Bryan Sullivan - Wants to demonstrate how to deploy the platform with a wrapper inside a wrapper approach that makes it simple to maintain the platform across diverse environment with only a few key options that you have to select. That trickles down into the maintain deployment of components. I have used this with 5 different (farheen, 15:22:02)
    4. ACTION: / Guy add to mid December agenda item. The 10th would be better for scheduling. (farheen, 15:23:08)
    5. ACTION: Bryan put the system design documentation into the repo of how things are deployed. (farheen, 15:23:35)
    6. Sayee - off topic - What does logging API mean? (farheen, 15:23:57)
    7. Vineet leverages a few additional methods and will help with multiple thread requests. It will give you a log statement for each thread. (farheen, 15:24:37)
    8. is this going to be service or standard? (farheen, 15:24:47)
    9. this is standard. we are using the jars right now. We publish the jars needs to be applied to components. (farheen, 15:25:10)
    10. Once logging is enabled will we pull into kibana? (farheen, 15:25:22)
    11. yes (farheen, 15:25:28)
    12. logging will have the same architecture but be improved. (farheen, 15:25:43)
    13. we need to get the metric for the log. Have we thought this through completely? Is this funcitonal, system, or metric log? (farheen, 15:26:15)
    14. for now it is based on the services. The rest services they find in each component. (farheen, 15:26:47)
    15. Sayee would like a further discussion with Vineet on this topic. (farheen, 15:27:06)
    16. Will Jacob from Orange be joining us? (farheen, 15:28:17)
    17. Nat - Angel project from Tencent. (farheen, 15:28:33)
    18. Guy - We are working with Fitz from Tencent trying to onboard a Huawei model. We are trying to assist. It is not relevant for Architecture. (farheen, 15:29:26)
    19. Bryan - the issue they has been resolved this morning. (farheen, 15:29:55)

  4. Review the Demeter Release (Murali) (farheen, 15:30:57)
    1. Murali reviewed (farheen, 15:31:47)
    2. https://wiki.acumos.org/display/REL/Demeter+Release+Requirements (farheen, 15:31:50)
    3. epics are due November 22. (farheen, 15:32:33)
    4. Guy - This is very high level. (farheen, 15:33:01)
    5. Murali do not use the Demeter tag. Someone has used the Demeter tag. This needs to be removed. Contact Murali Vuppari for details. (farheen, 15:34:28)

  5. Acumos-3659 (Nat) (farheen, 15:35:06)
    1. this is targeted for the point release. The wireframe team showed screens and the meeting was recorded. Manoop and Reuben were on the call. They wanted to start the process and provide the role based restrictions. The roles will be mvp and catalogs may not be in Demeter. We will add the link to this summary on the Architecture Committee (farheen, 15:36:49)
    2. Bryan updated value page for the Demeter. (farheen, 15:37:29)
    3. Does anyone have specific items they want to put on the agenda. (farheen, 15:37:46)
    4. Bryan insure the Acumos platform fully supports the product. It is not clear that there is any assurance. We have not tested. Bryan has added it to the agenda. (farheen, 15:38:51)
    5. Bryan insure the Acumos operation of platform and the logs. (farheen, 15:39:33)
    6. Explore alternates such as filebeat for logging. (farheen, 15:39:54)
    7. the dependance of logs that filebeat mines requires overhead with the side car. The current log file collection design. (farheen, 15:40:41)

  6. Bryan Automating platform maintenance (farheen, 15:41:53)
    1. Big goal is CI/CD. another expanding the community with projects inside public clouds. (farheen, 15:42:37)
    2. having an automated process for the purpose of managing and deploying training models. We want a seamless, reliable, management. The limitation we may have with trust and security with obligations of licenses. (farheen, 15:43:40)
    3. we can mitigate the risk by ensuring those solutions are deployed in the controlled environments that can't be hacked. Controlling the process will help to make it more manageable. Expanding the data scientists interest including training and data set sharing. (farheen, 15:44:36)
    4. platform unification and reliability between components should be easier for the user. Details can be found at https://wiki.acumos.org/display/REL/Demeter+Release+Requirements see my entries on the wiki page against my name. (farheen, 15:48:46)
    5. https://wiki.acumos.org/display/REL/Demeter+Release+Requirements (farheen, 15:48:55)
    6. Sayee - The Azure belongs in ML workbench. (farheen, 15:49:15)
    7. Phillippe - add discussing of protobuf and metatags to onboarded Dockerized models (AI4EU) to allow their use. (farheen, 15:51:53)


Meeting ended at 15:51:58 UTC (full logs).

Action items

  1. / Bryan Sullivan - Wants to demonstrate how to deploy the platform with a wrapper inside a wrapper approach that makes it simple to maintain the platform across diverse environment with only a few key options that you have to select. That trickles down into the maintain deployment of components. I have used this with 5 different
  2. / Guy add to mid December agenda item. The 10th would be better for scheduling.
  3. Bryan put the system design documentation into the repo of how things are deployed.


People present (lines said)

  1. farheen (55)
  2. collabot (3)


Generated by MeetBot 0.1.4.