#opendaylight-netvirt: NetVirt Weekly 10/31/17

Meeting started by shague at 15:03:25 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:04:46)
    1. skitt (skitt, 15:04:47)
    2. Janki (janki, 15:04:56)
    3. Andre Fredette (afredette, 15:05:01)

  2. Review existing action items (shague, 15:05:07)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_24_17/opendaylight-netvirt-netvirt_weekly_10_24_17.2017-10-24-15.02.html (shague, 15:05:23)
    2. jamoluhrsen (jamoluhrsen, 15:05:49)
    3. Aswin (aswins, 15:05:58)
    4. jamoluhrsen: verify if bug still present [NETVIRT-905](https://jira.opendaylight.org/browse/NETVIRT-905) (shague, 15:06:14)
    5. ACTION: jamoluhrsen wip (shague, 15:06:39)
    6. ACTION: jamoluhrsen to close out NETVIRT-905 (jamoluhrsen, 15:06:42)

  3. jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw (shague, 15:06:57)
    1. ACTION: jamoluhrsen to create a new job just for the bgpvpn suite (jamoluhrsen, 15:08:18)

  4. [DONE] vpickard to push patch to remove vpnservice suite from l2gw Done: https://git.opendaylight.org/gerrit/#/c/64669/ (shague, 15:08:19)
  5. [WIP] vpickard to verify the genius autotunnel. Verified in local setup for L2GW for stable/carbon and newton. Patch in progress to change this config for L2GW CSIT. https://git.opendaylight.org/gerrit/#/c/64885/. Once this is working, do we want to do the same for netvirt in general? (shague, 15:08:34)
    1. ACTION: jamoluhrsen add genius autotunnel to netvirt suite (shague, 15:09:24)
    2. then decide if netvirt should switch to genius autotunnel as default (shague, 15:10:00)
    3. e/// is using pre-configured tunnel mesh (shague, 15:11:23)
    4. long term is to go to oftunnel mesh (shague, 15:11:51)
    5. likely move to genius autotunnel as default if testing looks good (shague, 15:13:21)

  6. https://trello.com/c/iD2fOfF1/16-nitrogen-release-planning - SR1 10/26/17 (shague, 15:13:38)
    1. aswins snat patches were showing some exceptions and failures (shague, 15:15:31)
    2. should patches be blockers (shague, 15:16:21)
    3. https://git.opendaylight.org/gerrit/#/c/64933/ (aswins, 15:16:38)

  7. bug scrub [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946) (shague, 15:16:46)
    1. https://git.opendaylight.org/gerrit/#/c/64697/ (aswins, 15:16:57)

  8. [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - [bug-7826](https://bugs.opendaylight.org/show_bug.cgi?id=7826) - openflowplugin patch was abandoned, new patch [63896](https://git.opendaylight.org/gerrit/63896) - group-id exception is still present (shague, 15:17:03)
    1. sunil sees lats run has passed and does nto have exceptions (shague, 15:17:47)
    2. need to rerun patch to verify it is fixed (shague, 15:18:07)

  9. [NETVIRT-972](https://jira.opendaylight.org/browse/NETVIRT-972) - table 21 , closed 940 and 946 - [bug-9245]() - [NETVIRT-940](https://jira.opendaylight.org/browse/NETVIRT-940) - [gerrit 64382](https://git.opendaylight.org/gerrit/64382) (shague, 15:18:57)
    1. https://jira.opendaylight.org/browse/NETVIRT-972?filter=10116 (shague, 15:19:37)
    2. other table 21 fixes are working, but a new one is coming up (shague, 15:19:59)

  10. [bug-9297](https://bugs.opendaylight.org/show_bug.cgi?id=9297) - adjacency]} does not exist - [NETVIRT-959](https://jira.opendaylight.org/browse/NETVIRT-959) (shague, 15:20:27)
    1. chetan and hanamant triaging (shague, 15:20:47)
    2. need help understanding the tempest tests (shague, 15:22:16)
    3. hanamant adjacency is not there, then attempt to modify adjacency is done and fails (shague, 15:23:31)

  11. [bug-9298](https://bugs.opendaylight.org/show_bug.cgi?id=9298) - port-name=e21f56c9-1513-4753-bf40-f9d391c45658}] does not exist - [NETVIRT-960](https://jira.opendaylight.org/browse/NETVIRT-960) - chetan pushed https://git.opendaylight.org/gerrit/#/c/64930/ - running csit to verify (shague, 15:24:10)
    1. ACTION: jamoluhrsen to file a jira issue to help track the odl crashing problem (jamoluhrsen, 15:24:53)

  12. ODL is crashing in CSIT [odl karaf log](https://logs.opendaylight.org/releng/jenkins092/netvirt-csit-1node-openstack-ocata-upstream-stateful-nitrogen/319/odl1_karaf.log.gz) (shague, 15:25:27)
    1. jamoluhrsen running sandbox jobs to triage (shague, 15:26:12)
    2. Hanamantagoud (Hanamantagoud, 15:26:38)
    3. initial ssh to odl to capture fails (shague, 15:27:57)
    4. sft jobs are oom'ing (shague, 15:28:08)

  13. vthapar: Should we add a CSIT testplan? if so, add new tests to test plan when reviewing feature specs. (shague, 15:28:35)
    1. should there be a real doc or just part of the robot files/ (shague, 15:30:36)
    2. start with short description doc and add new detailed tests (shague, 15:32:18)

  14. Branches no longer in sync. Be prepared for cherry-picks. (shague, 15:32:34)
    1. moving to add findbugs (shague, 15:34:32)
    2. dualstack patches need to be in for nitrogen sr2 (shague, 15:43:46)
    3. single router patches should go in 1-2 weeks (shague, 15:44:12)
    4. remaining 10-12 patches should also go in for sr2 (shague, 15:44:42)


Meeting ended at 15:54:31 UTC (full logs).

Action items

  1. jamoluhrsen wip
  2. jamoluhrsen to close out NETVIRT-905
  3. jamoluhrsen to create a new job just for the bgpvpn suite
  4. jamoluhrsen add genius autotunnel to netvirt suite
  5. jamoluhrsen to file a jira issue to help track the odl crashing problem


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen wip
    2. jamoluhrsen to close out NETVIRT-905
    3. jamoluhrsen to create a new job just for the bgpvpn suite
    4. jamoluhrsen add genius autotunnel to netvirt suite
    5. jamoluhrsen to file a jira issue to help track the odl crashing problem


People present (lines said)

  1. shague (43)
  2. jamoluhrsen (4)
  3. odl_meetbot (3)
  4. aswins (3)
  5. skitt (1)
  6. Hanamantagoud (1)
  7. afredette (1)
  8. janki (1)


Generated by MeetBot 0.1.4.