13:33:16 <ChrisPriceAB> #startmeeting OPNFV Blueprint handling and OpenStack community discussions
13:33:16 <collabot> Meeting started Tue Mar 10 13:33:16 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:33:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:33:16 <collabot> The meeting name has been set to 'opnfv_blueprint_handling_and_openstack_community_discussions'
13:33:23 <ChrisPriceAB> #info Chris Price
13:33:31 <dku> #info Dirk Kutscher
13:33:32 <ulik> #info Uli Kleber
13:33:44 <bryan_att> #info Bryan Sullivan
13:34:27 <dneary> ChrisPriceAB, Just joined - GoToMeeting connection issues
13:34:31 <dneary> Resolved now
13:34:37 <dneary> #info Dave Neary
13:34:45 <sgordon> #info Steve Gordon
13:35:12 <ChrisPriceAB> #topic agenda
13:35:34 <ChrisPriceAB> #info Introduction to the OpenStack feature processes
13:35:34 <ChrisPriceAB> #info Overview of the OPNFV community page for OpenStack
13:35:34 <ChrisPriceAB> #info Requirements project leader responsibilities
13:35:34 <ChrisPriceAB> #info OPNFV community building and OpenStack coordination
13:35:34 <ChrisPriceAB> #info Next steps and planning
13:37:09 <ChrisPriceAB> #topic Introduction to the OpenStack feature processes
13:37:34 * russellb here from OpenStack in case I can answer any questions from OpenStack perspective
13:37:55 <ChrisPriceAB> #info Ildiko outlines that there is some discrepancy between the currently submitted OPNFV blueprints and what the OpenStack community expects in a blueprint
13:38:17 <ChrisPriceAB> #info she describes that there should be a more implementation focus on the blueprints which is not there today
13:38:45 <ChrisPriceAB> #info The blueprint process is now implemented in gerrit in OpenStack with a review process carried out in that toolchain.
13:38:58 * sgordon thinks it is combinational - not clear enough problem statement / use case definition and too high level solution descriptions
13:39:16 <sgordon> (full openstack specification template is intended to guide submitters in defining these)
13:39:28 <russellb> sgordon: o/
13:39:30 <ChrisPriceAB> #info many OPNFV blueprints are currently only submitted in etherpad which does not fall into the process.
13:39:44 <dneary> Is that project specific? I thought some projects were still using Launchpad, and others had moved to Gerrit
13:39:47 * ChrisPriceAB thanks russellb jump in with additions/comments where you see fit
13:40:01 <ChrisPriceAB> #chair dneary
13:40:01 <collabot> Current chairs: ChrisPriceAB dneary
13:40:10 <russellb> dneary: almost all use a combination of launchpad and gerrit actually
13:40:29 <russellb> launchpad for tracking against releases / milestones, gerrit for design spec review
13:40:40 <ChrisPriceAB> #chair russellb
13:40:40 <collabot> Current chairs: ChrisPriceAB dneary russellb
13:40:45 <sgordon> dneary, i think most have gerrit specs now
13:40:45 <russellb> ooh
13:40:55 <ChrisPriceAB> #chair sgordon
13:40:55 <collabot> Current chairs: ChrisPriceAB dneary russellb sgordon
13:40:55 <sgordon> certainly all the ones i am seeing opnfv proposals raised for so far
13:41:04 * ChrisPriceAB feel free to add to minutes guys
13:41:22 <dneary> #info russellb points out that almost all projects use a combination of Gerrit and Launchpad. ildikov says that blueprints get uploaded to Launchpad once they have been approved in Gerrit, it is not the starting point any more
13:41:56 <sgordon> #info full openstack specification template is intended to guide provision of clear problem statement / use case definition and detailed solution proposal
13:42:13 <dneary> #info The project repo "${project}-specs" is used for spec submission in Gerrit
13:42:31 * ChrisPriceAB can someone # link in a reference to the process form openstack?
13:42:43 <sgordon> sure hang on
13:42:53 * ChrisPriceAB thanks sgordon
13:42:55 <russellb> #info what sgordon is referring to -- here is an example for Nova: http://git.openstack.org/cgit/openstack/nova-specs/tree/specs/liberty-template.rst
13:43:09 <russellb> that's the spec template, not the process
13:43:49 <sgordon> #link https://wiki.openstack.org/wiki/Blueprints
13:43:51 <russellb> #info process documentation: https://wiki.openstack.org/wiki/Blueprints
13:43:55 <ChrisPriceAB> #info dneary asks for a best practice of a blueprint that improved and was finally accepted in Kilo as an example to refer to
13:44:06 <russellb> sgordon: jinx
13:44:13 * ChrisPriceAB lol
13:44:28 <dneary> Thanks sgordon, russellb
13:44:53 <ChrisPriceAB> #link https://github.com/openstack/nova-specs/blob/master/specs/liberty-template.rst
13:45:05 <ChrisPriceAB> #link https://github.com/openstack/nova-specs
13:45:35 <ChrisPriceAB> #action Ildiko will look for a good example of a specification that went through improvement to adoption as a case study for the OPNFV community.
13:45:45 <russellb> rendered version:
13:45:47 <russellb> #link http://specs.openstack.org/openstack/nova-specs/
13:45:54 <sgordon> apologies i have to drop from the call, nova feedback session at the openstack operators meetup is starting, will try stay on irc
13:46:03 * ChrisPriceAB thanks
13:46:58 <ChrisPriceAB> #topic Overview of the OPNFV community page for OpenStack
13:47:44 <bryan_att> link?
13:47:52 <ChrisPriceAB> #info Dave describes the community page as it is being developed.  Initially as a landing page for openstack activity in OPNFV, it is evolving from that already.
13:48:12 <r-mibu> #link https://wiki.opnfv.org/community/openstack
13:48:18 <ChrisPriceAB> #info Dave states the goal of the page will be to see at a high level which rojects in OPNFV is generating blueprints, who is responsible for them and what stage they are in
13:48:19 <B_Smith_> can we have a link to the page
13:48:44 <ChrisPriceAB> #info this will provide us with a method of engaging as a community with OpenStack
13:48:53 <sgordon> B_Smith_, r-mibu just linked it
13:49:10 <ChrisPriceAB> #info Dave points out the Doctor project has done this and asks other projects to begin to work in this way
13:49:58 <ChrisPriceAB> #info Dave outlines that we have the "telco group" in OpenStack as a community we should be working very closely with.
13:50:03 <ChrisPriceAB> #topic OPNFV community building and OpenStack coordination
13:50:10 <ildikov> russellb: sgordon: thanks for the additional links :)
13:50:26 <russellb> np
13:50:34 <ChrisPriceAB> #info There is a need to establish a blueprint review process in OPNFV where we can focus on bringing the blueprints forward to an implementation centric document
13:50:44 <bryan_att> #info we need some planned effort to review blueprints coming out of OPNFV to ensure that we are not delivering point solutions that risk architectural fragmentation in the upstream community
13:51:02 <ChrisPriceAB> #info We want to be a good partner to the OpenStack project, that we have thought about how the work will be done and who will do the work in OpenStack
13:51:30 <ChrisPriceAB> #info we need to be able to articulate the need for the feature in a broader context to motivate why we need to feature in OpenStack
13:51:51 <ChrisPriceAB> #info we additionally have a chance to garner support from the ETSI opensource WG to motivate features upstream.
13:51:53 <bryan_att> #info My points about the overlap between the state/event awareness mechanisms related to Fault Mgmt and the similar need for this in Promise and Doctor, were intended to raise the need for such coordinated design of common elements
13:52:19 <sgordon> "we need to be able to articulate the need for the feature in a broader context to motivate why we need to feature in OpenStack" <-- this is really what the telco working group within openstack has been trying to refocus on
13:52:36 <sgordon> making nfv/telco use cases "real" for people in the community coming from other contexts
13:52:42 <ChrisPriceAB> #info Bryan agrees that we need to perform due dilligence in OPNFV before upstreaming to OpenStack
13:53:01 <ChrisPriceAB> #info Not rush into OpenStack features that are half-baked.
13:53:32 <ChrisPriceAB> #info dneary points out that we now have a set of blueprints upstream where we can work through these issues in full view of the OpenStack community
13:54:16 <ChrisPriceAB> #info bryan_att asks how we make that discussion happen in OPNFV.
13:54:46 <russellb> #info deadlines for Liberty have not yet been set
13:54:46 <bryan_att> #info #1 question is What is the real deadline?
13:54:53 <ChrisPriceAB> #info dneary indicates that now is the time for us to focus on the development of our blueprints.
13:55:34 <bryan_att> #info #2 question is can we create a new weekly meeting to align on blueprints, or use our existing meetings - let's get agreement today
13:55:42 <russellb> #info you can get insight into past schedule from Kilo here: https://wiki.openstack.org/wiki/Kilo_Release_Schedule
13:55:51 <ChrisPriceAB> #info Question #1 the deadline is indicated on the OpenStack process page.  The real deadline for blueprint review is in May.
13:55:53 <sgordon> #info ideally specifications need to be well framed *before* openstack summit
13:56:33 <Yuriy> #info we also need new maillist filter for blueprint discussion
13:56:42 <ChrisPriceAB> #action dneary will identify a suitable time for blueprint develoment activities in OPNFV.  (May be the Thursday tech-call time, unconfirmed...)
13:57:00 <bryan_att> #info I assume "well-framed" means clarity on exactly what modules/functions need to be patched and how, from the description given at the start of this meeting
13:57:11 * ChrisPriceAB yes
13:57:18 <sgordon> bryan_att, and use case/problem statement that is clear to non-telco
13:57:30 <sgordon> that is not acronym/abbreviation soup
13:57:33 <ChrisPriceAB> in non-telco language  :)'
13:57:46 <sgordon> ultimately need review buy in from stakeholders with a wide range of backgrounds
13:58:37 * ChrisPriceAB can't we just add an API for IMS on the VIM interface for the Or-Vnfm reference point?
13:58:54 <bryan_att> #info I'm not sure we in OPNFV are adequately aware of Openstack code details to enable us to create that "well-formed" a blueprint in 6 weeks - but I am willing to support any effort to try - and if there is flexibility in the needed detail level, even better - but we should set expectations going in on what detail level we expect to provide
13:58:57 <ChrisPriceAB> dneary pleace # action
13:59:19 <ChrisPriceAB> #action Requirement project leads ensure all blueprints are listed on the openstack community page.
13:59:38 <Ashiq> #info there are people who are quite familiar with OpenStack code base. Lets give it a try.
13:59:43 <ChrisPriceAB> #action Establish discussion calls to have the blueprints ready for review by the end of may
13:59:50 <ildikov> approved BP on gerrit for Ceilometer:
13:59:50 <ildikov> #link https://review.openstack.org/#/c/130678/
13:59:50 <ildikov> corresponding blueprint on Launchpad:
13:59:50 <ildikov> #link https://blueprints.launchpad.net/ceilometer/+spec/self-disabled-pollster
14:00:09 <dneary> #action project leaders to add blueprints in flight to the OpenStack community page for tracking
14:00:18 * ChrisPriceAB thanks ildikov
14:01:06 <dneary> #action dneary to ensure we have weekly meetings for blueprint review and improvement
14:01:56 <russellb> bye all!  feel free to reach out anytime
14:02:01 <dneary> #info ulik says we should not have an additional meeting
14:02:01 <ChrisPriceAB> #endmeeting