#opnfv-meeting: RC1 status and RC2 readiness meeting

Meeting started by frankbrockners at 13:59:47 UTC (full logs).

Meeting summary

  1. roll call (frankbrockners, 13:59:59)
    1. trozet (trozet, 14:00:38)
    2. Fatih Degirmenci (fdegir, 14:00:55)
    3. morgan (morgan_orange, 14:02:03)
    4. Trevor (trevor_intel, 14:02:31)
    5. iben (iben__, 14:02:57)
    6. Fuel didnt make it for RC1 ([1]JonasB, 14:03:13)
    7. Bryan (bryan_att, 14:03:49)

  2. Agenda for the meeting (frankbrockners, 14:04:13)
    1. we're working hard to make it for RC2, and have more hands on the deploy script ([1]JonasB, 14:04:16)
    2. RC execution reporting and issue logging – Fatih/Aric (frankbrockners, 14:04:24)
    3. Project reports on RC completion and next RC readiness – Project Leads (frankbrockners, 14:04:36)
    4. Actions and activities planned - All (frankbrockners, 14:04:47)
    5. Any other topics people would like to see on the meeting? (frankbrockners, 14:05:00)
    6. HW pods, Ericsson Lab utilization ([1]JonasB, 14:05:33)
    7. Uli (ulik, 14:05:38)

  3. RC execution reporting and issue logging (frankbrockners, 14:06:35)
    1. this is an irc only meeting. No audio (iben__, 14:06:46)
    2. We had very little progress over the week due to holidays, HW availability, connection to OPNFV Jenkins (fdegir, 14:07:15)
    3. Due to not being able to connect Intel POD to OPNFV Jenkins, we haven't been able to progress much with FuncTest (fdegir, 14:07:37)
    4. However, we were able to connect a server from Orange POD (fdegir, 14:07:49)
    5. we hae identified issue with Intel POD and woking to resolve (firewall issue) (trevor_intel, 14:08:05)
    6. We also started working with FuncTest(Morgan) to try out basic rally execution (fdegir, 14:08:24)
    7. on Orange POD (fdegir, 14:08:36)
    8. apart from this, we haven't been able to progress much (fdegir, 14:08:49)
    9. have we agreed on common paswords for the hardware (to use by jenkins)? (frankbrockners, 14:09:10)
    10. documentation jenkins jobs are ready to test (just need some documentation) (aricg, 14:09:16)
    11. also Huawei lab is connected. (ulik, 14:10:04)
    12. We're rearranging the Ericsson lab such that more people can work on it at the same time. ([1]JonasB, 14:10:38)
    13. also to get a more potent build server incase LF is delayed further ([1]JonasB, 14:11:06)
    14. BGS team to resolve consistent user names for RC1 - still open - will action again (frankbrockners, 14:12:55)
    15. adapters came in for HW yesterday, plan is to finish today. (aricg, 14:12:59)
    16. ACTION: BGS team to resolve consistent user names for RC1. (frankbrockners, 14:12:59)
    17. ACTION: aricg to send "HW ready" status to opnfv-tech-discuss as soon as the LF HW is ready for use (frankbrockners, 14:14:25)
    18. we here in huawei are using libvirt vms to test compass bgs track. each jenkins slave will stand up a "pod" within (jerryz, 14:15:48)
    19. ACTION: (frankbrockners, 14:16:01)
    20. ACTION: Pharos team to provide consistent usernames for infrastucture (frankbrockners, 14:16:06)

  4. Project reports on RC completion and next RC readiness (frankbrockners, 14:17:02)
    1. BGS RC1 status report and RC2 readiness? (frankbrockners, 14:17:35)
    2. Because LF hardware not yet available to project teams, "deploy to LF HW" pending (frankbrockners, 14:17:57)
    3. Issues which were pending from RC0 resolved (HA deployment, Ceph deployment)# (frankbrockners, 14:18:07)
    4. Fuel track didn't make the target for RC1, we have more hands on the deployment and we hope to recoupe til RC2 ([1]JonasB, 14:18:25)
    5. Fuel and Foreman deployment approaches both have build scripts available (in the process of maturing) (frankbrockners, 14:18:26)
    6. Hope/expectation is that RC2 can be fully met (which was move from "deploy available (RC1)" to "fully functional (RC2)") (frankbrockners, 14:18:50)
    7. However fuel deploys fine manually ([1]JonasB, 14:19:04)
    8. dneary (dneary, 14:19:27)
    9. Foreman/Quickstack has a deploy.sh script, although it needs testing (trozet, 14:20:18)
    10. FuncTest RC1 status report and RC2 readiness? (frankbrockners, 14:21:04)
    11. Intel POD not providing working OpenStack needed for functest, apparently due to some Foreman issues (martintaylor, 14:21:09)
    12. first commits today on ODL and OpenStack test suites (morgan_orange, 14:22:30)
    13. E/// POD only available POD so far, Intel not connected to jenkins, Orange alpha version without ODL (morgan_orange, 14:22:56)
    14. doc initiated first draft under gerrit review, to be completed (morgan_orange, 14:24:15)
    15. Docs RC1 status and RC2 readiness? (frankbrockners, 14:29:04)
    16. here is how we are standing: have the jobs defined via JJB + script to search for files to be converted - done ; packages for conversion installed on Jenkins - done ; documentation sent for review (opnfvdocs, pharos, genesis, functest) - waiting for review and submit ; artifacts storage - in progress (vlaza, 14:30:31)
    17. ACTION: vlaza to add pharos spec (what is there now is project info) to docs (frankbrockners, 14:31:16)
    18. Octopus needs documentation template and corresponding document generation job available (fdegir, 14:31:22)
    19. if we have things submitted we can already build artifacts (vlaza, 14:31:31)
    20. it just has to be in reST markup format and best practice is that main file to be docs/main.rst ; jjb job template is standard for all projects (vlaza, 14:35:16)
    21. ACTION: opnfvdocs to create boilerplate templates for each project (frankbrockners, 14:36:33)
    22. ACTION: vlaza to write an email to the mailing list with documentation details (format, template, location in repo etc.) (frankbrockners, 14:37:35)
    23. https://gerrit.opnfv.org/gerrit/#/c/254/ (frankbrockners, 14:38:01)
    24. draft directory structure for docs (frankbrockners, 14:38:30)
    25. see all patchsets submitted by vlaza related to documentation from below link (fdegir, 14:38:57)
    26. https://gerrit.opnfv.org/gerrit/#/q/owner:%22Victor+Laza+%253Cvlaza%2540cloudbasesolutions.com%253E%22 (fdegir, 14:39:02)
    27. https://gerrit.opnfv.org/gerrit/#/c/268/ (fdegir, 14:40:22)

  5. Actions and activities planned - All (frankbrockners, 14:41:36)
    1. Octopus is working with FuncTest to get basic testing job created (fdegir, 14:42:18)
    2. Octopus will also work with BGS with regards to deployment parts (fdegir, 14:42:31)
    3. BGS team hopes to have functional deploy.sh ready by RC2 (frankbrockners, 14:43:13)
    4. hopefully tomorrow, latest Monday. ([1]JonasB, 14:48:00)
    5. We will host one build server, 1 repo mirror server, one landing server 5 servers for BM deploy and 8 GP servers. ([1]JonasB, 14:49:55)
    6. GP=general purpose wich we can partition the way we like. ([1]JonasB, 14:50:24)
    7. https://build.opnfv.org/ci/view/functest/job/functest-vim_bench-test/ (fdegir, 14:53:44)
    8. https://build.opnfv.org/ci/view/functest/job/functest-vim_bench-test/1/console (fdegir, 14:54:11)
    9. fdegir says first real-ish functest job has just been created (frankbrockners, 14:54:13)


Meeting ended at 14:55:28 UTC (full logs).

Action items

  1. BGS team to resolve consistent user names for RC1.
  2. aricg to send "HW ready" status to opnfv-tech-discuss as soon as the LF HW is ready for use
  3. Pharos team to provide consistent usernames for infrastucture
  4. vlaza to add pharos spec (what is there now is project info) to docs
  5. opnfvdocs to create boilerplate templates for each project
  6. vlaza to write an email to the mailing list with documentation details (format, template, location in repo etc.)


Action items, by person

  1. aricg
    1. aricg to send "HW ready" status to opnfv-tech-discuss as soon as the LF HW is ready for use
  2. vlaza
    1. vlaza to add pharos spec (what is there now is project info) to docs
    2. vlaza to write an email to the mailing list with documentation details (format, template, location in repo etc.)
  3. UNASSIGNED
    1. BGS team to resolve consistent user names for RC1.
    2. Pharos team to provide consistent usernames for infrastucture
    3. opnfvdocs to create boilerplate templates for each project


People present (lines said)

  1. frankbrockners (97)
  2. fdegir (36)
  3. morgan_orange (24)
  4. vlaza (19)
  5. [1]JonasB (17)
  6. iben__ (14)
  7. dneary (9)
  8. aricg (8)
  9. trevor_intel (7)
  10. iben_ (5)
  11. martintaylor (5)
  12. collabot (4)
  13. trozet (3)
  14. ulik (3)
  15. jerryz (2)
  16. pbandzi (1)
  17. bryan_att (1)
  18. B_Smith_ (1)


Generated by MeetBot 0.1.4.