13:59:41 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:41 <collabot> Meeting started Tue May 12 13:59:41 2015 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:41 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:41 <collabot> The meeting name has been set to 'opnfv_tsc'
13:59:45 <ulik> #info Uli Kleber
13:59:46 <ChrisPriceAB> #topic Roll Call
13:59:51 <ChrisPriceAB> #info Chris Price
13:59:59 <bryan_att> #info Bryan Sullivan
13:59:59 * ChrisPriceAB too fast uli :D
14:00:05 <lmcdasm> #info daniel smith
14:00:08 <ulik> #info Uli Kleber
14:00:30 <Gerald_K> #info Gerald Kunzmann (DOCOMO)
14:00:35 * bryan_att asks if #info only works during the role call topic
14:00:39 <dku> #info Dirk Kutscher
14:01:00 * ChrisPriceAB info works all the time. but in the minutes I like to capture the members signing in on roll call
14:01:56 <frankbrockners> #info Frank Brockners
14:02:27 <ChrisPriceAB> #topic approval of previous minutes
14:02:29 <tallgren> #info Tapio tallgren
14:02:38 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc previous minutes
14:02:50 <ChrisPriceAB> #agree previous minutes approved.
14:02:51 <morgan_orange> #info Morgan Richomme
14:02:57 <ChrisPriceAB> #topic Agenda Bashing
14:03:03 <ChrisPriceAB> #link https://wiki.opnfv.org/wiki/tsc current agenda
14:03:45 <Wenjing_> #info Wenjing
14:04:14 <frankbrockners> Can we have an update from marketing on NFV WC?
14:04:38 <hui> #info Hui
14:04:50 <dlenrow> #info dlenrow
14:05:23 <ChrisPriceAB> #info Heather to provide an NFV WC update during the OpenStack planning discussionm
14:05:30 <dneary> Hi all
14:05:37 * ChrisPriceAB morning dneary
14:07:00 <bryan_att> I agree - Keynotes start at 9AM, we can be finishing the call as we walk in
14:07:43 <rajeev> #info Rajeev Koodli
14:08:15 <rpaik> #info Consensus to keep the TSC call next week in Vancouver.  TSC reps encouraged to line up an alternate
14:08:20 <trozet> #info Tim Rozet
14:08:51 <rpaik> #info if you can secure a room for the TSC call next week please let ChrisPriceAB know
14:09:00 <julien_ZTE> #info Julien
14:09:04 <ChrisPriceAB> #topic Arno Project plans & tracking
14:09:34 <ChrisPriceAB> #info BGS update
14:09:49 <frankbrockners> #link https://wiki.opnfv.org/releases/arno/releasereadiness
14:09:58 <ChrisPriceAB> #info progress tracking link above
14:10:25 <ChrisPriceAB> #info deployments ongoing on both POD's, testing ongoing across both pods
14:10:43 <ChrisPriceAB> #info troubleshooting of functional testing ongoing
14:10:51 <trevor_intel> #info Trevor Cooper
14:11:08 <ljlamers> #info Larry Lamers
14:11:47 <morgan_orange> #link https://wiki.opnfv.org/opnfv_functional_testing
14:12:54 <Parviz> #info Parviz
14:12:58 <ChrisPriceAB> #info Octopus update
14:13:26 <ChrisPriceAB> #info automatic deployment ongoing on POD2, not yet integrated on POD1.
14:13:43 <ChrisPriceAB> #info tests can be triggered automatically, but not all are ready yet
14:13:49 <ChrisPriceAB> #info ETA 10 minutes from ready
14:14:27 <fdegir> #link http://artifacts.opnfv.org/octopus/docs/opnfv-jenkins-slave-connection.html
14:14:54 <ChrisPriceAB> #info functest update
14:15:15 <ChrisPriceAB> #info currently connected to linux POD's, testing running on POD2
14:15:23 <ChrisPriceAB> #info vIMS out of scope for Arno
14:15:23 <ulik> #link https://wiki.opnfv.org/octopus/jenkins_slave_connection octopus document to be part of Arno
14:15:41 <ChrisPriceAB> #info errors being worked through, reduced numbers of failed tests day over day
14:16:20 <ChrisPriceAB> #info prepared to begin testing on POD1 once go is given
14:16:50 <ChrisPriceAB> #info automation of environment preparation approaching finalization for automation
14:17:00 <ChrisPriceAB> #info of testing
14:17:39 <bryan_att> is there a link link to current issues found in test? https://etherpad.opnfv.org/p/functest-lfpod2-testresults seems only (May 5)
14:17:40 <ChrisPriceAB> #info may need to reduce the tests list to provide only passing test cases, technical evaluation is ongoing
14:19:53 <frankbrockners> #info test results (incl. links to tests) are found at https://wiki.opnfv.org/opnfv_functional_testing
14:20:49 <bryan_att> which link? that's a long page
14:21:25 <ChrisPriceAB> #info Pharos update
14:21:45 <ChrisPriceAB> #info pharos spec is being defined within the release documentation.
14:21:47 <morgan_orange> bryan_att: I was about to update with last run for POD 2
14:22:05 <bryan_att> it's not clear which link on that page gives the current status, ala the etherpad link above (test run log)
14:22:10 <ChrisPriceAB> #info work is ongoing to make these documents accurate in accordance with the Arno delivery and improve the quality of the documentation
14:22:28 <frankbrockners> bryan_att: see https://wiki.opnfv.org/opnfv_functional_testing#testcases
14:22:49 <ChrisPriceAB> #info documentation review is needed.
14:23:05 <ChrisPriceAB> #info opnfvdocs update
14:23:21 <bryan_att> I'd like to see the actual test run log as in the etherpad above to see what's failing etc
14:23:45 <frankbrockners> and the team is working on a summary table (not in etherpad but on wiki) to detail root causes of failed test
14:23:51 <bryan_att> can you link that to the wiki, or past the output into the etherpad (update it)?
14:24:08 <dneary> ChrisPriceAB, cdub is flying, I will proxy for him today for votes.
14:24:39 * ChrisPriceAB thanks dneary, info in plz :)
14:24:50 <dneary> #info dneary (proxy for cdub)
14:28:29 <ChrisPriceAB> #info release docs being captured on the following wiki page:
14:28:40 <ChrisPriceAB> #link https://wiki.opnfv.org/documentation/Arno arno preliminary documentation
14:30:14 <bryan_att> frank, I'd recommend that people didn't spend extra time summarizing the test results - rather just link to the test log output which when the issues have been addressed with be self-evident as a status - at least if you could provide a link to the details in addition it would help
14:31:53 <bryan_att> e.g. the test logs should be logged somewhere, e.g. a folder that is web or git-accessible - that would be more directly useful to those watching, at least - we might be able to find something
14:31:57 * ulik need to run outside an close some windows since some storm is coming. brb
14:35:05 <rpaik> #info request community for review & feedback on arno documentation
14:36:46 <RayNugent> request we document the critical path. i.e. what are the key bugs blocking the release of Arno? I would like to document this in a single page so we can all have a single view of where we need resources/need trade offs.
14:39:33 <bryan_att> I have experience using JavaScript to automatically generate HTML documents - if it would help, the issue with the autogeneration may be something I can look into. I will reach out to the doc project team to see how I can help (in addition to reviewing the docs).
14:40:10 <frankbrockners> thanks bryan_att -- if you can find a way to further beautify .rst - that would be awesome
14:42:32 <ChrisPriceAB> #info Release readiness discussion
14:43:59 <ChrisPriceAB> #info until we have an understanding of the root cause of the issues in the deployments we are not ready to provide a release date.
14:45:01 <B_Smith> where does the daily BGS meting take place?
14:45:05 <RayNugent> Still don't have a plan. The current plan is we don't know what we don't know.
14:45:50 <frankbrockners> BGS daily meetings at at 9am PDT on IRC channel #opnfv-meeting
14:46:03 <ChrisPriceAB> #topic Requirements project document approvals and next steps
14:46:06 <frankbrockners> BGS daily meetings are at 9am PDT on IRC channel #opnfv-meeting
14:47:14 <RayNugent> Propose we have a release management effort outside of any particular project with the singular goal of being able to identify a release date and a path to it
14:51:02 <Gerald_K> #info Uli presents slideset with current lifecylce description and a proposal how to proceed with requirement project documents
14:53:07 <dneary> Gesundheit
14:53:38 <dneary> Gesundheit again
14:53:46 <frankbrockners> +1 TomNadeau
15:00:11 <Gerald_K> #info Ray: in the end we will need a gate/bar, so we need to write down what that bar is
15:01:34 <Gerald_K> we should distinguish two things: how to deal with single project documents and a graduation of the whole project
15:01:40 <Gerald_K> on a longer time scale
15:03:40 <ulik> looks like I lost audio
15:03:51 <dneary> ulik, We could still hear you but you couldn't hear us
15:03:53 * ulik I can hear again
15:03:58 <Gerald_K> uli, you are still sharing your screen
15:04:25 <rpaik> #info consensus on the need to establish a simultaneous release process
15:07:39 <dneary> One at a time please
15:13:30 * ulik I don't hear very well.....
15:15:15 <Gerald_K> #info Chris believes stable requirement documents will be good to support our BPs upstream
15:20:00 <Gerald_K> #info review of Doctor and Promise requirement documents was announced to TSC few weeks ago
15:20:09 <Gerald_K> #info process may not have been clear at that time
15:25:23 <rpaik> #info ChrisPriceAB suggests requirements projects owners to review the current process and bring proposals back to TSC
15:27:18 <dneary> RayNugent, an answer to which project, precisely?
15:27:50 <ChrisPriceAB> #topic OpenStack Summit Update & NFV WC report
15:28:54 <RayNugent> None specific. We will be asked about the differences between the project types and the differences of each project type lifecycle
15:29:04 <ChrisPriceAB> #info approcaimately 1/3 of the overall congress attendees attended the NFV WC OPNFV event
15:29:21 <ChrisPriceAB> #info presentations were well received
15:30:09 <dneary> RayNugent, I think we can answer that
15:30:25 * ChrisPriceAB ray, fully understand and the discussion around requirements projects roles and processes needs to be documented here in the development process and proposed to the TSC: https://wiki.opnfv.org/requirements_projects
15:31:14 <dlenrow> Do we have army of devs to do upstream work for promise and doctor? First question from upstream may be: who plans tondo this work? Should we pass the hat? Contributor on req. project != contrib on upstream implementation
15:31:19 <rpaik> #link https://www.openstack.org/summit/vancouver-2015/schedule/
15:31:43 <rpaik> #info click on OPNFV Day on the right to get a schdule for Monday
15:32:33 <RayNugent> dlenrow agree, our ability to contribute will be a major topic and I'm not sure we can articulate
15:33:32 <dlenrow> RayNugent: should form upstream team by Monday?
15:35:03 * ChrisPriceAB dlenrow: do you mean https://wiki.opnfv.org/community/openstack
15:36:36 <dneary> #link https://wiki.opnfv.org/community/openstack
15:38:16 <ChrisPriceAB> #topic TSC creation review of the Moon project
15:38:29 <ChrisPriceAB> #link https://wiki.opnfv.org/moon moon project creation review
15:40:56 <RayNugent> would be helpful to have an inventory of BPs either accepted or in flight and a discussion about them during the OPNFV day. This affords the Openstack community a clear view of what  OPNFV is up to and gives OPNFV members the ability to support each other in the individual BP discussions.
15:43:42 <Gerald_K> Ray, have a look here: https://wiki.opnfv.org/community/openstack?&#opnfv_related_blueprints
15:43:54 <ChrisPriceAB> #info Ruan outlines the difference between OpenStack native and Moon is the use of a realtime mechanism to mitigate the security risk with having a one hour trust window for a provided security token
15:44:19 <Gerald_K> list might not be up-to-date. we should revise before the summit
15:45:47 <Gerald_K> https://wiki.openstack.org/wiki/Monasca
15:46:52 <RayNugent> https://wiki.openstack.org/wiki/Monasca
15:48:58 <cdub> https://wiki.opnfv.org/project_proposals#collaborative_development_projects
15:49:25 <cdub> projects which perform collaborative development with one or multiple upstream open source development projects, industry forums/projects, or standard development organizations (SDO).
15:52:51 <dlenrow> I have serious reservations about this fitting into existing upstream SDN controller roadmaps...
15:53:05 <hui> thanks ray
15:55:20 <TomNadeau> I am confused.  We've been up and down the pole on this. Development of major functionality that can be done elsewhere like Open Stack here is not a great idea.
15:57:33 <ChrisPriceAB> #startvote Vote to create the project Moon as an incubation project in OPNFV? (-1, 0, +1)
15:57:33 <collabot> Begin voting on: Vote to create the project Moon as an incubation project in OPNFV? Valid vote options are , -1, 0, +1, .
15:57:33 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
15:57:39 <TomNadeau> #vote -1
15:57:40 <bryan_att> #vote +1
15:57:40 <Parviz> # vote +1
15:57:48 <dneary> #vote +1
15:57:49 <dlenrow> #vote +1
15:57:50 <hui> +1
15:57:56 <ulik> #vote +1
15:57:58 <dneary> Parviz, You need to vote without the " "
15:57:58 <ChrisPriceAB> #vote +1
15:57:59 <dku> #vote +1
15:58:04 <frankbrockners> #vote +1
15:58:04 <hui> #vote +1
15:58:06 <rpaik> #vote +1
15:58:11 <julien_ZTE> #vote +1
15:58:14 * bryan_att Parviz you need to have no space after the #
15:58:16 <tallgren> #vote +1
15:58:17 <rpaik> #info proxy for Rajeev
15:58:38 <Parviz> #vote +1
15:58:46 <ChrisPriceAB> #endvote
15:58:46 <collabot> Voted on "Vote to create the project Moon as an incubation project in OPNFV?" Results are
15:58:46 <collabot> +1 (12): dneary, dku, dlenrow, frankbrockners, bryan_att, ChrisPriceAB, hui, Parviz, julien_ZTE, tallgren, rpaik, ulik
15:58:46 <collabot> -1 (1): TomNadeau
15:59:01 <dlenrow> Will raise SDN controller issues at project meetings. Congratulations Moon
15:59:59 <tallgren> Thursday is a holiday in Finland
16:00:01 <TomNadeau> is there a meeting invite for the Thursday call?
16:00:54 <TomNadeau> thanks!
16:00:54 <rpaik> #action Ray to send out a meeting invite for Thursday sync mtg
16:02:12 <frankbrockners> done?
16:02:54 <[1]JonasB> frank: Chris probably forgot to end the meeting
16:03:36 <ChrisPriceAB> #endmeeting