#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:54:30 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 13:54:38)
    1. Chris Price (ChrisPriceAB, 13:54:50)
    2. Frank Brockners (frankbrockners, 13:59:49)
    3. Tapio Tallgren (tallgren, 14:00:47)
    4. Gerald Kunzmann (DOCOMO) (Gerald_K, 14:01:03)
    5. Carlos Goncalves (cgoncalves, 14:02:23)
    6. Trevor Cooper (trevor_intel, 14:03:08)
    7. Rajeev Koodli (rajeev, 14:04:25)

  2. Approve previous minutes (ChrisPriceAB, 14:06:42)
    1. AGREED: Previous minutes Approved (ChrisPriceAB, 14:07:01)

  3. Agenda Bashing (ChrisPriceAB, 14:07:07)
    1. Bryan Sullivan (bryan_att, 14:08:02)

  4. OPNFV Release Manager role & update (ChrisPriceAB, 14:11:37)
    1. Heather mentions that we hired a new release manager who will start on June 1st (rpaik, 14:12:37)
    2. she will start helping us with Release 2 planning (rpaik, 14:13:18)
    3. Larry Lamers (ljlamers, 14:13:20)
    4. Uli Kleber (ulik, 14:13:22)

  5. OPNFV Day @ OpenStack overview (ChrisPriceAB, 14:13:40)
    1. dneary (proxy for cdub) (dneary, 14:14:10)
    2. huge audience and interest in OPNFV day (Gerald_K, 14:14:26)
    3. Heather noted that email was sent out with recommended sessions at OpenStack Summit on Sunday (rpaik, 14:15:03)
    4. https://etherpad.opnfv.org/p/Vancouver_OpenStack (dneary, 14:15:16)
    5. plan is to also participate as a commuity at OpenStack Tokyo (rpaik, 14:15:54)
    6. OpenStack Design Summit 101: https://libertydesignsummit.sched.org/event/e480edc1483038153cf2dcd99686686a#.VVtFvMuCnsw (dneary, 14:16:39)
    7. previous topic (Debra Scott is the name of the Release Manager) (rpaik, 14:16:51)

  6. Arno Project plans & tracking (ChrisPriceAB, 14:17:26)
    1. Debra Scott: https://www.linkedin.com/in/debrascottpmp (frankbrockners, 14:17:32)
    2. opnfvdocs update (ChrisPriceAB, 14:19:20)
    3. Chris updates that a lot of people are still heads down on Arno work and need to find time to edit documentation (rpaik, 14:20:22)
    4. opnfv docs is approaching readiness, the remaining work is required by the same resources performing other activities in the projects (ChrisPriceAB, 14:20:41)
    5. Chris asks for community to help with reviewing documents (rpaik, 14:22:43)
    6. https://wiki.opnfv.org/documentation/Arno Arno documentation references for all release docs (ChrisPriceAB, 14:24:25)
    7. ACTION: ChrisPriceAB to send a mail to the tech discuss list to request help with reviewing documentation. (ChrisPriceAB, 14:26:24)
    8. Octopus update (ChrisPriceAB, 14:27:36)
    9. nothing to report (ChrisPriceAB, 14:28:06)
    10. release ready (ChrisPriceAB, 14:28:19)
    11. pharos update (ChrisPriceAB, 14:32:26)
    12. Pharos Arno docs still under review (ChrisPriceAB, 14:32:57)
    13. Pharos project is in a ready state apart from needing to complete the documentation (ChrisPriceAB, 14:33:33)
    14. functest update (ChrisPriceAB, 14:34:05)
    15. https://wiki.opnfv.org/opnfv_functional_testing#testcases_follow-up (frankbrockners, 14:34:12)
    16. transient failures usually take some time to debug (rpaik, 14:36:56)
    17. BGS update (ChrisPriceAB, 14:37:16)
    18. https://wiki.opnfv.org/meetings/bgs?&#may182015 (frankbrockners, 14:37:28)
    19. frankbrockners mentioned that autodeploy on both PODs are green (rpaik, 14:38:39)
    20. still need ISO that boots (rpaik, 14:40:47)
    21. see test cases 1-3 on link above from frankbrockners (these are critical tests failures that need to be addressed) (rpaik, 14:43:46)
    22. artifacts.opnfv.org (rpaik, 14:47:45)
    23. BGS feels release cannot be done before June 4 (ulik, 14:49:54)
    24. rpaik proxy for Bryan Sullivan (rpaik, 14:57:41)
    25. VOTE: Voted on "Shall the TSC set an Arno release date of June 4th?" Results are, +1: 10 (ChrisPriceAB, 14:58:36)
    26. The TSC has agreed to set a release date of June 4th for the Arno release, the Arno team has approximately 2 weeks to complete release activity. (ChrisPriceAB, 15:01:01)

  7. Release 2 preparation and planning (ChrisPriceAB, 15:01:45)
    1. Chris suggests having a post-mortem session after the Arno release (rpaik, 15:03:22)
    2. simultaneous release process needs to be defined and will be a learning prcess for the community (rpaik, 15:05:16)
    3. dneary outlines that system state definition will be important in release 2 (ChrisPriceAB, 15:11:46)
    4. dneary adds that identifying a marquee feature or set of features for release 2 would be helpful (ChrisPriceAB, 15:14:11)
    5. ideas for such marky features were discussed: (ulik, 15:18:11)
    6. Carrier grade as an example (ulik, 15:18:26)
    7. SFC as an example (ulik, 15:18:36)
    8. Security and Performance as example (ulik, 15:20:20)
    9. suggestion for the community to think of other possible themes for Release 2 (rpaik, 15:20:52)
    10. We should do some homework and think about this. (ulik, 15:21:24)
    11. testing (performance, functional, etc.) is another possible topic (rpaik, 15:23:21)

  8. TSC update to the Board (ChrisPriceAB, 15:23:32)
    1. development process updates requiered (ChrisPriceAB, 15:25:53)
    2. Project definitions and classification (ChrisPriceAB, 15:28:00)

  9. Project Review and approvals of the Inspector project (ChrisPriceAB, 15:29:50)
    1. https://wiki.opnfv.org/requirements_projects/inspector (jaosorior, 15:29:57)
    2. Juan notes that other people (e.g. from Huawei) expressed interest in joining the Inspector project (rpaik, 15:33:17)
    3. suggestion to add contributors/committers to the project proposal (rpaik, 15:34:20)
    4. rprakash is interested in joining as contributor if ONOS is included (rpaik, 15:40:11)
    5. bryan_att says CADF = Cloud Audit Data Federation. http://www.dmtf.org/standards/cadf (dneary, 15:41:22)
    6. will vote on the project proposal after committer/contributor list is updated (next week) (rpaik, 15:42:48)
    7. Mike Young (Huawei) is also interested in joining the project (rpaik, 15:44:00)

  10. Project creation review Juju OPNFV Infrastructure Deployer (ChrisPriceAB, 15:45:58)
    1. https://wiki.opnfv.org/project_proposals/joid JOID project proposal (ChrisPriceAB, 15:46:23)
    2. add David Karr (ATT) to the project (rpaik, 15:51:16)
    3. discussion on how BGS will be structured post Arno (rpaik, 15:53:27)
    4. discussion that we’re not making a decision on JOID being part of release 2 yet (rpaik, 16:00:08)
    5. ACTION: Artur to update the committer/contributor list before approval next week (rpaik, 16:00:42)
    6. ACTION: joid team to update the committer and contributor list (ChrisPriceAB, 16:01:16)


Meeting ended at 16:01:42 UTC (full logs).

Action items

  1. ChrisPriceAB to send a mail to the tech discuss list to request help with reviewing documentation.
  2. Artur to update the committer/contributor list before approval next week
  3. joid team to update the committer and contributor list


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to send a mail to the tech discuss list to request help with reviewing documentation.
  2. UNASSIGNED
    1. Artur to update the committer/contributor list before approval next week
    2. joid team to update the committer and contributor list


People present (lines said)

  1. ChrisPriceAB (47)
  2. dneary (28)
  3. rpaik (27)
  4. collabot (14)
  5. frankbrockners (9)
  6. ulik (7)
  7. jaosorior (5)
  8. bryan_att (5)
  9. rajeev (3)
  10. Gerald_K (3)
  11. TomNadeau (3)
  12. cgoncalves (2)
  13. RayNugent (2)
  14. dlenrow (2)
  15. AndreaP (1)
  16. trevor_intel (1)
  17. tallgren (1)
  18. ljlamers (1)
  19. Tapio_ta (1)


Generated by MeetBot 0.1.4.