#opnfv-meeting: OPNFV TSC meeting

Meeting started by frankbrockners at 14:00:19 UTC (full logs).

Meeting summary

    1. dlenrow (dlenrow, 14:02:24)
    2. Uli (uli-k, 14:02:29)
    3. Ildiko Vancsa (ildikov, 14:02:35)
    4. Juha Oravainen (Nokia) (JuhaO, 14:02:46)
    5. Uli (uli-k, 14:02:48)
    6. Dirk Kutscher (dku, 14:02:50)
    7. Tim Rozet (trozet, 14:02:51)
    8. Ildiko is stand in for Chris Price (ildikov, 14:02:56)
    9. fuqiao proxy for deng hui (fuqiao, 14:03:16)
    10. Parviz Yegani (Parviz, 14:03:30)
    11. Juha Oravainen is stand in for Tapio Tallgren (JuhaO, 14:03:37)
    12. Julien (julien_ZTE, 14:03:42)
    13. Gerald Kunzmann (DOCOMO) proxy for Ashiq Khan (Gerald_K, 14:03:42)

  1. approval of previous (frankbrockners, 14:04:11)
    1. https://wiki.opnfv.org/wiki/tsc#july_7_2015 (frankbrockners, 14:05:03)
    2. Chris Wright (cdub, 14:05:11)
    3. previous minutes were approved by the TSC (frankbrockners, 14:06:01)
    4. Trevor Cooper (trevor_intel, 14:06:04)

  2. agenda bashing (frankbrockners, 14:06:09)
    1. https://wiki.opnfv.org/wiki/tsc#july_14_2015 (frankbrockners, 14:06:24)
    2. Rajeev Koodli (rajeev, 14:08:44)
    3. agenda was agreed (frankbrockners, 14:08:58)

  3. Requirements projects development process (frankbrockners, 14:09:18)
    1. https://wiki.opnfv.org/requirements_projects (ildikov, 14:09:23)
    2. Narinder Gupta (narindergupta, 14:10:36)
    3. Frank Brockners (frankbrockners, 14:11:35)
    4. Ildiko presents the current thinking on evolving the requirements projects development process (frankbrockners, 14:12:31)
    5. ildikov notes that requirements projects should have end-to-end coverage from use cases to implementation (rpaik, 14:13:28)
    6. there will be a breakout session at the upcoming hackfest for further discussions on requirements projects (rpaik, 14:14:42)
    7. Doctor project was a kind of "test" project using git and gerrit and to get lessons learned (Gerald_K, 14:18:54)
    8. frankbrockners asks if there’s a test project to test out the new approch. ildikov responds that she can look for new projects as a beach head (rpaik, 14:20:26)
    9. current proposal includes two sections: (1) generic thoughts on the evolution of the current set of project categories (2) specifics on the requirements projects' process (frankbrockners, 14:27:06)
    10. discussion should focus on (2) (frankbrockners, 14:27:19)
    11. ACTION: RayNugent and ildikov to start a discussion on (1): Thoughts on evolving the current set of project categories (frankbrockners, 14:29:39)

  4. Request for formal approval to allow CI/CD Pipeline to support script and ISO deploy methods (frankbrockners, 14:29:50)
    1. for Arno, we both support a deployment of both - script based and .iso based deployment (frankbrockners, 14:32:54)
    2. for Brahmaputra, it is too early to decide on what the packaging options would be (frankbrockners, 14:34:49)
    3. AGREED: for Arno - we support deployment both ways (.iso and script based) as part of the CI/CD pipeline (frankbrockners, 14:35:50)
    4. release artifacts are bootable disk images, i.e. ".iso"s (frankbrockners, 14:36:56)

  5. Support for OPNFV hardware @LF data center (frankbrockners, 14:37:20)
    1. LF right now only focuses on bare metal hardware support (cabling, power, network connectivity) for OPNFV (frankbrockners, 14:38:51)
    2. Contract with LF does not include configuration of the LF lab hardware. (frankbrockners, 14:39:21)
    3. https://wiki.opnfv.org/pharos/lf_support (trevor_intel, 14:40:09)
    4. looking for additional infrastructure support from the community (rpaik, 14:41:52)
    5. I can volunteer to help (trozet, 14:44:49)

  6. Quarterly Awards (frankbrockners, 14:46:06)
    1. More than a dozen nominations received for quaterly rewards - nominations still open ('till noon tomorrow PDT) (frankbrockners, 14:47:02)
    2. please send nominations to Ray (frankbrockners, 14:47:11)
    3. Ray will send email to TSC members by Thursday for voting (rpaik, 14:47:35)

  7. Splitting two hours TSC call into 1 hour TSC and 1 hour "technical work stream (frankbrockners, 14:49:57)
    1. proposal is to have 2 calls, with 1hr each. One for TSC, one for technical topics (frankbrockners, 14:51:44)
    2. TSC call would be focused on decision making only - and less so on technical discussions (frankbrockners, 14:52:01)
    3. helps TSC members know when they need to attend for a quorum (rpaik, 14:52:09)
    4. ACTION: dlenrow to bring the discussion to the list (topic: reduce TSC call to 1hr (focus on decision making) - and have technical discussions done in another forum (e.g. thrusdays tech call)) (frankbrockners, 14:55:34)

  8. Project creation review: Apex (frankbrockners, 14:55:57)
    1. https://wiki.opnfv.org/project_proposals/apex_opnfv (trozet, 14:56:20)
    2. https://wiki.opnfv.org/project_proposals/apex_opnfv (frankbrockners, 14:56:21)
    3. continuation of the Foreman work that was done as part of BGS (frankbrockners, 14:56:58)
    4. https://bluejeans.com/s/8o1U/ rdo-manager demo (cdub, 14:58:26)
    5. will include fixes for Foreman for Arno SR1 and a new installer (RDO manager) for Brahmaputra (frankbrockners, 14:58:37)
    6. https://wiki.opnfv.org/genesis - draft on Genesis (frankbrockners, 15:04:10)
    7. anyone interested in being committers/contributors to the project, contact trozet (rpaik, 15:05:55)
    8. VOTE: Voted on "Approve APEX as an OPNFV project?" Results are, +1: 11 (frankbrockners, 15:09:04)
    9. Tim Rozet will be my proxy as RH TSC rep (cdub, 15:09:48)
    10. APEX has been approved by the TSC. Congrats (frankbrockners, 15:09:53)

  9. Project creation review: Connectivity services LSO (frankbrockners, 15:10:12)
    1. https://wiki.opnfv.org/lar-e (frankbrockners, 15:10:38)
    2. No representative of Connectivity Services LSO project team was on the TSC call. Review postponed to next week. (frankbrockners, 15:12:16)

  10. Project creation review: Releng (frankbrockners, 15:12:36)
    1. https://wiki.opnfv.org/project_proposals/release_engineering (frankbrockners, 15:12:53)
    2. Releng project is to formalize the already ongoing work for "OPNFV infrastructure" across various projects. releng repo exists already and was intrumental for Arno. (frankbrockners, 15:17:02)
    3. VOTE: Voted on "Approve Release-Engineering (RELENG) as an OPNFV project?" Results are, +1: 12 (frankbrockners, 15:26:34)
    4. Project release engineering was approved by the TSC. Congrats! (frankbrockners, 15:27:14)

  11. Project creation review: Connectivity services LSO (frankbrockners, 15:27:34)
    1. https://wiki.opnfv.org/lar-e (frankbrockners, 15:27:45)
    2. requirements project for API on OpenDaylight controller to drive MetroEthernet Services (ELINE etc.) (frankbrockners, 15:32:35)
    3. ODL is just the initial focus of the effort - API could apply to other controllers as well (frankbrockners, 15:35:15)
    4. Bryan Sullivan (bryan_att, 15:36:30)
    5. can you add me to the cmmiters to help support Openstack API and ONOS support (rprakash, 15:37:21)
    6. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-July/003655.html Kevin’s answers to community questions (rpaik, 15:37:27)
    7. if Michael young is added I need not be added as commiter but just a contributor (rprakash, 15:38:34)
    8. suggestion to change the repom name to all lower case with no hyphens (rpaik, 15:39:37)
    9. suggestion to change the repo name to all lower case with no hyphens (rpaik, 15:40:59)
    10. ildikov to contact Kevin reg. new requirements projects process (rpaik, 15:42:23)
    11. Having trouble with my microphone. I'm happy to vote for this, but as chairman of ONF NBI there are disconnects that we will need to iron out. I'll follow up with CableLabs team.. (dlenrow, 15:43:45)
    12. VOTE: Voted on "Approve "Connectivity Services LSO" as an OPNFV project?" Results are, +1: 10 (frankbrockners, 15:44:40)
    13. The TSC approved project "Connectivity Services LSO". Congrats. (frankbrockners, 15:45:35)


Meeting ended at 15:46:17 UTC (full logs).

Action items

  1. RayNugent and ildikov to start a discussion on (1): Thoughts on evolving the current set of project categories
  2. dlenrow to bring the discussion to the list (topic: reduce TSC call to 1hr (focus on decision making) - and have technical discussions done in another forum (e.g. thrusdays tech call))


Action items, by person

  1. dlenrow
    1. dlenrow to bring the discussion to the list (topic: reduce TSC call to 1hr (focus on decision making) - and have technical discussions done in another forum (e.g. thrusdays tech call))
  2. ildikov
    1. RayNugent and ildikov to start a discussion on (1): Thoughts on evolving the current set of project categories


People present (lines said)

  1. frankbrockners (65)
  2. collabot (21)
  3. dlenrow (13)
  4. rpaik (13)
  5. tnadeau (12)
  6. trozet (7)
  7. cdub (7)
  8. ildikov (5)
  9. JuhaO (5)
  10. rajeev (5)
  11. Gerald_K (5)
  12. uli-k (5)
  13. Parviz (5)
  14. julien_ZTE (3)
  15. RandyLevensalor (3)
  16. dku (3)
  17. ildikov_ (2)
  18. fdegir (2)
  19. trevor_intel (2)
  20. rprakash (2)
  21. bryan_att (2)
  22. narindergupta (1)
  23. fuqiao (1)


Generated by MeetBot 0.1.4.