14:00:24 <fdegir> #startmeeting Octopus and Releng Weekly Meeting
14:00:24 <collabot> Meeting started Mon Aug 17 14:00:24 2015 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:24 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:24 <collabot> The meeting name has been set to 'octopus_and_releng_weekly_meeting'
14:00:32 <fdegir> #topic Rollcall
14:00:40 <fdegir> Octopus and Releng meeting participants
14:00:44 <fdegir> please type in your name
14:00:57 <dduffey> #info David Duffey
14:01:00 <chenshuai> #info chenshuai
14:01:14 <fdegir> #info Fatih Degirmenci
14:01:25 <MatthewL2> #info Jun Li
14:02:14 <Mofassir> #info Mofassir
14:02:20 <meimei1> #info meimei
14:02:24 <pbandzi> #info Peter Bandzi
14:02:25 <trozet> #info Tim Rozet
14:02:34 <fdegir> #topic Agenda Bashing
14:02:40 <morgan_orange> #info Morgan Richomme
14:02:43 <fdegir> I have the agenda below
14:02:49 <fdegir> #info Meeting Structure Update
14:02:58 <fdegir> #info Octopus: Action Item Review / Lab Compliancy / B-Release Work
14:03:10 <fdegir> #info Releng: Lab Reconfiguration Status / Brahmaputra Support
14:03:14 <fdegir> #info AoB
14:03:27 <fdegir> #topic Meeting Structure Update
14:03:52 <fdegir> #info Releng Team has decided to use same meeting slot as Octopus
14:04:02 <fdegir> #info And this has been agreed with uli-k as well
14:04:26 <fdegir> #info So we will have both Octopus and Releng meetings at this time until we see the need to change
14:04:54 <fdegir> #topic Octopus Action Item Review
14:05:11 <fdegir> #info There are 3 action items from last week
14:05:17 * ChrisPriceAB wonders which meeting this is???
14:05:31 * fdegir ChrisPriceAB Octopus and Releng
14:05:39 <fdegir> first action item is
14:05:42 <fdegir> #info uli-k trozet: report back once ChrisPriceAB clarifies the need of doing Brahmaputra release on LF Lab
14:06:00 <fdegir> trozet: did you have chance to get some input?
14:06:10 * ChrisPriceAB thinks not... :s
14:06:16 <trozet> no
14:06:28 <fdegir> then I'll action all of you
14:06:45 <meimei1> I think it is very important, Lab compliant depends on that
14:06:52 <fdegir> #action uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
14:07:10 <trozet> ChrisPriceAB: can you answer now, or do we need to wait and bring it up in a TSC call?
14:07:40 <ChrisPriceAB> I think it needs to wait until next week, post TSC call.
14:07:51 <fdegir> I agree
14:08:12 <trozet> ok
14:08:25 <fdegir> we need to assume that we will do the release from LF lab until Pharos starts delivering something concrete
14:08:48 <fdegir> moving to next item
14:08:53 <kaipule> #info kaipue(HaoRan Li)
14:08:59 <fdegir> #info chigang to try on a POD to apply new naming scheme to a slave
14:09:06 <fdegir> anyone any update regarding this?
14:09:18 <meimei1> yes
14:09:23 <fdegir> please info in meimei
14:09:25 <meimei1> we name the slave just according to provider and usage(build/deployment), is that ok?
14:09:43 <fdegir> meimei1: that sounds good to start with
14:10:00 <fdegir> perhaps <provider>-<build/deploy>-<digit>
14:10:09 <fdegir> given that we might have multiple slaves attached from same lab
14:10:10 <meimei1> ok!
14:10:10 <meimei1> If there is no problem, I will ask Aric for help to rename huawei 's slaves
14:10:22 <meimei1> 4 for build , named huawei-build-1~4
14:10:22 <meimei1> 1 for baremetal deployment, named huawei-deployment
14:10:25 <meimei1> ok?
14:10:39 <fdegir> how does huawei-deploy-1 sounds?
14:10:43 <fdegir> you have 5 slaves there
14:10:57 <meimei1> yes, one for deployment
14:11:01 <fdegir> ok
14:11:33 <meimei1> ok!
14:11:34 <fdegir> #action meimei1 to apply naming scheme for Huawei slaves: huawei-build-[1-4], huawei-deploy-1
14:11:56 <fdegir> just added 1 to deploy in case you provide additional deployment resources
14:12:08 <fdegir> and the last action item is
14:12:25 <fdegir> #info  uli-k to contact silent committers and encourage them to start working.
14:12:35 <fdegir> I think this is not done
14:12:45 <fdegir> since uli-k is enjyoing his vacation so keeping it open
14:12:57 <fdegir> #action uli-k to contact silent committers and encourage them to start working.
14:13:11 <fdegir> this was all, moving to the next topic
14:13:25 <meimei1> excuse me,Aric is on vacation now?
14:13:43 <dneary> meimei1, He was, but I think he's back this week
14:13:53 <meimei1> thank you
14:13:57 <fdegir> could aricg be on Linux conf?
14:14:01 <dneary> meimei1, I could be wrong
14:14:18 <fdegir> meimei1: you need to keep pinging
14:14:26 <chigang> #info chigang
14:14:27 <meimei1> ok
14:14:46 <meimei1> just like that
14:14:49 <fdegir> meimei1: I think we can try it together
14:14:54 <fdegir> the lab renaming thing
14:14:57 <dneary> fdegir, meimei1, remember: https://blogs.gnome.org/markmc/2014/02/20/naked-pings/
14:14:59 <meimei1> great
14:15:06 <fdegir> I probably have some rights
14:15:26 * fdegir thanks dneary
14:15:39 <fdegir> moving on
14:15:50 <fdegir> #topic Octopus Lab Compliancy
14:16:05 <fdegir> #info meimei1 started up the topic on Etherpad
14:16:15 <fdegir> #link https://etherpad.opnfv.org/p/octopusR2
14:16:29 <fdegir> #info The discussion has been happening there and we need to finalize it
14:16:48 <fdegir> #info Look for the heading: Octopus requirements onĀ  labs compliance and provide your input
14:17:02 <fdegir> #info We plan to talk to Pharos soon and pass our requirements to them
14:17:14 <meimei1> yes, and just depends on action 1, I think
14:17:30 <fdegir> please have a look at it if you have ideas/concerns
14:18:18 <fdegir> I'll action meimei1 and myself to follow this up
14:18:39 <meimei1> I think the PTL of pharos must take part in
14:18:55 <fdegir> #action meimei1 fdegir Follow-up Octopus Requirements with Pharos
14:19:23 <fdegir> anyone wants to add anything quick regarding this topic?
14:19:51 <fdegir> then the next item in the agenda
14:19:59 <fdegir> #topic Octopus B-Release Work
14:20:39 <fdegir> #info Octopus still needs some dependencies to be solved in order to continue working with pipelines
14:20:57 <fdegir> #info Such as Lab Compliancy/getting community labs up & running, LF lab reconfiguration
14:22:10 <fdegir> not much to say regarding B-work apart from what we have been talking
14:23:08 <fdegir> moving to Releng Items now if noone wants to add anything regarding Octopus
14:23:22 <fdegir> #topic Releng Lab Reconfiguration Status
14:23:35 <fdegir> trozet: pbandzi: can you please give a short status update?
14:23:59 <meimei1> Fatih, I have a question
14:24:02 <meimei1> I saw the disccussion about how to use  LF-pods
14:24:06 <pbandzi> yes
14:24:21 <fdegir> pbandzi: please go ahead
14:24:27 <meimei1> lf-POD2 will be used for virtual deployment?
14:24:27 <meimei1> My question is ,  why not put these 2 lf-pods into a pool
14:24:27 <meimei1> and the baremetal deployment will choose one pod randomly to implement
14:24:34 <meimei1> ?
14:24:47 <trozet> #info Fuel fixes were put in.  A common clean that should work between installers was added as well.  We tested Foreman to make sure it was working, but for some reason it's nodes cannot ping on the public interface
14:24:56 <trozet> #info pbandzi is looking into it
14:24:56 * fdegir meimei1 will come back to it once trozet pbandzi give the update
14:25:01 <meimei1> OK
14:25:03 <meimei1> NP
14:25:20 <fdegir> thanks trozet
14:25:30 <pbandzi> #info moreover I  requested more public IP from LF in order to have more Virtual env on POD1
14:26:20 <pbandzi> a question was raised from Konstantin if it is ok to have those IPs by next week?
14:26:29 <pbandzi> is it ok?
14:26:45 <fdegir> pbandzi: I think we have to wait
14:26:52 <fdegir> they're all out travelling I suppose
14:27:22 <pbandzi> and my question regarding Ubuntu vesrion on pod1. 14.04 is ok?
14:27:35 <szilard_> #info 1 more Fuel fix is required, that is the installation of prerequisites: libvirt & qemu, before Fuel deployment job is launched
14:27:48 <fdegir> pbandzi: 14.04 is ok for builds
14:27:55 <szilard_> sorry I just saw some discussions about Fuel
14:28:03 <fdegir> thx szilard_
14:28:42 <fdegir> #info The summary of Lab Reconfiguration is
14:28:56 <fdegir> #info There is still some work left to do for Foreman and Fuel
14:29:21 <fdegir> #info Public IPs for POD1 will probably be fixed by next week given that most of the LF people are not available
14:29:45 <fdegir> anyone wants to get more info can join the bgs/genesis meeting after this one
14:29:51 <fdegir> meimei1: can you please #info in your question
14:30:00 <meimei1> ok
14:30:41 <meimei1> #info lf-POD2 will be used for virtual deployment?
14:30:42 <meimei1> #info why not put 2 lf-pods into a pool, and the baremetal deployment will choose one pod randomly to implement
14:31:14 <meimei1> #info we can utilize other labs  for virtual deployment
14:31:20 <meimei1> Is that better?
14:31:34 <chenshuai> what kinds of other labs?
14:31:42 <fdegir> #info We severly need hardware resources
14:32:15 <MatthewL2> yep we should add more PODs there
14:32:20 <fdegir> #info And sorting out the ther labs will probably take long time since Pharos is still in the process of clarifying the compliance
14:32:38 <fdegir> #info We have been requesting additional build/virt deployment resources for months
14:32:50 <fdegir> #info and the easiest way is to reconfigure LF Lab
14:32:56 <fdegir> #info According to decision
14:33:10 <fdegir> #info Servers from LF POD1 will be converted to standalone slaves
14:33:25 <fdegir> #info 2 servers for build, 2 for virt deploys, 2 for virt deploys + other project work
14:33:36 <fdegir> #info LF POD2 will be used for bare-metal deployment
14:34:04 <fdegir> meimei1: what you say is what we want to have
14:34:07 <fdegir> but we can't wait forever
14:34:31 <meimei1> yes, wait for pharos compliant
14:34:32 <fdegir> we can restructure/adjust where we run stuff when we have that luxury/resources
14:35:14 <meimei1> ok!
14:35:28 <meimei1> sounds good
14:35:28 <fdegir> #info Once the LF Lab reconfiguration work is done, we will increase the CI coverage by running virt deployments for patchset verification
14:35:38 <chigang> I think we can use Xian(Chinese) Lab, there are 2 PODs for community.
14:36:15 <fdegir> chigang: I think it can be evaluated
14:36:31 <fdegir> but we should finish what we started and get LF lab work done
14:36:51 <fdegir> chigang: do you want to look at it?
14:36:56 <fdegir> Xian lab?
14:37:20 <meimei1> Xian lab is huawei's lab
14:37:24 <chigang> fdegir: np, I am working on Xian LAB VPN and accessing google storage
14:37:43 <fdegir> we can discuss it offline then
14:37:54 <chigang> fdegir: nice
14:38:02 <fdegir> moving on
14:38:13 <fdegir> #topic Releng Brahmaputra Support
14:38:30 <fdegir> #info Some items to support Brahmaputra is put on Etherpad
14:38:46 <fdegir> #info The items are grouped as below
14:38:52 <fdegir> #info 1. Lab Infrastructure
14:38:58 <fdegir> #info Test Result Handling
14:39:03 <fdegir> #undo
14:39:03 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b200d0>
14:39:09 <fdegir> #info 2. Test Result Handling
14:39:17 <fdegir> #info 3. Improvements in CI/Automation/Toolchain/Guidelines
14:39:23 <fdegir> #info 4. Release Process
14:39:30 <fdegir> #link https://etherpad.opnfv.org/p/releng
14:40:09 <fdegir> #info As it is written there, the items listed on Etherpad is not priority ordered
14:40:26 <fdegir> #info Please go ahead and put your comments/thoughts latest Wednesday
14:40:45 <fdegir> #info By Wednesday, Releng backlog will be created based on what is there on the Etherpad
14:40:51 <MatthewL2> my pleasure, will do that
14:41:00 * fdegir thx MatthewL2
14:41:24 <fdegir> #info Some of the items such as test reporting api and lab reconfig are already in progress
14:42:14 <fdegir> anyone wants to add anything regarding this?
14:42:44 <fdegir> then we're almost done
14:42:49 <fdegir> #topic AoB
14:42:56 <fdegir> last words?
14:42:59 <fdegir> anything we missed?
14:43:17 <chenshuai> fdegir: me
14:43:26 <fdegir> chenshuai: please go ahead
14:43:38 <chenshuai> fdegir: for Test Result Handling, do we need add some tools for analyzing ?
14:44:01 <fdegir> that's been discussed within Test group
14:44:06 <fdegir> morgan_orange: are you around?
14:44:06 <kaipule> I want to know Wednesday,we talk to Releng using the same channel?
14:44:13 <chenshuai> fdegir: ok
14:44:16 <morgan_orange> fdegir: yep
14:44:23 <pbandzi> yes that's true 5 days ago was changed yum repo there
14:44:29 <morgan_orange> first step collect the results into an homogeneous format
14:44:35 <pbandzi> sory
14:44:59 <aricg> added my comments to https://etherpad.opnfv.org/p/releng
14:45:04 <morgan_orange> but analytics will follow
14:45:07 * fdegir thanks aricg
14:45:39 <morgan_orange> there is a reflexion onstorage (already started through the API) / dashboard (discussed during summit) and analytics
14:45:57 <fdegir> #info chenshuai asked the question if we will have something to analyze test results
14:45:59 <morgan_orange> for Brahmaputra, analytics is not in the scope
14:46:18 <fdegir> #info morgan_orange answered that the first step is to collect the results into an homogeneous format
14:46:31 <fdegir> #info and then analytics will follow
14:46:43 <fdegir> #info there is a reflexion onstorage (already started through the API) / dashboard (discussed during summit) and analytics
14:46:46 <morgan_orange> #info test dashboard based on stored results planned for B release
14:47:22 <fdegir> morgan_orange: I suppose it is ok to say analytics has lower priority then the result collection and the dashboard
14:47:30 <morgan_orange> yes
14:47:35 <fdegir> #info Analytics has lower priority then the result collection and the dashboard
14:47:49 <fdegir> #info Analytics might not be available for Brahmaputra
14:48:04 <MatthewL2> it's OK for we to start the data collection and analysis work, when we find better solution, we can discuss then
14:48:10 <MatthewL2> that's my opinion
14:48:36 <fdegir> MatthewL2:  data collection work is ongoing
14:48:50 <MatthewL2> fdegir: yep I saw the patch
14:48:51 <morgan_orange> please join functest meeting :)
14:48:58 <fdegir> so please keep an eye on gerrit releng repo :)
14:49:17 <fdegir> thanks morgan_orange chenshuai for the input
14:49:22 <fdegir> anything else?
14:49:48 <fdegir> then we're done for today
14:49:53 <fdegir> thank you all for joining
14:49:58 <fdegir> and having good discussion
14:50:01 <fdegir> talk to you later
14:50:05 <fdegir> #endmeeting