14:00:04 <fdegir> #startmeeting Octopus and Releng Weekly Meeting
14:00:04 <collabot> Meeting started Mon Aug 31 14:00:04 2015 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:04 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:04 <collabot> The meeting name has been set to 'octopus_and_releng_weekly_meeting'
14:00:19 <fdegir> Please #info in your name if you're going to join the meeting
14:00:24 <dduffey> #info David Duffey
14:00:24 <fdegir> #topic Rollcall
14:00:34 <fdegir> #info Fatih Degirmenci
14:00:37 <meimei> #info meimei
14:00:38 <chenshuai> #info chenshuai
14:00:40 <r-mibu> #info Ryota Mibu (IRC only)
14:00:40 <uli-k> #info Uli Kleber
14:00:46 * fdegir welcome back uli-k
14:00:51 <fdegir> #chair uli-k
14:00:51 <collabot> Current chairs: fdegir uli-k
14:00:54 <morgan_orange> #info Morgan Richomme
14:01:27 <uli-k> Hi, everybody! Happy to "hear" from you again.... First day after vacation and I was totally stuck in email heap...
14:01:44 <fdegir> uli-k: good luck with that
14:01:48 <bryan_att> #info Bryan Sullivan
14:01:49 <uli-k> :D
14:01:58 <fdegir> #info Please note that this is an IRC-only meeting
14:02:04 <fdegir> I think we can start
14:02:10 <fdegir> #topic Agenda Bashin
14:02:27 <fdegir> #info Octopus: Action Item Review / Lab Compliancy / B-Release Work
14:02:28 <radez> #info Dan Radez
14:02:34 <fdegir> #info Releng: LF Lab Configuration Status Update / Releng Backlog
14:02:41 <fdegir> #info AoB
14:03:04 <fdegir> #topic Action Item Review
14:03:29 <fdegir> #info uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
14:03:34 <fdegir> any news on this?
14:03:47 <trozet> no
14:03:57 <uli-k> no also from my side....
14:04:05 <fdegir> ok, then we keep it open
14:04:13 <fdegir> #action uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
14:04:30 <fdegir> #info meimei fdegir Follow-up Octopus Requirements with Pharos
14:04:38 <fdegir> no update from me
14:04:47 <fdegir> meimei: have you had a chance to talk to anyone?
14:04:53 <meimei> no from me
14:04:57 <fdegir> ok
14:05:18 <fdegir> #info No progress with the Octopus requirements on Pharos
14:05:27 <fdegir> #action meimei fdegir: Follow-up Octopus Requirements with Pharos
14:05:31 <bryan_att> can i ask one question about that item?
14:05:47 <fdegir> bryan_att: please do
14:05:56 <bryan_att> what is the meaning of "need of doing"? i think its obvious we need to get B release working in LF lab
14:06:17 <bryan_att> we need a common lab environment running B asap
14:06:25 <fdegir> bryan_att: we lack enough hw resources
14:06:37 <fdegir> we currently have only 1 POD left in LF OPNFV Lab
14:06:46 <bryan_att> ok, then something has to give - but not the future!
14:06:54 <fdegir> the question was that if we can do the CI stuff on community labs
14:07:04 <fdegir> or does it have to be done on LF OPNFV Lab as we did for Arno
14:07:23 <fdegir> bryan_att: yes, it is needed for now not for the future
14:07:32 <uli-k> bryan_att: what would be the problem if we decide to do final release B test in other lab?
14:07:46 <bryan_att> I would like to support CI in community labs as well, but the variation in lab environments makes that more complex
14:08:06 <bryan_att> if by CI you mean also deployment and smoke tests
14:08:14 <fdegir> bryan_att: that's one of  the reasons we are trying to get Octopus requirements included in Pharos Compliance
14:08:18 <uli-k> as I understood that AI, it is not about having CI on community labs.
14:08:23 <morgan_orange> it is a question for Pharos. There are several declared community Labs. Pharos shall know is some PODs among these labs can be dedicated to CI..
14:08:42 <fdegir> Pharos knows them
14:08:46 <uli-k> morgan_orange: agree.
14:09:00 <uli-k> and I hope, we can run CI on multiple labs.
14:09:01 <fdegir> but the labs might not be providing what they intend to provide yet
14:09:08 <fdegir> I see many of them going down
14:09:11 <fdegir> or not available at all
14:09:21 <fdegir> and for CI, we need certain SLA, uptime requirements
14:09:35 <morgan_orange> and there are several possible roles: build/deploy/test
14:09:38 <uli-k> Yes. meimei has specified these reqs.
14:09:42 <bryan_att> ok, in the short term if there is some activity that can't be moved from LF lab then we can leverage community labs - but we need to know where and that the work will translate to other labs without major rework
14:10:13 <morgan_orange> in Orange we will have 2 labs but due to lack of resources they will be dedicated to test only (even they must be connected to CI)
14:10:53 <morgan_orange> but we may image in labs where there are several PODS (Huawei, Intel, Ericsson) that one could be dedicated to build/deploy/test in addition of LF PODs
14:11:00 <chenshuai> at the moment Huawei is providing 2 labs(xi'an and shanghai)
14:11:07 <bryan_att> the work in a community lab needs to be open enough for other labs to observe and duplicate - I thought that was the key value of the LF lab - accessible by all
14:11:19 <chenshuai> last week we submit another 40 blades
14:11:34 <fdegir> having the labs on paper/wiki is something
14:11:40 <morgan_orange> fdegir: you can action directly trevor for that?
14:11:41 <chenshuai> ok
14:11:41 <fdegir> and having them up and running in CI is another
14:11:47 <uli-k> Many labs will have similar issue as orange - they are used now for other OPNFV work.
14:12:13 <uli-k> So we have to identify some PODs and get them assigned for CI.
14:12:37 <fdegir> #action trevor_intel to propose way forward with community labs
14:13:07 <bryan_att> we need to avoid solving the same B release issues in multiple places - at the least there needs to be transparency on what exactly is happening and the source (scripts etc) that are being worked in the CI labs
14:13:30 <uli-k> Right.
14:13:39 <bryan_att> ok, enough from me on that
14:13:49 <fdegir> ok
14:13:54 <fdegir> moving on to the next item
14:13:55 <uli-k> But at the moment, I am not sure, whether a test that works in lab A will also work in lab B (unhanged)
14:14:06 <fdegir> #info meimei to apply naming scheme for Huawei slaves: huawei-build-[1-4], huawei-deploy-1
14:14:34 <meimei> it has been carried out in huawei's slaves
14:14:49 <fdegir> #info meimei applied the new naming schement for Huawei Slaves
14:14:58 <fdegir> #link https://build.opnfv.org/ci/computer/
14:15:05 <fdegir> thx meimei
14:15:23 <fdegir> the last action item is on uli-k
14:15:35 <fdegir> #info uli-k Clean up the Octopus committer list
14:15:43 <fdegir> any news uli-k ?
14:15:57 <uli-k> I have contacted all inactive committers
14:16:14 <fdegir> #info uli-k contacted all inactive committers
14:16:33 <uli-k> Not much feedback. So I will go for second round and tell them that we start removal process.
14:16:55 <fdegir> ok, then I keep this open until we finalize it
14:17:02 <uli-k> I try to be gracious :D and consider the vacation time, which may slow down responses.
14:17:09 <uli-k> Agree to keep open.
14:17:18 <fdegir> #action uli-k Clean up the Octopus committer list
14:17:32 <fdegir> these were all the action items
14:17:35 <fdegir> moving to the next topic
14:17:52 <fdegir> #topic Lab Compliancy
14:18:02 <fdegir> #info As we discussed above just minutes ago
14:18:22 <fdegir> #info meimei documented the requirements and we had the discussion on Etherpad
14:18:44 <fdegir> #info But not much happened with compliancy
14:18:56 <meimei> is ther a TSC tonight?
14:19:06 <meimei> TSC meeting
14:19:14 <aricg> yes in 24h
14:19:15 <fdegir> #info since Pharos doesn't have place to discuss these things and generally downprioritized against testing stuff ion Thursdays
14:19:44 <fdegir> uli-k: can you bring this to TSC perhaps?
14:19:48 <fdegir> just a small push
14:19:56 <fdegir> or reminder that we have a project called Pharos
14:20:09 <uli-k> Yes.
14:20:14 <fdegir> actioning oyu then
14:20:23 <uli-k> ok.
14:20:29 <fdegir> #action uli-k to bring slow progress with Pharos to TSC
14:20:57 <morgan_orange> for information we discussed that during the hackfest
14:20:58 <fdegir> moving on the next topic
14:21:05 <uli-k> We can then also raise that we need more PODs.
14:21:21 <morgan_orange> it was strongly suggested to create a weekly meeting for Pharos and that each community lab provides a contributor to the project
14:21:36 <uli-k> for CI - that is by the community labs as discussed before
14:21:58 <uli-k> OK. Let's do that in that way on TSC.
14:22:12 <fdegir> yep, we need to highlight the risk
14:22:20 <fdegir> both the lack of work in Pharos
14:22:24 <fdegir> and lack of the resources
14:22:28 <fdegir> or not utilizing community labs
14:22:54 <bryan_att> I support the requirement for community labs to be represented in Pharos meetings
14:23:08 <bryan_att> I think this will force needed issues to the front
14:23:18 <fdegir> #info There was a discussion regarding Pharos during hackfest
14:23:32 <fdegir> #info morgan_orange states that it was strongly suggested to create a weekly meeting for Pharos and that each community lab provides a contributor to the project
14:23:38 <bryan_att> (I wish *we* had a lab already)
14:24:07 <meimei> or Pharos can have the weekly meeting with Octopus together
14:24:25 <chenshuai> meimei: +1
14:24:39 <fdegir> meimei: it might not work out given that we have full agenda for octopus and releng items
14:24:49 <uli-k> Maybe Trevor needs some support for these issues in Pharos.
14:24:50 <fdegir> and pharos items should not be downprioritized
14:25:21 <fdegir> uli-k: agree on that - let's see what happens tomorrow during TSC meeting
14:25:33 <meimei> wait for news
14:25:39 <fdegir> uli-k: can you please make sure this gets to TSC agenda for tomorrow as well?
14:25:51 <uli-k> Yes.
14:25:54 <fdegir> ok, thx
14:26:07 <uli-k> I'll contact also Trevor.
14:26:18 <uli-k> I think Frank chairs tomorrows TSC.
14:26:20 <fdegir> that's even better
14:26:32 <uli-k> (not sure yet about my emails :D)
14:26:42 <fdegir> moving on now
14:26:45 <uli-k> ok
14:26:48 <fdegir> #topic B-Release Work
14:27:01 <fdegir> #info There have been some questions regarding how to be integrated to CI
14:27:32 <uli-k> you mean projects that want to start using CI?
14:27:40 <fdegir> #info some of the projects are trying to figure out how to get their stuff integrated to CI
14:27:48 <fdegir> uli-k: yes
14:28:31 <r-mibu> doctor is
14:28:33 <fdegir> #info  kvmfornfv and ovsnfv have asked some questions
14:28:43 <fdegir> #info Some information and links have been provided to those projects
14:28:56 <fdegir> r-mibu: can you type in what help doctor needs?
14:28:59 <r-mibu> Should those project work with BGS first?
14:29:24 <fdegir> r-mibu: they need to work with genesis and octopus initially
14:29:37 <fdegir> we provide info regarding what jobs we have
14:29:43 <r-mibu> Doctor want its feature developed in OpenStack to CI and B-release
14:30:09 <fdegir> r-mibu: can you please put some info on etherpad perhaps to give some more info?
14:30:15 <fdegir> https://etherpad.opnfv.org/p/octopusR2
14:30:23 <r-mibu> got it
14:30:26 <fdegir> then we take it from there
14:30:47 <fdegir> #info kvmfornfv started working with their build script which will be integrated to verify jobs
14:31:02 <fdegir> #info ovsnfv is in the process of identifying what they need
14:31:04 <uli-k> I think the issue here is the general collaborative development issue. How to run OPNFV CI builds of upstreamed code.
14:31:23 <fdegir> that's one part of the problem
14:31:31 <fdegir> for kvmfornfv, they cloned the kernel completely
14:31:36 <fdegir> and doing stuff locally in opnfv
14:31:45 <fdegir> kind of fork if you ask me
14:31:54 <uli-k> which helps them to progress, but might lead to a fork
14:32:04 <uli-k> :D
14:32:06 <fdegir> I suppose the reason for this is to get their stuff tested as early as possible
14:32:16 <fdegir> while waiting upstream to accept their patches
14:32:24 <fdegir> need to keep an eye on it :D
14:32:55 <fdegir> #info Apart from new projects, we have some good updates in CI
14:33:20 <fdegir> #info Thanks to trozet, we can now run virtual deployment for foreman patches
14:33:46 <trozet> and some help from fdegir :)
14:33:50 <aricg> fyi I asked them to just keep their patches in the repo, and to apply them as part of the build step.
14:33:56 <fdegir> #info Due to lack of resources, this is only available for foreman but will be made available to other installer(s)
14:34:06 <aricg> they told me to show up at the meeting and suggest it there.
14:34:16 <fdegir> aricg: I've seen that
14:34:23 <fdegir> will you do that?
14:34:31 <aricg> I hope so.
14:34:33 * fdegir thinks actioning aricg
14:35:02 <fdegir> #action aricg to help kvmfornfv with regards to keeping their patches in the repo, and to apply them as part of the build step.
14:35:14 <fdegir> thx aricg
14:35:32 <fdegir> ovsnfv guys might need similar help
14:35:44 <fdegir> will see when they arrive to that point
14:36:20 <fdegir> moving to Releng agenda if noone objects
14:36:29 <uli-k> Mike Lynch approached me during vacation.
14:36:36 <uli-k> Did he also talk to you?
14:36:44 <fdegir> for ovsnfv?
14:36:47 <uli-k> yes
14:36:55 <fdegir> I was just in their meetings an hour ago
14:37:08 <fdegir> and pointed them to some links to get started with CI stuff
14:37:09 <uli-k> OK. Then I guess they know now.
14:37:16 <fdegir> they said they will discuss it and come back
14:37:24 <uli-k> :D That what I thought is needed.
14:37:48 <fdegir> #topic Releng LF Lab Reconfiguration Status
14:38:09 <fdegir> #info pbandzi, trozet, and aricg finished the reconfiguration of LF POD2
14:38:16 <uli-k> OK. Thanks fdegir for running Octopus during vac.
14:38:24 * fdegir np uli-k
14:38:31 <fdegir> #info We are now able to run both installers on a single POD
14:39:02 <fdegir> #info We have a script now that rolls back the POD2 to original state
14:39:14 <bryan_att> which are "both" - foreman and fuel?
14:39:19 <morgan_orange> yes
14:39:25 <uli-k> Will these scripts help also for the other installers?
14:39:27 <fdegir> #info And then foreman/fuel build and deployment scripts get executed depending on which installer job is running
14:39:32 <fdegir> uli-k: yes
14:39:46 <uli-k> Can compass volonteer to be the next?
14:39:48 <fdegir> but some work is needed to be done for respective installers
14:39:54 <bryan_att> isnt foreman being deprecated for the B release? (for the new RDO installer)
14:39:59 <fdegir> uli-k: yes
14:40:09 <morgan_orange> fdegir: but is it still OK?
14:40:27 <fdegir> morgan_orange: what is still ok?
14:40:27 <uli-k> I think we need the rollback for different use cases
14:40:32 <morgan_orange> it used to alrenate properly for a while, but as far as I can see, foreman has not been deployed since 3 days
14:40:47 <fdegir> oops, haven't checked it recently
14:40:53 <morgan_orange> it did not fail but was not automatically run
14:40:57 <uli-k> eg. rollback a foreman Arno deploy and then run Fuel Brahmaputry
14:41:03 <fdegir> trozet: are you aware of this?
14:41:22 <fdegir> uli-k: I think we will kill foreman/fuel genesis installers after SR1
14:41:27 <trozet> fdegir: ?
14:41:28 <fdegir> and stop running them
14:41:38 <fdegir> trozet: morgan_orange says foreman deployment has been failing
14:41:55 <trozet> fdegir: its been passing on virtual, you talking about baremetal?
14:42:03 <fdegir> trozet: yes, on POD2
14:42:15 <fdegir> trozet: can you please take a look at it?
14:42:36 <trozet> fdegir: I assume it has something to do with a patch that went infor khaleesi that was wrong.  Randylevensalor fixed it on Saturday I think
14:42:38 <morgan_orange> #link https://build.opnfv.org/ci/job/genesis-foreman-deploy-master/58/console
14:42:41 <trozet> fdegir: but yes will look
14:42:48 <morgan_orange> but it has not been relauch since
14:43:16 <fdegir> morgan_orange: if there is no new change in git repo, there is no new daily run
14:43:32 <fdegir> it polls for changes in the repo
14:43:35 <morgan_orange> fdegir: ok
14:43:36 <trozet> fdegir, morgan_orange: we moved vagrant boxes
14:43:53 <trozet> fdegir, morgan_orange: the vagrant base box we were using was removed from the Atlas site, we added an opnfv one
14:44:03 <trozet> fdegir, morgan_orange: its failing to download the new box
14:44:08 <trozet> fdegir, morgan_orange: timing out?
14:44:21 <fdegir> trozet: can't say much, sorry
14:44:36 <trozet> ill download the new box manually to jumphost
14:44:36 <fdegir> can we talk about this after the meeting?
14:44:58 <fdegir> #info The script that does the configuration is located in releng repo
14:44:59 <trozet> morgan_orange: thanks for noticing it
14:45:06 <fdegir> #link https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=tree;f=utils/lab-reconfiguration
14:45:20 <fdegir> #info There are installer specific configuration files there
14:45:39 <arnaud_orange> http://sinawiki/wiki/images/8/8f/Archi_reseau.svg
14:45:42 <arnaud_orange> oups
14:45:44 <morgan_orange> trozet: sorry I should have told you earlier, I was about to ask for a redeployement of foreman_master becasue there is a bug on functest related to foreman installer (creds badly retrieved..)
14:45:53 <fdegir> #info So please feel free to look at it if you want to configure a specific installer for it
14:46:07 <fdegir> uli-k: compass guys can take a look at the configuration and script
14:46:36 <uli-k> ok. I will send them the link.
14:46:38 <chenshuai> fdegir: yes
14:46:54 <fdegir> pbandzi is the one who wrote the script so you need to chase him in case of any questions
14:47:12 <chenshuai> fdegir: thx, got it
14:47:27 <fdegir> #info It is still pending to restructure LF POD1 in order to provide build, virt deploy, and other testing resources
14:47:45 <trozet> morgan_orange: Going to re-trigger deploy daily on pod2 ok?
14:47:46 <fdegir> #info There is an action on LF Admins to adjust the networking
14:48:14 <fdegir> #info More info will follow coming days/weeks once the work progresses
14:48:21 <aricg> fdegir: I think the action is waiting on hardware.
14:48:39 <fdegir> aricg: I thougt it was the IP configuration
14:48:41 <morgan_orange> trozet: ok
14:49:05 <trozet> morgan_orange: actually need to wait until a patch goes through.  I'll drop you an email when everything is working as intended again
14:49:25 <fdegir> aricg: more public IP subnets are needed - according to pbandzi
14:49:26 <aricg> fdegir: "the plan is to add a simple router with basic ACLs where we can manage OPNFV vlans without them impacting the core firewall. I'm pricing one out with CDW. How much impact it would be if we had to push this change out to September 13?" -K
14:49:41 <fdegir> aricg: OK, that's the 2nd paragraph
14:49:54 <fdegir> you're right
14:50:05 <aricg> mail is on the infra list
14:50:12 <fdegir> just saw it
14:50:44 <fdegir> #info The suggestion from Konstantin to push the change to September 13
14:51:07 <fdegir> will report back here once there is progress
14:51:19 <fdegir> the last item in the agenda is
14:51:29 <fdegir> #topic Releng Backlog
14:51:41 <fdegir> #info Releng Stories are collected under 4-epics
14:51:51 <fdegir> #info Automation and Development of Test Result Reporting/Dashboard/Analytics
14:51:58 <fdegir> #info  Improvements in Automation/Toolchain/CI
14:52:06 <fdegir> #info  Automation for Pharos Lab Infrastructure
14:52:14 <fdegir> #info  Release Process Support
14:52:23 <fdegir> #link https://jira.opnfv.org/browse/RELENG
14:52:42 <fdegir> #info Stories from all epics but release process have been progressing
14:52:59 <fdegir> #info morgan_orange is driving testing related epic
14:53:12 <fdegir> #info aricg is working with documentation toolchain and DB for test reporting
14:53:22 <fdegir> #info pbandzi with Lab stuff
14:53:38 <fdegir> thanks for great work btw
14:53:46 <fdegir> #info Anyone is free to take items from the backlog
14:54:00 <fdegir> #info Or come up with suggestions
14:54:12 <fdegir> anyone wants to add anything quick?
14:54:48 <fdegir> #topic AoB
14:54:55 <fdegir> aynone wants to add anything?
14:54:59 <bryan_att> I will review and see if anything else or something we can pickup from the backlog
14:55:00 <uli-k> yes.
14:55:02 <uli-k> There was a short discussion in the mail about SR1 and branches etc.
14:55:10 <uli-k> I am still not finished with all the updates on the description.
14:55:15 * fdegir thanks uli-k for reminding it
14:55:26 <uli-k> Was there something unclear? Do we know when some backporting might start? I was a bit confused about the new repos of some installers.
14:55:40 <fdegir> #info uli-k reminds the discussion regarding where the Arno SR1 will come out from
14:55:55 <fdegir> #info There is a documented process for stable branch handling
14:56:26 <fdegir> #link https://wiki.opnfv.org/releases/stablebranch?s[]=stable
14:56:51 <fdegir> #info The release will come out from stable/arno branch
14:57:20 <fdegir> #info The process is: do the work/bugfixing on master, cherrypick to stable/arno accordingly
14:57:41 <uli-k> What is this with new genesis repos?
14:57:55 <fdegir> uli-k: there is a new genesis repo (genesisreq)
14:58:11 <fdegir> which will be used for B-release
14:58:23 <fdegir> and existing genesis will be left out to die
14:58:50 <fdegir> sorry but we need to finish as the BGS meeting will start
14:59:00 <uli-k> right......
14:59:01 <fdegir> we can clarify this in that meeting I think
14:59:12 <fdegir> since it is kind of BGS/genesis specific
14:59:18 <uli-k> fine.
14:59:20 <fdegir> thank you everyone!
14:59:23 <fdegir> #endmeeting