#opnfv-meeting: Infra Work Group Weekly

Meeting started by jmorgan1 at 15:59:20 UTC (full logs).

Meeting summary

  1. Roll Call (jmorgan1, 15:59:27)
    1. Jack Morgan (jmorgan1, 15:59:31)
    2. Fatih Degirmenci (fdegir, 16:00:18)
    3. Hongbo (hongbo2122, 16:00:31)
    4. Tianwei Wu (hw_wutianwei, 16:01:32)
    5. David McBride (dmcbride, 16:02:03)
    6. Bryan Sullivan (bryan_att, 16:02:08)
    7. Trevor Bramwell (bramwelt, 16:02:19)
    8. https://global.gotomeeting.com/join/819733085 (hongbo2122, 16:03:03)

  2. Dovetail Support (jmorgan1, 16:03:12)
    1. MathewLi presents slides on Dovetail requirements (jmorgan1, 16:04:46)
    2. Uli Kleber (uli-k, 16:05:33)
    3. details on Dovetail wiki page (jmorgan1, 16:05:40)
    4. Dovetail needs stable version of OPNFV deployed in order to run tests (fdegir, 16:07:46)
    5. rprakash (rprakash, 16:07:47)
    6. Due to OPNFV turning off CI against stable branches (colorado), Dovetail will not have possibility to run against it (fdegir, 16:08:11)
    7. In order to run Dovetail, we need Colorado deployed on baremetal PODs (fdegir, 16:08:42)
    8. But we still lack dynamic allocation of resources so Dovetail probably needs 4 baremetal PODs, 1 per installer (fdegir, 16:09:06)
    9. An additional ARM POD is needed for running Dovetail against ARM on Fuel (fdegir, 16:12:01)
    10. Which makes 5 PODs in total (fdegir, 16:12:08)
    11. Apex is working on ARM support for E release (jmorgan1, 16:13:13)
    12. Fatih asks how oftern we need to run Dovetail against stable branches (jmorgan1, 16:13:51)
    13. Dovetail will be part of release testing process (jmorgan1, 16:16:12)
    14. had some discussion on dedicated hardware vs dovetails jobs on current hardware (jmorgan1, 16:18:27)
    15. Hongbo points out that the amount of testing is short - a coupls of tests / a few hours (jmorgan1, 16:21:59)
    16. ACTION: fdegir to work with Dovetail in Releng to coordiate a test plan in the short (jmorgan1, 16:24:19)
    17. fdegir mentions that this will be difficult as we get closer to release time as release testing increases (jmorgan1, 16:24:44)
    18. ACTION: MatthewLi to work with releng project to coordiate planning (jmorgan1, 16:26:25)

  3. CI resource redundancy (jmorgan1, 16:27:52)
    1. due to recent ourtage and maintenance work jenkins jobs failed and projects suffered (jmorgan1, 16:28:59)
    2. need to rebalance jenkins jobs to different labs to add redundancy (jmorgan1, 16:29:23)
    3. Huawei has POD available for dynamic ci or similar efforts (jmorgan1, 16:30:32)
    4. ACTION: tianwei_wu to return to once Huawei POd as available to discuss allocation (jmorgan1, 16:32:35)
    5. https://wiki.opnfv.org/display/pharos/Huawei%27s+munich+Lab (uli-k, 16:32:37)
    6. ACTION: Fatih and Jack to propose a solution to rebalancing jenkins jobs in the labs (jmorgan1, 16:33:56)
    7. the Infra PTL need to consolidate slides to present to TSC then request time at TSC to present (jmorgan1, 16:36:40)
    8. ACTION: aricg to follow up with Rudy on UCS support and present update next week (jmorgan1, 16:37:52)
    9. ACTION: jmorgan1 Move Infra WG meeting minutes to general meeting page (fdegir, 16:49:21)
    10. move Infra meeting minutes to Meeting space for reporting and send out update to mailing list (jmorgan1, 16:51:35)

  4. MS4 for Danube (jmorgan1, 16:51:45)
    1. David presents his slides on improving definition of MS4 (jmorgan1, 16:52:30)
    2. MS4 needs better definition of what it means and how to measure it (jmorgan1, 16:53:37)
    3. MS4 is "infra updates completed" currently for projects/senarios, CI capacity, and Infra WG improvements (jmorgan1, 16:54:22)
    4. issue #1 timing - when should we have this milestone (currently its 3+ months before release) (jmorgan1, 16:56:03)
    5. issue #2 release manager - what questions should be asked to provide status update on completion of this milestone (jmorgan1, 16:56:55)
    6. issue #3 derive capacity - how to collect requirements and what is the process for this (jmorgan1, 16:57:50)
    7. issue #4 Infra WG plans / improvements - how to coordiante with release manager and how to approve the plan (jmorgan1, 16:58:36)
    8. David to upload slides to Software release wiki space and send link to Jack to include in meeting minutes (jmorgan1, 17:03:06)
    9. We will discuss this topic again next week to propose solutions to the problem statemnts (jmorgan1, 17:03:58)


Meeting ended at 17:04:08 UTC (full logs).

Action items

  1. fdegir to work with Dovetail in Releng to coordiate a test plan in the short
  2. MatthewLi to work with releng project to coordiate planning
  3. tianwei_wu to return to once Huawei POd as available to discuss allocation
  4. Fatih and Jack to propose a solution to rebalancing jenkins jobs in the labs
  5. aricg to follow up with Rudy on UCS support and present update next week
  6. jmorgan1 Move Infra WG meeting minutes to general meeting page


Action items, by person

  1. fdegir
    1. fdegir to work with Dovetail in Releng to coordiate a test plan in the short
  2. jmorgan1
    1. jmorgan1 Move Infra WG meeting minutes to general meeting page
  3. UNASSIGNED
    1. MatthewLi to work with releng project to coordiate planning
    2. tianwei_wu to return to once Huawei POd as available to discuss allocation
    3. Fatih and Jack to propose a solution to rebalancing jenkins jobs in the labs
    4. aricg to follow up with Rudy on UCS support and present update next week


People present (lines said)

  1. jmorgan1 (38)
  2. fdegir (18)
  3. hongbo2122 (8)
  4. ChrisPriceAB (8)
  5. hw_wutianwei (5)
  6. collabot (4)
  7. uli-k (3)
  8. bramwelt (2)
  9. bryan_att (2)
  10. dmcbride (2)
  11. aimeeu (1)
  12. rprakash (1)


Generated by MeetBot 0.1.4.