15:00:10 <fdegir> #startmeeting Infra WG Weekly Meeting
15:00:10 <collabot`> Meeting started Mon Apr  3 15:00:10 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:10 <collabot`> The meeting name has been set to 'infra_wg_weekly_meeting'
15:00:40 <fdegir> #topic Rollcall
15:01:04 <thaj> #info Thaj
15:01:10 <lhinds> #info lhinds
15:01:13 <uli-k> #info Uli
15:02:19 <fdegir> #topic Security WG Group Integration with the Infra WG
15:03:11 <fdegir> #info lhinds gives background for integrating Security WG and Infra WG
15:03:43 <fdegir> #info There is an ongoing collaboration between Security and Infra WGs already (threat analysis, security gate checks, CII badging)
15:04:34 <fdegir> #info In order to work on items together and implement things faster, it is beneficial to integrate these WGs
15:04:58 <fdegir> #info A vote has been taken by Security WG for this and agreed
15:06:10 <fdegir> #info When/If Infra WG agrees, we need to fix the logistics (TSC, informing community, etc.)
15:06:29 <fdegir> #info uli-k mentions that there are 2 kinds of main items
15:06:45 <fdegir> #info 1. Security issues with development/release process
15:07:25 <fdegir> #info 2. Security features of the target platform
15:08:02 <fdegir> #info The discussion to combine WGs is valid for first item
15:09:10 <fdegir> #info Security Project will continue its existence with its current committers/contributors so the merge of Security and Infra WG doesn't change the project scope/governance
15:09:41 <fdegir> #info But the topics for the 2nd (target platform features) can be handled by the project as usual
15:10:46 <fdegir> #agree Infra WG agrees to combine with Security WG
15:11:08 <fdegir> #action lhinds to notify TSC and Technical community about this change
15:12:04 <fdegir> #action jmorgan1, uli-k, fdegir, lhinds to update wiki
15:12:47 <fdegir> #info PTL from Security WG will also take part in being Infra WG meeting chair
15:12:58 <fdegir> #topic Static checking
15:13:43 <fdegir> #info The thread about static checking is still pending to be resolved
15:14:09 <fdegir> #info It is important for community to apply static checking to their development process
15:14:26 <fdegir> #info For example Octopus will employ yamllink for SDF
15:14:54 <fdegir> #info Projects need to contact Infra WG/Releng to activate static checks
15:15:47 <fdegir> #info This needs to be managed in order to make sure we have various static checks employed by the projects
15:17:39 <thaj> #info Flake for python.
15:18:13 <fdegir> #info Releng has some checks available to community
15:18:16 <fdegir> #link https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=jjb/releng/opnfv-lint.yml
15:18:47 <uli-k> #link https://wiki.opnfv.org/display/INF/Contiuous+Integration
15:19:04 <thaj> #link https://wiki.opnfv.org/display/INF/Continuous+Integration#ContinuousIntegration-StaticCheckToolsofCI
15:19:11 <uli-k> #info if you scroll down, there is a list of tools
15:19:52 <fdegir> #info CII Badging also requires this and run static analysis as applicable
15:21:30 <fdegir> #action lhinds and Sona to come up with initial list of static checks we can apply to OPNFV proejcts
15:22:12 <fdegir> #action uli-k to activate yamllint for octopus
15:22:20 <fdegir> #action jmorgan1 to activate yamllint for pharos
15:22:50 <fdegir> #action fdegir to activate yamllint for releng/jjb
15:23:52 <fdegir> #topic Moving Installers to VMs on jumphosts
15:29:56 <fdegir> #info This topic needs to be discussed further and flagged as risk due to not having enough people and possibility of causing issues
15:30:25 <fdegir> #topic Action Item Review
15:30:37 <fdegir> #action aricg radez Work on creating an additional repo for Apex to trial this before bringing topic to TSC
15:31:04 <fdegir> #action uli-k jmorgan1 fdegir Identify what can be moved from OPNFV Wiki Infra Space to RTD and what can stay on Wiki
15:31:19 <fdegir> #action uli-k MatthewLi Come up with different options to handle Dovetail Infra requirements for further discussion
15:31:45 <fdegir> #action jmorgan1 Collect centralized resource requirements for OPNFV as part of LF Infra Collab/Lab workstream
15:32:14 <fdegir> #action TBD Start capturing ideas/issues with moving installers into VMs on OPNFV POD Jumphosts for community feedback
15:32:38 <fdegir> #endmeeting