15:00:19 <uli-k> #startmeeting Infra working group
15:00:19 <collabot> Meeting started Mon May 15 15:00:19 2017 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:19 <collabot> The meeting name has been set to 'infra_working_group'
15:00:31 <uli-k> #topic roll call
15:00:51 <Sona> hi Uli
15:01:10 <MatthewLi> #info Jun Li
15:01:10 <thaj> #info Thaj
15:01:20 <chigang> #info Justin
15:01:51 <Julien-zte> #info Julien
15:02:05 <fdegir> #info Fatih Degirmenci
15:02:10 <jmorgan1> #info Jack Morgan
15:03:02 <Julien-zte> Thanks uli-k for your kindly arrangement :)
15:04:21 <uli-k> #topic Usage of VM instances by Compass
15:04:49 <chigang> Can you hear me?
15:04:56 <uli-k> no
15:04:57 <thaj> No
15:04:57 <MatthewLi> no
15:05:06 <chigang> I try to reconnect
15:06:29 <chigang> sorry, I am offline and reconect later
15:06:45 <uli-k> ok. we wait.
15:07:06 <uli-k> #topic dovetail and infrastructure
15:07:20 <uli-k> #chair fdegir
15:07:20 <collabot> Current chairs: fdegir uli-k
15:07:27 <uli-k> #chair jmorgan1
15:07:27 <collabot> Current chairs: fdegir jmorgan1 uli-k
15:08:43 <fdegir> #info A helpdesk ticket is needed for LF POD2
15:08:47 <uli-k> #info MatthewLi explains how dovetail uses docker
15:09:00 <fdegir> #info ENEA/ARM team needs to be contacted to update docker version
15:09:57 <uli-k> #action MatthewLi to open helpdesk ticke for LF POD2 and trigger ENEA/ARM team to update docker version
15:11:31 <uli-k> #info Open issue ho to trigger dovetail only for some scenarios
15:11:54 <jose_lausuch> so far, done only in bgpvpn https://build.opnfv.org/ci/job/dovetail-fuel-baremetal-proposed_tests-danube/
15:12:49 <uli-k> #info fdegir recommends to use dummy scenarios in CI sandbox to test scenario specific triggers
15:13:37 <fdegir> #info The jobs for dummy scenarios can be created using the conditional buildstep plugin
15:13:44 <fdegir> #link https://wiki.jenkins-ci.org/display/JENKINS/Conditional+BuildStep+Plugin
15:14:23 <fdegir> #link https://docs.openstack.org/infra/jenkins-job-builder/builders.html#builders.conditional-step
15:16:53 <lhinds> #info lhinds
15:18:54 <uli-k> #info MatthewLi explains we would need another CI POD for bgpvpn to run dovetail.
15:19:17 <uli-k> #info fdegir clarifies that there might be issues if we create a third Fuel CI POD.
15:22:19 <uli-k> #info jmorgan1 suggests to work with the scenario owner.
15:23:44 <Julien-zte> #link https://wiki.opnfv.org/display/SWREL/Danube+Scenario+Status
15:23:55 <fdegir> MatthewLi: check these jobs
15:23:57 <fdegir> MatthewLi: https://sandbox.opnfv.org/view/Dovetail%20Conditional%20Step/job/installerX-scenarioA-daily-master/
15:24:01 <fdegir> MatthewLi: https://sandbox.opnfv.org/view/Dovetail%20Conditional%20Step/job/installerX-scenarioB-daily-master/
15:24:24 <fdegir> MatthewLi: you might need to adjust stuff as they were created quickly to show how it would look
15:24:39 <uli-k> #topic Compass VM usage
15:25:17 <uli-k> #info Current plan is to use 5 docker containers
15:26:38 <uli-k> #info chigang thinks it is easy to do dynamic POD allocation with the docker containers.
15:28:53 <MatthewLi> fdegir: thx , will check  that , I have researched in https://docs.openstack.org/infra/jenkins-job-builder/builders.html for conditional steps, however, in steps, may not support to include other jobs, only scripts. we can discuss more after meeting :)
15:29:43 <fdegir> MatthewLi: you can take a look at the jobs I created
15:29:52 <fdegir> MatthewLi: you can trigger jobs as downstream jobs
15:30:45 <fdegir> MatthewLi: dovetail is not triggered if the scenario is scenarioB: https://sandbox.opnfv.org/view/Dovetail%20Conditional%20Step/job/installerX-scenarioB-daily-master/1/console
15:31:15 <fdegir> MatthewLi: dovetail is triggered if the scenario is scenarioA: https://sandbox.opnfv.org/view/Dovetail%20Conditional%20Step/job/installerX-scenarioA-daily-master/2/console
15:31:42 <jose_lausuch> https://build.opnfv.org/ci/view/functest/job/functest-fuel-baremetal-daily-danube/407/consoleFull
15:31:44 <MatthewLi> fdegir: so where is the codes of those jobs?
15:31:45 <jose_lausuch> sorry, wrong chat
15:31:58 <fdegir> MatthewLi: there is no code, manually created them on Jenkins
15:32:07 <fdegir> MatthewLi: you need to convert them to jjb
15:32:29 <fdegir> MatthewLi: you should be able to login to sandbox and take a look at the configuration
15:32:52 <uli-k> #info Open which way to go for dynamic allocation with compass.
15:33:09 <MatthewLi> fdegir: need some priviledge? can't login to sandbox ....
15:33:20 <fdegir> MatthewLi: ticket to helpdesk
15:33:23 <aricg> MatthewLi: your linus foundation ID is not working?
15:33:33 <aricg> MatthewLi: Can you give me your linuxfoundation ID I will add you?
15:33:37 <uli-k> #topic Next steps stackalytics
15:33:49 <MatthewLi> aricg: MatthewLi
15:34:17 <aricg> MatthewLi: Is that the correct case for your login, jenkins is case sensitive
15:34:58 <uli-k> #info it would be best if each contributor would maintain his/her own info in openstack database.
15:36:10 <MatthewLi> aricg: yep
15:36:16 <aricg> MatthewLi: ok
15:37:44 <aricg> MatthewLi: access granted
15:37:59 <MatthewLi> aricg: thx!
15:38:47 <aricg> MatthewLi: are the requirements for the compass installer clear? Virtual install must be possible, a virtual machine must run on the jump server https://wiki.opnfv.org/display/INF/CI+Evolution
15:39:40 <aricg> MatthewLi: can you look at this patch as well? https://gerrit.opnfv.org/gerrit/#/c/34281/
15:40:28 <MatthewLi> aricg: will check with May-meimei of the virtual install. yep will to see the patch
15:42:44 <MatthewLi> aricg: actually, I don't quite know why a virtual machine mush run on jump server, however, maybe I should to check the evolution page first....
15:44:02 <fdegir> https://opnfv.biterg.io/app/kibana#/dashboard/Overview
15:45:42 <ChrisPriceAB> OPNFV works with bitergia for our tooling, this is the result of a lot of discussion over more than a year.  That does not exclude people using Stackalytics if they want to.  What are we proposing here?
15:47:32 <ChrisPriceAB> Suggest reaching out to rpaik on this topic first
15:48:06 <uli-k> #agree we should discuss requirements first, so Julien starts a discussion in Thursday technical call about the requirements.
15:49:21 <aricg> MatthewLi: the reason that we must have a virtual machine on the jump host, is that your installer will be dynamically given a diffrent pod from a pool of baremetal pods each time it deploys, thus we must have a common way to deploy on a jump host (we decided on a VM do do this), and a common way to clean up afterwards (destroy vm, reset the pods networking to default).
15:50:20 <jmorgan1> aricg: i think Compass is able to support a vPOD jumphost as they support baremetal jumphost
15:50:49 <jmorgan1> aricg: Compass said they will also support docker containers in the future
15:50:59 <jmorgan1> for jump host
15:53:08 <uli-k> #topic PDF converter
15:53:56 <uli-k> #info jmorgan is sending pdf for intel POD 18 to aric as input for the converter
15:54:27 <uli-k> #topic updates on security gate checks
15:54:58 <uli-k> #info repo is created; code is currently put in
15:55:15 <aricg> lhinds: can you link the patch you are waiting on?
15:58:03 <Julien-zte> hi fdegir, aricg, please refer to the link
15:58:03 <Julien-zte> #link https://wiki.opnfv.org/display/INF/Stackalytics
15:58:17 <Julien-zte> the document has been uploaded in the wiki
16:00:10 <fdegir> we probably have lots of existing issues and having non-voting checks for current release to get people familiar with the checks we will have
16:00:27 <fdegir> and this is project internal meaning that it has no release impacts
16:00:56 <fdegir> if the projects don't fix them, they will have issues for the upcoming release, when the voting enabled since they will not be able to submit patches that fail on the gate
16:01:37 <Julien-zte> it's reasonable to try in E
16:04:03 <uli-k> #info with the submits, the tool is available in the repo.
16:04:13 <uli-k> #info we still have to agree how to use it.
16:04:56 <uli-k> #action lhinds to provide a proposal how to use the tool
16:05:11 <Julien-zte> hi lhinds, can you show me the jenkins job or gerrit patch ?
16:05:41 <uli-k> #endmeeting