13:59:24 <tallgren> #startmeeting Weekly TSC meeting
13:59:24 <collabot`> Meeting started Tue May 30 13:59:24 2017 UTC.  The chair is tallgren. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:24 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:24 <collabot`> The meeting name has been set to 'weekly_tsc_meeting'
13:59:35 <tallgren> #chair rpaik
13:59:35 <collabot`> Current chairs: rpaik tallgren
13:59:47 <tallgren> #chair ChrisPriceAB
13:59:47 <collabot`> Current chairs: ChrisPriceAB rpaik tallgren
14:00:05 <rpaik> #rollcall
14:00:12 <tallgren> #info Tapio Tallgren
14:00:16 <morgan_orange> #info Morgan Richomme (IRC only)
14:00:17 <uli-k> #info Uli
14:00:18 <hongbo2839> #info hongbo
14:00:22 <rprakash> #info rprakas
14:00:29 <frankbrockners> #info Frank Brockners
14:00:35 <bh526r> #info Bin Hu
14:00:40 <fdegir> #info Fatih Degirmenci
14:00:45 <cgoncalves> #info Carlos Goncalves (proxy for Xavier Costa)
14:00:48 <jmorgan1> #info Jack Morgan
14:01:03 <bjskerry> #info Brian Skerry
14:01:16 <timirnich> #info Tim Irnich
14:01:32 <rpaik> we have a quorum
14:02:23 <rpaik> #topic approval of previous minutes
14:02:38 <rossella_> #info Rossella Sblendido
14:02:40 <rpaik> #info no comments thus previous minutes approved
14:02:42 <mbeierl> #info Mark Beierl (proxy for Edgar StPierre)
14:03:02 <bryan_att> #info Bryan Sullivan
14:03:34 <rpaik> #info no other agenda topics suggested
14:03:43 <rpaik> #topic annual award reminder
14:04:02 <tallgren> #info Annual awards voting ends tomorrow
14:05:12 <rpaik> #topic Danube/Euphrates planning
14:05:59 <dneary> #info Dave Neary
14:06:20 <trevor_intel_> #info Trevor Cooper
14:06:25 <rpaik> #info dmcbride notes that there's a full compliance on MS2 for Euphrates (with Escalator dropping out)
14:07:01 <rpaik> #info MS3 (installer integration) is today and dmcbride will be following up with installer teams
14:07:24 <rpaik> #info daily meetings will start for Danube 3.0
14:07:27 <tallgren> #info Danube 3 is coming out on June 8th. It is the last Danube release
14:10:23 <rpaik> #info dmcbride reviewed 3 sub-milestones for MS3 and noted that there's no change to the overall release schedule
14:11:29 <rpaik> #info 3.0 is OpenStack integration + nosdn + Functest support for health check
14:12:16 <rpaik> #info 3.1 is installers passing health check
14:12:52 <rpaik> #info 3.2 is deploying integrated SDN scenario and passing health check
14:13:09 <cgoncalves> rpaik: did you mean to say Euphrates 3.0 (as oppose to Danube 3.0)?
14:13:51 <jmorgan1> cgoncalves: no, MS 3.0 (MS = milestone)
14:14:07 <jmorgan1> cgoncalves: not associated to a release yet
14:15:09 <rpaik> #info MS4 will be "test framework ready"
14:16:30 <cgoncalves> jmorgan1: right. thing is rpaik wrote "daily meetings will start for _Danube_ 3.0"
14:17:11 <jmorgan1> cgoncalves: sorry, your right. it is Danube 3.0 release milestone is June 8th
14:17:31 <rpaik> #info for SDN controllers, it's up to the team to deploy which controller is deployed
14:18:15 <ChrisPriceAB> /me thinks he might propose changin "no-sdn" to "neutron" for clarity of meaning
14:18:30 <morgan_orange> +1
14:18:52 <hongbo2839> +1
14:19:21 <mbeierl> +1
14:19:23 <rpaik> #info discussion on adding a similar milestone for Kubernetes
14:20:03 <fuqiao> #info fuqiao
14:20:23 <rpaik> #info suggestion to change OpenStack/Kubernetes to VIM
14:21:05 <tallgren> #info Kubernetes does not work with Functest at the moment but this is planned within the next two weeks
14:21:40 <tallgren> #info So the Functest+Kubernetes integration will be ready by MS4 (Test case ready)
14:23:23 <rpaik> #info there is also discussion on Kubernetes plug-in for ODL
14:24:15 <rpaik> #startvote does the TSC approve additional sub-milestones for Milestone 3? (+1, 0, -1)
14:24:15 <collabot`> Begin voting on: does the TSC approve additional sub-milestones for Milestone 3? Valid vote options are , +1, 0, -1, .
14:24:15 <collabot`> Vote using '#vote OPTION'. Only your last vote counts.
14:25:20 <rpaik> #undo
14:25:20 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x21e3710>
14:25:37 <Julien-zte> #info Julien
14:26:24 <rpaik> #info 3.0 is OpenStack integration + nosdn + Functest support for health check/3.1 is installers passing health check/3.2 is deploying integrated SDN scenario and passing health check
14:27:05 <mbeierl> #info with 2-3 weeks in between each milestone
14:27:38 <rpaik> #info 3.0 is OpenStack integration + nosdn/no feature + Functest support for health check
14:28:00 <rpaik> #startvote does the TSC approve additional sub-milestones for Milestone 3? (+1, 0, -1)
14:28:00 <collabot`> Already voting on 'does the TSC approve additional sub-milestones for Milestone 3'
14:28:04 <bryan_att> #vote +1
14:28:08 <tallgren> #vote +1
14:28:09 <dneary> #vote +1
14:28:10 <cgoncalves> #vote +1
14:28:11 <hongbo2839> #vote +1
14:28:12 <timirnich> #vote +1
14:28:12 <bjskerry> #vote +1
14:28:13 <fdegir> #vote +1
14:28:15 <uli-k> #vote +1
14:28:15 <bh526r> #vote +1
14:28:16 <mbeierl> #vote +1
14:28:16 <Julien-zte> #vote +1
14:28:16 <jmorgan1> #vote +1
14:28:17 <morgan_orange> #vote +1
14:28:18 <rossella_> #vote +1
14:28:19 <fuqiao> #vote +1
14:28:25 <frankbrockners> #vote 0
14:28:34 <rpaik> #endvote
14:28:34 <collabot`> Voted on "does the TSC approve additional sub-milestones for Milestone 3?" Results are
14:28:34 <collabot`> 0 (1): frankbrockners
14:28:34 <collabot`> +1 (16): fdegir, dneary, fuqiao, cgoncalves, timirnich, bryan_att, morgan_orange, Julien-zte, tallgren, rossella_, hongbo2839, uli-k, jmorgan1, bjskerry, mbeierl, bh526r
14:28:44 <dmcbride> #link https://wiki.opnfv.org/download/attachments/2925933/MS3%20MS4%20changes.pdf?version=1&modificationDate=1496154486772&api=v2
14:28:59 <rpaik> #topic Dovetail discussion/approval
14:33:34 <rpaik> #info Wenjing reviewed the overall CVP process and went over files for test cases (e.g. for BGPVPN)
14:34:13 <tallgren> #info It is not decided at the moment whether all tests need to pass for certification
14:34:28 <rpaik> #info there is still no consensus on optional test cases (whether one needs to pass optional test cases or not)
14:34:51 <ChrisPriceAB> #action trevor_intel_  and DoveTail team, add a description on what level of test case passing should be enough to pass the CVP into to the addendum for  Danube. :)
14:36:50 <rpaik> #info there are also docs for test case requirements, user documentation, and Danube addendum
14:37:15 <rpaik> #link https://wiki.opnfv.org/display/dovetail/Dovetail+Documentation+for+Review
14:38:19 <rpaik> #info test results will be captured in testresults.opnfv.org
14:40:07 <tallgren> #info The CVP program will be announced (but not launched) in the Summit
14:40:09 <rpaik> #info CVP will be introduced at the upcoming Summit (i.e. our intent), but this will not be an official launch
14:43:11 <rpaik> #info frankbrockners asked if all mandatory tests are subset of OpenStack tests (as all tests in IPV6, HA, BGPVPN are optional)
14:46:16 <rpaik> #info dneary notes that focus has been on documentation prior to test cases becoming mandatory
14:50:17 <rpaik> #info discussion if there's a need to define a "bar" that is actually testing OPNFV
14:52:16 <rpaik> #info decision on mandatory/optional tests were made by individual project teams
14:52:17 <ChrisPriceAB> #info rosella asks what the process for determining mandatory or optional test cases is.
14:53:25 <ChrisPriceAB> #info Tim gives an example of why he selected to be optional, due to not all NFVi will support SDNVPN features.  At this time a criteria for selection has not yet been documented.
14:55:31 <ChrisPriceAB> #info tallgren asks if we need an optional section to the testing at this time.  As there are very few optional test cases at this time.
14:59:26 <ChrisPriceAB> #info rpaik asks what the TSC is being asked for today
15:00:43 <ChrisPriceAB> #info frankbrockners adds that the comments from the TSC indicate DoveTail is heading in the right direction however it is too early approve the scope as a program.
15:01:13 <ChrisPriceAB> #info timirnich asks that the TSC provides input to the project as to what tests would be valuable to be added to the test suites for the CVP
15:02:04 <ChrisPriceAB> #info frankbrockers states that a good starting point would be to ensure we evaluate the key features provided as market messages for any given release.
15:02:06 <rpaik> #info frankbrockners adds that key ingredients of the release should be tested in the CVP
15:02:14 <rpaik> :-)
15:02:50 <ChrisPriceAB> #info timirnich states items like robustness are key for OPNFV, beyond what the existing refstack test cases provide.
15:05:53 <tallgren> #endmeeting