15:00:30 <lhinds> #startmeeting infra-wg
15:00:30 <collabot`> Meeting started Mon Jul 10 15:00:30 2017 UTC.  The chair is lhinds. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:30 <collabot`> The meeting name has been set to 'infra_wg'
15:00:39 <lhinds> #info roll call
15:00:48 <lhinds> #topic roll call
15:00:55 <durschatz_> # Dave Urschatz (CENGN)
15:01:01 <fdegir> #info Fatih Degirmenci
15:01:02 <bramwelt> #info Trevor Bramwell
15:01:04 <uli-k> #info Uli
15:01:07 <aricg-> #info Aric Gardner
15:01:25 <basic`> #info Rudy Grigar
15:01:49 <thaj> #info Thaj
15:02:36 <lhinds> #topic LaaS
15:03:52 <lhinds> #info which installers can support LaaS?
15:04:27 <lhinds> #info lhinds to email techi-discuss with the above
15:04:29 <durschatz_> # I can hear but cannot be heard.  I'll just try to type any questions here in IRC
15:06:51 <lhinds> #info ask Bryan S what the hardware requirements are, questionaire to onap community, what is the basic amount of nodes required?
15:07:19 <lhinds> #info arm does not support nested virt - bob monkman
15:07:28 <fdegir> #info We need to clarify ARM resource specs with bob
15:07:41 <lhinds> #info Luke Hinds to email tech discuss to find out which installers
15:08:08 <fdegir> #action bryan_att to clarify ONAP hardware specs and number of nodes needed for basic ONAP scenario (pharos POD + x number of nodes)
15:08:10 <durschatz_> I have a question
15:08:22 <durschatz_> is it possible
15:08:32 <durschatz_> to define a dev pod
15:08:41 <bryan_att> this meeting is not in my calendar
15:08:50 <durschatz_> book it during the day and then release it for CI at night?
15:09:23 <bryan_att> is there a GTM for this?
15:09:31 <uli-k> The usual.....
15:09:35 <bryan_att> link?
15:09:43 <bramwelt> bryan_att: https://global.gotomeeting.com/join/819733085
15:09:48 <uli-k> •GTM Link https://global.gotomeeting.com/join/819733085
15:09:53 <bryan_att> not in my calendar for some reason - can you resend?
15:09:56 <uli-k> sry
15:10:03 <durschatz_> thx
15:10:05 <fdegir> bryan_att: invitation wasn't sent for this week
15:10:18 <lhinds> #info fdegir replied to durschatz_ that they should remain dedicated resources for each env
15:10:24 <uli-k> .. but it happens every week as noted in wiki ..
15:10:28 <fdegir> durschatz_: that's an option but it doesn't mean we should share all our resources between ci and dev
15:10:46 <bryan_att> please send a recurring meeting - this is the main reason I am not on calls - they need to be in my calendar
15:11:00 <fdegir> durschatz_: ci should have number of dedicated resources but we should have ability/possibility to offload work on dev resources if they are idling
15:11:25 <aricg-> https://gerrit.opnfv.org/gerrit/#/c/36297/
15:13:27 <durschatz_> fdegir: Yes CENGN would like to be able to book its pods for dev and have them used by CI when idling.
15:14:04 <bryan_att> #info my AI was addressed at https://wiki.opnfv.org/display/INF/Lab+as+a+Service
15:14:22 <fdegir> bryan_att: one of the AIs :)
15:14:33 <fdegir> bryan_att: did you have chance to check the hardware specs?
15:14:46 <fdegir> bryan_att: for example RAM per node?
15:15:53 <bryan_att> fdegir: assumed to be normal pharos server specs
15:16:04 <uli-k> #agree do a side by side review of the PDF template next week in infra call
15:16:30 <fdegir> bryan_att: it says 32GB minimum on pharos spec
15:16:52 <fdegir> bryan_att: but what I remember from the conversations we had during the summit, ONAP needs 256GB or 512GB per node
15:17:07 <bryan_att> #info here are the details https://www.irccloud.com/pastebin/zPox4eFs/
15:17:57 <bryan_att> fdegir: my analysis assumes that ONAP is running in their lab, and we are only provide LaaS for VIM testing in combination with ONAP
15:19:18 <fdegir> bryan_att: just seen this https://wiki.onap.org/display/DW/ONAP+Lab+Specification
15:19:26 <bryan_att> #info I will add some info on ONAP running in OPNFV PODs. My current analysis assumes that ONAP is running in their lab, and we are only provide LaaS for VIM testing in combination with ONAP. I am less optimistic about running ONAP in OPFNV labs due to the resource requirements, except for OPNFV-internal projects such as proposed for ONAP integration.
15:19:40 <Julien-zte> #info Julien
15:19:52 <fdegir> bryan_att: so if we have 256GB per node in LaaS, it should be possible for ONAP developers to use LaaS as well on top of using ONAP's own labs
15:20:15 <fdegir> bryan_att: one last question
15:20:24 <bryan_att> fdegir: that page is not as specific as it needs to be on what exactly they are using that lab for.
15:20:39 <aricg-> Julien-zte: when you have time can you review https://gerrit.opnfv.org/gerrit/#/c/36297/
15:21:20 <Julien-zte> aricg- OK, I will do it
15:21:26 <fdegir> bryan_att: I've seen that link on onap open lab invitation
15:22:01 <fdegir> bryan_att: so it could be partially correct which we can use it to move forward with LaaS
15:22:15 <lhinds> #actopm fdegir to check uli-k 's email on compass creates install vm instances
15:22:24 <lhinds> #action fdegir to check uli-k 's email on compass creates install vm instances
15:23:20 <Julien-zte> I know the issue and will discuss you later, aricg-
15:23:46 <fdegir> bryan_att: minimum no of nodes needed for a basic ONAP scenario seems to be 2; 1 controller & 1 compute
15:23:48 <fdegir> uli-k: ^
15:24:16 <fdegir> again, based on that wiki page
15:24:43 <bryan_att> fdegir: I would not recommend using that page for anything substantial. I think it will end up being a generic lab env for running ONAP instances. But not include any VIM etc functions. They are testing against generic OpenStack. Where I think OPNFV can add value is only in the access to VIM flavors in OPNFV LaaS resources.
15:25:45 <fdegir> bryan_att: ok
15:28:45 <basic`> I wonder if there is a qemu/kvm kernel flag or sysctl for nesting limits?
15:32:01 <bramwelt> #link https://fogproject.org/
15:32:17 <fdegir> #action fdegir to update LaaS Wiki to include ARM nested virtualization support status and not supporting non-pharos pod based deployments initially
15:34:56 <durschatz_> fdegir: Is the idea for booking tool to clean a booked pod back to a known state upon the end of a booking.  Possibly using something like Fog?
15:35:49 <fdegir> aricg-: do you have the link to intel pod18?
15:35:51 <fdegir> on wiki?
15:36:07 <lhinds> #topic action-items
15:37:01 <lhinds> #action aricg- and rose to discuss intel pod 18
15:37:19 <fdegir> #info intel-pod18 can be assigned to stress testing ^
15:46:03 <lhinds> #action uli-k to take CI topic to TSC
15:46:24 <lhinds> #chair fdegir
15:46:24 <collabot`> Current chairs: fdegir lhinds
15:46:29 <lhinds> #chair uli-k
15:46:29 <collabot`> Current chairs: fdegir lhinds uli-k
15:46:54 <fdegir> #action uli-k to add topic to TSC to discuss how to move forward with doing "true" CI
15:49:54 <lhinds> #action aricg- to send tech-discuss about gerrit verify-plugin
15:50:20 <Julien-zte> #link https://wiki.jenkins.io/display/JENKINS/Gerrit+Verify+Status+Reporter+Plugin
15:51:23 <Julien-zte> aricg-, my production env is 2.11, and no version for this gerrit.
15:51:38 <Julien-zte> it requires 2.13+ for gerrit
15:51:48 <Julien-zte> opnfv gerrit meets the requirement
15:53:39 <lhinds> #action aricg- to go ahead and implement verify-plugin
15:54:01 <Julien-zte> the plugin 'verify-status' for gerrit works fine with gerrit, I don't have env to test Jenkins+Gerrit.
15:55:38 <lhinds> #topic aob
15:55:46 <Julien-zte> #link for the plugin: https://gerrit-ci.gerritforge.com/job/plugin-verify-status-stable-2.13/lastSuccessfulBuild/artifact/buck-out/gen/plugins/verify-status/verify-status.jar
15:57:20 <durschatz_> fdegir: please add me to the dedicated XCI meeting also
15:57:49 <thaj> #info please add me in XCI meeting as well
15:58:38 <bryan_att> #info add me to
15:59:07 <uli-k> #endmeeting