12:59:03 <uli-k> #startmeeting TSC weekly call
12:59:03 <collabot> Meeting started Tue Jul 18 12:59:03 2017 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:59:03 <collabot> The meeting name has been set to 'tsc_weekly_call'
12:59:11 <uli-k> #chair rpaik
12:59:11 <collabot> Current chairs: rpaik uli-k
12:59:23 <rpaik> #rollcall
12:59:41 <uli-k> #topic rollcall
12:59:49 <lhinds> #info Luke Hinds
12:59:51 <hongbo4536982147> #info  hongbo
13:00:16 <rossella_s> #info Rossella Sblendido
13:00:28 <jose_lausuch> #info Jose Lausuch (Morgan's proxy)
13:01:00 <yifei> #info Yifei Xue (proxy for Justin)
13:01:25 <rpaik> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-July18,2017 today's agenda
13:01:38 <fuqiao> #info fuqiao
13:02:05 <timirnich> #info Tim Irnich
13:02:47 <dneary> #info dneary
13:02:57 <dneary> (on phone)
13:03:47 <dneary> All these European slackers and their 2 or 3 week vacations... ;-)
13:04:03 <rpaik> #topic  agenda bashing
13:04:05 <trevor_intel> #info Trevor Cooper
13:04:07 <rpaik> no other topics
13:04:15 <rpaik> #topic Security gate check/Anteater
13:04:22 <uli-k> #topic Security gate check/Anteater
13:06:07 <rpaik> #info lhinds notes that anteater scans against patchsets and logs are done (e.g. flagging security issues)
13:07:52 <rpaik> #info lhinds discussed setting up anteater as a chron job and notifying project team members (PTLs, committers, etc.) and asks how this could be done in a secure manner
13:09:17 <rpaik> #info uli-k proposes that scanning could also be scheduled via Jenkins
13:11:24 <trevor_intel> #info The reason to restrict scan results is to prevent security vulnerabilities from being made public
13:12:41 <uli-k> #info uli-k also proposed to notify PTL and committers about findings
13:13:09 <uli-k> #info still looking for the right location where to store these results, so only PTL and committers can access.
13:14:09 <uli-k> #action lhinds aricg- to provide the missing details for the proposal
13:14:32 <rpaik> #action lhinds/aricg to start a maling list conversation on where to store/communicate sensitive information from anteater
13:15:31 <rpaik> #topic multiple repo's for OPNFV projects
13:15:34 <jose_lausuch> split of releng repo: https://wiki.opnfv.org/display/INF/Split+up+Releng+Repository
13:16:24 <jose_lausuch> there are already 3 repos for releng
13:16:31 <jose_lausuch> https://gerrit.opnfv.org/gerrit/#/admin/projects/?filter=releng
13:17:43 <rpaik> #info trozet shares that for Apex they need to modify upstream code and additional repo's are used to fork upstream code to put NFV features
13:18:29 <aricg-> #info https://wiki.opnfv.org/display/INF/Split+up+Releng+Repository
13:18:36 <rpaik> #info Apex team had a separate Github repo for upstream work, but this was brought into OPNFV
13:19:41 <bryan_att> #info Bryan Sullivan
13:19:46 <aricg-> jose_lausuch: only the anteater on is being used right now..
13:21:12 <rpaik> #info uli-k notes if a process is needed for projects having multiple repos, or simply allow projects to create multiple repo's (by default)
13:21:26 <uli-k> #info bryan_att suggests not to restrict projects
13:22:35 <rpaik> #action rpaik to confirm if there's written "rule" somewhere for 1 repo/project
13:23:30 <rpaik> #info there seems to be consensus to allow project teams to decide what is best for their project in terms of number of repo's
13:24:45 <rpaik> #action rpaik to follow-up with community members via mailing list
13:26:05 <bryan_att> #info in the absence of any specific bylaws constraint I suggest we just enable projects to notify (as a courtesy) the TSC that a new repo has been created, and if for some reason it seems that the freedom to do so is cuasing misbehavior, the TSC can step in later
13:26:23 <rpaik> #info 3rd party license codes have been put into a "3rd party" directory
13:27:05 <uli-k> #topic Request for OPNFV infra resources for project Bamboo PNDA instance
13:27:57 <uli-k> #info Aric and Ray propose to do it via google cloud
13:28:14 <uli-k> #info cost estimate would be 350$
13:28:44 <rpaik> #info aricg notes that additional GCE resources maybe needed but donaldh is looking into this
13:29:14 <uli-k> #info that could be covered by TSC money
13:29:26 <bryan_att> #info we need to look at alternatives that are not GCE based
13:30:06 <rpaik> #info suggestion from trevor_intel and bryan_att is to also look at other alternatives and evaluate if resources are being used (after the decision is made)
13:30:40 <rpaik> we now have a quorum
13:31:56 * uli-k rpaik: thx
13:32:43 <rpaik> #action rpaik to ping donaldh and ask him to return to the next TSC call
13:32:47 <Julien-zte> #info Julien
13:33:13 <rpaik> #topic approval of previous meeting minutes
13:33:24 <rpaik> #info no feedback/comments on previous minutes, thus minutes approved
13:33:38 <hwoarang> #info mchandras
13:33:45 <rpaik> #info Danube/Euphrates update
13:34:03 <uli-k> #topic Danube/Euphrates update
13:34:05 <rpaik> #info dmcbride notes that Danube 3.0 is out
13:34:16 <rpaik> #link https://www.opnfv.org/software/downloads SW downloads page
13:34:24 <hwoarang> #info mchandras (proxy for Fatih)
13:34:56 <rpaik> #info for Euphrates Milestone 5 is July 28th (scenario integration & feature freeze)
13:36:37 <rpaik> #info MS6 (test case implementation) is August 11th
13:38:31 <uli-k> #info Milestone 5 implies that we don't expect new scenarios created after that
13:38:39 <jose_lausuch> fuel or MCP?
13:38:56 <Julien-zte> I think it is MCP
13:39:02 <hongbo4536982147> MCP?
13:39:05 <uli-k> Fuel is implemented as MCP
13:39:08 <rpaik> #info dmcbride notes that Fuel team has also documented their scenarios
13:40:40 <rpaik> #topic LF IT/infra update
13:41:25 <uli-k> #info Rudy reports from the outage in Portland
13:41:30 <rpaik> #info basic notes that there was a power outage in Portland data center last week
13:42:13 <rpaik> #info this impacted many of our services in OPNFV (git/gerrit, wiki, etc)
13:44:32 <rpaik> #info outage for git/gerritt and JIRA was about 30 minutes, but for wiki it was bout 3 hours
13:45:00 <rpaik> #info root cause analysis is still on-going and there will be further communication to mailing lists
13:45:28 <lhinds> have to drop a little early, thanks folks
13:46:30 <rpaik> #info opnfv-tech-discuss is now subscribed to status.opnfv.org page
13:47:01 <rpaik> #action basic to test the automatic posting on opnfv-tech-discuss
13:47:42 <rpaik> #topic Test WG proposal
13:48:34 <rpaik> #info uli-k notes that there's a further action item for Test WG to work with Infra WG but this has not been done yet
13:49:11 <Julien-zte> #info Gabriel requires for a pod for long term stress test from test WG
13:51:14 <bryan_att> link to what is being displayed?
13:51:28 <uli-k> It is on GTM
13:51:50 <uli-k> #link https://global.gotomeeting.com/join/798898261 (GTM)
13:51:54 <bryan_att> yes, but it's a link on the mail archive
13:51:55 <rpaik> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-July/017025.html
13:52:00 <bryan_att> thx
13:53:37 <bryan_att> what is OSA ?
13:53:50 <jose_lausuch> bryan_att: OpenStack Ansible
13:54:05 <uli-k> (used by XCI)
13:54:28 <bryan_att> is that an installer?
13:54:53 <uli-k> no
13:55:12 <uli-k> It is part of CI
13:55:26 <bryan_att> I know ansible is used by some installers for some functions, but why wouldn't we use an existing OPNFV build for this?
13:55:47 <uli-k> We want to feed back to OpenStack master
13:56:00 <bryan_att> #info Is this about x-CI or stability testing?
13:59:33 <Julien-zte> in earlier time I remember I shall perform stress test after the stable branch is released
14:00:09 <Julien-zte> I agree with bryan to perform stress test on OPNFV release instead upstream release
14:00:43 <bryan_att> #info we need further discussion on this. I don't understand why we are using a new installer for this rather than the existing installers.
14:01:34 <trozet> +1 bryan_att
14:01:36 <bryan_att> #info we need to do stability testing on the existing OPNFV scenarios using existing OPNFV installers.
14:01:48 <rpaik> #info propose to postpone this discussion to next week
14:02:33 <rpaik> #endmeeting