13:29:39 <fuqiao> #startmeeting high availavility project weekly meeting
13:29:39 <collabot> Meeting started Wed Jan 24 13:29:39 2018 UTC.  The chair is fuqiao. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:29:39 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:29:39 <collabot> The meeting name has been set to 'high_availavility_project_weekly_meeting'
13:29:56 <fuqiao> #info fuqiao
13:30:22 <georgk> #info Georg Kunz
13:30:36 <Kanglin> #info Kanglin
13:30:47 <fuqiao> those who are in the channel please put your name following #info so that we can record you~
13:31:59 <GregWaines> #info Greg Waines
13:32:06 <fuqiao> #topic HA test case process update
13:32:51 <fuqiao> we have 3 testcase describtion file uploaded to git now
13:33:06 <fuqiao> #info https://gerrit.opnfv.org/gerrit/#/c/50759/
13:33:28 <fuqiao> #info https://gerrit.opnfv.org/gerrit/#/c/50991/
13:33:49 <fuqiao> #info https://gerrit.opnfv.org/gerrit/#/c/49245/
13:34:39 <georgk> fuqiao: do you want to review them in order?
13:34:39 <fuqiao> Please everyone take time review these 3 in the following week.
13:35:31 <fuqiao> Georg, I suppose we may not have enough time to review them here.
13:35:52 <fuqiao> I suggest we review on gerrit
13:36:05 <georgk> fuqiao: fine
13:36:28 <fuqiao> A few things we may need to confirm with kanglin about the HA framework
13:36:50 <fuqiao> I will first raise questions about TC085
13:37:42 <fuqiao> @Kanglin, doesthe current testing framework have such feature to generate a steady packet flow of a certain rate
13:37:43 <collabot> fuqiao: Error: "Kanglin," is not a valid command.
13:38:34 <fuqiao> Because I see comments from Georg for TC085: "Should the test purpose also include a measurement of outage on a benchmark system/hardware setup ? Or at least some minimum outage requirement ?
13:38:34 <fuqiao> where outage could be measured by the VM under test doing simple L3 Routing for a steady state bi-directional packet flow of (say) 1,000 packets / second, and simply record the number of packets lost across the failure and recovery.
13:38:34 <fuqiao> "
13:38:47 <fuqiao> I am wondering if current framework can do this
13:39:31 <Kanglin> fuqiao: if it can implemented by bash, I think it's ok
13:40:05 <Kanglin> or we have to include some tools into framework
13:40:30 <GregWaines> kanglin: you do not currently have any simple test packet generators in your test framework / environment ?
13:40:42 <fuqiao> what do you mean by implemented by bash?
13:41:04 <fuqiao> I think Yardstick framework has, but can we use that in HA test cases?
13:41:26 <Kanglin> GregWaines: currently we only have some connectivity check by ping command
13:42:13 <Kanglin> fuqiao: I didn't tried it before, I have to discuss it with kubi and mingjiang
13:42:52 <fuqiao> #info Kanglin indicates that the current HA framework can not support packet generation. only support connectivity check with ping
13:43:24 <fuqiao> #action Kanglin will go to Kubi and Mingjiang to make sure whether we can use packet generation tool support by yardstick
13:43:38 <GregWaines> https://wiki.linuxfoundation.org/networking/pktgen is a simple software based one that you could run in another VM ...
13:43:47 <fuqiao> Kanglin: thanks. would you please help ask and give us a feedback?
13:44:37 <fuqiao> Greg: yes, this is what I expect, I think other projects in OPNFV also use packetgen. But don't know if we can use this in the current HA framework
13:44:40 <GregWaines> http://pktgen-dpdk.readthedocs.io/en/latest/socket.html ... actually this might be the better link ... it's DPDK-based packet generator
13:44:49 <Kanglin> fuqiao: ok
13:45:19 <fuqiao> Greg: could you please put the link following #info, so that the meetbot can help record that~
13:45:28 <GregWaines> only problem with pktgen is that i can't remember if it accurately reports dropped packets
13:45:32 <GregWaines> #info http://pktgen-dpdk.readthedocs.io/en/latest/socket.html
13:45:56 <fuqiao> Greg: that could be a problem, I will check out.
13:46:12 <GregWaines> i typically do these type of outage tests with Hardware-based packet generators like IXIA's ... but they are expensive
13:46:19 <GregWaines> pktgen is free
13:46:21 <GregWaines> :)
13:46:22 <stefan______> Greg: does this tool also provide the necessary receiver code?
13:46:30 <GregWaines> yes
13:46:59 <fuqiao> Georg: I have go through your TC, one question is with the TC number, I see you use TC059 & TC060, however these two are not found in the yardstick project TC wiki page?
13:47:11 <GregWaines> #info http://pktgen-dpdk.readthedocs.io/en/latest/
13:48:29 <fuqiao> @Georg: are you still here?
13:48:29 <collabot> fuqiao: Error: "Georg:" is not a valid command.
13:50:05 <fuqiao> Kanglin: Would you please review the 3 testcases?
13:50:21 <Kanglin> fuqiao: yes, I will
13:50:35 <fuqiao> great
13:51:41 <stefan______> fuqiao: the thre cases are TC060, TC084 and TC086?
13:52:05 <fuqiao> Kanglin: another question is, does the current framework support checking L2/L3 connectivity?
13:52:31 <georgk> fuqiao: yes
13:52:33 <georgk> sorry
13:52:47 <Kanglin> fuqiao: I think verification via VMs is OK
13:52:57 <fuqiao> Stefan: I am not sure the TC number is correct now, please follow the 3 link I send at the start of the meeting
13:53:04 <Kanglin> or you mean other checking methods
13:53:07 <georgk> fuqiao: ok, I´ll check the test case IDs again
13:53:19 <georgk> fuqiao: I basically just chose the next free one
13:53:46 <fuqiao> Georg: OK. They do have a wiki page to record the TC
13:53:49 <Kanglin> I wrote the new test case id on yardstick test case wiki page, I think you can use those test case ids
13:54:03 <Kanglin> https://wiki.opnfv.org/display/yardstick/Yardstick+Test+Cases
13:54:34 <fuqiao> #info wiki page for yardstick test cases: https://wiki.opnfv.org/display/yardstick/Yardstick+Test+Cases
13:54:56 <georgk> ok, but there is only one testcase for the three I am planning
13:55:08 <fuqiao> Kanglin: what do you mean by verification via VM?
13:55:15 <georgk> TC87 covers SDN controller and vswitch HA
13:55:21 <fuqiao> Georg: I guess you can edit the page and include your 3
13:55:29 <georgk> that´s my plan
13:55:35 <fuqiao> I edit it directly to include mine~
13:55:50 <georgk> fuqiao: ok
13:55:52 <Kanglin> georgk: can you give the description of other two test cases on jira, I'll add two cases later
13:56:07 <georgk> I created three tickets in the HA Jira
13:56:16 <georgk> HA-31, HA-33, and HA-34
13:56:34 <Kanglin> georgk: got it, I'll add them later
13:56:44 <georgk> Kanglin: ok, thanks
13:56:49 <fuqiao> #action Kanglin will add TC into the wiki page for HA-31, HA-33 and HA-34
13:57:10 <fuqiao> Great. I guess we will be kicked off by the following meeting in a few minutes
13:57:29 <fuqiao> Everyone please take time to review the 3 test cases.
13:57:46 <fuqiao> I will update my patch in the following week according to the comments now have
13:58:05 <fuqiao> Georg: do you have further questions to Kanglin for the framework details?
13:58:39 <fuqiao> #info Kanglin mentioned the L2/L3 VPN connectivity can be verified in VM
13:58:41 <Kanglin> fuqiao: I mean verifying connectivity by checking whether two VM connected by L2/L3 agent can ping each other
13:59:04 <fuqiao> Kanglin: got that. Thanks
13:59:28 <georgk> Kanglin: I have a question later on on how the processes are restarted (if at all)
13:59:53 <georgk> Kanglin: there is something with rollbacks in teh code, I´d like to understand that
14:00:11 <georgk> Kanglin: we can figure this out via email
14:00:38 <Kanglin> georgk: okay, we can discuss on mail later
14:00:51 <fuqiao> sorry, have to end the meeting now.
14:01:00 <fuqiao> Will follow the email thread
14:01:06 <fuqiao> #endmeeting