#opnfv-promise: promise

Meeting started by r-mibu at 06:35:07 UTC (full logs).

Meeting summary

    1. Marc was able to setup Promise with local Fuel plugin today. (GeraldK, 06:46:26)
    2. Still things to do to make it smarter and more robust. will work on this after this micro-MS. (GeraldK, 06:47:00)
    3. There had been a conflict with Promise port 4000, which is used by default by Keystone and thus was changed to port 5050 (GeraldK, 06:47:43)
    4. Hiro is working on the Juju charms. Following the same steps (but using a startup script) (GeraldK, 06:48:21)
    5. https://github.com/opnfv/juju-plugin-promise Juju charm (bertys, 06:50:07)
    6. Peter asks team for support reviewing the other files/plugins in Promise github (GeraldK, 06:50:22)
    7. https://github.com/opnfv/fuel-plugin-promise Fuel plugin (bertys, 06:50:31)
    8. plugins tested in local setups, but they do not have access to PODs (credentials) yet. (GeraldK, 06:55:40)
    9. ACTION: review README.md for both plugins (GeraldK, 06:55:55)

  1. Promise code (GeraldK, 06:57:07)
    1. Bertrand was providing few bug reports already fixed by Peter (GeraldK, 06:57:31)
    2. with the patches also small additional functionalities had been added (GeraldK, 06:58:40)
    3. Marc: we are currently using OpenStack Kilo (GeraldK, 06:59:30)
    4. OPNFV Brahmaputra will use Liberty, but for Promise Marc does not expect so much difference. (GeraldK, 07:00:10)
    5. Peter: we should be okay, but need to verify. Bertrand is working on Liberty. (GeraldK, 07:00:41)
    6. Peter: there might be a slight change to the APIs with respect to limiting the number of providers / internal handling of this, otherwise APIs are fixed for Brahmaputra (GeraldK, 07:03:26)
    7. Bertrand had been updating the documentation (see Gerrit patches) (GeraldK, 07:03:55)

  2. test cases (GeraldK, 07:05:04)
    1. Excel sheet with 15 functests; less scenario based test but more basic tests (GeraldK, 07:10:23)
    2. we need to update http://213.77.62.197/test_projects/promise/cases with the new test cases (GeraldK, 07:14:54)
    3. Bertrand proposes to remove test cases 2-4, as this is not implemented in Promise yet (GeraldK, 07:16:06)
    4. proposal to add create/destroy instance test cases (GeraldK, 07:16:33)

  3. AOB (GeraldK, 07:20:50)
    1. next meeting: discuss offline via email (GeraldK, 07:21:57)
    2. due to the time differences, ClearPath team should directly communicate with functest on the updated test cases (GeraldK, 07:25:50)
    3. ACTION: Peter to send Promise milestone E.2 update to Debra CC mailing list (GeraldK, 07:26:22)
    4. ACTION: Peter to invite for Promise call Thursday morning (GeraldK, 07:26:43)


Meeting ended at 07:28:36 UTC (full logs).

Action items

  1. review README.md for both plugins
  2. Peter to send Promise milestone E.2 update to Debra CC mailing list
  3. Peter to invite for Promise call Thursday morning


People present (lines said)

  1. GeraldK (26)
  2. collabot` (4)
  3. r-mibu (2)
  4. bertys (2)


Generated by MeetBot 0.1.4.