#opnfv-promise: Promise

Meeting started by GeraldK at 15:59:57 UTC (full logs).

Meeting summary

  1. Roll call (GeraldK, 16:00:04)
    1. Shintaro Mizuno (shintaro, 16:00:43)
    2. Bertrand Souville (bertys, 16:03:17)
    3. Agenda: 1) D-release, 2) updates to Promise shimlayer, 3) PWG user story, 4) next steps towards Blazar, 5) NTT gap analysis, 6) Committer/contributor updates, 7) OpenStack Summit (GeraldK, 16:05:28)
    4. Arturo Martin (ArturoM, 16:07:07)
    5. https://etherpad.opnfv.org/p/promise_ntt_poc (hiro-kobayashi, 16:08:01)
    6. Kobayashi-san is introducing the gap analysis results he has provided in the Etherpad (GeraldK, 16:10:02)
    7. architectural perspective: gap is usage of RestAPI. bertys mentions that this could be done by defining Mistral workflows (GeraldK, 16:13:48)
    8. Arturo will answer the "???" in the detailed functions part (GeraldK, 16:18:21)
    9. ACTION: All to review gap analysis (GeraldK, 16:20:03)

  2. OpenStack PWG user story (GeraldK, 16:20:47)
    1. http://review.openstack.org/#/c/358888 (GeraldK, 16:21:29)
    2. most likely this will also be discussed in the PWG in Barcelona (GeraldK, 16:28:38)
    3. Arun reports from the development side they are currently breaking down their work into smaller user stories (GeraldK, 16:29:27)
    4. this is to prepare for the planned BP to Blazar (GeraldK, 16:30:17)
    5. https://etherpad.openstack.org/p/PWG_Session_Oct16_BCN (shintaro, 16:30:38)
    6. GeraldK offers this can be reviewed in Promise team before submission to OpenStack Blazar (GeraldK, 16:31:09)
    7. Product WG Working Session either on Wed 2:15 - 3:45 or Tue 3:05 - 4:35 (bertys, 16:31:39)
    8. Madhu is trying to arrange a meeting with an HPE Nova core (GeraldK, 16:32:07)

  3. OpenStack Summit (GeraldK, 16:34:08)
    1. Plan is to have F2F Promise session in Barcelona with remote access (GeraldK, 16:35:25)

  4. Updates to Promise shimlayer code (GeraldK, 16:38:41)
    1. https://github.com/opnfv/promise/tree/develop/ (GeraldK, 16:39:25)
    2. Peter reports that he has done some tweaks to the Promise code based on some related modeling work (GeraldK, 16:40:59)
    3. Peter plans to continue this work as part of Danube release, introducing also some missing features (GeraldK, 16:41:48)
    4. Peter envisions some possible merge of the currently discussed approaches. (GeraldK, 16:43:03)
    5. Peter mentions some new automated documentation feature for the APIs he has introduced (GeraldK, 16:44:12)
    6. ACTION: ALL to create Jira tasks for topics/features you plan to work on as part of Danube release (GeraldK, 16:48:32)
    7. deadline is October 25th. it is easier to remove a task later on than add a new task for a new feature (GeraldK, 16:49:08)
    8. ACTION: Peter to fill a Danube survey as requested by David the release manager (GeraldK, 16:49:52)

  5. Committer/contributor updates (GeraldK, 16:51:06)
    1. ACTION: Peter to check committer list (GeraldK, 16:52:10)
    2. Proposal to add some of the new Promise members to become contributor / committer (GeraldK, 16:53:41)


Meeting ended at 16:56:20 UTC (full logs).

Action items

  1. All to review gap analysis
  2. ALL to create Jira tasks for topics/features you plan to work on as part of Danube release
  3. Peter to fill a Danube survey as requested by David the release manager
  4. Peter to check committer list


People present (lines said)

  1. GeraldK (29)
  2. bertys (4)
  3. shintaro (3)
  4. collabot (3)
  5. hiro-kobayashi (1)
  6. ArturoM (1)


Generated by MeetBot 0.1.4.