08:00:32 <yujunz> #startmeeting qtip
08:00:32 <collabot> Meeting started Wed Sep 28 08:00:32 2016 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:32 <collabot> The meeting name has been set to 'qtip'
08:00:53 <yujunz> #chair zhihui_wu
08:00:53 <collabot> Current chairs: yujunz zhihui_wu
08:01:03 <zhihui_wu> #info zhihui
08:01:20 <yujunz> Let's wait a few minutes
08:01:54 <yujunz> agenda https://etherpad.opnfv.org/p/qtip-meetings-2016-09-28
08:02:00 <yujunz> #link https://etherpad.opnfv.org/p/qtip-meetings-2016-09-28
08:02:09 <yujunz> #topic rollcall
08:02:29 <yujunz> #info Yujun Zhang
08:04:42 <yujunz> #topic Project vision
08:04:53 <yujunz> #link https://etherpad.opnfv.org/p/qtip-vision
08:05:08 <yujunz> This is the **long term** vision for qtip project
08:05:23 <yujunz> It may take several release to complete.
08:06:12 <yujunz> QTIP shall focus on performance benchmarking and aim to boost the platform benchmark to extreme
08:06:27 <yujunz> The whole chain would be Benchmark->Report->Analysis->Predict->Improve
08:06:53 <yujunz> We shall start with benchmark and reporting
08:07:32 <yujunz> The rest steps are planned for future but need to be taken into consideration during development
08:07:46 <yujunz> Any questions?
08:08:13 <zhihui_wu> No
08:08:16 <yujunz> Good
08:08:50 <zhihui_wu> I think we can create jira ticket about what we plan to do.
08:08:53 <yujunz> OK, let's move on to next topic
08:09:12 <yujunz> Yes, we have created many jira tickets
08:09:18 <zhihui_wu> Ok
08:09:40 <yujunz> I'll try to categorize them.
08:09:45 <SerenaFeng> I suggest EPIC
08:09:53 <yujunz> But first we need to define the target
08:09:56 <SerenaFeng> each EPIC includes some tasks
08:09:59 <yujunz> Then we know the priority
08:10:41 <yujunz> #topic Release D planning
08:11:06 <yujunz> I have sent intention to participate release D
08:11:13 <yujunz> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012840.html
08:11:39 <yujunz> Here is the etherpad for brainstorming
08:11:41 <yujunz> #link https://etherpad.opnfv.org/p/qtip-release-d
08:12:53 <yujunz> Currently we are a small group. So I put friendlyness as one of the target
08:13:24 <yujunz> Friendly means both on api and documents
08:13:28 <zhihui_wu> I agree with you
08:14:09 <yujunz> And we want to create a typical benchmark suite for dedicated purpose
08:14:29 <yujunz> For example, to evaluate a Pharos lab, providing a qtip score
08:15:43 <yujunz> To achieve this, we need to run different perf tools to collect data and  *invent* a formula to calculate the score and
08:16:18 <Guest47887> #info Julien
08:18:03 <yujunz> Any questions?
08:18:35 <yujunz> OK, let's move on to next topic
08:18:55 <yujunz> #topic CI job status
08:19:01 <yujunz> zhihui_wu could you update?
08:19:37 <zhihui_wu> From ci log, qtip job is stable
08:19:48 <yujunz> how many test cases are included?
08:20:42 <zhihui_wu> For now, qtip has three test suites- compute, network and storage.
08:21:03 <yujunz> both bm and vm?
08:21:42 <zhihui_wu> yes, there are 15 test cases
08:22:05 <yujunz> OK
08:22:24 <yujunz> #topic RESTful API progress
08:22:53 <yujunz> It seems Zhifeng is not online
08:23:30 <yujunz> #topic Select test suite to run instead of al
08:23:36 <yujunz> ^ all
08:23:52 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/22407/
08:24:00 <yujunz> This is a request from mailing list
08:24:13 <yujunz> Taseer is working on it
08:24:29 <SerenaFeng> the patch is already abandoned
08:25:07 <yujunz> Yes, too many errors. He says he will check it locally first.
08:25:19 <yujunz> I have send a license of PyCharm to him
08:25:24 <zhihui_wu> I invite him to attend irc meeting.
08:25:54 <yujunz> Could you send a mail to follow up the progress?
08:25:56 <yujunz> zhihui_wu
08:26:05 <SerenaFeng> tell him if he needs help, feel free to contact us
08:26:08 <zhihui_wu> yujunz, ok
08:26:34 <yujunz> #action zhihui_wu contact Taseer to follow up on selecting test suites
08:26:38 <Guest47887> where is the agenda list
08:26:53 <yujunz> #link https://etherpad.opnfv.org/p/qtip-meetings-2016-09-28
08:27:12 <yujunz> Select test case
08:27:42 <yujunz> OK, next
08:27:56 <yujunz> #topic CLI progress
08:28:02 <yujunz> SerenaFeng could you update?
08:28:16 <SerenaFeng> not start yet
08:28:27 <yujunz> Do you need any help?
08:28:32 <yujunz> Or info
08:28:36 <SerenaFeng> we agree to start it after the Restful api is ready
08:28:56 <SerenaFeng> So, I am waiting for the Restful apis
08:29:00 <yujunz> I think Zhifeng said it is almost ready.
08:29:04 <yujunz> I'll confirm with her
08:29:15 <yujunz> #action yujunz to confirm RESTful api progress
08:29:18 <SerenaFeng> yes, and the wiki documentt
08:29:31 <yujunz> Link?
08:29:42 <yujunz> Have you created it?
08:29:47 <Guest47887> SerenaFeng, just like testapi?
08:29:55 <SerenaFeng> No, it will be created by zhifeng
08:30:18 <SerenaFeng> Guest47887 yes
08:30:34 <SerenaFeng> a swagger link a documents written by hands
08:30:39 <yujunz> OK, I'll forward this request to her also
08:30:49 <SerenaFeng> a swagger link or a document written by hands
08:30:56 <SerenaFeng> She knew it
08:31:02 <yujunz> I'm not sure
08:31:09 <SerenaFeng> we talked it in a morning meeting
08:31:12 <yujunz> OK
08:31:27 <yujunz> Next
08:31:37 <yujunz> #topic gerrit reviews
08:31:42 <SerenaFeng> base on the restful document I will create a CLI proposal page
08:31:51 <yujunz> #link  https://gerrit.opnfv.org/gerrit/#/c/20661/
08:32:04 <yujunz> zhihui_wu are you going to break it into small ones?
08:32:33 <zhihui_wu> yes, 20661 is a huge patchset, not easy to do a codereview
08:32:53 <yujunz> And many conflicts
08:33:13 <zhihui_wu> I will abandond 20661
08:33:17 <yujunz> I see
08:33:17 <SerenaFeng> is it used to implement one function or multiple function?
08:34:04 <zhihui_wu> multiple
08:34:28 <SerenaFeng> then break it
08:34:28 <zhihui_wu> It effect baremetal and virtual test env
08:34:30 <yujunz> Maybe you can consider one patchset for each bullet in current commit message
08:34:57 <yujunz> There are six bullets, so six patchsets?
08:35:16 <SerenaFeng> Yes, I agree
08:35:32 <zhihui_wu> six patchsets
08:35:47 <yujunz> OK, next
08:35:51 <yujunz> #topic AOB
08:36:04 <yujunz> Anything else to talk?
08:36:25 <SerenaFeng> I think we should take some time talk about the working mechanism
08:36:37 <yujunz> what is working mechanism
08:36:57 <SerenaFeng> for example, like function do with epic, and sprint
08:37:24 <yujunz> OK, get it.
08:37:34 <yujunz> Any good practise from functest?
08:38:05 <SerenaFeng> tasks are catalogued to epics
08:38:19 <SerenaFeng> almose each task is linked to one epic
08:38:37 <SerenaFeng> one task one patch
08:39:10 <SerenaFeng> 3 weeks per sprint
08:39:26 <SerenaFeng> try to finish one task within one sprint
08:39:47 <yujunz> OK, we can try.
08:40:06 <SerenaFeng> and we need to collect all the urgent work we are doing now
08:40:18 <yujunz> And prioritize them in JIRA?
08:40:43 <SerenaFeng> yes
08:40:59 <SerenaFeng> estimate the time comsuming,  set a deadline
08:41:37 <yujunz> Will there be too much overhead doing all this?
08:42:50 <SerenaFeng> I think only the infrastructure work need to be speeded up
08:43:30 <yujunz> Infra for qtip?
08:43:34 <SerenaFeng> yes
08:43:39 <yujunz> You mean the RESTful api and cli and etc?
08:43:47 <SerenaFeng> yes
08:44:10 <yujunz> Yes, that's one of the basic target for this release. To make it complete and easy to run
08:45:01 <SerenaFeng> ok
08:45:28 <yujunz> Thanks
08:45:38 <yujunz> Next week will be holiday in China
08:46:14 <yujunz> So the meeting will be canceled. Next one will be 12 Oct
08:46:25 <yujunz> Thank you everyone.
08:46:41 <yujunz> #endmeeting