08:01:24 <yujunz> #startmeeting qtip
08:01:24 <collabot`> Meeting started Mon Nov 21 08:01:24 2016 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:24 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:24 <collabot`> The meeting name has been set to 'qtip'
08:01:36 <yujunz> #topic roll call
08:01:39 <yujunz> #info Yujun Zhang
08:01:49 <Taseer> #info Taseer
08:02:16 <yujunz> ping SerenaFeng
08:02:53 <yujunz> Agenda today
08:02:55 <yujunz> #link https://etherpad.opnfv.org/p/qtip-meetings-2016-11-21
08:03:18 <yujunz> ping akhillbatra
08:03:23 <zhihui> #info zhihui
08:03:24 <yujunz> ping akhilbatra
08:03:32 <SerenaFeng> -it#info SerenaFeng
08:03:41 <SerenaFeng> #info SerenaFeng
08:03:58 <akhilbatra> #info akhilbatra
08:04:20 <yujunz> Would you please give a short self introduction akhilbatra
08:05:43 <yujunz> He is applying for internship program. We will talk about it later.
08:05:55 <yujunz> #topic Action followup
08:05:58 <akhilbatra> Hey all, I'm Akhil, senior year undergrad at IIIT Hyderabad.
08:06:35 <yujunz> AP: @zhihui to do some research on dovetail on how to consume test data from YardStick this week
08:06:37 <yujunz> Any update? zhihui
08:07:05 <yujunz> Welcome akhilbatra \o/
08:07:06 <zhihui> I read dovetail's code
08:07:23 <zhihui> but not run dovetail's container.
08:07:42 <akhilbatra> Thank you :)
08:08:06 <zhihui> And I feel sorry. last week, ZTE pods met some problem, I spend most of time to troubleshoot
08:08:35 <yujunz> No worries zhihui . The purpose for studying dovetail is for YardStick integration
08:09:25 <zhihui> I see.
08:09:30 <yujunz> So will you continue on the YardStick integration proposal this week? zhihui
08:09:50 <zhihui> sure.
08:09:52 <yujunz> To get it done in this sprint, I think we need a draft before next meeting
08:09:55 <yujunz> Thanks
08:10:05 <zhihui> I will run dovetail on my local env.
08:10:35 <zhihui> Dovetail doesnot have a daily CI jenkins job for now.
08:10:47 <yujunz> OK
08:11:09 <yujunz> #info AP: [done] @SerenaFeng to provide yujunz some detail about internship program after talking to her student
08:11:43 <yujunz> It's done but I am also curious on where did know about OPNFV and QTIP akhilbatra Taseer
08:11:43 <SerenaFeng> I think I have given you all the information I know
08:11:58 <yujunz> Yes, thanks SerenaFeng I marked it as done
08:13:20 <yujunz> Which channel? You don't have to answer it but it helps us to know where to reachout
08:14:10 <akhilbatra> Hi, It's part of my college culture to contribute in projects of GSOC, Open Day Light etc
08:14:10 <akhilbatra> I got to know about OPNFV from my friend who was an ODL intern this year
08:14:49 <Taseer_> I was working on OPNFV as my final year project.
08:15:09 <yujunz> Thank you both
08:15:21 <yujunz> #topic internship program proposals
08:15:30 <yujunz> #link https://wiki.opnfv.org/display/qtip/Intern+Projects
08:15:36 <yujunz> I updated some content
08:16:49 <yujunz> Currently the two projects are in SerenaFeng and my scope. But I know SerenaFeng has already taking one internship program in FuncTest
08:17:47 <yujunz> So it is possible that only one project will be open since we don't have extra mentor resources
08:17:48 <SerenaFeng> It's ok, I can take another one, It won't take too much time I think, they are very talent
08:18:17 <yujunz> OK, take my words back
08:18:23 <yujunz> Thanks SerenaFeng
08:18:55 <yujunz> If you need a hand in your YardStick integration work CI jobs, you can also propose one zhihui
08:19:14 <SerenaFeng> As far as you think it is necessary, you can count on me :)
08:19:39 <akhilbatra> Saw the page. I can see some additional requirements. Are those prerequisites for application or have to be done during the program?
08:19:55 <yujunz> I'm just about talking about it
08:20:12 <akhilbatra> Ok sure :)
08:20:35 <yujunz> For first two, it is required
08:20:39 <yujunz> For the last one, I don't know where it is too hard or not
08:20:43 <zhihui> yujunz, ok. It is glad to have a helper.
08:21:06 <yujunz> But we expect the candidates know basic skills to work in OPNFV
08:21:34 <yujunz> How long does it take you for the first three, Taseer_
08:22:02 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/q/owner:taseer94%2540gmail.com+status:merged
08:22:43 <Taseer_> About two weeks I guess. You just need to be following all the progress from other contributors.
08:23:20 <yujunz> It could be anything, not limited to QTIP. Just a practise on how to work in the community.
08:23:57 <yujunz> It's for MEDIUM and HIGH only.
08:24:17 <Taseer_> I have submitted my proposal. Do we also need to setup for an interview ?
08:25:01 <yujunz> Yes, I think so. Let's do it like a formal job. We'll organize an interview and have the evaluation report reviewed by the committers
08:25:04 <yujunz> and mentor
08:25:22 <Taseer_> Ok.
08:25:59 <yujunz> If you have any questions on the expectations, we can talk during interview
08:26:20 <yujunz> Do you have any questions, akhilbatra
08:27:57 <akhilbatra> I am new to OPNFV. Will start trying my hand on it.
08:27:57 <akhilbatra> I found my skills relevant to the projects given. How should i proceed for it?
08:28:45 <yujunz> Try to find a project you are interested to work on and understand the current status.
08:29:05 <yujunz> During the exploration, I think you can finish the 3 commits
08:30:20 <yujunz> The previous contribution in open source community is a reference, not a criteria
08:30:46 <akhilbatra> Alright thanks for the guidance. I will start from today.
08:31:28 <yujunz> OK, feel free to contact me if anything unclear
08:31:41 <yujunz> Taseer_ can prove that I'm answering mail quite timely :-)
08:32:08 <yujunz> #topic servers for qtip
08:32:19 <akhilbatra> Yeah :)
08:32:22 <Taseer_> Yes.
08:32:35 <yujunz> Currently we have two servers for qtip development
08:32:37 <yujunz> one in AWS, one in aliyun
08:33:00 <yujunz> Anyone who want to work in QTIP project can apply ssh access by submitting a patch on gerrit
08:33:48 <yujunz> It is quite expensive and currently sponsored by ZTE
08:34:11 <yujunz> We are trying to make some internal resources available for public access
08:34:57 <yujunz> The security rule is under review. I'll send a notification to mailing list when it is ready.
08:35:40 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/24477/
08:35:58 <yujunz> Please check your access to Aliyun server SerenaFeng zhihui Taseer_
08:36:10 <SerenaFeng> Mine works fine
08:36:23 <yujunz> +1 on gerrit please
08:36:28 <SerenaFeng> sorry, Aliyun not checked
08:36:39 <Taseer_> I'll let you know.
08:36:52 <yujunz> Aliyun server is 1 CPU + 1GB Mem, 100Mbps Network
08:37:38 <zhihui> I will post my key later.
08:37:55 <Taseer_> what is it for ?
08:38:12 <yujunz> I bought it on the 11.11 sale
08:38:18 <yujunz> Just because it is quite cheap...
08:38:35 <yujunz> Not sure how we are using it yet.
08:38:52 <yujunz> Named test, so if you want to try something dangerous, play with it
08:39:08 <Taseer_> OK
08:39:25 <yujunz> As more services are deployed on dev server, the changes should be careful to not breaking existing features
08:39:42 <SerenaFeng> How long will the account last?
08:39:45 <yujunz> One year
08:40:07 <yujunz> Till Nov 2017
08:40:35 <yujunz> AWS is monthly subscription and will be migrated to ZTE internal resource when it is ready
08:40:38 <yujunz> Too expensive to afford
08:40:51 <SerenaFeng> ok, get it
08:41:05 <yujunz> As we are having more resources, it's time to give names!
08:41:13 <yujunz> There are two proposals
08:41:24 <yujunz> #info sofa, chair, table and other furnitures (deriving from bench)
08:41:32 <yujunz> #info pen, ruler, knife and other stationaries (deriving from mark)
08:42:20 <yujunz> Which one do you prefer?
08:42:47 <zhihui> I perfer furnitures
08:42:50 <zhihui> :)
08:43:09 <yujunz> +1 furnitures from me also
08:43:21 <SerenaFeng> +1
08:44:00 <Taseer_> majority is authority
08:44:35 <yujunz> OK, 3 out of 5
08:44:37 <yujunz> #agreed using furnitures for server names
08:44:58 <yujunz> #topic google account for document sharing and review
08:46:02 <yujunz> Some materials are stored on google services, such as presentation, resumes and security reports
08:46:23 <yujunz> So everyone who need access please send me your Google account
08:46:40 <yujunz> #action everyone send yujunz google account for document sharing and review
08:47:05 <yujunz> #topic active sprint review
08:47:07 <yujunz> #link https://jira.opnfv.org/secure/RapidBoard.jspa?projectKey=QTIP&rapidView=135
08:47:29 <yujunz> Anything particular you want to talk about current sprint?
08:47:33 <yujunz> Any blocking issue?
08:48:36 <yujunz> None. So we move to next
08:48:40 <Taseer_> does cli need to be completely done again ?
08:48:53 <yujunz> What do you mean completely
08:49:04 <Taseer_> because of directory restructure ?
08:49:26 <yujunz> Partly yes
08:49:33 <Taseer_> OK
08:49:37 <yujunz> It's not about directory
08:50:01 <yujunz> The importance is separate the function from CLI so it can be shared with api server
08:50:05 <yujunz> And easier for unit test
08:50:07 <SerenaFeng> we can close tasks and leave epic for further working
08:50:38 <yujunz> It's on your call Taseer_
08:50:51 <yujunz> For me, it can only be continued after architecture adjust is done
08:51:07 <Taseer_> yes its fine by me.
08:51:15 <SerenaFeng> just suggestion
08:51:46 <yujunz> OK, you can unassign yourself if no longer working on that or close it if all content in it is considered completed
08:52:38 <yujunz> #topic last week update in JIRA
08:52:41 <yujunz> #link  https://jira.opnfv.org/issues/?filter=11198
08:52:56 <yujunz> I modified the filter, so only the new issues are displayed
08:53:31 <yujunz> When a new issue is created, it does not mean we need to get it done in current sprint
08:54:20 <yujunz> Normally they are evaluated when starting next sprint
08:54:49 <yujunz> But if you think it is preferred to get it done in current sprint, feel free to take it
08:55:20 <yujunz> We are an autonomous team, don't be afraid to make actions
08:55:36 <yujunz> And no need to ask for permission, just keep a good communication with the team
08:56:21 <yujunz> #AoB
08:56:37 <yujunz> Anything else you want to talk today?
08:57:13 <yujunz> If none, I'm going to close this meeting
08:57:18 <yujunz> Thank you all
08:57:21 <yujunz> #endmeeting