07:33:18 <yujunz> #startmeeting qip
07:33:18 <collabot> Meeting started Mon Jan  9 07:33:18 2017 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:33:18 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:33:18 <collabot> The meeting name has been set to 'qip'
07:33:20 <SerenaFeng> or emergence
07:33:34 <yujunz> Not urgent, but important
07:33:46 <yujunz> Anyway they can check the minutes later
07:34:02 <SerenaFeng> ok
07:34:02 <yujunz> Taseer is probably in class
07:34:17 <yujunz> ping akhilbatra
07:34:21 <yujunz> Are you online?
07:34:33 <yujunz> #link https://etherpad.opnfv.org/p/qtip-meetings-2017-01-09
07:34:49 <akhilbatra> Hello
07:34:50 <akhilbatra> i am present here, but caught up in an urgency of college dedline. Pardon me if I miss something.
07:34:50 <akhilbatra> Apology
07:35:19 <yujunz> Maybe we can talk about the intern project first
07:35:26 <yujunz> Are you available for 5 minutes
07:35:35 <akhilbatra> Sure
07:36:14 <yujunz> I saw you achieved 3 commits today, so are you still interesting in the api server project?
07:36:23 <yujunz> #topic intern project qtip-api
07:37:07 <akhilbatra> Yes I am interested.
07:37:07 <akhilbatra> I can make a rough draft of the proposal today.
07:37:07 <akhilbatra> Will submit the final after approval
07:37:22 <yujunz> OK, anything else required from you SerenaFeng
07:37:44 <yujunz> Are you planning for a 3 month full time or 6 month half time akhilbatra
07:37:47 <SerenaFeng> for the moment, no
07:38:05 <SerenaFeng> we can discuss it offline, if I have some questions
07:38:14 <yujunz> OK
07:38:18 <akhilbatra> Ok
07:39:04 <yujunz> OK, let's put it in offline talk
07:39:07 <yujunz> Hi Taseer
07:39:13 <Taseer> Hi
07:39:26 <yujunz> So we can start the first topic now
07:39:51 <yujunz> #topic Action followup
07:40:14 <yujunz> #info AP1 zhihui to investigate how to detect yardstick finishing after xmas and new year holiday
07:40:19 <yujunz> #info AP2 zhihui to propose design specification of yardstick integration
07:40:31 <yujunz> Both are under discussion with yardstick team
07:40:55 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/26563/
07:41:07 <yujunz> #link https://wiki.opnfv.org/display/yardstick/Yardstick-Qtip+integration
07:41:34 <yujunz> If you have comments, please leave them in gerrit or wiki
07:42:16 <yujunz> zhihui will lead this task. She is on leave today. So we won't go deep in it today
07:42:54 <yujunz> #action all review yardstick-qtip integration proposal if interested
07:43:27 <yujunz> yardstick integration would be a PoC of qtip agent mode
07:43:51 <yujunz> And one of the most common deployment of QTIP in OPNFV
07:44:27 <yujunz> #info AP4 yujunz create a design specification on the architecture and design evolution
07:44:30 <yujunz> Still in progress
07:44:38 <yujunz> I'll invite you to review when it is ready
07:44:59 <yujunz> #topic intern bootcamp proposal
07:45:11 <yujunz> #link https://etherpad.opnfv.org/p/qtip-bootcamp
07:45:51 <yujunz> This would be an Orientation for intern candidates of OPNFV QTIP project before application
07:46:47 <yujunz> akhilbatra Taseer could you help on Prequisite and OPNFV part?
07:48:30 <Taseer> Not sure about Etherpad in OPNFV
07:48:51 <Taseer> What's that for ?
07:48:59 <yujunz> How to use etherpad
07:49:09 <yujunz> Just provide some link
07:49:20 <Taseer> Ok.
07:49:53 <yujunz> I'll handle the QTIP and Evaluation part
07:50:18 <Taseer> https://etherpad.opnfv.org/p/QTIP_CLI
07:50:35 <Taseer> My Etherpad for internship
07:50:44 <yujunz> Yes, a brief introduction on how to use it and when
07:50:56 <yujunz> It should be quite straight forward
07:51:29 <Taseer> It can be used to track your progress.
07:51:39 <yujunz> Some new comer don't know how to create a new page in etherpad
07:51:59 <Taseer> OK, Should I edit it in the bootcamp etherpad ?
07:52:14 <yujunz> Yes
07:52:16 <yujunz> etherpad is mainly used for brainstorming
07:52:25 <yujunz> When things are almost stable, we shall move it to wiki
07:52:56 <Taseer> Ok, I'll do it.
07:53:00 <yujunz> Thanks
07:53:38 <yujunz> #action Taseer update Prequisite and OPNFV section on https://etherpad.opnfv.org/p/qtip-bootcamp
07:53:42 <Taseer> You are welcome
07:54:14 <yujunz> #action yujunz finalize qtip-bootcamp and move it to wiki page
07:54:19 <yujunz> #topic fast track submit
07:54:51 <yujunz> I'm raising this topic because patch sets are piling up in gerrit
07:55:02 <yujunz> Partly because Zhihui is in vacation last week
07:55:18 <yujunz> And the root cause is that we lack enough active committers
07:55:59 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/q/project:qtip+AND+status:open
07:56:21 <yujunz> We have 11 patch sets under review
07:56:46 <yujunz> Some of them are more than one week old
07:57:07 <yujunz> Especially the architecture evolution patches
07:57:21 <yujunz> They are a bit difficult to understand since it is a big change
07:57:46 <yujunz> So I'd like to propose a fast track approval
07:58:22 <yujunz> normally, committer need at least one +2 vote from others before submit any patch set
07:58:51 <yujunz> for fast track, I propose we allow approval if no objection from other committer for one working day
07:59:33 <yujunz> Any comments? akhilbatra Taseer SerenaFeng
07:59:49 <Taseer> Not from my side
07:59:58 <Taseer> +1
08:02:14 <yujunz> OK, I'll notify all committers about this proposal
08:02:29 <yujunz> #action send proposal of fast track submit to all committers
08:02:33 <yujunz> #undo
08:02:33 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2461810>
08:02:56 <yujunz> #action yujunz send proposal of fast track submit to all committers
08:03:08 <yujunz> #topic architecture evolution
08:03:12 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/26585/
08:03:29 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/26783/
08:03:53 <yujunz> I am planning to move legacy code to a separate folder so that it won't confuse the new comers
08:04:56 <yujunz> It is possible that some code are still reusuable. If so, move them from legacy back to /qtip folder
08:05:22 <yujunz> For example, the api server
08:05:29 <yujunz> Without handler part
08:05:40 <yujunz> I suppose you will work on it akhilbatra
08:07:03 <yujunz> Also for part of the old CLI
08:07:14 <yujunz> #topic developer guide
08:07:39 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/26779/
08:08:29 <yujunz> An outline is created, please help complete the content.
08:08:57 <yujunz> #topic coding style
08:10:00 <yujunz> We may consider to apply openstack hacking check to achieve a consistent style in project
08:10:02 <yujunz> #link http://docs.openstack.org/developer/hacking/
08:10:59 <yujunz> Nothing particular in recurring topics today
08:11:05 <SerenaFeng> #agreed to adopt OpenStack style guideline
08:11:08 <yujunz> #topic AoB
08:11:31 <yujunz> Any other topics from your side? akhilbatra SerenaFeng
08:11:49 <SerenaFeng> about the developer guide
08:11:54 <yujunz> Yes?
08:12:02 <SerenaFeng> I suggest we adopt OpenStack guideline
08:12:14 <yujunz> Is there a link?
08:12:24 <SerenaFeng> ok, you already give the link
08:12:49 <yujunz> You mean the coding style?
08:12:55 <yujunz> Yes, we shall follow openstacks
08:13:16 <yujunz> The developer guide gives some additional information on how to get started in QTIP development
08:13:34 <yujunz> I got some feedback from Sanketh
08:13:49 <yujunz> He might help on it.
08:15:33 <yujunz> I think that's all for today.
08:15:43 <yujunz> See you next week :-)
08:15:46 <yujunz> #endmeeting