07:31:55 <yujunz> #startmeeting QTIP
07:31:55 <collabot> Meeting started Mon Jan 16 07:31:55 2017 UTC.  The chair is yujunz. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:31:55 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:31:55 <collabot> The meeting name has been set to 'qtip'
07:32:27 <yujunz> #topic Action review
07:32:38 <yujunz> #AP1 all review yardstick-qtip integration proposal if interested
07:32:51 <yujunz> akhilbatra have you look at it?
07:33:07 <yujunz> It includes some requirements to qtip-api
07:33:18 <akhilbatra> no I haven't yet.
07:33:43 <zhihui_> We will have a irc meeting with yardstick tomorrow.
07:33:56 <yujunz> Maybe too early for akhilbatra
07:34:08 <yujunz> It's UTC0030 if I remember it right
07:34:33 <zhihui_> Yes. It is too early for akhilbatra
07:34:46 <yujunz> #link https://wiki.opnfv.org/display/yardstick/Yardstick-Qtip+integration
07:35:22 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/26563/
07:35:43 <yujunz> akhilbatra please consider this in the early stage of qtip-api intern project
07:35:52 <akhilbatra> Okay
07:35:54 <yujunz> We are targeting it in Danube release
07:36:16 <yujunz> We'll discuss the schedule later
07:36:26 <yujunz> Hi Taseer
07:36:32 <yujunz> We are going through the action points
07:36:32 <Taseer> Hi
07:36:48 <yujunz> #info AP2 #done Taseer update Prequisite and OPNFV section on https://etherpad.opnfv.org/p/qtip-bootcamp
07:37:08 <yujunz> Thank you Taseer for providing the content
07:37:21 <yujunz> #info AP3 #done yujunz finalize qtip-bootcamp and move it to wiki page
07:37:35 <yujunz> Published on wiki
07:37:46 <yujunz> #link https://wiki.opnfv.org/display/qtip/Bootcamp
07:38:03 <yujunz> #info AP4 #done yujunz send proposal of fast track submit to all committers
07:38:19 <yujunz> Done and merged though not many feedback from inactive reviewers...
07:38:38 <yujunz> Let's consider it as an agreement and move fast to our target
07:39:17 <yujunz> Before we going to the scheduled topics, I'd like to have an update from your side
07:39:21 <yujunz> #topic Status update
07:40:04 <yujunz> From my side, I moved the legacy code out of qtip folder and hope it will reduce the burden on Danube release
07:40:14 <yujunz> The code repo should be much clearer now
07:40:32 <yujunz> I will continue working on the arch and doctor profiler
07:40:55 <yujunz> That's all. Who's next?
07:41:36 <yujunz> How are you going with qtip-yardstick and compute QPI  zhihui_
07:42:48 <zhihui_> Not yet.
07:43:25 <yujunz> We may need to get prepared for tomorrow's discussion.
07:44:23 <yujunz> Do you have any problem of deliver it in release D?
07:44:50 <zhihui_> I think we have a little risk in release D.
07:45:15 <yujunz> Which part? Or both?
07:45:42 <zhihui_> Qtip agent. I have no idea about this part for now
07:46:44 <yujunz> OK. We may need to make decision on priority of these topics if we can't finish them all.
07:46:57 <yujunz> We shall revisit it after meeting with yardstick
07:47:03 <zhihui_> Since yardstick feedback they still have something unclear about our design spec. So I guess maybe there are some part we don't consider well.
07:47:40 <yujunz> So it seems qtip-yardstick is in more risky than compute-qpi
07:47:51 <yujunz> Since it has more external dependency
07:48:36 <yujunz> We may take compute-qpi for higher priority and followup with yardstick's progress on the integration task, what do you think?
07:49:06 <zhihui_> I agree.
07:49:23 <yujunz> Good. How about you taseer_ ? Any update on CLI?
07:50:05 <taseer_> I am working on the presentation for Wednesday now.
07:50:18 <yujunz> OK, looking forward to it
07:50:22 <taseer_> Ok
07:50:50 <yujunz> And qtip-api akhilbatra could you update?
07:50:58 <yujunz> SerenaFeng is away at the moment
07:52:02 <akhilbatra> Proposed frameworks to be used. Need to decide on that.
07:52:02 <akhilbatra> Will decide the specifications once that is done
07:52:24 <yujunz> OK, is the proposal public for all?
07:52:38 <yujunz> You may put it in qtip-public folder on Google drive
07:52:47 <akhilbatra> ok will do that
07:53:08 <akhilbatra> I think architecture of `agent mode` need update if api is part of it.
07:53:15 <yujunz> #action akhilbatra put qtip-api in public folder for review
07:53:27 <yujunz> Good point
07:53:30 <akhilbatra> #link https://wiki.opnfv.org/display/qtip/Architecture
07:53:51 <yujunz> I may need to put a draft wiki page for such change
07:54:00 <yujunz> Since it is not so easy to review changes on wiki
07:54:52 <yujunz> #action yujunz create a draft page for proposals on architecture evolution
07:55:24 <yujunz> OK, next
07:55:32 <yujunz> #topic revisit coding style
07:56:02 <yujunz> We are following OpenStack coding style, but currently there is no check
07:56:10 <yujunz> #link  http://docs.openstack.org/developer/hacking/
07:56:17 <yujunz> I've create a ticket for it
07:56:26 <yujunz> #link https://jira.opnfv.org/projects/QTIP/issues/QTIP-203
07:56:51 <yujunz> Not so urgent, but we may apply it in next release and together with Python 3 support
07:57:28 <yujunz> #topic Danube release schedule
07:57:38 <yujunz> #link https://wiki.opnfv.org/display/SWREL/Danube
07:57:56 <yujunz> We are now approaching milestone 5
07:57:59 <yujunz> #link https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description
07:58:32 <yujunz> MS5 and MS6 is more related to feature project. Not applicable for QTIP, a testing project
07:58:34 <zhihui_> There is another link about python3 in openstack. we can refer too. link https://wiki.openstack.org/wiki/Python3
07:58:50 <yujunz> Thanks zhihui_
07:59:15 <yujunz> For MS5, we just have an external task in DOCTOR
07:59:26 <yujunz> To report the performance data to testdb
07:59:50 <yujunz> I think SerenaFeng will be the best candidate for it since she designed the api in testdb
08:00:10 <yujunz> I'll discuss with her later
08:02:08 <yujunz> MS7 is something we need to pay attention to
08:02:31 <yujunz> The date is 2016/3/10
08:02:56 <yujunz> This will be the date for feature freeze in QTIP
08:03:15 <yujunz> So please make sure your change is merged into the repo.
08:03:21 <yujunz> After that only bug fix will be accepted in stable branch
08:03:35 <yujunz> The date is less than 3 sprints from now
08:03:53 <yujunz> #topic Sprint followup
08:04:20 <yujunz> It is the last day of sprint QTIP-D5
08:04:44 <yujunz> Please update the issue status before tomorrow morning akhibatra zhihui_ SerenaFeng
08:05:26 <yujunz> #topic AoB
08:05:57 <yujunz> #info Arrangement during Sprint Festival
08:06:25 <yujunz> I think we shall cancel next two meetings
08:07:00 <yujunz> Next project meeting will be on Feb 6th
08:07:18 <yujunz> Spring Festival in China
08:07:52 <yujunz> #info qtip-yardstick joint meeting Jan 17, 2017 00:30 AM UTC
08:08:14 <yujunz> #info qtip-cli intern project 1st review Jan 18, 2017 03:15 AM UTC
08:08:36 <yujunz> That's all from my side. Any other thing from your side? akhilbatra zhihui_
08:09:20 <akhilbatra> where is the qtip-yardstick meeting? I will try to join
08:10:04 <zhihui_> channel is #opnfv-yardstick
08:10:11 <akhilbatra> ok
08:10:15 <yujunz> IRC only? or with GTM
08:10:54 <zhihui_> IRC
08:11:30 <yujunz> OK, thanks
08:11:55 <yujunz> Anything else?
08:12:03 <zhihui_> Nope from me
08:12:08 <akhilbatra> None from my side
08:12:15 <yujunz> OK, thank you all
08:12:19 <yujunz> #endmeeting