07:32:45 <yujunz-zte> #startmeeting qtip
07:32:45 <collabot> Meeting started Mon Jul 17 07:32:45 2017 UTC.  The chair is yujunz-zte. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:32:45 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:32:45 <collabot> The meeting name has been set to 'qtip'
07:32:56 <yujunz-zte> #topic roll call
07:33:00 <yujunz-zte> #info Yujun Zhang
07:33:06 <akhilbatra> #info akhil
07:33:11 <Sridhar> #info Sridhar
07:33:36 <yujunz-zte> ping zhihui_wu serena-zte
07:34:01 <zhihui_wu> #info zhihui
07:34:12 <yujunz-zte> Welcome Sridhar
07:34:20 <yujunz-zte> Would you give a brief self introduction?
07:34:30 <zhihui_wu> Welcome Sridhar
07:34:39 <Sridhar> Sure. Hi Guys. I'm Sridhar and I work for Spirent.
07:34:53 <Sridhar> I have been mostly working with VSPERF and Barometer projects
07:35:04 <serena-zte> welcome Sridhar
07:35:15 <Sridhar> Started with Yardstick and now QTIP
07:35:15 <akhilbatra> Hi Sridhar
07:35:42 <Sridhar> My Goal, is enable Trafficgenerators - both OS and Commercial (Spirent) into QTIP
07:36:25 <Sridhar> I have gone through the network suite document and have some set of queries.. which I'll ask later.. once I get a chance
07:36:31 <serena-zte> do you mind telling more about trafficgenerators?
07:36:51 <Sridhar> Currently, I suppose QTIP is using IPERF.. right?
07:37:18 <Sridhar> I want to integrate Spirent STCv (a virtualized traffic generator cum protocol emulator)
07:37:27 <Sridhar> and other Opensource trafficgens
07:37:40 <zhihui_wu> Actually, the network suite you found in QTIP may be out of date.
07:38:06 <Sridhar> Okie.. so, Am I wrong in IPERF assumption?
07:38:32 <yujunz-zte> No, you are not. Out of date means out of maintenance
07:39:04 <Sridhar> Ahh.. No issues, once we do the actual work, we can update the same!
07:40:38 <yujunz-zte> OK. I suppose the trafficgenerators you mentioned ares already supported in YardStick and VSPERF, right?
07:40:50 <Sridhar> YES.
07:41:53 <yujunz-zte> OK, I may have a look at it to get more ideas
07:42:26 <Sridhar> Sure, maybe I can explain - if we can setup a call.
07:43:06 <yujunz-zte> Great, can we schedule it in next Monday weekly meeting?
07:43:40 <Sridhar> Yes. That would be nice
07:43:50 <yujunz-zte> OK. I'll put it in agenda
07:44:09 <Sridhar> My recent report in vsperf - https://wiki.opnfv.org/display/vsperf/Traffic+Generator+Testing
07:44:43 <Sridhar> I'm keen on translating this metrics to "Indicators" - the QTIP principle!
07:45:19 <zhihui_wu> It sounds great.
07:46:08 <Sridhar> I'm sorry, I have one last question... Do QTIP has its own testbed running?
07:46:55 <yujunz-zte> What do you mean testbed? We schedule the QTIP performance tests on two ZTE pods daily
07:47:29 <yujunz-zte> I just want to mention it in today's agenda
07:47:31 <yujunz-zte> #link https://etherpad.opnfv.org/p/qtip-meetings-2017-07-17
07:48:32 <yujunz-zte> #topic CI job updates
07:49:19 <zhihui_wu> I have changed QTIP danube CI job from a daily job to a weekly one.
07:50:14 <zhihui_wu> And for now, as you know, all zte pods are deployed with fuel.
07:51:39 <zhihui_wu> Recently MCP deployment has been failed for a while. so QTIP CI job with branch master can be executed.
07:51:54 <yujunz-zte> Can or can not?
07:52:03 <zhihui_wu> sorry, can not
07:52:36 <zhihui_wu> We have to wait MCP deployment back to normal.
07:53:16 <zhihui_wu> That is all about QTIP CI job.
07:53:57 <yujunz-zte> OK, thanks.
07:54:20 <yujunz-zte> Sridhar, by testbed, do you mean a Pod for running the performance test?
07:54:33 <yujunz-zte> How is it done in VSPERF?
07:55:03 <Sridhar> Yes. its the pod for running the tests
07:55:24 <OPNFV-Gerrit-Bot> Merged qtip: Add further enhancements into compute-report  https://gerrit.opnfv.org/gerrit/37409
07:55:24 <Sridhar> Currently, the traffic generators are running on Intel's Pod
07:55:28 <Sridhar> for VSPERF
07:56:12 <Sridhar> So, we have to talk (maybe over mail) on installing Spirent solutions on ZTE_pod
07:56:19 <Sridhar> along with licenses for OPNFV users
07:56:33 <yujunz-zte> OK, let's discuss it over email
07:58:25 <yujunz-zte> #topic jupyter notebook for reports
07:58:51 <yujunz-zte> Currently Taseer and I are working on the output of the test report with jupyter.
07:59:39 <yujunz-zte> It is still work in progress. You can install jupyter and start a local server to see the output.
07:59:50 <yujunz-zte> Or view it online with nbviewer
08:00:00 <yujunz-zte> #link http://nbviewer.jupyter.org/url/git.opnfv.org/qtip/plain/examples/compute-qpi-report/report.ipynb
08:01:24 <yujunz-zte> A patch has been uploaded in releng to help the review process.
08:01:28 <yujunz-zte> #link https://gerrit.opnfv.org/gerrit/#/c/37247/
08:01:42 <yujunz-zte> serena-zte please help review the patch
08:01:55 <yujunz-zte> It seems many committers of releng are on PTO...
08:02:08 <serena-zte> okey, I will soon do it
08:03:00 <yujunz-zte> Any questions?
08:03:32 <yujunz-zte> OK, next
08:03:41 <yujunz-zte> #topic progress on qtip-web
08:04:02 <yujunz-zte> akhilbatra could you update?
08:04:17 <akhilbatra> Baisc authentication and crud tasks are done on db
08:04:39 <akhilbatra> Curently working on the module to clone repos, run and return the log
08:05:36 <akhilbatra> meanwhile I want to get suggestions for the frontend template.
08:05:40 <akhilbatra> #link https://etherpad.opnfv.org/p/qtip-web
08:06:28 <akhilbatra> Please review and add +1 on the right of the templates you like. I'll get the idea which one is better :)
08:06:57 <yujunz-zte> I have reviewed the list. Most of them look good to me. Any recommendation from your own point of view?
08:08:05 <akhilbatra> 2nd and 5th one
08:08:32 <akhilbatra> 4th is also descent
08:09:00 <akhilbatra> the link is open for new suggestions also
08:09:43 <yujunz-zte> OK, I'll put an action.
08:09:45 <yujunz-zte> #action all review the template proposal in https://etherpad.opnfv.org/p/qtip-web
08:10:30 <akhilbatra> thanks
08:11:57 <yujunz-zte> #topic status and progress
08:12:19 <yujunz-zte> Anything else to share about last week?
08:13:22 <yujunz-zte> No? Let's move on to last topic.
08:13:26 <yujunz-zte> #topic AoB
08:13:53 <yujunz-zte> I noticed VSPERF submit a draft spec to IETF last week
08:13:56 <yujunz-zte> #link https://tools.ietf.org/html/draft-ietf-bmwg-vswitch-opnfv-04
08:17:34 <Sridhar> Yes, by Al morton.
08:18:11 <Sridhar> Lot of overlap with the TST001 and other IETF draft
08:18:12 <zhihui_wu> It is very professional.
08:20:15 <Sridhar> I can request Al to attend QTIP call to share his thoughts on Network PIs.
08:20:59 <yujunz-zte> That would be great. Which time zone is he in?
08:21:11 <Sridhar> East Coast - US.
08:21:47 <yujunz-zte> OK, please put me in cc list so we can arrange a suitable time slot.
08:22:12 <Sridhar> Will do that.
08:22:45 <yujunz-zte> Thanks. Anything else?
08:24:00 <yujunz-zte> OK. Thank you all for coming. See you next week :-)
08:24:02 <yujunz-zte> #endmeeting