16:00:22 <morgan_orange> #startmeeting Functest weekly 6th october
16:00:22 <collabot> Meeting started Tue Oct  6 16:00:22 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:22 <collabot> The meeting name has been set to 'functest_weekly_6th_october'
16:00:30 <morgan_orange> #info Morgan Richomme
16:00:31 <jose_lausuch> punktlich!!
16:00:35 <jose_lausuch> #info Jose Lausuch
16:00:53 <morgan_orange> valentin told me he will at the pub
16:01:05 <jose_lausuch> at the pub?
16:01:11 <morgan_orange> irish pub
16:01:29 <jose_lausuch> hehehe
16:01:34 <jose_lausuch> so
16:01:38 <jose_lausuch> no more SR1 today
16:01:40 <jose_lausuch> :)
16:01:49 <morgan_orange> yes agenda https://wiki.opnfv.org/functest_meeting
16:02:14 <morgan_orange> let's start (I have to leave at 6h30)
16:02:18 <morgan_orange> #topic R2
16:02:47 <morgan_orange> #info agile board status: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59
16:03:12 <morgan_orange> #info SLA on Rally implemented => save more than 30 minutes
16:03:13 <jose_lausuch> I'll start tomorrow pushing the run_Tempest script
16:03:29 <morgan_orange> #info we can see that Nova and Neutron are failed (what we already know)
16:03:41 <morgan_orange> #info access to LF POD granted to juha for troubleshooting
16:03:53 <morgan_orange> #info run-tempest to be pushed tomorrow
16:04:21 <morgan_orange> #info push rally results => issue on the API (500 on Tornado) => Rodrigue is investigating
16:04:53 <morgan_orange> #info vIMS Valentin_Orange committed the scripts, integration in progress, maybe an issue of connectivity from the LF Jumphost to the VM created in IMS tenant
16:05:06 <jose_lausuch> regarding this
16:05:12 <jose_lausuch> you can access from your laptop morgan
16:05:19 <jose_lausuch> can you provide me the ssh_config parameteres you have?
16:05:23 <morgan_orange> #info sprint ends 16th of October
16:05:29 <morgan_orange> jose_lausuch: OK I will do
16:05:33 <jose_lausuch> /etc/ssh/ssh_config
16:05:36 <jose_lausuch> thanks
16:05:36 <morgan_orange> maybe tomorrow morning :)
16:05:39 <jose_lausuch> sure
16:05:46 <morgan_orange> are you OK with the remaining task?
16:05:56 <morgan_orange> there are 2 for peter
16:06:00 <morgan_orange> one is more a collective one
16:06:15 <morgan_orange> have a look at ODL tests to select test to integrate into OPNFV
16:06:21 <jose_lausuch> he is not here
16:06:34 <jose_lausuch> regarding the FUNCTEST-49
16:06:38 <morgan_orange> the second one is more to transform current results into jsop so we could push the result into result DB
16:06:50 <jose_lausuch> Its a bit unclear since I dont have any onos deployment to test that
16:07:21 <morgan_orange> is it a Functest issue or a genesis issue?
16:07:31 <jose_lausuch> what do you mean?
16:07:31 <morgan_orange> would we have the controller as a parameter?
16:07:58 <morgan_orange> if I understand well 49 consist to retrieve which SDN controller is deployed?
16:07:58 <jose_lausuch> we can do that
16:08:03 <jose_lausuch> yes
16:08:08 <morgan_orange> so it is an upgrade of fetch creds
16:08:14 <morgan_orange> to retrive SDN controller type?
16:08:28 <jose_lausuch> mmmm do you think it sohuld be in fetch_creds?
16:08:37 <jose_lausuch> why? it has nothing to do with openstack credentials
16:08:39 <morgan_orange> do not know
16:08:50 <morgan_orange> yes you are right
16:08:55 <morgan_orange> not in fetch os creds
16:09:08 <morgan_orange> but a script to duynamically retrieve the SDN on an installed system
16:09:13 <jose_lausuch> I can check for ODL how to see, but for ONOS/OpenContrail still a bit early to say
16:09:29 <morgan_orange> so to test it you need a solution running with OpenContrail and Onos
16:09:38 <jose_lausuch> what do we need that for, btw? to run the SDN-specific tests, right?
16:09:39 <morgan_orange> Onos I think it shall be installed on a Huawei lab
16:09:45 <morgan_orange> but it is not connected to pharos
16:09:45 <jose_lausuch> trigger ONOS, or ODL, or whatever
16:10:08 <morgan_orange> #info we need the info of the SDN controller to perform the accurate test (Functest-49)
16:10:26 <morgan_orange> #info testbed running non ODL alpha Brahmaputra needed
16:10:27 <jose_lausuch> Qinglong_Lan is on vacation and will be back tomorrow
16:10:30 <jose_lausuch> so I will ask him
16:10:46 <morgan_orange> #action  Quiglong find a compatible lab for ONOS
16:10:50 <morgan_orange> and for contrail...
16:11:04 <jose_lausuch> #info remote access to non Huawei folks possible?
16:11:10 <morgan_orange> we were wondering whether we should install a joid-opencontrail in our second lab
16:11:27 <morgan_orange> jose_lausuch: if not possible should find resource able to test...
16:11:42 <morgan_orange> so functest-49 could be delayed until we find a non ODL lab...
16:11:48 <jose_lausuch> ja
16:11:51 <jose_lausuch> if we do that
16:11:59 <jose_lausuch> we can bring the docker user story in this sprint
16:12:01 <morgan_orange> #info functest-49 could be delayed until we find a non ODL lab...
16:12:14 <jose_lausuch> which is almost ready
16:12:41 <morgan_orange> yep I do not know if we can modify the spring during a sprint or if we have to wait the next one
16:12:46 <morgan_orange> anyway
16:12:48 <jose_lausuch> ok
16:12:51 <morgan_orange> does not matter
16:13:06 <morgan_orange> ok so for sprint1 nothing to add?
16:13:17 <jose_lausuch> not from my side
16:13:26 <morgan_orange> maybe save 1 h for Functest-54 and create a wiki page
16:13:40 <morgan_orange> #action morgan_orange initiate wiki page for functest-54
16:13:42 <morgan_orange> ok
16:13:43 <jose_lausuch> odl test suite?
16:13:55 <morgan_orange> the idea here is just to have a look at the existing suites
16:14:04 <morgan_orange> and select which ones we could backport in OPNFV
16:14:11 <jose_lausuch> ok
16:14:16 <morgan_orange> and the task was just dealing with selection
16:14:22 <morgan_orange> we will have to implement after
16:14:24 <jose_lausuch> do we need dfarrell07? :)
16:14:26 <morgan_orange> but a first filter
16:14:40 <morgan_orange> we could initiate the page and ask for his feedback
16:14:57 <morgan_orange> #topic docker
16:15:13 <morgan_orange> #info jose_lausuch made very good progress able to run functest from docker on LF POD2
16:15:27 <jose_lausuch> #info commit here : https://gerrit.opnfv.org/gerrit/#/c/2143/16
16:15:31 <morgan_orange> #info adaptations required but this item of Sprint 3 is not far...
16:15:39 <jose_lausuch> #info 95% ready to merge
16:15:57 <morgan_orange> #info there was a question from valentin about 1 docker versus N dockers
16:16:02 <jose_lausuch> I ran a tests with the latests patch and they succedded
16:16:08 <jose_lausuch> yes
16:16:11 <jose_lausuch> he just left...
16:16:15 <morgan_orange> #info from my perspective one docker is fine => replace current functest running diurectly on the jumphost
16:16:51 <morgan_orange> #info Valentin concern was about the abaility to run a functional test independently from the others
16:17:09 <morgan_orange> #info 1 docker with all the possibl e scenario does not mean we will run them all
16:17:24 <jose_lausuch> #info frommy perspective, 1 docker is fine. We can have different scripts to test the big uses cases, thats fine. But similar dockers with slightly different contents doesn't make much sense for me
16:17:41 <morgan_orange> #info nothing prevent from creating a dedicated docker for a testcase that will be complex
16:18:05 <jose_lausuch> #info if we see a real need we can always create a new one if we need a real isolated system
16:18:06 <morgan_orange> ok we will sent the minutes for review to the project members and will see
16:18:09 <morgan_orange> we both agree :)
16:18:26 <morgan_orange> #topic integration of new testcases "on the fly"
16:18:29 <jose_lausuch> #info the existing docker contains all the packages and libraries that are need for any functest activity
16:18:34 <jose_lausuch> opps
16:18:35 <jose_lausuch> a bit late
16:18:35 <jose_lausuch> hehe
16:18:41 <morgan_orange> np
16:18:55 <jose_lausuch> amaged__: there?
16:18:56 <morgan_orange> #question today on the way to submit test cases to functional testing
16:19:01 <morgan_orange> #undo
16:19:01 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2fd67d0>
16:19:07 <amaged__> jose_lausuch: yes
16:19:08 <morgan_orange> #info question today on the way to submit test cases to functional testing
16:19:16 <morgan_orange> that is a good question
16:19:17 <jose_lausuch> morgan_orange: tempest test cases
16:19:32 <morgan_orange> tempest test cases or even scenario using Openstack API
16:19:32 <jose_lausuch> right amaged__?
16:19:35 <jose_lausuch> thats what you wanted
16:19:43 <amaged__> jose_lausuch: coorect
16:19:46 <jose_lausuch> ok
16:20:09 <jose_lausuch> #info we will have a script for running tempest, the way we run tempest now might change a bit
16:20:12 <morgan_orange> basically today it is difficult to have a good view of the testing ecosystem: what is tested, what are the testcases, is my testcase relevant, how to execute it...
16:20:23 <jose_lausuch> #info possibility to add new python-coded test cases?
16:20:35 <morgan_orange> for tempest tes case, I think the best way is to contibute upstream
16:20:44 <jose_lausuch> I agree
16:20:45 <morgan_orange> directly in tempest
16:20:56 <jose_lausuch> but amaged__ do you want to describe a bit the type of tests you wanted?
16:21:14 <jose_lausuch> to see where they make sense to fit
16:21:32 <jose_lausuch> maybe the upstream comminuty doesnt need that because is too specific? (just thinking loud)
16:21:55 <amaged__> jose_lausuch: failure testing, what if a VNF crashes, will traffic be impacted in a scenario with diff VNFs
16:22:15 <jose_lausuch> #info proposed tempest tests :  failure testing, what if a VNF crashes, will traffic be impacted in a scenario with diff VNFs
16:22:17 <jose_lausuch> thanks
16:22:31 <jose_lausuch> what do you think guys?
16:22:36 <jose_lausuch> is that something for upstream?
16:22:43 <jose_lausuch> or for opnfv?
16:23:22 <morgan_orange> no easy
16:23:52 <jose_lausuch> yep...
16:23:57 <morgan_orange> I think some test projects identified these use cases (bottleneck)
16:23:59 <amaged__> jose_lausuch: rephrasing, tests that are heavily dependent on VNFs behavior
16:24:26 <morgan_orange> I would say that in-VNF related tests have to be discussed with yardstick
16:24:44 <jose_lausuch> yes
16:24:45 <morgan_orange> I think what you mention is one of their use case
16:24:56 <jose_lausuch> just in case we dont do the work twice
16:25:24 <morgan_orange> https://wiki.opnfv.org/candidates_for_test_cases
16:25:32 <jose_lausuch> #action amaged__ contact yardstick (Ana) to see if your proposals are already covered by yardstick framework
16:25:51 <morgan_orange> ana is active on the chan, she will be able to answer
16:26:08 <jose_lausuch> yes
16:26:16 <jose_lausuch> amaged__:  #opnfv-yardstick
16:26:22 <jose_lausuch> maybe tomorrow we can ask her together
16:26:39 <jose_lausuch> or propose it for next yardstick meeting
16:27:34 <morgan_orange> maybe a good first step IRC or mail to the community detailing the testcase
16:27:55 <morgan_orange> that is what I tried to explain in https://wiki.opnfv.org/_media/devtest_journey.pdf
16:28:02 <jose_lausuch> yes
16:28:18 <morgan_orange> #info new testcase => discover through IRC or mailing list
16:28:25 <amaged__> how about tests that might include both VNF and openstack components : what happens to orchestration if compute/DC fails ?
16:28:26 <jose_lausuch> you can info your pdf :)
16:28:47 <morgan_orange> #info landing page for tests: https://wiki.opnfv.org/testing
16:28:53 <jose_lausuch> amaged__: I propose we discuss it together with yardstick
16:29:01 <morgan_orange> #info process proposal in  https://wiki.opnfv.org/_media/devtest_journey.pdf
16:29:05 <jose_lausuch> but in principle its a good idea what you define
16:29:58 <jose_lausuch> what else in the agenda?
16:30:06 <morgan_orange> #topic AoB
16:30:15 <morgan_orange> I got a request from our Chinese contributors
16:30:25 <morgan_orange> even Asian meeting is late for them
16:30:36 <morgan_orange> so we could do it earlier
16:30:49 <jose_lausuch> this time is supposed to fit the Pacific time zone :)
16:30:50 <morgan_orange> when we made the poll, there were no real answers from China
16:30:59 <jose_lausuch> next week will be ok for Asian time ,right?
16:31:13 <morgan_orange> now that we have a real contributor we may adapt to him
16:31:25 <jose_lausuch> anyway, Qinglong_Lan told me that he couldnt join today
16:31:29 <jose_lausuch> and he had no specific things to info
16:31:30 <morgan_orange> next tim was 1PM UTC
16:31:41 <morgan_orange> PM in Beijing
16:32:24 <jose_lausuch> ok
16:32:24 <morgan_orange> what about something like 6 PM China?
16:32:39 <morgan_orange> I have to check but it will be in the morning for us
16:32:42 <morgan_orange> in Europe
16:32:43 <jose_lausuch> they have to answer anyway
16:32:51 <jose_lausuch> morning is fine also
16:32:53 <jose_lausuch> for us
16:32:56 <morgan_orange> Ok I will propse something
16:33:10 <morgan_orange> #info trial to move Asian meeting time earlier
16:33:17 <morgan_orange> #action morgan_orange propose new time
16:33:27 <morgan_orange> we haev also to make some cleaning in the project
16:33:36 <morgan_orange> there are discussions on sleeping contributors
16:33:37 <jose_lausuch> what kind of cleaning?
16:33:40 <jose_lausuch> heheh yes
16:33:44 <morgan_orange> i will send a mail as I used to do
16:33:51 <jose_lausuch> a protocol how to remove commiters
16:34:16 <morgan_orange> #action morgan_orange apply contributor protocol removal for ghost contributors
16:34:29 <jose_lausuch> #info functest repo to be restructured a bit (as suggested by fdegir )
16:34:47 <morgan_orange> #info wiki page refactored (based on yardstick) https://wiki.opnfv.org/opnfv_functional_testing
16:34:53 <morgan_orange> what did he sugges?
16:35:11 <jose_lausuch> some of the things are common
16:35:17 <jose_lausuch> and they shouldnt belong to "testcases"
16:35:22 <jose_lausuch> but we can discuss this further another day
16:35:23 <jose_lausuch> its not urgent
16:35:28 <jose_lausuch> and not critical
16:35:29 <morgan_orange> ok
16:35:46 <morgan_orange> I think I should send a reminder
16:35:56 <morgan_orange> maybe juha and viktor would have joined
16:36:23 <morgan_orange> any question
16:36:25 <morgan_orange> ?
16:36:30 <jose_lausuch> nop
16:36:32 <morgan_orange> enough for today
16:36:37 <morgan_orange> good evening
16:36:39 <morgan_orange> #endmeeting