#opnfv-testperf: Functest weekly meeting May 3rd

Meeting started by morgan_orange at 08:00:14 UTC (full logs).

Meeting summary

  1. role call (morgan_orange, 08:00:21)
    1. Morgan Richomme (morgan_orange, 08:00:26)
    2. Jun Li (MatthewLi, 08:00:40)
    3. CG_Nokia (Colum Gaynor) (CG_Nokia, 08:00:52)
    4. Jose Lausuch (jose_lausuch, 08:00:53)
    5. Juha Haapavirta (JuhaHaapa, 08:01:07)
    6. Luke Hinds (lhinds) (lhinds, 08:01:08)
    7. agenda https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:01:36)

  2. Action points (morgan_orange, 08:02:29)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-04-26-08.03.html (morgan_orange, 08:02:36)
    2. video done and sent to brandon Wick to be referenced in OPNFV youtube channel (morgan_orange, 08:02:54)
    3. AP2: discussion within release manager and by mail, I tried to reach new PTLs by mail, got the support of Uli (for new huawei PTLs) but no feedback so far (morgan_orange, 08:03:45)
    4. AP3: raghavendrachari push code => issue to push code (morgan_orange, 08:05:06)
    5. Juha Kosonen (juhak, 08:05:24)
    6. Viktor Tikkanen (viktor_nokia, 08:05:31)
    7. ACTION: raghavendrachari contact aric or helpdesk to fix git issue (morgan_orange, 08:07:25)
    8. AP4: sync with Cedric, not sure... (morgan_orange, 08:07:52)
    9. AP5: JIRA sprint 7 started, we have a dedicate topic (morgan_orange, 08:08:56)
    10. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (jose_lausuch, 08:09:39)

  3. Brahmaputra 3.0 (morgan_orange, 08:09:43)
    1. Brahmaputra 3.0 has been released last week (before the refactoring doom day) (morgan_orange, 08:09:59)
    2. minor fixes and scenario updates (morgan_orange, 08:10:11)
    3. some scenarios used to be OK on joid but were not more oK, so they were not declared (they could have been in 2.0) (morgan_orange, 08:10:40)
    4. new scenarios: apex/bgpvpn and fuel/bgpvpn, fuel/sfc, fuel/kvm (morgan_orange, 08:11:35)
    5. we are not 100% clean....if we would have followed all our test criteria, we would not have declared the new scenarios (vIMS, Rally, ..) (morgan_orange, 08:12:21)
    6. we should try to be more strict in the future... (morgan_orange, 08:12:58)
    7. summary: brahmaptura 3.0 for Functest = no new feature, just minor fix and new scenarios (morgan_orange, 08:16:25)

  4. git best practice (morgan_orange, 08:16:30)
    1. jose and Cedric initiated a wiki page on git best practice... (morgan_orange, 08:16:45)
    2. rebasing, merging, cherry picking...will have no more secret (morgan_orange, 08:17:02)
    3. best best practices are inherited from OpenStack (morgan_orange, 08:17:19)
    4. https://wiki.opnfv.org/display/functest/git+tutorial (morgan_orange, 08:17:41)

  5. refactoring doom Day (morgan_orange, 08:18:33)
    1. on stable issue (because releng has no branch sowe were calling the stable docker image with command for the refactored master) now fixed with an old but alway efficient if ${{branch}} == brahmaputra ... (morgan_orange, 08:19:49)
    2. refactor almost done, now it's running according to this https://wiki.opnfv.org/download/attachments/2925495/Proposal%20Functest%20Tiers%20Colorado.pptx?api=v2 (jose_lausuch, 08:20:01)
    3. still missing : stopping the tests when something fails (jose_lausuch, 08:20:16)
    4. https://build.opnfv.org/ci/view/functest/ (morgan_orange, 08:20:22)
    5. still missing: add loop type (daily, weekly) for the test cases according to this table https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria (jose_lausuch, 08:20:41)
    6. https://gerrit.opnfv.org/gerrit/#/c/13609/ (jose_lausuch, 08:21:31)
    7. CLI template created : https://gerrit.opnfv.org/gerrit/#/c/13455/ (jose_lausuch, 08:22:43)
    8. target refactoring complete end of the week (morgan_orange, 08:23:03)
    9. ACTION: everyone contributing to the CLI to have a look, review it and start adding the code for the desired commands (jose_lausuch, 08:23:22)
    10. now the commands work but do nothing (jose_lausuch, 08:23:28)
    11. the commands are explained here: https://wiki.opnfv.org/display/functest/Functest+CLI (jose_lausuch, 08:23:48)

  6. Sprint 7 (morgan_orange, 08:24:45)
    1. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&view=planning.nodetail&selectedIssue=FUNCTEST-237 (morgan_orange, 08:25:03)
    2. ACTION: JuhaHaapa CG_Nokia test and adapt user guide (morgan_orange, 08:28:39)
    3. as a reminder the Sprint is a 3 weeks sprint (morgan_orange, 08:30:44)
    4. for our internal dev in Colorado, we will have only 2 sprints... (morgan_orange, 08:31:07)
    5. feature freeze end of May ... test freeze is later as it depends on the feature/installers/scenarios/... (morgan_orange, 08:31:33)
    6. ACTION: morgan_orange create JIRA for user guide review (after refactoring) (morgan_orange, 08:37:07)
    7. ACTION: morgan_orange reask questions for access to LF PODs for juhak and viktor_nokia (morgan_orange, 08:37:50)
    8. Nokia lab is now available for e.g. functest related testing (see details at https://wiki.opnfv.org/display/pharos/Nokia+Hosting) (morgan_orange, 08:38:21)

  7. Berlin Design Summit (morgan_orange, 08:39:32)
    1. https://wiki.opnfv.org/display/EVNT/Proposals+for+Berlin+Design+Summit+Session (morgan_orange, 08:39:37)
    2. https://wiki.opnfv.org/display/EVNT/Berlin+Design+Summit+Planning (morgan_orange, 08:39:47)
    3. schedule to be announced by the end of the week (jose_lausuch, 08:43:25)
    4. CFP notification initially planned on the 25th are expecting for the end of this week (morgan_orange, 08:44:08)
    5. ACTION: morgan_orange ask ray if possible to change time to have functest and carrier grade session not in // (morgan_orange, 08:47:47)
    6. possible session proposals for design summit: Functest tutorial, Test API evolution, ELK tutorial, Open Source VNFs, fear sharing of CI time, CI organization, .. (morgan_orange, 08:54:02)
    7. possible session proposals (suite): dashboards, security testing, (morgan_orange, 08:55:27)
    8. ACTION: jose_lausuch session on tutorial for Design Summit (morgan_orange, 08:56:30)
    9. ACTION: serena-zte: lhinds jlinkes__ see if possible to manage a session for design summit (morgan_orange, 08:57:27)
    10. ACTION: morgan_orange see with fdegir ofr proposal on git/jira best practice for design summit (morgan_orange, 08:59:38)

  8. AoB (morgan_orange, 08:59:58)


Meeting ended at 09:03:44 UTC (full logs).

Action items

  1. raghavendrachari contact aric or helpdesk to fix git issue
  2. everyone contributing to the CLI to have a look, review it and start adding the code for the desired commands
  3. JuhaHaapa CG_Nokia test and adapt user guide
  4. morgan_orange create JIRA for user guide review (after refactoring)
  5. morgan_orange reask questions for access to LF PODs for juhak and viktor_nokia
  6. morgan_orange ask ray if possible to change time to have functest and carrier grade session not in //
  7. jose_lausuch session on tutorial for Design Summit
  8. serena-zte: lhinds jlinkes__ see if possible to manage a session for design summit
  9. morgan_orange see with fdegir ofr proposal on git/jira best practice for design summit


Action items, by person

  1. CG_Nokia
    1. JuhaHaapa CG_Nokia test and adapt user guide
  2. jose_lausuch
    1. jose_lausuch session on tutorial for Design Summit
  3. JuhaHaapa
    1. JuhaHaapa CG_Nokia test and adapt user guide
  4. juhak
    1. morgan_orange reask questions for access to LF PODs for juhak and viktor_nokia
  5. lhinds
    1. serena-zte: lhinds jlinkes__ see if possible to manage a session for design summit
  6. morgan_orange
    1. morgan_orange create JIRA for user guide review (after refactoring)
    2. morgan_orange reask questions for access to LF PODs for juhak and viktor_nokia
    3. morgan_orange ask ray if possible to change time to have functest and carrier grade session not in //
    4. morgan_orange see with fdegir ofr proposal on git/jira best practice for design summit
  7. raghavendrachari
    1. raghavendrachari contact aric or helpdesk to fix git issue
  8. serena-zte
    1. serena-zte: lhinds jlinkes__ see if possible to manage a session for design summit
  9. viktor_nokia
    1. morgan_orange reask questions for access to LF PODs for juhak and viktor_nokia


People present (lines said)

  1. morgan_orange (137)
  2. jose_lausuch (71)
  3. lhinds (10)
  4. JuhaHaapa (9)
  5. raghavendrachari (9)
  6. collabot` (6)
  7. serena-zte (4)
  8. MatthewLi (4)
  9. CG_Nokia (4)
  10. viktor_nokia (4)
  11. juhak (1)


Generated by MeetBot 0.1.4.