08:00:14 <morgan_orange> #startmeeting Functest weekly meeting May 3rd
08:00:14 <collabot`> Meeting started Tue May  3 08:00:14 2016 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:14 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:14 <collabot`> The meeting name has been set to 'functest_weekly_meeting_may_3rd'
08:00:21 <morgan_orange> #topic role call
08:00:26 <morgan_orange> #info Morgan Richomme
08:00:40 <MatthewLi> #info Jun Li
08:00:52 <CG_Nokia> #info CG_Nokia (Colum Gaynor)
08:00:53 <jose_lausuch> #info Jose Lausuch
08:01:00 <morgan_orange> #chair jose_lausuch
08:01:00 <collabot`> Current chairs: jose_lausuch morgan_orange
08:01:07 <JuhaHaapa> #info Juha Haapavirta
08:01:08 <lhinds> #info Luke Hinds (lhinds)
08:01:17 <morgan_orange> #chair JuhaHaapa
08:01:17 <collabot`> Current chairs: JuhaHaapa jose_lausuch morgan_orange
08:01:36 <morgan_orange> #info agenda https://wiki.opnfv.org/display/functest/Functest+Meeting
08:01:42 <JuhaHaapa> what?
08:01:50 <JuhaHaapa> chair?
08:02:03 <morgan_orange> if you want to type notes in the minutes
08:02:11 <morgan_orange> do not worry no extra money
08:02:13 <morgan_orange> :)
08:02:16 <JuhaHaapa> :)
08:02:29 <morgan_orange> #topic Action points
08:02:36 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-04-26-08.03.html
08:02:54 <morgan_orange> #info video done and sent to brandon Wick to be referenced in OPNFV youtube channel
08:03:26 <jose_lausuch> nice
08:03:38 <jose_lausuch> thanks for that
08:03:44 <MatthewLi> morgan_orange: can u give the youtube channel link?
08:03:45 <morgan_orange> #info AP2: discussion within release manager and by mail, I tried to reach new PTLs by mail, got the support of Uli (for new huawei PTLs) but no feedback so far
08:04:19 <jose_lausuch> MatthewLi: https://www.youtube.com/channel/UC3EjXLJbub0tPFpnI3vEmYg
08:04:25 <MatthewLi> thank u
08:04:25 <jose_lausuch> it's not yet there
08:04:42 <morgan_orange> yep sent the link yesterday, just got the ACK from brandon
08:05:06 <morgan_orange> #info AP3: raghavendrachari push code => issue to push code
08:05:12 <morgan_orange> raghavendrachari: did you solve the issue
08:05:20 <MatthewLi> what I mean is that do we have an unit opnfv channel for vedios?
08:05:22 <morgan_orange> we cannot rely on proxy, we must solve the issue
08:05:24 <juhak> #info Juha Kosonen
08:05:26 <raghavendrachari> no morgon
08:05:31 <viktor_nokia> #info Viktor Tikkanen
08:05:37 <raghavendrachari> am getting issue while uploading to gerrit
08:05:40 <morgan_orange> raghavendrachari: how can we help you
08:05:50 <raghavendrachari> might be ssl issue i think
08:06:02 <morgan_orange> ok maybe a known issue, did you contact aric
08:06:08 <morgan_orange> there is an operation to be done
08:06:22 <raghavendrachari> no
08:06:35 <raghavendrachari> could u please sned me the details i'll contact
08:06:38 <morgan_orange> please contact aricg on opnfv-meeting chan (or any chan), he will guide you
08:06:45 <raghavendrachari> ok
08:07:06 <morgan_orange> or send a mail to opnfv-helpdesk@rt.linuxfoundation.org
08:07:25 <morgan_orange> #action raghavendrachari contact aric or helpdesk to fix git issue
08:07:26 <raghavendrachari> ok sure
08:07:52 <morgan_orange> #info AP4: sync with Cedric, not sure...
08:08:31 <morgan_orange> raghavendrachari: you can either see on this chan ollivier (but not here right now) or contact him by mail cedric.ollivier AT orange.com
08:08:49 <raghavendrachari> ok
08:08:56 <morgan_orange> #info AP5: JIRA sprint 7 started, we have a dedicate topic
08:08:59 <jose_lausuch> raghavendrachari: let's try to fix that asap so that you can push code to gerrit and do reviews as well :)
08:09:14 <raghavendrachari> yeah
08:09:30 <morgan_orange> #chair viktor_nokia
08:09:30 <collabot`> Current chairs: JuhaHaapa jose_lausuch morgan_orange viktor_nokia
08:09:39 <jose_lausuch> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59
08:09:43 <morgan_orange> #topic Brahmaputra 3.0
08:09:59 <morgan_orange> #info Brahmaputra 3.0 has been released last week (before the refactoring doom day)
08:10:11 <morgan_orange> #info minor fixes and scenario updates
08:10:14 <jose_lausuch> the refactor doom is not yet 100% ok :)
08:10:40 <morgan_orange> #info some scenarios used to be OK on joid but were not more oK, so they were not declared (they could have been in 2.0)
08:11:35 <morgan_orange> #info new scenarios: apex/bgpvpn and fuel/bgpvpn, fuel/sfc, fuel/kvm
08:12:21 <morgan_orange> #info we are not 100% clean....if we would have followed all our test criteria, we would not have declared the new scenarios (vIMS, Rally, ..)
08:12:58 <morgan_orange> #info we should try to be more strict in the future...
08:13:05 <jose_lausuch> we tried already
08:13:11 <jose_lausuch> I hope we become majority for colorado
08:13:15 <jose_lausuch> when it comes to criteria :)
08:14:02 <morgan_orange> yep but here for instance, we could have decide to to nothing and add no scenario for Functest but it would have been a little bit unfear for the contributors on the new scenarios as some errors could be our errors...
08:14:29 <morgan_orange> at the ned I consider vpings, tempest and feature projects
08:15:06 <morgan_orange> we should have probably decide it during the weekly meeting, but it was done very late and we were focused on colorado
08:15:25 <morgan_orange> we will also have to deal with multi versions in the future, which is not always trivial
08:15:44 <morgan_orange> anyway let's say that brahmaptura 3.0 = no new feature, just minor fix and new scenarios
08:16:16 <morgan_orange> #summary: brahmaptura 3.0 for Functest = no new feature, just minor fix and new scenarios
08:16:25 <morgan_orange> #info summary: brahmaptura 3.0 for Functest = no new feature, just minor fix and new scenarios
08:16:30 <morgan_orange> #topic git best practice
08:16:45 <morgan_orange> #info jose and Cedric initiated a wiki page on git best practice...
08:17:02 <morgan_orange> #info rebasing, merging, cherry picking...will have no more secret
08:17:19 <morgan_orange> #info best best practices are inherited from OpenStack
08:17:41 <morgan_orange> #link https://wiki.opnfv.org/display/functest/git+tutorial
08:17:45 <jose_lausuch> yes
08:18:00 <morgan_orange> I like the merge conflicts TBD ... :)
08:18:05 <jose_lausuch> I created so that all of us follow the same procedure
08:18:10 <jose_lausuch> haha
08:18:16 <jose_lausuch> I'd put something when I have time
08:18:22 <jose_lausuch> merge conflicts are tricky
08:18:33 <morgan_orange> #topic refactoring doom Day
08:18:41 <jose_lausuch> haha I like the title
08:18:47 <jose_lausuch> Doom week
08:18:54 <morgan_orange> jose_lausuch: could you give the last status on master
08:19:25 <jose_lausuch> yes
08:19:49 <morgan_orange> #info on stable issue (because releng has no branch sowe were calling the stable docker image with command for the refactored master) now fixed with an old but alway efficient if ${{branch}} == brahmaputra ...
08:20:01 <jose_lausuch> #info refactor almost done, now it's running according to this  https://wiki.opnfv.org/download/attachments/2925495/Proposal%20Functest%20Tiers%20Colorado.pptx?api=v2
08:20:16 <jose_lausuch> #info still missing : stopping the tests when something fails
08:20:22 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/
08:20:41 <jose_lausuch> #info still missing: add loop type (daily, weekly) for the test cases according to this table https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria
08:21:10 <jose_lausuch> and I won't info this but there was a big mistake
08:21:30 <jose_lausuch> the script was calculating all the test cases to be executed but it wasn't executing them :)
08:21:31 <jose_lausuch> https://gerrit.opnfv.org/gerrit/#/c/13609/
08:21:55 <morgan_orange> last run https://build.opnfv.org/ci/view/functest/job/functest-fuel-opnfv-jump-2-daily-master/lastFailedBuild/console
08:22:06 <jose_lausuch> yes,
08:22:10 <jose_lausuch> and now the failure is in push results
08:22:17 <jose_lausuch> but maybe because there are no results at all
08:22:20 <jose_lausuch> just empty directories
08:22:40 <morgan_orange> I can have a look at that
08:22:43 <jose_lausuch> #info CLI template created : https://gerrit.opnfv.org/gerrit/#/c/13455/
08:23:03 <morgan_orange> #info target refactoring complete end of the week
08:23:22 <jose_lausuch> #action everyone contributing to the CLI to have a look, review it and start adding the code for the desired commands
08:23:28 <jose_lausuch> #info now the commands work but do nothing
08:23:48 <jose_lausuch> #info the commands are explained here:  https://wiki.opnfv.org/display/functest/Functest+CLI
08:23:59 <morgan_orange> any question on the refactoring?
08:24:45 <morgan_orange> #topic Sprint 7
08:24:54 <jose_lausuch> I will modify the developer guide
08:25:03 <morgan_orange> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&view=planning.nodetail&selectedIssue=FUNCTEST-237
08:25:24 <jose_lausuch> this view is also nice https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59
08:25:25 <morgan_orange> jose_lausuch: would it make sense to action someone else for the modification of the user guide...to have a fresh look
08:25:47 <jose_lausuch> morgan_orange: it would help me a lot, yes
08:25:47 <morgan_orange> and someone testing the docker management post refactoring?
08:26:41 <morgan_orange> JuhaHaapa: CG_Nokia would it be possible to action you for that (idea is to test the new behavior of the container and adapt the documentation)
08:27:05 <morgan_orange> with our support of course, but it would be interesting to have a new look on the documentation
08:27:35 <morgan_orange> the idea would be to get the latest version of the docker file in your lab and just report what is clear/unclear and adapt the rst file
08:27:41 <jose_lausuch> what docker management post refactoring?
08:28:00 <jose_lausuch> ok
08:28:21 <JuhaHaapa> We would need great deal of help and guidance but why not
08:28:39 <morgan_orange> #action JuhaHaapa CG_Nokia test and adapt user guide
08:28:45 <morgan_orange> thanks
08:28:46 <CG_Nokia> Back from vacation but we can try to see if we understand the needed work
08:28:47 <jose_lausuch> JuhaHaapa: sure, you'll have it, and also its a good way to test on another environment
08:29:22 <morgan_orange> and to see if we are only 5 to understand the user guide... :)
08:29:23 <JuhaHaapa> Should that work on nested virt env also?
08:29:32 <morgan_orange> yes
08:29:44 <morgan_orange> and if not we should add a section
08:30:17 <morgan_orange> ok back on JIRA, any question/concern/remark/criticism on the allocation
08:30:20 <jose_lausuch> JuhaHaapa: in theory yes
08:30:44 <morgan_orange> #info as a reminder the Sprint is a 3 weeks sprint
08:31:07 <morgan_orange> #info for our internal dev in Colorado, we will have only 2 sprints...
08:31:33 <morgan_orange> #info feature freeze end of May ... test freeze is later as it depends on the feature/installers/scenarios/...
08:31:39 <morgan_orange> but it is relativelly short..
08:31:40 <jose_lausuch> can you info the code freeze date?
08:31:44 <jose_lausuch> ok
08:31:57 <jose_lausuch> it is short but we don't have many many things
08:32:50 <morgan_orange> so everybody is confident with the allocated tasks...
08:33:17 <CG_Nokia> Hmmmm...
08:33:20 <morgan_orange> lhinds: I commented your Jira for lab access, did you create one on Pharos
08:33:44 <morgan_orange> JuhaHaapa: CG_Nokia, I will create a new JIRA for user guide review & update :)
08:33:47 <lhinds> morgan_orange, thanks for that. Trevor got back so opening a jira..just getting my GPG set up
08:34:05 <lhinds> so I can get the auth details
08:34:29 <morgan_orange> lhinds: ok cool, and if needed as discussed by mail, it is possible to grant you an access on orange POD 2
08:34:49 <lhinds> thanks morgan_orange , remind me which installer is on there? I think its fuel?
08:34:53 <JuhaHaapa> morgan_orange: OK. try inserting TOO much details in it :)
08:35:12 <morgan_orange> viktor_nokia: juhak jose_lausuch I would like to retry to get an access for juha and viktor to LF PODs... (as they are committers now), it gives access to 2 CI PODs..
08:35:29 <morgan_orange> lhinds: Orange POD 2 = joid
08:35:42 <morgan_orange> + odl_l2-nofeature-ha (at the moment)
08:35:43 <lhinds> morgan_orange, that will be useful too
08:35:52 <jose_lausuch> it would be useful
08:35:55 <lhinds> morgan_orange, will get back to you there
08:35:58 <morgan_orange> lhinds: ok so send me your ssh public key
08:36:05 <lhinds> will do
08:36:06 <morgan_orange> I will grant you an access on the jumphost
08:36:28 <morgan_orange> lhinds: a new contributor from orange could probably help you on security issue
08:37:07 <morgan_orange> #action morgan_orange create JIRA for user guide review (after refactoring)
08:37:29 <lhinds> morgan_orange, sounds great..very happy to have others involved
08:37:49 <viktor_nokia> BTW, nokia lab is now available for e.g. functest related testing (see details at https://wiki.opnfv.org/display/pharos/Nokia+Hosting)
08:37:50 <morgan_orange> #action morgan_orange reask questions for access to LF PODs for juhak and viktor_nokia
08:38:12 <morgan_orange> viktor_nokia:  good news, we can info that..
08:38:21 <morgan_orange> #info Nokia lab is now available for e.g. functest related testing (see details at https://wiki.opnfv.org/display/pharos/Nokia+Hosting)
08:38:56 <morgan_orange> ok if no more question on Jira, we can jump to next topic
08:39:32 <morgan_orange> #topic Berlin Design Summit
08:39:37 <morgan_orange> #link https://wiki.opnfv.org/display/EVNT/Proposals+for+Berlin+Design+Summit+Session
08:39:47 <morgan_orange> #link https://wiki.opnfv.org/display/EVNT/Berlin+Design+Summit+Planning
08:40:07 <morgan_orange> question 1: Who will be in berlin for the Design Summit (June 20-21th)
08:40:20 <morgan_orange> I will be there
08:40:25 <jose_lausuch> me too
08:40:34 <jose_lausuch> hotel already booked :)
08:40:43 <viktor_nokia> I will
08:41:00 <JuhaHaapa> Nokia travel approvals should be in place by end of August normally
08:41:03 <JuhaHaapa> :)
08:41:06 <morgan_orange> same for me but not the one of the conf (too expensive for a little European telco company)
08:41:21 <serena-zte> I will be there
08:41:28 <jose_lausuch> not the one of the conf?
08:41:59 <morgan_orange> my hotel is not the recommended one but it is very closed to it
08:42:07 <jose_lausuch> ah ok
08:42:10 <jose_lausuch> hehe
08:42:45 <morgan_orange> so back to the 2 pages initiated by Ray
08:43:22 <viktor_nokia> what is the status of CFPs, are the accepted presentations visible somewhere?
08:43:25 <jose_lausuch> #info schedule to be announced by the end of the week
08:43:33 <jose_lausuch> hopefully
08:43:34 <morgan_orange> First sessions has been set, I am a bit surprised by some topics (which look more like session of the show)
08:44:08 <morgan_orange> #info CFP notification initially planned on the 25th are expecting for the end of this week
08:44:23 <morgan_orange> we have already a session for Functest
08:44:36 <morgan_orange> 11:15-11:45 => OPNFV Functest From Brahmaputra to C release: many rivers to cross…
08:44:49 <morgan_orange> with Jimmy Jose Cliff
08:45:26 <jose_lausuch> yes
08:45:27 <morgan_orange> I will ask Ray if it is possible not to put Carrier-Grade OpenStack performance benchmarking for NFV deployments in //
08:45:41 <jose_lausuch> it would be a pitty
08:45:44 <morgan_orange> as it is probably more interesting for us than Dynamic Services for the Digital Economy and Hyper-connected World
08:45:44 <jose_lausuch> since both are interesting for us
08:46:45 <morgan_orange> shall we propose a session on the Test API (Serena) or ELK (Juraj)?
08:47:03 <morgan_orange> a perspective session on open source VNFs?
08:47:31 <serena-zte> you mean show something on the summit?
08:47:43 <jose_lausuch> can we put more sessions?
08:47:47 <morgan_orange> #action morgan_orange ask ray if possible to change time to have functest and carrier grade session not in //
08:47:59 <morgan_orange> precisions
08:48:04 <morgan_orange> the design summit
08:48:12 <morgan_orange> is something different from the OPNFV summit
08:48:20 <jose_lausuch> ok
08:48:32 <morgan_orange> the design summit is for the developers/contributors, it is much more informal
08:48:41 <morgan_orange> the OPNFV summit is a communication exercice
08:49:45 <serena-zte> If we propose a session on Test API, what should we do?
08:50:10 <morgan_orange> expose what we want to do, why, the possible alternatives
08:50:36 <morgan_orange> it is the occasion to collect direct feedback (as this APi can be used by Functest and other projects)
08:51:40 <morgan_orange> I would also suggest a tutorial session
08:52:01 <morgan_orange> my understanding => proposals must be declared here https://wiki.opnfv.org/display/EVNT/Proposals+for+Berlin+Design+Summit+Session
08:52:33 <morgan_orange> then there is a selection that goes https://wiki.opnfv.org/display/EVNT/Berlin+Design+Summit+Planning
08:53:09 <morgan_orange> I will info possible session, (depends on people if they want to manage them or not)
08:53:30 <jose_lausuch> I see a lot of blanks
08:53:32 <jose_lausuch> to be filled
08:53:33 <jose_lausuch> right?
08:54:02 <morgan_orange> #info possible session proposals for design summit: Functest tutorial, Test API evolution, ELK tutorial, Open Source VNFs, fear sharing of CI time, CI organization, ..
08:54:23 <morgan_orange> jose_lausuch: yes but it is usual..last minute completion :)
08:54:38 <morgan_orange> lhinds: a topic on security testing?
08:54:44 <jose_lausuch> maybe something about dashboards
08:55:02 <serena-zte> maybe we can, still some time left, we can make some preparation for it
08:55:05 <lhinds> morgan_orange, not much to update, been out of action with Austin and public holiday
08:55:16 <lhinds> next steps are to get it working in lab, should have more next week
08:55:27 <morgan_orange> #info possible session proposals (suite): dashboards, security testing,
08:55:31 <morgan_orange> lhinds: no problem
08:55:38 <morgan_orange> it is just a list for the moment
08:55:54 <jose_lausuch> I can also add a functest tutorial (new CLI, new refactor, etc)
08:56:03 <morgan_orange> the idea is to share with as many contributors as possible
08:56:04 <jose_lausuch> so, what you proposed, I volunteer
08:56:30 <morgan_orange> #action jose_lausuch session on tutorial for Design Summit
08:56:57 <jose_lausuch> I already recorded a video for brahmaputra
08:57:01 <jose_lausuch> worst case I play it :D
08:57:25 <CG_Nokia> You had cool music!
08:57:27 <morgan_orange> #action serena-zte: lhinds jlinkes__ see if possible to manage a session for design summit
08:57:53 <morgan_orange> we may also share our best practices git and jira?
08:58:38 <jose_lausuch> haha
08:58:49 <morgan_orange> a slot for our discussion with Rally (boris-42) if Rally contributors planned to attend (post Austin and prior to barcelona)
08:58:54 <jose_lausuch> morgan_orange: we could, or leave it for fatih :p
08:59:38 <morgan_orange> #action morgan_orange see with fdegir ofr proposal on git/jira best practice for design summit
08:59:50 <morgan_orange> ok
08:59:53 <morgan_orange> it is already time
08:59:56 <jose_lausuch> yes
08:59:58 <morgan_orange> #topic AoB
09:00:30 <morgan_orange> any information you want to share/discuss, put in the agenda for next week (I will attend the plugfest so jose and Viktor will be the Master of Ceremony)
09:00:46 <jose_lausuch> ok
09:00:49 <jose_lausuch> oh, its next week
09:01:20 <jose_lausuch> viktor_nokia: we'll lead this, big power, big responsability :D
09:02:28 <morgan_orange> so big...
09:02:32 <morgan_orange> last word
09:03:03 <jose_lausuch> nope
09:03:05 <morgan_orange> any feedback from Texas? Luke attended OpenStack Summit, I saw Heather singing in a karaoke, any other smashing news?
09:03:42 <morgan_orange> Thanks for attending
09:03:44 <morgan_orange> #endmeeting