#opnfv-testperf: Functest weekly meeting May 17th

Meeting started by morgan_orange at 08:00:02 UTC (full logs).

Meeting summary

    1. Jose Lauushc (jose_lausuch, 08:00:12)

  1. call roll (morgan_orange, 08:00:12)
    1. Morgan Richomme (morgan_orange, 08:00:17)
    2. Viktor Tikkanen (viktor_nokia, 08:00:19)
    3. Juha Kosonen (juhak, 08:00:20)
    4. SerenaFeng (SerenaFeng, 08:00:22)
    5. CG_Nokia (ColumGaynor) (CG_Nokia, 08:00:33)
    6. agenda: https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:00:39)

  2. Action Point Follow up (morgan_orange, 08:00:52)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-05-10-08.00.html (morgan_orange, 08:01:00)
    2. Action Point #1: viktor_nokia jose_lausuch troubleshoot healthcheck, instances don't get an IP on Nokia's POD with ODL (morgan_orange, 08:01:16)
    3. May (May-meimei, 08:01:21)
    4. healthcheck problems were investigated together with Apex experts (viktor_nokia, 08:01:59)
    5. lhinds (lhinds, 08:02:16)
    6. seems that flow creation takes too long time (minutes) (viktor_nokia, 08:02:21)
    7. Action Point #2: Viktor_nokia remove duplicated/obsolete files in the repo (morgan_orange, 08:04:09)
    8. done (morgan_orange, 08:04:29)

  3. Plugfest summary (morgan_orange, 08:04:50)
    1. Plugfest took place last week in Colorado (Cable Labs) (morgan_orange, 08:05:07)
    2. main participants: Huawei, Intel, China Mobile, Windriver, Canonical, Redhat, EMC, Arm, Linux Foundation, Orange (morgan_orange, 08:05:37)
    3. plugfest: functest run successfully towards the different systems (morgan_orange, 08:05:46)
    4. tests done over 2 local clusters Intel & Huawei (morgan_orange, 08:05:51)
    5. several config tested (morgan_orange, 08:05:56)
    6. on huawei: fuel-onos, compass-nosdn (morgan_orange, 08:06:02)
    7. on Intel: mirantis fuel-nosdn, windriver, apex-nosdn (morgan_orange, 08:06:08)
    8. tests also done on remote cengn joid/nosdn lab (morgan_orange, 08:06:16)
    9. results stored in plugfest DB (morgan_orange, 08:06:21)
    10. some logs shared (morgan_orange, 08:06:29)
    11. globally adaptation of Brahamputra functest for the plugfest was simple (morgan_orange, 08:06:36)
    12. thanks to José and David late support (morgan_orange, 08:06:45)
    13. Functest, yardstick and storperf were introduced to the participants (morgan_orange, 08:07:04)
    14. http://plugfest.opnfv.org/testapi/results (morgan_orange, 08:07:23)
    15. next plugfest planned in France beginning of December for Colorado (morgan_orange, 08:10:39)
    16. we can see 4 types of activities during such plugfest (at least in #1) (morgan_orange, 08:10:59)
    17. knowledge sharing on testing (morgan_orange, 08:11:07)
    18. VNF testing (morgan_orange, 08:11:11)
    19. install party (morgan_orange, 08:11:16)
    20. interco/interop testing (morgan_orange, 08:11:26)

  4. Sprint #7 follow-up (morgan_orange, 08:16:24)
    1. we are almost at the end of Sprint 7 (Sprint 8 to be started this week) (morgan_orange, 08:16:40)
    2. refactoring completed (morgan_orange, 08:16:48)
    3. CI run back to nominal (morgan_orange, 08:16:57)
    4. Test API swagger integration also almost ready (morgan_orange, 08:17:20)
    5. CLI completed (jose_lausuch, 08:17:39)
    6. ACTION: morgan_orange ask fdegir if we could add pep8 check on releng (useful for the test API) (morgan_orange, 08:24:02)
    7. http://postimg.org/image/hk7eleakx/20683b3d/ (morgan_orange, 08:24:06)
    8. ACTION: viktor_nokia increase timeout value for healthcheck (morgan_orange, 08:40:59)
    9. ACTION: viktor_nokia create Jira on Apex regarding the timeout issue in healthcheck test (morgan_orange, 08:41:15)
    10. question on security_groups tests (morgan_orange, 08:46:27)
    11. resource issue on David side, 2 options => someone volunteer to replace David, or move it ro D release (morgan_orange, 08:46:57)
    12. https://gist.github.com/davidblaisonneau-orange/bb74fb1a9d4a87552fc2cdf68608f69f (jose_lausuch, 08:47:44)
    13. ACTION: lhinds sync with David for secrurity_group test cases (morgan_orange, 08:47:51)
    14. https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria (morgan_orange, 08:48:20)
    15. ACTION: morgan_orange jose_lausuch answer lhinds mail (how to retrieve dynamically IP for security test) (morgan_orange, 08:55:32)
    16. ACTION: morgan_orange add security test in test Criteria page (morgan_orange, 08:55:46)

  5. Berlin Summit (morgan_orange, 08:58:53)
    1. progams has been announced (morgan_orange, 08:59:07)
    2. several presentation to be planned (for the Design and the Summit) (morgan_orange, 08:59:26)
    3. ACTION: morgan_orange check the Functest related pres and see with involved people (morgan_orange, 08:59:53)
    4. Functesters in Berlin: lhinds, jose_lausuch SerenaFeng raghavendrachari viktor_nokia ollivier morgan_orange ... (morgan_orange, 09:01:11)

  6. AoB (morgan_orange, 09:01:16)
    1. http://testresults.opnfv.org/reporting/index-tempest-apex.html (morgan_orange, 09:02:31)
    2. question on the opportunity to put the Tempest failed case in the results pushed to the DB (morgan_orange, 09:04:10)


Meeting ended at 09:10:07 UTC (full logs).

Action items

  1. morgan_orange ask fdegir if we could add pep8 check on releng (useful for the test API)
  2. viktor_nokia increase timeout value for healthcheck
  3. viktor_nokia create Jira on Apex regarding the timeout issue in healthcheck test
  4. lhinds sync with David for secrurity_group test cases
  5. morgan_orange jose_lausuch answer lhinds mail (how to retrieve dynamically IP for security test)
  6. morgan_orange add security test in test Criteria page
  7. morgan_orange check the Functest related pres and see with involved people


Action items, by person

  1. jose_lausuch
    1. morgan_orange jose_lausuch answer lhinds mail (how to retrieve dynamically IP for security test)
  2. lhinds
    1. lhinds sync with David for secrurity_group test cases
    2. morgan_orange jose_lausuch answer lhinds mail (how to retrieve dynamically IP for security test)
  3. morgan_orange
    1. morgan_orange ask fdegir if we could add pep8 check on releng (useful for the test API)
    2. morgan_orange jose_lausuch answer lhinds mail (how to retrieve dynamically IP for security test)
    3. morgan_orange add security test in test Criteria page
    4. morgan_orange check the Functest related pres and see with involved people
  4. viktor_nokia
    1. viktor_nokia increase timeout value for healthcheck
    2. viktor_nokia create Jira on Apex regarding the timeout issue in healthcheck test


People present (lines said)

  1. morgan_orange (151)
  2. jose_lausuch (95)
  3. SerenaFeng (32)
  4. viktor_nokia (29)
  5. lhinds (14)
  6. collabot` (3)
  7. raghavendrachari (2)
  8. CG_Nokia (2)
  9. juhak (1)
  10. May-meimei (1)


Generated by MeetBot 0.1.4.