08:00:02 <morgan_orange> #startmeeting Functest weekly meeting May 17th
08:00:02 <collabot`> Meeting started Tue May 17 08:00:02 2016 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:02 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:02 <collabot`> The meeting name has been set to 'functest_weekly_meeting_may_17th'
08:00:12 <jose_lausuch> #info Jose Lauushc
08:00:12 <morgan_orange> #topic call roll
08:00:17 <morgan_orange> #info Morgan Richomme
08:00:19 <viktor_nokia> #info Viktor Tikkanen
08:00:20 <juhak> #info Juha Kosonen
08:00:22 <SerenaFeng> #info SerenaFeng
08:00:33 <CG_Nokia> #info CG_Nokia (ColumGaynor)
08:00:39 <morgan_orange> #info agenda: https://wiki.opnfv.org/display/functest/Functest+Meeting
08:00:52 <morgan_orange> #topic Action Point Follow up
08:01:00 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-05-10-08.00.html
08:01:16 <morgan_orange> #info Action Point #1: viktor_nokia jose_lausuch troubleshoot healthcheck, instances don't get an IP on Nokia's POD with ODL
08:01:21 <May-meimei> #info May
08:01:59 <viktor_nokia> #info healthcheck problems were investigated together with Apex experts
08:02:15 <jose_lausuch> it seems to be an OLD thingy
08:02:16 <lhinds> #info lhinds
08:02:21 <viktor_nokia> #info seems that flow creation takes too long time (minutes)
08:02:32 <jose_lausuch> email from Jamo?
08:03:03 <viktor_nokia> Jamo referenced some old bugs but this is probably different one
08:03:24 <jose_lausuch> ok
08:04:09 <morgan_orange> #info Action Point #2: Viktor_nokia remove duplicated/obsolete files in the repo
08:04:25 <viktor_nokia> done
08:04:29 <morgan_orange> #info done
08:04:50 <morgan_orange> #topic Plugfest summary
08:05:07 <morgan_orange> #info Plugfest took place last week in Colorado (Cable Labs)
08:05:37 <morgan_orange> #info main participants: Huawei, Intel, China Mobile, Windriver, Canonical, Redhat, EMC, Arm, Linux Foundation, Orange
08:05:46 <morgan_orange> #info plugfest: functest run successfully towards the different systems
08:05:47 <jose_lausuch> great success right ?
08:05:51 <morgan_orange> #info tests done over 2 local clusters Intel & Huawei
08:05:56 <morgan_orange> #info several config tested
08:06:02 <morgan_orange> #info on huawei: fuel-onos, compass-nosdn
08:06:07 <jose_lausuch> it was nice helping until late hours in europe :p
08:06:08 <morgan_orange> #info on Intel: mirantis fuel-nosdn, windriver, apex-nosdn
08:06:16 <morgan_orange> #info tests also done on remote cengn joid/nosdn lab
08:06:21 <morgan_orange> #info results stored in plugfest DB
08:06:29 <morgan_orange> #info some logs shared
08:06:36 <morgan_orange> #info globally adaptation of Brahamputra functest for the plugfest was simple
08:06:45 <morgan_orange> #info thanks to José and David late support
08:07:01 <jose_lausuch> can you share the results url?
08:07:04 <morgan_orange> #info Functest, yardstick and storperf were introduced to the participants
08:07:23 <morgan_orange> #link http://plugfest.opnfv.org/testapi/results
08:07:35 <morgan_orange> results are anonymzed (except cengn)
08:08:02 <morgan_orange> test successfully run on Apex but not stored in DB and no time to relaunch them befor leaving
08:08:15 <jose_lausuch> nice
08:08:17 <morgan_orange> but everything in place on Intel local POD (a bay they brought to cable labs)
08:08:29 <jose_lausuch> was there any orange box?
08:08:35 <morgan_orange> note that tests were done on a pure fuel/mirantis and on windriver
08:08:39 <jose_lausuch> with NUCs?
08:08:43 <morgan_orange> no orange box
08:09:08 <morgan_orange> only 1 guy from Ericsson the first day
08:09:14 <morgan_orange> but nobody in the the labs
08:09:35 <morgan_orange> note that the most ambitious testcase was the one managed by China Mobile / Windriver / Intel / Redhat
08:10:03 <morgan_orange> they performed an interconnection between 2 Clouds for a vEPC scenario, which was quiete nice
08:10:18 <morgan_orange> wait for the official summary to get details
08:10:39 <morgan_orange> #info next plugfest planned in France beginning of December for Colorado
08:10:59 <morgan_orange> #info we can see 4 types of activities during such plugfest (at least in #1)
08:11:07 <morgan_orange> #info knowledge sharing on testing
08:11:11 <morgan_orange> #info VNF testing
08:11:16 <morgan_orange> #info install party
08:11:16 <jose_lausuch> who was there from Ericsson?
08:11:26 <morgan_orange> #info interco/interop testing
08:12:34 <morgan_orange> jose_lausuch: hmmm do not remember but I will try to find back
08:12:38 <jose_lausuch> no problem
08:12:49 <morgan_orange> any question on this first plugfest?
08:13:02 <jose_lausuch> nope, glad to hear good news and success!
08:13:30 <SerenaFeng> what is interco/interop testing?
08:13:52 <morgan_orange> test a VNFs distributed in 2 clouds for instance
08:14:03 <morgan_orange> so Apex versus windriver
08:14:12 <morgan_orange> for instance with VNFs distributed in both clouds
08:14:33 <SerenaFeng> ok, thank you
08:14:44 <morgan_orange> both installed on a hardware people discover the same day
08:15:03 <morgan_orange> initially the ambitious would have been to also run all the installer in a given scenario (odl_l2) on the same hardware...
08:15:12 <morgan_orange> but we did not have time to do it
08:15:30 <morgan_orange> but it would also have been interesting (to compare apple with apple..)
08:15:32 <morgan_orange> next time
08:15:47 <morgan_orange> and next time we may imagine more VNFs and interop
08:15:56 <morgan_orange> it is a good neutral place to trey such things
08:16:24 <morgan_orange> #topic Sprint #7 follow-up
08:16:40 <morgan_orange> #info we are almost at the end of Sprint 7 (Sprint 8 to be started this week)
08:16:48 <morgan_orange> #info refactoring completed
08:16:57 <morgan_orange> #info CI run back to nominal
08:17:20 <morgan_orange> #info Test API swagger integration also almost ready
08:17:33 <jose_lausuch> good progress so far
08:17:39 <jose_lausuch> #info CLI completed
08:18:01 <morgan_orange> SerenaFeng: if you want to complete, I just tested before taking the plane, looks nice, verion was fine, some issue with other methods but the GUI fully OK
08:18:04 <SerenaFeng> as regards to testAPI swagger
08:18:29 <SerenaFeng> it needs lots of modify to the original code
08:18:40 <SerenaFeng> without any test, I dare not to do it
08:18:48 <SerenaFeng> so, I am working on the unittest
08:18:57 <SerenaFeng> so far, the framework is almost done
08:19:01 <jose_lausuch> can you show us the GUI life?
08:19:06 <jose_lausuch> live*
08:19:07 <SerenaFeng> I will make the git review today
08:20:36 <SerenaFeng> then I want to write the unittest first, with the unittest's guarantee, I will continue with the swagger work
08:20:37 <morgan_orange> jose_lausuch: I take a picture and share it
08:20:38 <SerenaFeng> is that OK?
08:20:44 <morgan_orange> SerenaFeng: yes
08:21:17 <morgan_orange> BTW during the plugfest I discussed with Mark Beier from Storperf, they have (as Yardstick) unit tests and nice coverage indication without Jenkins
08:21:25 <morgan_orange> place for improvement for us in D release
08:21:25 <jose_lausuch> ok
08:21:57 <morgan_orange> For the current Jiras, any concerns?
08:22:06 <SerenaFeng> and I found that, we don't have pep8 check(use tox) in our testAPI project
08:22:25 <SerenaFeng> I think it is necessary
08:22:38 <SerenaFeng> so do we need pep8 check?
08:23:12 <SerenaFeng> I think it is better to add the pep8 check
08:23:16 <morgan_orange> we have pep8 check in Functest
08:23:22 <morgan_orange> it is already activated
08:23:27 <morgan_orange> in Releng, not sure
08:23:41 <morgan_orange> we may ask fdegir
08:24:02 <morgan_orange> #action morgan_orange ask fdegir if we could add pep8 check on releng (useful for the test API)
08:24:03 <SerenaFeng> ok
08:24:06 <morgan_orange> #link http://postimg.org/image/hk7eleakx/20683b3d/
08:24:11 <jose_lausuch> its not in other repos
08:24:15 <jose_lausuch> just functest
08:24:28 <jose_lausuch> SerenaFeng: anyway, you can install flake8 locally
08:24:31 <jose_lausuch> and to a local scan
08:24:38 <jose_lausuch> I do that before commiting anything :)
08:24:48 <jose_lausuch> the violations you get on gerrit are not enough
08:24:53 <morgan_orange> I posted the image of the swagger interface in the link
08:24:59 <SerenaFeng> ok, thank you
08:25:00 <jose_lausuch> you get only 1 message of each violation type
08:25:04 <jose_lausuch> better to do it locally
08:25:16 <morgan_orange> I have a question on the reporting
08:25:18 <jose_lausuch> just pip install flake8
08:25:24 <jose_lausuch> and then run it against your directory
08:25:26 <jose_lausuch> flake8 ./
08:25:40 <morgan_orange> now that we decided that scenario will be validated by Healthcheck+smoke + scenario specific tests
08:25:45 <SerenaFeng> I don't do the pep8 before, I will do it later, thank you
08:26:05 <morgan_orange> I planned to refactor a little bit the current reporting -includign the call to the new test case yaml description file)
08:26:18 <morgan_orange> jose_lausuch: will we push results for the health check?
08:26:41 <morgan_orange> I assume no, but if healthcheck fails then we do not execute the other tests..
08:26:44 <jose_lausuch> shall we?
08:26:50 <jose_lausuch> yes
08:26:51 <jose_lausuch> well
08:26:57 <jose_lausuch> its a very simplet test
08:26:59 <jose_lausuch> it doesnt say much
08:27:02 <jose_lausuch> just verify the API
08:27:06 <morgan_orange> agree
08:27:07 <jose_lausuch> but sometimes it fails (Nokia lab)
08:27:22 <morgan_orange> for the smoke we have the tests in pink in https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria
08:27:27 <jose_lausuch> but for our verification automatic reporting page it owuld be niace to have
08:27:32 <viktor_nokia> regarding healthcheck: it's not a very simple test :)
08:27:42 <jose_lausuch> the test itself is simple
08:27:52 <viktor_nokia> it covers the whole neutron+ODL chain
08:27:55 <jose_lausuch> if it fails, its not so simple to understand why :D
08:28:14 <jose_lausuch> well, yes, but the tests just boots 4 Instances :)
08:28:24 <jose_lausuch> if that doesnt work, we are in trouble!
08:28:36 <viktor_nokia> vping_ssh/userdata are more simple :)
08:29:24 <jose_lausuch> mmmm
08:29:29 <jose_lausuch> nope
08:29:40 <jose_lausuch> vping is about pining instances
08:29:47 <jose_lausuch> healthcheck doesn't do any pining
08:29:53 <jose_lausuch> it's the step before
08:30:01 <jose_lausuch> just bringning up instances
08:30:08 <viktor_nokia> healthcheck create a lot of objects (users/projects/images/volumes/networks/subnets/floating IPs/routers/router interfaces etc.
08:30:40 <raghavendrachari> healthcheck for vm ?
08:30:42 <viktor_nokia> and assumes that e.g. ODL is functional in SDN scenarios
08:30:43 <jose_lausuch> the only thing vping_ssh does not create is volumes
08:31:44 <morgan_orange> healthcheck is not supposed to be SDN or feature dependant
08:31:58 <jose_lausuch> vping also creates /images/networks/subnets/floating IPs/routers/router interfaces etc.
08:32:10 <morgan_orange> it corresponds to basic commands at the end of an OpenStack installation
08:32:13 <jose_lausuch> the only difference is that it creates only 2 VMs
08:32:16 <jose_lausuch> healthcheck 4
08:32:29 <morgan_orange> ok so not only basic commands
08:32:30 <jose_lausuch> agree
08:33:28 <SerenaFeng> so, lots of duplicated test scenarios in healthcheck and vping?
08:33:37 <SerenaFeng> why do we need both of them?
08:33:39 <viktor_nokia> It is OK for me; I just afraid that in some cases we will not get other test results if healthcheck will fail
08:33:49 <SerenaFeng> quite time-consuming
08:33:57 <jose_lausuch> if healthcheck fails, it doesnt make to run other things :)
08:34:19 <viktor_nokia> why not?
08:34:19 <jose_lausuch> how can you sell something to a telco/operator where you can't create instances normally?
08:35:03 <morgan_orange> SerenaFeng: the first tests are very short, ~ 1 or 2 minutes max
08:35:05 <jose_lausuch> SerenaFeng: not really, less than 5 minutes in total :)
08:35:51 <viktor_nokia> For example, if flow creation is delayed 2 minutes (as in Apex setup
08:35:57 <morgan_orange> Ok let's see in practice in the next weeks if it is OK to deal with a healthcheck first (if ok => run smoke tests else tests not triggered)
08:36:01 <viktor_nokia> healthchek will fail
08:37:10 <jose_lausuch> viktor_nokia: do you think if we increase the timeout it will pass?
08:37:24 <jose_lausuch> we can do that
08:37:30 <viktor_nokia> It passed when I added 1 min delay
08:37:36 <jose_lausuch> we can do that
08:37:43 <jose_lausuch> that's fine
08:37:46 <jose_lausuch> as long as it works in the end
08:37:46 <morgan_orange> but is it acceptable to have delay in flow creation?
08:38:09 <viktor_nokia> should we create an APEX ticket?
08:38:13 <jose_lausuch> timeout=60 currently
08:38:25 <jose_lausuch> can you push a patch with the value you have tested and it works?
08:38:32 <morgan_orange> I think it makes sens to report it to Apex
08:38:42 <viktor_nokia> I can do it
08:38:53 <jose_lausuch> but honestly... more than 1 minute to boot a cirros VM and get an IP... is not telco grade :D
08:38:58 <jose_lausuch> viktor_nokia: ok, thanks
08:39:11 <viktor_nokia> jose_lausuch: I agree :)
08:39:28 <morgan_orange> according to jenkins it is OK with fuel and joid
08:39:33 <morgan_orange> on Master
08:39:47 <morgan_orange> withouth timer changes
08:40:01 <jose_lausuch> viktor_nokia: let's do that then, let's add more time
08:40:03 <jose_lausuch> 3 min max?
08:40:37 <viktor_nokia> I'm not sure, it will delay the whole test
08:40:52 <viktor_nokia> because we need to wait before launchng instances
08:40:59 <morgan_orange> #action viktor_nokia increase timeout value for healthcheck
08:41:15 <morgan_orange> #action viktor_nokia create Jira on Apex regarding the timeout issue in healthcheck test
08:41:23 <viktor_nokia> not really reasonable
08:41:54 <morgan_orange> Let's see with Apex team first
08:42:08 <viktor_nokia> One possibility is to not require IP addresses during healthcheck
08:42:11 <jose_lausuch> wait before launching? why?
08:42:14 <morgan_orange> as our main goal is to have a better control of the time, if we start bu increasing the timeout on test #1... :)
08:42:42 <viktor_nokia> jose_lausuch: because cirros tries only three times
08:42:43 <jose_lausuch> the idea I had about waiting for the IP is that if that fails, vping_tests can fail as well (if they dont get ips)
08:42:51 <jose_lausuch> viktor_nokia: ah ok
08:42:54 <jose_lausuch> mmmm
08:43:12 <jose_lausuch> viktor_nokia: ok, let's add a delay before creating the instances then
08:43:14 <viktor_nokia> but in apex case vping passes since it creates less networks :)
08:43:16 <jose_lausuch> let's make it generic
08:44:30 <morgan_orange> another point on the smoke test cases
08:45:02 <morgan_orange> we have still the security_groups test mentioned
08:45:18 <morgan_orange> I think it will be hard for David to do it (baby in approach...)
08:45:52 <morgan_orange> ollivier: or anyone volunteer to implement this testcase or shall we report it to Colorado SR2 or D river?
08:46:16 <jose_lausuch> ohh nice
08:46:21 <jose_lausuch> baby coming
08:46:27 <morgan_orange> #info question on security_groups tests
08:46:30 <jose_lausuch> I don't want to volunteer... too many things already :)
08:46:40 <jose_lausuch> if its not possible, then for D
08:46:57 <morgan_orange> #info resource issue on David side, 2 options => someone volunteer to replace David, or move it ro D release
08:47:08 <viktor_nokia> are they neutron security groups or something else?
08:47:16 <lhinds> morgan_orange, i can take a look at it
08:47:29 <jose_lausuch> viktor_nokia: yes
08:47:33 <jose_lausuch> let me find the link
08:47:33 <lhinds> main thing is I want to get this scap scanning finished first
08:47:44 <jose_lausuch> #link https://gist.github.com/davidblaisonneau-orange/bb74fb1a9d4a87552fc2cdf68608f69f
08:47:51 <morgan_orange> #action lhinds sync with David for secrurity_group test cases
08:47:55 <morgan_orange> good transition
08:47:56 <jose_lausuch> this is the test description
08:48:00 <morgan_orange> lhinds: upadte on security scan
08:48:14 <morgan_orange> we did not mention in the Test Criteria
08:48:20 <morgan_orange> https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria
08:48:27 <morgan_orange> but for me it should be in blue
08:49:05 <viktor_nokia> FYI: tempest_full contains number of scenario test cases for security groups
08:49:17 <lhinds> security scanning is almost there now. I found a way to make the SSH hop in paramiko, but I need to get a better view of how we can get SSH keys from each installer, and how do we discover the IP addresses in functest?
08:49:36 <lhinds> Second question you all should be able to help with
08:49:49 <morgan_orange> viktor_nokia: good point, I think David had a look, let's sync if testcase is needed or already covered by Tempest full
08:50:20 <lhinds> If its blackbox, do you have discovery of IP addresses (endpoint URL perhaps) or do you enter this manually?
08:50:28 <lhinds> trying to work out what hooks I can use
08:52:24 <morgan_orange> we got info from CI (INSTALLER_IP) and retrieve IPs also from scripts releng/fetch_os.sh The approach is different from one installer to another
08:53:18 <morgan_orange> for the ODL test case for instance we need th IP of keystone, Neutron and ODL
08:53:23 <morgan_orange> we do it through  keystone_ip=$(openstack catalog show identity |grep publicURL| cut -f3 -d"/" | cut -f1 -d":")
08:53:23 <morgan_orange> neutron_ip=$(openstack catalog show network | grep publicURL | cut -f3 -d"/" | cut -f1 -d":")
08:53:23 <morgan_orange> odl_ip=${neutron_ip}
08:54:26 <morgan_orange> we can discuss it offline (based on the mail you just sent)
08:54:42 <lhinds> would I be able to get the IP of other nodes in a similar way..I need compute / control and network
08:55:01 <lhinds> ok..if you can reply on where I can read more, that would be useful
08:55:32 <morgan_orange> #action morgan_orange jose_lausuch answer lhinds mail (how to retrieve dynamically IP for security test)
08:55:46 <morgan_orange> #action morgan_orange add security test in test Criteria page
08:55:50 <viktor_nokia> put me as CC
08:55:53 <jose_lausuch> it will be challenging :)
08:56:12 <jose_lausuch> maybe we can do it for opnfv installers
08:56:13 <morgan_orange> viktor_nokia: OK I think everybody is in CC
08:56:31 <jose_lausuch> but not for others, and ollivier will stand up :)
08:56:34 <lhinds> and otherwise, I have ported all argparse values into the the config_functest.yaml
08:56:56 <morgan_orange> shall we plan a demo next week? with a GTM?
08:57:16 <lhinds> morgan_orange, let me see what shape I am in at the end of the week
08:57:20 <jose_lausuch> demo?
08:57:29 <lhinds> if you meant secscanning that is
08:57:35 <morgan_orange> yep
08:57:41 <morgan_orange> demo of the scscanning
08:57:53 <morgan_orange> how long does it take on your POD?
08:58:20 <morgan_orange> let's see at the end of the week, if ready we may plan a lived demo next tuesday
08:58:26 <lhinds> I can show it working outside of functest, but need to get it integrated before I show it running in functests docker context
08:58:28 <morgan_orange> and probably a demo of SerenaFeng'as APi
08:58:36 <morgan_orange> lhinds: ok
08:58:46 <morgan_orange> we are a bt late
08:58:53 <morgan_orange> #topic Berlin Summit
08:59:07 <morgan_orange> #info progams has been announced
08:59:26 <morgan_orange> #info several presentation to be planned (for the Design and the Summit)
08:59:53 <morgan_orange> #action morgan_orange check the Functest related pres and see with involved people
09:00:04 <morgan_orange> who will be in Berlin?
09:00:11 <SerenaFeng> we planed to make the testAPI session, I will make the proposal later
09:00:12 <lhinds> I will
09:00:20 <jose_lausuch> me
09:00:24 <SerenaFeng> me
09:00:24 <morgan_orange> Ich auch
09:00:28 <raghavendrachari> me too
09:00:32 <viktor_nokia> I will
09:00:34 <jose_lausuch> :)
09:00:41 <morgan_orange> ok most of us, cool
09:01:11 <morgan_orange> #info Functesters in Berlin: lhinds, jose_lausuch SerenaFeng raghavendrachari viktor_nokia ollivier morgan_orange ...
09:01:16 <morgan_orange> #topic AoB
09:01:25 <morgan_orange> anything you want to share before we close the meeting
09:02:11 <morgan_orange> I have a question, I have a Jira, where I planned to add tempest errors on the tempest reporting
09:02:31 <morgan_orange> #link http://testresults.opnfv.org/reporting/index-tempest-apex.html
09:02:47 <morgan_orange> is it OK to add in the details section when we push teh results this list
09:03:19 <morgan_orange> I think it is the easiest way, otherwise I have to get the full logs on the artifcats and match the id betwwen the different runs
09:03:39 <jose_lausuch> ok
09:03:40 <jose_lausuch> yep
09:03:44 <morgan_orange> I think it is simple to add the testcases failed directly in teh results in addition of teh nb tests run / failed / ..
09:04:10 <morgan_orange> #info question on the opportunity to put the Tempest failed case in the results pushed to the DB
09:04:31 <morgan_orange> ok if any objection, I planned to do it thsi way
09:04:35 <morgan_orange> any other topic?
09:04:41 <jose_lausuch> no objections
09:04:41 <jose_lausuch> yes
09:04:45 <jose_lausuch> anual awards opened
09:04:49 <jose_lausuch> vote for morgan_orange!
09:05:02 <morgan_orange> no no vote for jose_lausuch!
09:05:10 <viktor_nokia> both :)
09:05:13 <CG_Nokia> +1 +1
09:05:15 <jose_lausuch> haha
09:05:20 <SerenaFeng> +1 +1
09:05:26 <jose_lausuch> :p
09:05:50 <SerenaFeng> morgan_orange: do you think, it's a better idea to make the testAPI a real project, I mean we can make the installation of it?
09:05:51 <jose_lausuch> morgan_orange is the plugfester
09:06:17 <morgan_orange> last info, it seems that installers will be late... (fuel already mentioned that mitaka nosdn will not be available immediately...)
09:06:43 <morgan_orange> SerenaFeng: what do you mean by we can make the installation of it?
09:06:55 <morgan_orange> something independent from releng?
09:07:16 <SerenaFeng> contains setup.py in it
09:07:37 <SerenaFeng> just like nova do
09:07:47 <morgan_orange> yes we could do that
09:07:53 <morgan_orange> for the moment it is very manual
09:08:00 <SerenaFeng> yeah
09:08:02 <morgan_orange> I clone the repos on the testresults.opnfv.org a
09:08:19 <morgan_orange> and I run the python result_test_api ...
09:08:24 <SerenaFeng> we have to download the project, run it as it is
09:08:24 <morgan_orange> we could have something better
09:08:41 <SerenaFeng> you got the meaning, thank you
09:08:50 <morgan_orange> idem for the test case we could also imagine for D or later rivers to use this API as a baseline for all the test projetcs to run the tests
09:09:03 <SerenaFeng> I don't know how to express myself, 55
09:09:36 <SerenaFeng> yeah
09:10:05 <morgan_orange> ok enjoy the ned of Sprint 7, see you next week for Sprint 8
09:10:07 <morgan_orange> #endmeeting