#opnfv-testperf: Functest weekly meeting June 7th

Meeting started by morgan_orange at 08:00:24 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 08:00:30)
    1. morgan Richomme (morgan_orange, 08:00:34)
    2. SerenaFeng (SerenaFeng, 08:01:04)
    3. Jose Lausuch (jose_lausuch, 08:01:15)
    4. agenda: https://wiki.opnfv.org/display/functest/Functest+Meeting (morgan_orange, 08:01:30)

  2. action point follow up (morgan_orange, 08:02:13)
    1. lhinds (lhinds, 08:02:18)
    2. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-05-31-08.01.html (morgan_orange, 08:02:21)
    3. AP1: we did not dive deeply into Apex logs, we were a bit optimistic last week (morgan_orange, 08:02:43)
    4. Apex tempest success rate = 63% (morgan_orange, 08:02:52)
    5. http://testresults.opnfv.org/reporting/functest/release/index-tempest-apex.html (morgan_orange, 08:03:00)
    6. troubleshooting to be planned on Tempest and ODL (morgan_orange, 08:03:14)
    7. AP2: Cedric had a llok at ODL tests: his conclusion refactoring is needed as some tests are not relevant and some will be needed (morgan_orange, 08:03:54)
    8. he planned to refactor incrementally (no risk / regarding the freeze) (morgan_orange, 08:04:07)
    9. AP3: Juha answered during last week meeting, so AP close (morgan_orange, 08:04:46)
    10. AP4: May-meimei are you there? any update on gsutils on all CI PODs? (morgan_orange, 08:05:22)
    11. AP5: no update on domain coverage page https://wiki.opnfv.org/display/functest/Testing+Coverage but discussion connected to test slicing (morgan_orange, 08:06:23)
    12. proposal shared with testing community https://wiki.opnfv.org/display/functest/Testing (morgan_orange, 08:06:40)
    13. slicing under review, discussion planned on thursday (morgan_orange, 08:06:52)
    14. AP6: did anyone contact his/her ETSI contact? (morgan_orange, 08:07:21)
    15. AP7: done SerenaFeng has access to the machine, we will discuss next steps in next topic (morgan_orange, 08:08:27)

  3. Sprint #8 follow-up (morgan_orange, 08:08:48)
    1. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (morgan_orange, 08:09:00)
    2. http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html (morgan_orange, 08:11:24)
    3. security scan: ome delays in testing, as the machine I was on got taken out to have a memory change (it failed), testing today (morgan_orange, 08:15:10)
    4. Functest versus Feature project : http://picpaste.com/BrahmaFunctestVsfeatureProject-AqTnwvgv.png (morgan_orange, 08:16:55)
    5. all the information not known yet, Summit will be the occasion to finalize that. A 1 h session is planned during the design summit on feature integration (morgan_orange, 08:17:25)
    6. table shared with David McBride (morgan_orange, 08:18:02)

  4. Berlin Summit (morgan_orange, 08:19:18)
    1. lots of slots prebooked for Functest during the Design Summit (morgan_orange, 08:19:32)
    2. https://wiki.opnfv.org/display/EVNT/Berlin+Design+Summit+Planning (morgan_orange, 08:19:47)
    3. https://wiki.opnfv.org/display/EVNT/Berlin+Design+Summit+Project+Breakouts+and+Hacking (morgan_orange, 08:20:01)
    4. Monday: 10h30-11: Plugfest, 11h-11h30: Functest, 11h30-12h: Conversation with the testing community, 16h-17h feature project integration*, 17h-17h30 Functest Colorado* (morgan_orange, 08:24:22)
    5. Tuesday 11h-11h30 Test API, 11h30-12h0 CI/CD panel, 13h-13h30 VNF discussion*, 13h30-14h0 test API* , 14h-14h30 Dashboard/ELK*, 15h15-15h45 D release* (morgan_orange, 08:24:29)
    6. *= break out sessions (morgan_orange, 08:24:36)
    7. ACTION: jose_lausuch viktor Juha complete https://git.opnfv.org/cgit/functest/tree/docs/com/pres/summit-Berlin.html (morgan_orange, 08:29:01)

  5. Status on test API refactoring (morgan_orange, 08:36:18)
    1. SerenaFeng did a great job (deserve the quartely awards...) (morgan_orange, 08:36:38)
    2. tets API fully refactored, including unit tests, backup/restore/deployment scripts, swagger framework for automatic documentation (morgan_orange, 08:37:09)
    3. next step migration on testresults.opnfv.org (morgan_orange, 08:37:24)
    4. ACTION: SerenaFeng finalize migration scripts (no manual operation) before switching APi on testresults (morgan_orange, 08:45:16)
    5. switch should be possible very soon (morgan_orange, 08:45:38)
    6. SerenaFengindicates possible evolution using container and ansible to simplify depliyment/update/.. (morgan_orange, 08:45:56)
    7. ACTION: morgan_orange send mail to the community to ask who did any change on kibana (morgan_orange, 08:47:15)
    8. ACTION: SerenaFeng morgan_orange consider ELK adapations once switch done (morgan_orange, 08:47:43)

  6. AoB (morgan_orange, 08:48:30)
    1. https://wiki.opnfv.org/display/multisite/Kingbird+integration (jose_lausuch, 08:48:45)
    2. ACTION: morgan_orange contact multi site to ask for test, test case declaration + Jira for integration (morgan_orange, 08:50:46)
    3. ACTION: morgan_orange contact PTL of feature projects for which one of this 3 elements is missing (morgan_orange, 08:51:07)
    4. https://build.opnfv.org/ci/job/functest-apex-apex-daily-master-daily-master/9/console (morgan_orange, 08:53:50)
    5. bgpvpn tests to be moved from yardstick to Functest ...pobably SFC (depending on the complexity) to be more consisten with the aggreed view (Functional testing = Functets) (morgan_orange, 08:55:17)
    6. some concern on the CI stability at the moment: no run on fuel/joid on Master since more than 10 days (morgan_orange, 08:56:28)


Meeting ended at 09:01:40 UTC (full logs).

Action items

  1. jose_lausuch viktor Juha complete https://git.opnfv.org/cgit/functest/tree/docs/com/pres/summit-Berlin.html
  2. SerenaFeng finalize migration scripts (no manual operation) before switching APi on testresults
  3. morgan_orange send mail to the community to ask who did any change on kibana
  4. SerenaFeng morgan_orange consider ELK adapations once switch done
  5. morgan_orange contact multi site to ask for test, test case declaration + Jira for integration
  6. morgan_orange contact PTL of feature projects for which one of this 3 elements is missing


Action items, by person

  1. jose_lausuch
    1. jose_lausuch viktor Juha complete https://git.opnfv.org/cgit/functest/tree/docs/com/pres/summit-Berlin.html
  2. morgan_orange
    1. morgan_orange send mail to the community to ask who did any change on kibana
    2. SerenaFeng morgan_orange consider ELK adapations once switch done
    3. morgan_orange contact multi site to ask for test, test case declaration + Jira for integration
    4. morgan_orange contact PTL of feature projects for which one of this 3 elements is missing
  3. SerenaFeng
    1. SerenaFeng finalize migration scripts (no manual operation) before switching APi on testresults
    2. SerenaFeng morgan_orange consider ELK adapations once switch done


People present (lines said)

  1. morgan_orange (150)
  2. jose_lausuch (80)
  3. SerenaFeng (31)
  4. lhinds (5)
  5. collabot` (3)


Generated by MeetBot 0.1.4.