#opnfv-yardstick: Yardstick

Meeting started by trevor_intel at 00:33:44 UTC (full logs).

Meeting summary

  1. Action follow-up (trevor_intel, 00:36:03)
    1. Action was to create Yardstick architecture Wiki, see https://wiki.opnfv.org/display/yardstick/Yardstick+Framework+Architecture+Evolution (trevor_intel, 00:37:52)
    2. Will be included in Danube documentation (trevor_intel, 00:39:03)
    3. Looking for feedback in next weeks meeting (trevor_intel, 00:39:51)
    4. ACTION: Ross will update diagram for NSB (trevor_intel, 00:43:43)
    5. See Jira ticket for status - waiting for Ruijing to reply https://jira.opnfv.org/browse/YARDSTICK-529 (trevor_intel, 00:46:10)

  2. Python 3 (trevor_intel, 00:46:53)
    1. Ross proposed plan in Etherpad https://etherpad.opnfv.org/p/YardstickPython3 (trevor_intel, 00:47:15)
    2. Everybody read Open Stack porting 3 guidelines (trevor_intel, 00:49:14)
    3. We are in step 1 today (trevor_intel, 00:49:45)
    4. Step 2 commit is in Gerrit for review - committers please review it (trevor_intel, 00:50:48)
    5. Ross would like to merge soon - touches lots of other files so have to keep re-basing (trevor_intel, 00:51:26)
    6. Adding Python 3 support https://gerrit.opnfv.org/gerrit/#/c/25539/ (rbbratta, 00:52:14)
    7. yardstick team should review about the patch: kubi, jing, jack, rex, kanglin, zhihui (Mingjiang, 00:54:32)
    8. Ross indicated Python 3 unit tests are key ... do it before or after Danube? (trevor_intel, 00:58:45)
    9. Rex suggested to do ASAP or will be harder (trevor_intel, 00:59:08)
    10. Deepak has proposed patches ... not sure if compatible with Python 3 ... Ross will inform Deepak to prepare accordingly and will help (trevor_intel, 01:00:17)
    11. Agreed to enable before Danube (trevor_intel, 01:01:10)
    12. AGREED: Enable Python 3 before Danube (trevor_intel, 01:01:44)
    13. Ross is willing to help anybody with porting to Python 3 (trevor_intel, 01:02:53)

  3. Yardstick-Qtip integration (trevor_intel, 01:03:24)
    1. #link https://wiki.opnfv.org/display/yardstick/Yardstick-Qtip+integration (trevor_intel, 01:05:33)
    2. https://etherpad.opnfv.org/p/qtip-yardstick (trevor_intel, 01:06:06)
    3. Discussion on Qtip relationship to Yardstick for integration is unclear (trevor_intel, 01:24:42)
    4. Needs some discussion between Yardstick and Qtip team (trevor_intel, 01:25:02)
    5. Qtip benchmarks listed in Wiki The Framework can run 5 computing benchmarks: 1. Dhrystone 2. Whetstone 3. RamBandwidth 4. SSL 5. nDPI (trevor_intel, 01:26:21)
    6. https://github.com/ntop/nDPI.git (rbbratta, 01:26:55)
    7. nDPI is an open source LGPLv3 library for deep-packet inspection. (rbbratta, 01:27:52)
    8. These benchmarks can be run in 2 test cases: 1. VM vs Baremetal 2. Baremetal vs Baremetal (rbbratta, 01:28:21)

  4. Sprint (trevor_intel, 01:29:46)
    1. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=145&view=planning&selectedIssue=YARDSTICK-529&versions=visible (Mingjiang, 01:30:32)
    2. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=145&view=detail&selectedIssue=YARDSTICK-524 (Mingjiang, 01:31:24)
    3. the sprint page is to show what yardstick is in progress/to do/done in the active sprint (Mingjiang, 01:32:50)
    4. all of this is in the "Agile of YARDSTICK" board: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=145&view=planning&selectedIssue=YARDSTICK-529&versions=visible (Mingjiang, 01:34:07)
    5. ACTION: kubi will contract with Qtip team to have a joint meeting at next weekly meeting (kubi001, 01:46:16)
    6. ACTION: kubi will contract with Qtip team to have a joint meeting at next weekly meeting (trevor_intel, 01:46:49)


Meeting ended at 01:47:09 UTC (full logs).

Action items

  1. Ross will update diagram for NSB
  2. kubi will contract with Qtip team to have a joint meeting at next weekly meeting
  3. kubi will contract with Qtip team to have a joint meeting at next weekly meeting


People present (lines said)

  1. trevor_intel (39)
  2. kubi001 (14)
  3. Mingjiang (12)
  4. rbbratta (10)
  5. collabot (4)
  6. JingLu (3)
  7. JackChan1 (1)


Generated by MeetBot 0.1.4.