#acumos-platform-oam: Platform OA&M Weekly Meeting

Meeting started by aimeeu at 15:03:32 UTC (full logs).

Meeting summary

    1. attendees Spondon, Parichay, Amit, Bryan, Aimee (aimeeu, 15:05:15)
    2. https://wiki.acumos.org/display/OAM/Meetings (aimeeu, 15:07:45)
    3. attendees: Mukesh Mantan (aimeeu, 15:09:06)

  1. Agenda Bashing (aimeeu, 15:09:11)
  2. Review of Committed Features (Jira Items) (aimeeu, 15:10:30)
    1. attendees Lorraine Welch, Nat Subramanian, Sanjay Agraharam (aimeeu, 15:11:02)
    2. Bryan covers release plan checklist (aimeeu, 15:12:43)
    3. https://wiki.acumos.org/display/OAM/Release+Planning (aimeeu, 15:12:58)

  3. Log Standards (aimeeu, 15:14:27)
    1. define log standards and implement in all components - Bryan has asked Spondon to lead this effort (aimeeu, 15:14:54)
    2. https://jira.acumos.org/browse/ACUMOS-710 (aimeeu, 15:15:20)
    3. Acumos-710 is the old implementation and needs to be updated; PTLs need to know exactly what needs to be implemented to comply with the new standard (aimeeu, 15:16:21)
    4. ACTION: Spondon will update Acumos-710 (aimeeu, 15:16:41)
    5. Bryan created a 'logging' label in Jira and added the label to relevant Jira items; asks everyone to add the label when creating logging-related items (aimeeu, 15:18:41)
    6. https://jira.acumos.org/browse/ACUMOS-622 (aimeeu, 15:19:02)
    7. Spondon asks about ^ (aimeeu, 15:19:17)
    8. Nat: suggests creating an Epic for updating logging in components to comply with new standard (aimeeu, 15:20:37)
    9. ACTION: Bryan will optimize the Jira items (aimeeu, 15:22:26)
    10. O&AM Support for ELK Kibana - Single logging system across components and generating usage reports #link https://jira.acumos.org/browse/ACUMOS-1091 (aimeeu, 15:23:04)
    11. log standardization and consistency design studio #link https://jira.acumos.org/browse/ACUMOS-624 (aimeeu, 15:25:23)
    12. team needs to create logging subtasks for the other components (aimeeu, 15:25:45)
    13. Aimee: what is the new logging standard, how will it be implemented? (aimeeu, 15:28:39)
    14. EELF is going away and Acumos will be using the Logging Service that has been developed in ONAP (aimeeu, 15:29:25)
    15. question: how will the ONAP logging service be used within Acumos? (aimeeu, 15:30:08)
    16. Parichay: we need to copy the ONAP code and customize it for Acumos (aimeeu, 15:30:53)
    17. need a clear example of the old way of logging and how to move to the new way of logging (aimeeu, 15:36:26)
    18. Michael O'Brien: upgrading to the new logging standard will break the old logging, so the logs will not be able to be consumed in ELK stack (aimeeu, 15:37:34)
    19. solution: provide 2 logback.xml files for backwards compatiblity (aimeeu, 15:37:54)
    20. 1) adapt ONAP logging library for Acumos; 2) components must switch to new logging library; 3) ELK Stack - configuration update (aimeeu, 15:39:31)
    21. elasticsearch config needs to be updated for new logging standards (aimeeu, 15:40:22)
    22. Mukesh has specific implementation questions (aimeeu, 15:46:08)
    23. components must implement AOP (aimeeu, 15:46:27)
    24. ACTION: Michael O'Brien will describe exactly how to use the logging library (aimeeu, 15:46:44)
    25. Lorraine: acumos will have a different set of MDCs - so if components pull the logging library from ONAP, who will this work? (aimeeu, 15:47:58)
    26. Michael: it is doable but ELK stack needs to be modified (aimeeu, 15:48:22)
    27. Aimee: some of our components are Python - how will they use the new logging library? (aimeeu, 15:49:26)
    28. Micheal: there is a Python library in the ONAP loggging library: pylog (which needs to be updated) (aimeeu, 15:50:03)
    29. will need an example of how to use pylog (aimeeu, 15:50:19)
    30. Michael: will OA&M provide a logging wrapper? (aimeeu, 15:52:10)
    31. yes - we should minimize components copying code (aimeeu, 15:52:25)
    32. inplement this in OA&M, then components reference the library in OA&M (aimeeu, 15:52:56)
    33. ACTION: Bryan and Spondon will update Jira (aimeeu, 15:53:39)
    34. Spondon: is there a workaround in terms of what we can implement if we don't leverage the ONAP logging library? (aimeeu, 15:54:40)
    35. Michael: yes, a number of ways but the logging library is meant to make life easier (aimeeu, 15:55:24)
    36. Nat: suggestion: bring in key component leads for quick conversation about the ONAP logging library (aimeeu, 15:56:44)
    37. get their input on complexity so OAM can decide how to implement in this release (aimeeu, 15:58:01)
    38. ACTION: Michael and Spondon will join next week's PTL meeting to present the new logging spec and options (aimeeu, 16:06:09)


Meeting ended at 16:06:14 UTC (full logs).

Action items

  1. Spondon will update Acumos-710
  2. Bryan will optimize the Jira items
  3. Michael O'Brien will describe exactly how to use the logging library
  4. Bryan and Spondon will update Jira
  5. Michael and Spondon will join next week's PTL meeting to present the new logging spec and options


People present (lines said)

  1. aimeeu (51)
  2. collabot (3)


Generated by MeetBot 0.1.4.