#fdio-csit: Weekly FD.io csit project meeting

Meeting started by skobza at 14:02:54 UTC (full logs).

Meeting summary

  1. agenda bashing (skobza, 14:03:39)
    1. list of jobs has been updated (skobza, 14:04:19)

  2. Jenkins jobs failures (skobza, 14:04:35)
    1. Jan reports vpp build failures causing vpp-csit jobs (vpp verify jobs) (skobza, 14:04:52)
    2. Carsten did some tcpdump on VIRL host, to see if the only expected_failing test (vxlan over dot1q) is due to vpp or the infra (VIRL host) (skobza, 14:06:16)
    3. Carsten mentions that the vlan tagged vxlan packet is received on VIRL, is forwarded to dest DUT, but further investigation is requried (skobza, 14:06:56)
    4. ACTION: Carsten to further debug vxlan-over-dot1q on VIRL (skobza, 14:07:12)
    5. Peter working on ipv6 perf tests (skobza, 14:08:06)
    6. Peter working on 4 core and 2 core configs (skobza, 14:08:18)
    7. Peter also working on stability of TREX related tests (skobza, 14:08:33)
    8. Miro vpp-csti-verify-perf-short got stuck in a weird loop. Looks like it was a ZUUL issue (between jenkins and gerrit). CJ restarted jenkins, slaves, and currently we are re-trying the failing job. (skobza, 14:09:33)
    9. ACTION: https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-perf-short/ (skobza, 14:10:19)
    10. https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-perf-short/ (skobza, 14:10:23)
    11. renaming a job in Jenkins causes removal of job runs history. (skobza, 14:11:03)
    12. Miro & Peter are going to re-test perf jobs in vpp to verify they are working (skobza, 14:11:39)
    13. functional-jobs failures: jobs started failing on VIRL after VIRL topology change - disabling of IPv6. VPP took all interfaces including mgmt interface. Newer version of VPP from nexus behaves correctly. (skobza, 14:13:55)
    14. despite quite a few failing jobs, all issues were and are addressed. Important thing is, all problems are related to integration, vpp, or combination, not really CSIT code. (skobza, 14:15:20)

  3. Jira task and issue tracking (skobza, 14:15:55)
    1. Miro worked out operational Kanban board (skobza, 14:16:09)
    2. we are filling the Jira dashbord with bugs, tasks - all are aligned with the plan on the wiki posted two weeks ago (skobza, 14:16:32)
    3. https://jira.fd.io/secure/RapidBoard.jspa?rapidView=1&projectKey=CSIT (skobza, 14:17:27)
    4. ACTION: mackonstan1: describe the proposed use of Jira - priorities, plan alignment, etc. (skobza, 14:20:00)
    5. ACTION: Peter is going to look into, and then propose a mechanism of storing data into different server than jenkins. (skobza, 14:23:08)
    6. ACTION: cj & Peter: develop mechanism how to store data on nexus (disk images, tarballs) (skobza, 14:25:39)
    7. https://wiki.fd.io/view/CSIT/Jobs list of csit jobs with documentation (skobza, 14:26:52)

  4. CSIT Jobs (skobza, 14:27:38)
    1. job #5 - identifying vpp-master-verified vpp build for csit-* jobs. Proposal is to run this twice a week. All tests have to be run against a VPP version: functional AND performance. (skobza, 14:30:20)
    2. ACTION: mackonstan1 will send out information on open e-mail mailing list to solicit review the list of jobs (skobza, 14:30:49)
    3. for vpp-master verify weekly has issue with tagging (there's arelready a helpdesk ticket for that) (skobza, 14:31:59)
    4. Jan confirms the problem with git tag is still not resolved (skobza, 14:33:03)
    5. CJ: packaging taking his time. Will prioritize this item. (skobza, 14:35:16)

  5. reorg of wiki pages (skobza, 14:35:48)
    1. aim is to implement all the must-haves [p0-r1] items (skobza, 14:37:55)
    2. on Kanban all p0-r1 are stored in Jira as high priority (skobza, 14:39:40)
    3. ... what is planned to be done by end of May is stored as medium prio (skobza, 14:39:55)
    4. CSIT will add pX-R1 tags to issues in CSIT jira to help tracking/pairing against wiki (skobza, 14:42:17)

  6. CSIT usability (skobza, 14:43:52)
    1. DPDK folks that reached out to CSIT over e-mail last week didn't reach out again after initial e-mail. (skobza, 14:49:28)
    2. VPP dev is looking into gcov usability in VPP (skobza, 14:50:45)
    3. Andrej works on LISP testcases for CSIT (skobza, 14:51:14)
    4. ACTION: mackonstan1: go after indirect adj and glean adj functionality, in form of vpp-dev (Damjan?), to help adding testcases to CSIT for these features (skobza, 14:53:50)
    5. ACTION: mackonstan1: ask vpp-dev how to verify adjacencies (skobza, 14:54:07)

  7. Documentation (skobza, 14:54:30)
    1. ... is linked, is alive for two weeks. It requries more work - everybody is encouraged to help with doc. (skobza, 14:54:47)
    2. ACTION: mackonstan1: to send feedback to skobza on documentaiton (skobza, 14:55:08)

  8. CSIT release strategy (skobza, 14:55:22)
    1. we decided to run CSIT jobs on weekly basis, and that is csit-verify* jobs. We are going to be releasing CSIT code on weekly basis (skobza, 14:56:00)
    2. additions to CSIT release is going to be documented by both Jira and gerrit logs (skobza, 14:56:40)
    3. trying to keep the overhead of releasing to minimum. (skobza, 14:58:52)
    4. release strategy is going to be done at TSC meeting. mackonstan1 is going to write something to TSC e-mail to solicit comments on CSIT release planning (skobza, 15:01:21)

  9. pressing issues (skobza, 15:01:45)
    1. mackonstan1 still don't have access to rt helpdesk (skobza, 15:01:54)
    2. ACTION: cj is going to follow up on reported inaccessibility of RT (skobza, 15:02:21)


Meeting ended at 15:02:33 UTC (full logs).

Action items

  1. Carsten to further debug vxlan-over-dot1q on VIRL
  2. https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-perf-short/
  3. mackonstan1: describe the proposed use of Jira - priorities, plan alignment, etc.
  4. Peter is going to look into, and then propose a mechanism of storing data into different server than jenkins.
  5. cj & Peter: develop mechanism how to store data on nexus (disk images, tarballs)
  6. mackonstan1 will send out information on open e-mail mailing list to solicit review the list of jobs
  7. mackonstan1: go after indirect adj and glean adj functionality, in form of vpp-dev (Damjan?), to help adding testcases to CSIT for these features
  8. mackonstan1: ask vpp-dev how to verify adjacencies
  9. mackonstan1: to send feedback to skobza on documentaiton
  10. cj is going to follow up on reported inaccessibility of RT


Action items, by person

  1. cj
    1. cj & Peter: develop mechanism how to store data on nexus (disk images, tarballs)
    2. cj is going to follow up on reported inaccessibility of RT
  2. mackonstan1
    1. mackonstan1: describe the proposed use of Jira - priorities, plan alignment, etc.
    2. mackonstan1 will send out information on open e-mail mailing list to solicit review the list of jobs
    3. mackonstan1: go after indirect adj and glean adj functionality, in form of vpp-dev (Damjan?), to help adding testcases to CSIT for these features
    4. mackonstan1: ask vpp-dev how to verify adjacencies
    5. mackonstan1: to send feedback to skobza on documentaiton
  3. skobza
    1. mackonstan1: to send feedback to skobza on documentaiton
  4. UNASSIGNED
    1. Carsten to further debug vxlan-over-dot1q on VIRL
    2. https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-perf-short/
    3. Peter is going to look into, and then propose a mechanism of storing data into different server than jenkins.


People present (lines said)

  1. skobza (58)
  2. collabot` (6)
  3. mmiklus (0)
  4. mackonstan1 (0)
  5. cj (0)


Generated by MeetBot 0.1.4.