#fdio-csit: CSIT-weekly-160803
Meeting started by mackonstan1 at 14:02:19 UTC
(full logs).
Meeting summary
- 
  - dwallacelf (dwallacelf,
    14:03:50)
 
  - Dave Wallace (mackonstan1,
    14:03:53)
 
  - Jan Gelety (mackonstan1,
    14:04:00)
 
  - Peter Mikus (mackonstan1,
    14:04:07)
 
  - Samuel Elias (mackonstan1,
    14:04:17)
 
  - Vladimir Holly (mackonstan1,
    14:04:25)
 
  - Hung Pham (mackonstan1,
    14:05:39)
 
 
- Inputs from FD.io projects - vpp, hc, ... (mmiklus, 14:07:53)
  - vpp migration to 16.07 dpdk (mmiklus,
    14:08:44)
 
 
- FD.io CSIT operational status. (mackonstan1, 14:09:09)
  - weekly and semi-weekly jobs runing OK
    (mackonstan1,
    14:09:36)
 
  - currently functional tests taking long time -
    42-to-45min, in addition to all environment setup (mackonstan1,
    14:14:15)
 
  - ACTION: Jan to send
    duration breakdown per test case, as well as environment setup
    times (mackonstan1,
    14:19:43)
 
  - ACTION: CSIT
    committers - review the time distribution, agree on the resolution
    options to reduce the overall execution time, make a
    proposal. (mackonstan1,
    14:20:18)
 
  - new nightly job for performance verification -
    Miro opened Jira ticket (mackonstan1,
    14:23:39)
 
  - https://jira.fd.io/browse/CIMANAGE-14
    <- nightly build waiting for review (mmiklus,
    14:24:41)
 
 
- Adding new test cases - TLDK (mackonstan1, 14:26:58)
  - Anna - asking for guidance on how to add TLDK
    test cases to CSIT (mackonstan1,
    14:29:15)
 
  - ACTION: Maciek - will
    provide links for intro new test cases into CSIT (mackonstan1,
    14:29:46)
 
  - ACTION: Anna -
    provide description of TLDK tests to be added to CSIT, email to
    csit-dev (mackonstan1,
    14:30:52)
 
 
- VPP 16.09 release readiness (mackonstan1, 14:35:26)
  - dpdk 16.07 intro - performance issues based on
    this patch https://gerrit.fd.io/r/#/c/2196/ (mackonstan1,
    14:35:58)
 
  - observing throughput drop after moving from
    dpdk 16.04 to 16.07 (mackonstan1,
    14:36:38)
 
  - Long IPv4 baseline PDR 64B 1 core, #2196 patch:
    2*3.3Mpps, nexus build(dpdk 16.04): 2*4.4Mpps (mmiklus,
    14:46:09)
 
  - https://git.fd.io/cgit/vpp/tree/dpdk/dpdk-16.04_patches/0013-Revert-ixgbe-fix-packet-type-from-vector-Rx.patch
    (mortderire,
    14:54:20)
 
  - https://git.fd.io/cgit/vpp/tree/dpdk/dpdk-16.04_patches/0013-Revert-ixgbe-fix-packet-type-from-vector-Rx.patch
    (mackonstan,
    14:55:39)
 
  - Ray confirmed that above patch is missing from
    both dpdk 16.07 and vpp 16.09, and should be added to address CSIT
    performance issues observed (mackonstan,
    14:57:15)
 
  - ACTION: Peter Mikus
    to send summary of performance comparison between dpdk1607 and
    dpdk1604, following testing of patch
    https://gerrit.fd.io/r/#/c/2196/ (mackonstan,
    15:04:14)
 
  - for baseline tests: ip4, ip6, l2xc,
    l2bd. (mackonstan,
    15:04:31)
 
 
Meeting ended at 15:07:55 UTC
(full logs).
Action items
  - Jan to send duration breakdown per test case, as well as environment setup times
 
  - CSIT committers - review the time distribution, agree on the resolution options to reduce the overall execution time, make a proposal.
 
  - Maciek - will provide links for intro new test cases into CSIT
 
  - Anna - provide description of TLDK tests to be added to CSIT, email to csit-dev
 
  - Peter Mikus to send summary of performance comparison between dpdk1607 and dpdk1604, following testing of patch https://gerrit.fd.io/r/#/c/2196/
 
People present (lines said)
  - mackonstan1 (21)
 
  - mmiklus (5)
 
  - collabot (5)
 
  - mackonstan (4)
 
  - mortderire (1)
 
  - dwallacelf (1)
 
Generated by MeetBot 0.1.4.